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Copyright
Power Matte is based on unpublished research and technology by Jue Wang 

from the Department of Electrical Engineering at the University of Washington.

No part of this document may be reproduced or transmitted in any form or by 

any means, electronic or mechanical, including photocopying and recording, 

for any purpose without the express written consent of Digital Film Tools.

Copyright © Digital Film Tools, LLC. 2015. All Rights Reserved

February 3, 2015

About Us
Digital Film Tools brings together the unbeatable combination of superior 

software designers, motion picture visual effects veterans, video editors and 

photographers. Add three Emmy Awards and experience in creating visual 

effects for hundreds of feature films, commercials and television shows and you 

have a recipe for success. The understanding of photography, film and video 

editing, and in particular visual effects, allows us to design productive and 

highly specialized software. Software that is useful as well as easy to use. Our 

products stand up to the rigors of production and are the culmination of many 

years of experience.

Our philosophy is to bring our visual effects tools and techniques to the 

masses. What was once found only in expensive high-end packages or existed 

as proprietary in-house tools, is now available to photographers, artists, 

designers, and video/film editors. Did I mention affordable? Our software 

doesn't cost an arm and a leg and won't break the bank.
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 POWER MATTE

Introduction
Power Matte is an easy to use interactive image matting tool capable of 

extracting almost any object in an image--even if you are dealing with fine hair 

detail, smoke, or reflections. This extraction process creates what is known as 

a matte--essentially a black and white cutout. White matte areas are extracted, 

black areas not, and gray areas in between represent a level of transparency. 

Once a matte is extracted, the foreground object can be seamlessly composed 

onto a new background as well as apply filter and image corrections only within 

the area defined by the matte.

To work this magic, Power Matte iteratively estimates the transparency value 

for every pixel in the image, based on a small sample of foreground (what you 

want to cut out) and background (what you want to get rid of) pixels marked by 

defining simple masks on the image. Results show that compared with previous 

Before After

Matte Masks
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approaches, our method is more efficient and requires minimal effort to extract 

high quality mattes for foregrounds with significant semi-transparent regions. In 

addition, the foreground edge colors can be estimated in the semi-transparent 

areas to create a seamless composite.
wer Matte User Guide
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 INSTALLATION

1 Download Power Matte at www.digitalfilmtools.com

2 Double-click on the file that was downloaded and run through the installation 
process.

3 When prompted, select the version of After Effects to install in.

4 Apply Power Matte to a clip in the timeline from the Effects > Digital Film Tools 
menu.

A dialog box pops up when you run Power Matte.

5 If you purchased the software, select Activate Power Matte and follow the 
instructions.

or 

6 Select Request Trial Activation (Internet Required) and click Next to receive a 
fully functioning version of Power Matte for the specified trial period. At the end 
of the trial period, Power Matte reverts to a limited demo mode.

or

7 Select Run in Demo Mode and click Finish.

Note: In Demo Mode, a watermark is superimposed over the image.
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 UNINSTALLING

Windows
From the Windows Start Menu, select Programs > Digital Film Tools > Power 

Matte v2.1 > Uninstall Power Matte.

Macintosh
Go to Applications/Digital Film Tools/Power Matte v2.1 and double-click on 

Uninstall Power Matte.
wer Matte User Guide
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 ACTIVATING, DEACTIVATING AND 
TRANSFERRING LICENSES

Activation Options

Internet Activate
Activates Power Matte over the Internet.

Request License from Self-Service Website
If you do not have an Internet Connection on the computer where you want to 

run Power Matte, use this option. The self-service website will generate a 

license file which you can then transfer to the desired computer.

Install a License File
Loads a license file obtained from the self-service website or received by email.

Note: If you experience an error when using Internet Activate, it is because you or your 
company uses a proxy server to access the Internet and/or your firewall is blocking our 
program’s access to the Internet. For proxy server users, select Advanced Options and 
enter the appropriate proxy server settings. For firewall users, open your firewall 
software and allow our software to access the Internet.

Deactivation Options
Once Power Matte has been activated, you can access the deactivation option 

by selecting the License button in the Effect controls.

Internet Deactivate
Deactivates Power Matte over the Internet and is only available if you initially 

activated over the Internet. Use this method to return your Product Code back 

to the activation server. You will then be able to use your Product Code to 

activate Power Matte on another computer.
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License Transfer
Your Product Code allows you to run Power Matte on one computer at a time. 

However, you may transfer the license by deactivating on one computer and 

activating on another.

Internet Deactivate / Internet Activate is the preferred method of license 

transfer between computers, but is only available if you initially activated over 

the Internet and currently have Internet access. If you do not have Internet 

access, you will need to contact customer support to assist you in transferring 

the license.

To transfer a license:

1 Apply Power Matte and click on License at the bottom of the Effect Controls 
window.

2 Choose Internet Deactivate and click Next.

Power Matte is now deactivated.

3 On the target computer, select Activate Power Matte and follow the instructions.

Power Matte will then activate on the new computer.
wer Matte User Guide
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 TUTORIALS

Open Mask Method
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown. Partial opacity values 

are then computed only for pixels inside the unknown region. Two trimap 

methods can be used: Open Mask or Closed Mask. This tutorial will use the 

Open Mask Method.

Unlike previous approaches, our trimaps can be relatively sparse consisting of 

open foreground and background masks. All pixels left unmarked will be 

treated as unknown.

1 Go to www.digitalfilmtools.com and download the tutorial images from the 
Power Matte download tab.

2 Double-click on the powermatte-ae-tutorial.zip file that you downloaded to 
uncompress it.

3 Start After Effects and double-click inside of the Project window.

Original Masks
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4 When the Import File window opens, navigate to the powermatte-ae-
tutorial/footage/dog folder, Shift-click both the dog.jpg foreground and 
dog_bg.jpg background files and click Open.

5 Create a Composition by clicking, dragging and dropping the two selected 
dog.jpg and dog_bg.jpg files on the Create a new Composition icon at the bottom 
of the Project window.

6 When the New Composition from Selection window opens, make sure Single 
Composition is selected and click OK.

A composition is automatically created wit the dog.jpg layer as the top layer in 

the Timeline.

7 Ctrl(Win)/Cmd(Mac)-click the dog_bg.jpg layer to deselect it.

Foreground Background
wer Matte User Guide
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A good Open Mask technique is to draw an inner and outer outline around the 

object you are extracting using open After Effects masks. Masks should be 

near the boundary of the foreground or background, but not right up against the 

edge. Also, if the foreground or background has varying colors, the masks 

should cross over these colors.

Note: The general rule is don’t put different mask types too close together unless you 
need to.

8 Select the Pen tool.

9 Create an open mask and define the area to be cutout by left-clicking around the 
inner edge of the dog. Do not close the mask.

Now, draw a mask to be define background areas.

10 Create a new open mask on the left side of the screen by first 
Ctrl(Win)/Cmd(Mac)-clicking once on the image in the Composition window and 
then proceed to left-click around the outside of the dog starting at the bottom of 
the image and ending at the top.
Power Matte User Guide    
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11 Using the technique in the previous step, create two more open masks on the 
right side of the screen so that your masks look something like below.

If the background has varying colors, the masks should cover these colors.

12 When you are done drawing your masks, choose the Selection tool and click 
once on the image in the Composition window so that all masks are deselected.

Warning: If you only provide a few sparse masks, the Open Mask Method will take 
longer to process with the result less accurate than the Closed Mask Method.

13 From the Effect pull-down menu, select Power Matte from the Digital Film Tools 
group.

When you apply Power Matte, nothing happens because you haven’t yet 

assigned the masks to the Power Matte Foreground and Background selectors.

14 In the Effect Controls, select Mask 1 from the Mask > Foreground pop-up menu 
and choose Mask 2 from the Mask > Background pop-up.

Good Mask Example Bad Mask Example
wer Matte User Guide
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Power Matte processes the matte. When it is done, you have probably noticed 

that the left side of the image looks good, but the right side remains 

unprocessed.

This is because Power Matte doesn’t know about the masks on the right side. 

Since only one mask can be selected in the Mask > Background pop-up menu, 

you need to link the background masks together by either the Mask Color or 

Mask Name. Masks that are linked together are considered as one and inherit 

the same adjustments. The name and color of the masks can be changed in 

the Timeline.

Note: Power Matte does not process automatically after the mask color or name is 
changed. If Link Masks > Mask Color or Mask Name is selected prior to the mask color 
or name being changed, you will need to press the Force Update button in the Effect 
Controls for Power Matte to process the change.

15 In the Timeline, click the right arrow next to the dog.jpg layer name and then the 
Masks heading to expand them.

16 Click on the color box to the left of the mask named Mask 1.

17 When the Color Picker opens, select a green color and press OK.

The inner foreground mask turns green. Now change the colors of the 

background masks.

18 Click on the name of Mask 2 to select it and then Shift-click both Mask 3 and Mask 
4 to add them to the selection.

19 Click on the color box to the left of the mask named Mask 2, select a red color 
and press OK.

All of the background masks change to a red color.
Power Matte User Guide    
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20 Back in the Effect Controls window, open the Options group and select Mask 
Color from the Link Masks pop-up.

Note: To link masks by color, the linked masks need to be the exact same color.

Power Matte re-renders and when done, you should have a result that looks 

like this.

Go to the Link Masks section on page 46 to see how to link masks by Mask 
Name.

21 If at any time you want to turn off the display of the masks, click in the gray area 
immediately outside of the image in the Composition window.

22 Now choose Matte in the View pop-up menu.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can either adjust the masks or add additional 

masks near the region where the matte is not accurate. If you need to adjust 

the masks after they have been created and assigned in Power Matte, you can 

enhance performance by either: 
wer Matte User Guide
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• Disable the Power Matte effect while adjusting the masks. To disable an effect, 
press the Effect switch (the “f” icon) at the top left of the Effect Controls window. 

• If Power Matte is enabled, set the Resolution/Down Sample Factor Popup at the 
bottom of the Composition window to something other than Full.

• In Preferences > Previews, set “Adaptive Resolution Limit” to 1/8 and “Accelerate 
Effects Using” to Adaptive Resolution. This will allow Power Matte parameter and 
mask editing to be snappier.

23 If you see gray areas in the foreground object that should be completely white, 
make additional foreground masks in those areas.

24 If you see gray areas in the background that should be completely black, make 
additional background masks in those areas.

25 Select View > Output to see the foreground composited over the background 
based on the generated matte.

If you look closely at the edges of the dog, you will see some white fringing 

created by the sky from the original image. By activating Power Matte’s Edge 

Color Estimation feature, the fringing can be removed by estimating the color 

of the foreground in unknown and semi-transparent areas.

Note: Edge Color Estimation can cause color flickering in edge areas of partial opacity 
if your mask position is not constant from frame to frame or if your source footage is 
grainy. Disable Edge Color Estimation if you see flickering in the edge areas after a 
preview or render.

Edge Color Estimation Off Edge Color Estimation On
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26 Turn on Edge Color Estimation.

27 If you would like to load up the final After Effects project for this tutorial, you can 
open dog.aep from the powermatte-ae-tutorial/projects folder.

Original Composite
wer Matte User Guide
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Closed Mask Method
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown.

The Closed Mask Method uses closed After Effects masks to mark definite 

foreground and background areas of the image--an inner mask just inside the 

object (foreground), and an outer mask just outside the object (background). 

The area between the closed masks is considered unknown, so make sure that 

any blurry or unknown areas of the object fall within the two masks. Partial 

opacity values are then computed only for pixels inside the unknown region.

1 You may skip steps 2 and 3 if you have already completed the previous exercise.

2 Go to www.digitalfilmtools.com and download the tutorial images from the 
Power Matte download tab.

3 Double-click on the powermatte-ae-tutorial.zip file that you downloaded to 
uncompress it.

4 Start After Effects and double-click inside of the Project window.

5 When the Import File window opens, navigate to the powermatte-ae-
tutorial/footage/hiker folder, select hiker.0001.jpg and click Open.

6 Double-click on the hiker.[0001-0015].jpg sequence in the Project window and 
click the Play icon in the Time Controls to see what the clip looks like.

7 When you are done playing the clip, hit the Spacebar to stop playback and close 
the Footage window.

Original Masks
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8 Create a Composition by clicking, dragging and dropping the hiker.[0001-
0015].jpg sequence on the Create a new Composition icon at the bottom of the 
Project window.

A good Closed Mask technique is to draw an inner and outer outline around the 

object you are extracting using closed After Effects masks. Masks should be 

near the boundary of the foreground or background, but not right up against the 

edge. Also, if the foreground or background has varying colors, the masks 

should cross over these colors.

Note: Make sure that the inner and outer masks are only over areas of solid foreground 
or background and not over any semi-transparent areas.

9 Select the Pen tool.
wer Matte User Guide
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10 Define the area to be cutout by left-clicking to create a mask around the inner 
edge of the hiker. To close the mask, click on the first point that you created.

Once the mask is closed, the area outside the mask turns black because the 

Mask Mode is set to Add. If the Mask Mode is set to None, you will be able to 

see the entire image, making animating the mask much easier. There are a 

number of ways to change the Mask Mode, but we will use the Timeline 

method.

11 In the Timeline, click the right arrow to the left of the hiker.[0001-0015].jpg layer 
name to expand it.

12 Click the right arrow next to the Masks heading to expand it and to reveal the 
mask on that layer.

13 Change Add to None.
Power Matte User Guide    
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The entire image is now visible.

Next, draw a mask to be define the background area.

14 Create another closed mask to define the background area, this time around the 
outer edge of the hiker. To close the mask, click on the first point that you 
created.

Once again, as soon as the mask is closed, the area outside the mask turns 

black because the Mask Mode is set to Add.

15 In the Timeline, change the Mask Mode from Add to None for Mask 2 so you can 
see the image area outside of the mask.

Now that you have a foreground and background mask, animate them over 

time so that they follow the motion of the hiker. To animate masks over time, 

you need to turn on the Time-vary Stop Watch icon for the Mask Shape 

parameter in the Timeline.
wer Matte User Guide
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16 Click the right arrow next to the Mask 1 name to expand it.

17 Press the Time-vary Stop Watch icon next to Mask Shape to activate keyframing.

18 Repeat the previous two steps for Mask 2.

19 Choose the Selection tool and go to different frames in the Timeline and adjust 
the masks as necessary.

The shape of the masks will now change over time.

20 Play through the Composition to make sure that the masks are properly 
following the hiker.

21 Once you are happy with your mask animation, position the Timeline at frame 1.

22 From the Effect pull-down menu, select Power Matte from the Digital Film Tools 
group.

When you apply Power Matte, nothing happens because you haven’t yet 

assigned the masks to the Power Matte Foreground and Background selectors.

23 In the Effect Controls, select Mask 1 from the Mask > Foreground pop-up menu 
and choose Mask 2 from the Mask > Background pop-up.

Power Matte processes the matte. Because there is not a background layer, the 

hiker is cutout and is displayed against black.
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24 If at any time you want to turn off the display of the masks, click in the gray area 
immediately outside of the image in the Composition window.

If you look closely at the edges of the hiker, you will see some white fringing 

created by the sky from the original image. By activating Power Matte’s Edge 

Color Estimation feature, the fringing can be removed by estimating the color 

of the foreground in unknown and semi-transparent areas.

25 To remove the white fringe around the hiker, turn on Edge Color Estimation.

Note: Edge Color Estimation can cause color flickering in edge areas of partial opacity 
if your mask position is not constant from frame to frame or if your source footage is 
grainy. Disable Edge Color Estimation if you see flickering in the edge areas after a 
preview or render.

26 Under the Composition window, click on the Show Channel icon and select 
Alpha.

Edge Color Estimation Off Edge Color Estimation On
wer Matte User Guide
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The Composition window displays the Alpha channel.

Note: If you have a layer below, a solid white screen will be displayed when you select 
Show Channel > Alpha. To see the generated matte in this configuration, use View > 
Matte from the Power Matte Effect Controls instead.

27 Select Composition > Preview > RAM Preview to check your results so far.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can adjust the masks. If you need to adjust 

the masks after they have been created and assigned in Power Matte, you can 

enhance performance by either: 

• Disable the Power Matte effect while adjusting the masks. To disable an effect, 
press the Effect switch (the “f” icon) at the top left of the Effect Controls window. 

• If Power Matte is enabled, set the Resolution/Down Sample Factor Popup at the 
bottom of the Composition window to something other than Full.

• In Preferences > Previews, set “Adaptive Resolution Limit” to 1/8 and “Accelerate 
Effects Using” to Adaptive Resolution. This will allow Power Matte parameter and 
mask editing to be snappier.

28 If you see gray areas in the foreground object that should be completely white, 
adjust the foreground mask in those areas.

29 If you see gray areas in the background that should be completely black, adjust 
the background mask in those areas.

30 Click on the Show Channel icon again and set it back to RGB.
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31 Click Play button to see the RGB image results.

32 If you would like to load up the final After Effects project for this tutorial, you can 
open hiker.aep from the powermatte-ae-tutorial/projects folder.

Original Result
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Blue/Green Screen Keying
Keying is a technique for blending two images, in which a color from one image 

is removed, or made transparent, revealing another image behind it. Either the 

Open or Closed Mask Method can be used when creating mattes for Blue or 

Green screen photography. Power Matte doesn’t require any specific color for 

the object to be photographed against, but blue and green screens will be 

referred to as these are the most common.

1 You may skip steps 2 and 3 if you have already completed the previous exercise.

2 Go to www.digitalfilmtools.com and download the tutorial images from the 
Power Matte download tab.

3 Double-click on the powermatte-ae-tutorial.zip file that you downloaded to 
uncompress it.

4 Start After Effects and double-click inside of the Project window.

5 When the Import File window opens, navigate to the powermatte-ae-
tutorial/footage/tv folder, select tv.0001.jpg and click Open.

6 Double-click on the tv.[0001-0015].jpg sequence in the Project window and click 
the Play icon in the Time Controls to see what the clip looks like.

Original

Masks
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7 When you are done playing the clip, hit the Spacebar to stop playback and close 
the Footage window.

8 Create a Composition by clicking, dragging and dropping the tv.[0001-0015].jpg 
sequence on the Create a new Composition icon at the bottom of the Project 
window.

Let’s start by creating some open masks. Masks should be near the boundary 

of the foreground or background, but not right up against the edge. Also, if the 

foreground or background has varying colors, the masks should cross over 

these colors.

9 Select the Pen tool.
wer Matte User Guide
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10 Create an open mask and define the area to be cutout by left-clicking around the 
outside of the television screen. This is the foreground or what we want to keep. 
Do not close the mask.

Now, draw a mask to define background areas. This would be the blue area 

within the television screen.

11 Create a new open mask within the blue area of the television screen by first 
Ctrl(Win)/Cmd(Mac)-clicking once on the image in the Composition window and 
and then proceed to left-click around the inside of the television starting at the 
bottom left cross and ending at the top left cross. Be sure that the mask 
intersects all of the crosses.

If the background has varying colors, the masks should cover these colors.

Now that you have a foreground and background mask, animate them over 

time so that they follow the motion of the television. To animate masks over 

time, you need to turn on the Time-vary Stop Watch icon for the Mask Shape 

parameter in the Timeline.

12 In the Timeline, click the right arrow next to the tv.[0001-0015].jpg layer name and 
then the Masks heading to expand them.

13 Click the right arrow next to the Mask 1 name to expand it.
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14 Press the Time-vary Stop Watch icon next to Mask Shape to activate keyframing.

15 Repeat the last two steps for Mask 2.

16 Choose the Selection tool, go to last frame in the Timeline and adjust the masks 
as necessary. 

The shape of the masks will now change over time.

17 Play through the Composition to make sure that the masks are properly 
following the television.

18 Once you are happy with your mask animation, position the Timeline at frame 1.

19 From the Effect pull-down menu, select Power Matte from the Digital Film Tools 
group.

When you apply Power Matte, nothing happens because you haven’t yet 

assigned the masks to the Power Matte Foreground and Background selectors.

20 In the Effect Controls, select Mask 1 from the Mask > Foreground pop-up menu 
and choose Mask 2 from the Mask > Background pop-up.

Power Matte processes the matte. Because there is not a background layer, the 

center of the television is cutout and is replaced with black.

21 If at any time you want to turn off the display of the masks, click in the gray area 
immediately outside of the image in the Composition window.
wer Matte User Guide
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When a foreground object has been photographed against a solid blue or green 

backdrop, the blue or green color can have a tendency to spill onto the 

foreground object. When extracting an object photographed against one of 

these colors, you may find it necessary to remove the blue or green spill. This 

is a process called Spill Suppression.

22 To remove the blue spill around the television, change the Spill Suppression > 
Screen Type parameter from None to Blue.

The blue spill is removed.

23 Under the Composition window, click on the Show Channel icon and select 
Alpha.

The Composition window displays the Alpha channel.

Note: If you have a layer below, a solid white screen will be displayed when you select 
Show Channel > Alpha. To see the generated matte in this configuration, use View > 
Matte from the Power Matte Effect Controls instead.

Spill Suppression Off Spill Suppression Off
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24 Select Composition > Preview > RAM Preview to check your results so far.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can adjust the masks. If you need to adjust 

the masks after they have been created and assigned in Power Matte, you can 

enhance performance by either: 

• Disable the Power Matte effect while adjusting the masks. To disable an effect, 
press the Effect switch (the “f” icon) at the top left of the Effect Controls window. 

• If Power Matte is enabled, set the Resolution/Down Sample Factor Popup at the 
bottom of the Composition window to something other than Full.

• In Preferences > Previews, set “Adaptive Resolution Limit” to 1/8 and “Accelerate 
Effects Using” to Adaptive Resolution. This will allow Power Matte parameter and 
mask editing to be snappier.

25 If you see gray areas in the foreground object that should be completely white, 
adjust the foreground mask in those areas.

26 If you see gray areas in the background that should be completely black, adjust 
the background mask.

27 Click on the Show Channel icon again and set it back to RGB.

28 Click Play button to see the RGB image results.

Result

Original
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29 If you would like to load up the final After Effects project for this tutorial, you can 
open tv.aep from the powermatte-ae-tutorial/projects folder.
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 POWER MATTE USER GUIDE

Description
Power Matte is an easy to use interactive image matting tool capable of 

extracting almost any object in an image--even if you are dealing with fine hair 

detail, smoke, or reflections. This extraction process creates what is known as 

a matte--essentially a black and white cutout. White matte areas are extracted, 

black areas not, and gray areas in between represent a level of transparency. 

Once a matte is extracted, the foreground object can be seamlessly composed 

onto a new background as well as apply filter and image corrections only within 

the area defined by the matte.

To work this magic, Power Matte iteratively estimates the transparency value 

for every pixel in the image, based on a small sample of foreground (what you 

want to cut out) and background (what you want to get rid of) pixels marked by 

defining simple masks on the image. Results show that compared with previous 

Before After

Matte Masks
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approaches, our method is more efficient and requires minimal effort to extract 

high quality mattes for foregrounds with significant semi-transparent regions. In 

addition, the foreground edge colors can be estimated in the semi-transparent 

areas to create a seamless composite.

Matte Creation
Power Matte uses open or closed After Effects masks to define the object you 

would like to isolate or extract. The masks can be loose--they don’t need to 

follow exactly around the edges. Areas not defined by masks are considered 

unknown areas and are automatically computed by Power Matte.

Trimaps
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown. Partial opacity values 

are then computed only for pixels inside the unknown region. Two trimap 

methods can be used: Open Mask or Closed Mask. When creating mattes, start 

with the Open Mask Method and move on to the Closed Mask Method if the 

results are not satisfying.

Power Matte uses After Effects masks, or alternatively an external matte 

source, to create the trimap that is then used to create the final matte.
Power Matte User Guide    
• 
• 
•
•
•



   Po

34 Power Matte User Guide

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Open Mask Method
Power Matte only requires a few open/unclosed After Effects masks to define 

foreground and background areas of the image when using the Open Mask 

Method. Areas not defined by masks are considered unknown areas with 

partial opacity values being computed between the areas marked by 

foreground and background masks.

Using the After Effects masks, Power Matte generates an intermediate matte 

result called a Trimap. White signifies solid foreground, black is complete 

background and gray is unknown area where Power Matte will compute partial 

opacity.

The Open Mask Method requires little user input, but when color ambiguity 

exists between the foreground and background, the Closed Mask Method may 

create a more accurate matte. In addition, the Open Mask Method will also take 

slightly longer to render as it requires an extra calculation step.

Masks Matte

Trimap
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Open Mask Method Tips & Tricks
• Make sure you draw enough foreground (what you want to cut out) and 

background (what you want to get rid of) masks. A good technique is to draw an 
open/unclosed inner mask within the object you are extracting and an outer, 
open/unclosed mask outside the object.

• The masks should be near the boundary of the object, but not right up against the 
edge. 

• If the foreground or background has varying colors, the masks should cover these 
colors.

• When viewing the matte, if you see gray areas in the foreground object that should 
be completely white, make additional foreground masks in those areas. If you see 
gray matte areas in the background that should be completely black, make 
additional background masks.

• The general rule is don’t put different mask types too close together unless you 
need to.

Warning: If you only provide a few sparse masks, the Open Mask Method will take 
longer to process with the result less accurate than the Closed Mask Method.

Good Mask Example Bad Mask Example
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Closed Mask Method
The Closed Mask Method uses closed After Effects masks to mark definite 

foreground and background areas of the image--an inner mask just inside the 

object (foreground), and an outer mask just outside the object (background). 

The area between the closed masks is considered unknown, so make sure that 

any blurry or unknown areas of the object fall within the two masks. Partial 

opacity values are then computed only for pixels inside the unknown region.

Closed Mask trimaps process slightly faster than Open Mask trimaps and can 

result in extracting a more accurate mask, most notably when color ambiguity 

exists between the foreground and background. However, they can be tedious 

to create and tend to fail for images with large portions of semi-transparent 

foreground where the trimap is difficult to create manually.

Masks Matte

Trimap
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Closed Mask Method Tips & Tricks
• First, define foreground areas by drawing a closed mask around the inside edges 

of the foreground (what you want to cut out).

• Next, define background areas (what you want to get rid of) by drawing a closed 
mask around the outside of the foreground. 

• Ideally, the unknown region, the area between the foreground and background 
masks, should only cover transparent pixels whose actual values are not 
completely foreground or background. In other words, the unknown region 
should be as thin as possible to achieve the best masking result.

Note: Large foreground objects take longer to process than small ones.
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After Effects Masks
Power Matte uses open or closed After Effects masks, or alternatively an 

external matte source, to create the trimap that is then used to compute the 

final matte.

Creating Masks

To create masks in After Effects:

1 Select the Pen tool and left-click to add mask points to the image in the 
Composition window.

2 To close a mask, click on the first point that you selected.

3 The easiest way to create multiple open masks in After Effects while the Pen tool 
is selected is to Ctrl(Win)/Cmd(Mac)-click on the image in the Composition 
window. The next time you left-click, a new mask is created.

Animating Masks
To animate masks so that they move over time, you need to turn on the Time-

vary Stop Watch icon for the Mask Shape parameter in the Timeline.

To animate a mask in After Effects:

1 Click the right arrow to the left of the layer’s name to expand it.

2 Click the right arrow next to the Masks heading to expand it, revealing all masks 
on that layer.

3 Click the right arrow next to the mask name to expand it.

4 Press the Time-vary Stop Watch icon next to Mask Shape to activate keyframing.

5 Go to different frames in the Timeline and adjust the mask.

The shape of the mask will now change over time.
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Linking Masks
You may have noticed that Power Matte only has one choice for the 

Foreground and Background mask selectors. So, you may ask, what if I want 

to use more than one mask to define the foreground or background? I’m glad 

you asked. Masks can be linked by either similar names or colors. Go to the 

Link Masks section on page 46 for more information.

Note: Refer to After Effects help for more information on creating and using masks.
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Parameters

Force Update
Forces Power Matte to process. Power Matte does not process automatically 

after the mask color or name is changed. If Link Masks > Mask Color or Mask 

Name is selected prior to the mask color or name being changed, you will need 

to use Force Update to process the change.

View
Chooses what to display in the Composition window.

Output
Displays the output of the Power Matte plug-in. Once masks have been 

assigned, the foreground is composited over the background based on the 

generated mask. If a background layer is not present below the foreground 

layer, the foreground is shown over black.
wer Matte User Guide



• 

Power Matte User Guide  41 

• 
• 
• 
•
•
•

Matte
Displays the final, generated matte.

Trimap
Displays the trimap matte.

Original
Displays the Foreground image.
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Mask

Foreground
Select the After Effects mask to be used to define foreground.

Background
Select the After Effects mask to be used to define background.

Holes
When using closed After Effects masks, the Holes mask selectors are used to 

specify holes within areas of a closed foreground mask. In the example below, 

green masks are foreground and red masks are background.

Foreground
Select the closed After Effects mask to be used to define the foreground area 

outside of the hole.

Background
Select the closed After Effects mask to be used to define the background area 

inside of the hole.

Hole
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To use more than one mask to define the foreground or background, you can 

link multiple masks together by either similar names or colors. Go to the Link 

Masks section on page 46 for more information.

Trimap
Instead of using After Effects masks, previously rendered external mattes can 

be used as the trimap source. When creating your external matte, assign black 

to background areas, white to foreground areas and 50% gray to unknown 

areas. Power Matte will then properly compute the matte.

Note: Enabling the Trimap control overrides masks assigned to the Masks > 
Foreground and Background selectors.

Layer
Selects the layer to use as the trimap source.

Channel
Chooses which channel from the selected layer to use for the trimap.

Alpha
Selects the Alpha channel.

Red
Selects the Red channel.

Green
Selects the Green channel.

Blue
Selects the Blue channel.

Original External Matte
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Edge Color Estimation
Estimates the color of the foreground in unknown and semi-transparent areas. 

Edge Color Estimation is off by default and when activated, prevents fringing to 

create a seamless composite. When disabled, a foreground object with 

transparent edges against a bright or dark background will have bright or dark 

edges in the composite.

Note: Edge Color Estimation can cause color flickering in edge areas of partial opacity 
if your mask position is not constant from frame to frame or if your source footage is 
grainy. Disable Edge Color Estimation if you see flickering in the edge areas after a 
preview or rendering.

Off On
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Spill Suppression
When a foreground object has been photographed against a solid blue or green 

backdrop, the blue or green color can have a tendency to spill onto the 

foreground object. When extracting an object photographed against one of 

these colors, you may find it necessary to remove the blue or green spill. This 

is a process called Spill Suppression. 

Screen Type
Selects whether blue or green is suppressed from the foreground image.

Amount
Suppresses color spill in the foreground.The default value of 100 should be 

sufficient for most situations.

Range
Increases the range of areas that are color suppressed. If color spill is still 

evident, increase this value.

Edge
Suppresses the color spill of the unknown edge areas to the color gray. This is 

useful for edges that contain a lot of neutral transparency like glass reflections.

Options
Various Power Matte preferences can be set by opening the Options group.

Off On
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Link Masks
Power Matte only has Foreground and Background mask selectors. If you want 

to use more than one mask to define the foreground or background, you will 

need to link the masks by either Mask Color or Mask Name. 

Mask Color
Masks of the same color will all be considered as the same mask as far as 

Power Matte is concerned. For instance, if you have selected a green colored 

mask using the Masks > Foreground selector, all green masks will contribute to 

the foreground computation. However, the color of the masks need to be 

exactly the same for this setting to work.

To change the color of a mask in the Timeline:

Mask are colored yellow by default. If you plan on linking masks together by 

their color, you will need to change the color of the masks.

1 In the Timeline, click the right arrow next to the layer name and then the Masks 
heading to expand them.

2 Click on the color box to the left of the mask name.

3 When the Color Picker opens, select a color and click OK.

Note: Power Matte does not process automatically after the mask color is changed. If 
Link Masks > Mask Color is selected prior to the mask color being changed, you will 
need to press the Force Update button in the Effect Controls for Power Matte to 
process the change.

Mask Name
Masks of a similar name will all be considered as the same mask as far as 

Power Matte is concerned. This is the default setting. For instance, if you have 

selected a Mask named Mask 1 using the Masks > Background selector, masks 

named Mask 1a, Mask 1b, Mask 1c, etc. will also contribute to the background 

computation. The masks must share a common prefix for this setting to work.

To rename a mask in the Timeline:

By default, masks are named Mask 1, Mask 2, Mask 3, etc. If you plan on 

linking masks together by their name, you will need to change their names.

1 In the Timeline, click the right arrow next to the layer name and then the Masks 
heading to expand them.

2 Click on the mask name to select it.
wer Matte User Guide



• 

Power Matte User Guide  47 

• 
• 
• 
•
•
•

3 Hit the Enter key and rename the mask.

Note: Power Matte does not process automatically after the mask name is changed. If 
Link Masks > Mask Name is selected prior to the mask name being changed, you will 
need to press the Force Update button in the Effect Controls for Power Matte to 
process the change.

Sensitivity
Sets the sensitivity of the Unknown areas. The higher the value, the more 

details are brought out.

Deartifact
Blurry artifacts can be generated in the matte while attempting to extract 

objects that have drop shadows, similar colors to the background or out of 

focus edges. Deartifact can be used to limit these artifacts and also works well 

to remove unwanted gray areas in the edges of the matte.

Accuracy
The accuracy of the generated matte can be increased with this control. When 

foreground and background masks are close together, setting the Accuracy to 

Higher or Full will result in a more accurate matte. It is best to work with Power 

Matte at the Accuracy setting that you will be rendering at.

Default
The Default accuracy will work for most images and will render faster than the 

other settings.

Higher
Higher results in better accuracy than the Default setting, but not quite as good 

as Full.

Full
Full will result in the most accurate matte, but will take longer to render.

Power Matte After Effects Tips and Tricks
There are a number of tips and tricks to streamline the use of Power Matte in 

After Effects.
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• If you need to adjust the masks after they have been created and assigned in 
Power Matte, you can either: 

•1) Disable the Power Matte effect while adjusting the masks. To disable an effect, 
press the Effect switch (the “f” icon) at the top left of the Effect Controls 
window. 

•2) If Power Matte is enabled, set the Resolution/Down Sample Factor Popup at 
the bottom of the Composition window to something other than Full.

•3) In Preferences > Previews, set “Adaptive Resolution Limit” to 1/8 and 
“Accelerate Effects Using” to Adaptive Resolution. This will allow Power 
Matte parameter and mask editing to be snappier.

• If the Edge Color Estimation parameter is active and if you see color flickering at 
the edge of your foreground object after previewing or rendering, disable Edge 
Color Estimation.
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