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 ABOUT THIS GUIDE

This User Guide is a reference for the zMatte keyer. You can read from start to 

finish or jump around as you please. This guide is available as an Adobe 

Acrobat file.

Copyright
No part of this document may be reproduced or transmitted in any form or by 

any means, electronic or mechanical, including photocopying and recording, 

for any purpose without the express written consent of Digital Film Tools.

Copyright © Digital Film Tools, LLC. 2014. All Rights Reserved

October 15, 2014

About Us
Digital Film Tools brings together the unbeatable combination of superior 

software designers, motion picture visual effects veterans, video editors and 

photographers. Add three Emmy Awards and experience in creating visual 

effects for hundreds of feature films, commercials and television shows and you 

have a recipe for success. The understanding of photography, film and video 

editing, and in particular visual effects, allows us to design productive and 

highly specialized software. Software that is useful as well as easy to use. Our 

products stand up to the rigors of production and are the culmination of many 

years of experience.

Our philosophy is to bring our visual effects tools and techniques to the 

masses. What was once found only in expensive high-end packages or existed 

as proprietary in-house tools, is now available to photographers, artists, 

designers, and video/film editors. Did I mention affordable? Our software 

doesn't cost an arm and a leg and won't break the bank.
atte User Guide



• 

zMatte  3 

• 
• 
• 
•
•
•

 ZMATTE

Introduction
zMatte is a full-featured keyer that is the result of our experience in creating 

hundreds of successful blue and green screen composites. Using proprietary 

matte extraction techniques, zMatte quickly and simply creates mattes with 

minimal parameters even if you are dealing with fine hair detail, smoke, or 

reflections. It is easy to use, yet provides the needed tools when faced with 

good, bad, or ugly shots — tools such as multiple matte creation, automatic spill 

suppression, sophisticated matte and edge manipulation, and color correction.

zMatte includes the following plug-ins to handle keying, matte generation and 

compositing: Color Suppress, DeArtifact, Edge Composite, Frame Averager, 

Holdout Composite, Keyer, Light Wrap, Matte Generator, Matte Repair, and 

Screen Smoother.

Before

After
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So, how does zMatte work? You tell it the type of color screen you are using 

and with a quick drag of the background and foreground sliders, you have a 

matte. If it looks good, you’re done. If not, there are tools to make it look right 

starting with DeArtifact controls, matte manipulators and spill suppression. 

DeArtifacting cleans up compression artifacts in DV and HD footage while blue 

or green spill can be removed separately from the foreground or its edge. For 

those really nasty blue and green screens, multiple mattes can be pulled and 

combined within zMatte and treated with Blur, Shrink and Wrap functions. Once 

the key is pulled, the foreground can be color matched to the background. You 

can then use Light Wrap to blend the foreground into the background by 

making the color of the background wrap into the foreground edges without 

completely losing the edge. To finish it off, there are tools to color correct, blur 

or mix only the edge of the key.

Simple matte extraction, de-artifacting, isolated color suppression, matte 

treatment, sophisticated color correction, light wrapping and edge tools are all 

you’ll need to make that perfect key.

Features
• Create mattes from blue, green, any color screen

• Multiple matte creation

• Matte shrink, blur and wrap functions

• DV and HD deartifacting

• Sophisticated color correction and suppression

• Light wrapping

• Edge tools to color correct or blur only the edge

• Integrated DVE

• Screen smoothing for unevenly lit blue and green screens

• Effectively composite fire, explosions and smoke

• 32 bit processing

• GPU Acceleration
atte User Guide
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Plug-Ins

Color Suppress
Removes either blue or green from an image. This is usually used to remove 

the blue or green light that commonly spills onto objects filmed in front of blue 

or green screens.

DeArtifact
DeArtifact is handy for cleaning up artifacts caused by DV and HD video 

footage. In fact, it is useful for cleaning up images that have aliased or jaggy 

edges.

Edge Composite
Edge Composite automatically generates an edge matte from an existing alpha 

channel and allows you to color correct or blur only the edge of the foreground. 

You can also mix the edge of the foreground with the background. This is very 

helpful for seamlessly integrating images as well as dealing with aliased 

mattes.

Frame Averager
The Frame Averager mixes frames together to create interesting motion 

effects. This plug-in is also useful for smoothing out film grain and video noise 

which can cause problems when pulling a key or generating a matte.

Holdout Composite
To add practical fire, explosions, smoke or other footage not containing an 

alpha channel, is normally a challenge. A normal Math Composite Add function 

would cause areas of the background to get brighter. This is bad. Using a key 

of some type would most likely generate unwanted, dark edges. This is also 

bad. Holdout Composite effectively composites images such as fire, explosions 

and smoke.

Keyer
zMatte is a full-featured keyer that is the result of our experience in creating 

hundreds of successful blue and green screen composites. Using proprietary 

matte extraction techniques, zMatte quickly and simply creates mattes with 

minimal parameters even if you are dealing with fine hair detail, smoke, or 
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reflections. It is easy to use, yet provides the needed tools when faced with 

good, bad, or ugly shots — tools such as multiple matte creation, automatic spill 

suppression, sophisticated matte and edge manipulation, and color correction.

Light Wrap
Light Wrap helps blend the foreground into the background by making the color 

of the background “wrap” into the foreground edges without softening the edge.

Matte Generator
The Matte Generator extracts and creates mattes using advanced matte 

extraction techniques. Methods of matte extraction are luminance, hue, 

saturation, average, red, green, blue, cyan, magenta, and yellow.

Matte Repair
Matte Repair grows, shrinks or blurs a matte. It also is handy for cleaning up 

impurities in the black or white areas of the matte.

Screen Smoother
Smooths out unevenly lit blue and green screens. By default, darker screen 

areas are brightened.
atte User Guide
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 INSTALLATION

1 Download zMatte at www.digitalfilmtools.com

2 Double-click on the file that was downloaded and run through the installation 
process.

3 When prompted, select the destination programs to install to. You can choose 
from After Effects, Avid, Final Cut Pro, Nuke, Premiere Pro and Vegas.

4 Start your program and apply a zMatte plug-in:

• After Effects: Apply a zMatte plug-in to a clip in the timeline from the Effects > DFT 
zMatte v4.0menu.

• Avid: Apply a zMatte plug-in to a clip in the timeline from the Effect Palette > 
DFT zMatte v4.0 group.

• Final Cut Pro: Select a clip in the timeline and apply a zMatte plug-in from the 
Effects > DFT zMatte v4.0 group.

• Motion: Drag a zMatte plug-in from the Library > Filters > DFT zMatte v4.0group to 
the image in the Canvas.

• Nuke: Apply a zMatte plug-in to a clip in the Node Graph by clicking the zMatte 
icon in the Toolbar.

• Premiere Pro: Apply a zMatte plug-in to a clip in the timeline from the Effects > 
Video Effects > DFT zMatte v4.0 group.

• Vegas: Apply a zMatte plug-in to a clip in the timeline from the Video FX > DFT 
zMatte v4.0 group. Please note that two track effects such as Holdout 
Composite, Keyer, and Light Wrap are accessed through the Composite Mode 
icon in the track controls and then navigating to the Custom > zMatte v4.0 
group.

After applying a zMatte plug-in, the activation window pops up. If the activation 

window does not automatically open, click License... at the bottom of the plug-

in’s parameters.

Note: In some OFX hosts, the License... button is located in the Options group.

5 Click License... at the bottom of the zMatte parameters and a dialog box pops up. 

6 If you purchased the software, select Activate zMatte and follow the instructions.

or 

Vegas Composite Mode Icon
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7 Select Request Trial Activation (Internet Required) and click Next to receive a 
fully functioning version of zMatte for the specified trial period. At the end of the 
trial period, zMatte reverts to a limited demo mode.

or

8 Select Run in Demo Mode and click Finish.

Note: In Demo Mode, a watermark is superimposed over the image.
atte User Guide
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 UNINSTALLING

Windows
From the Windows Start Menu, select Programs > Digital Film Tools > zMatte 

v4.0 > Uninstall zMatte.

Macintosh
Go to Applications/Digital Film Tools/zMatte v4.0 and double-click on Uninstall 

zMatte.
zMatte User Guide    
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 ACTIVATING, DEACTIVATING AND 
TRANSFERRING LICENSES

Activation Options

Internet Activate
Activates zMatte over the Internet.

Request License from Self-Service Website
If you do not have an Internet Connection on the computer where you want to 

run zMatte, use this option. The self-service website will generate a license file 

which you can then transfer to the desired computer.

Install a License File
Loads a license file obtained from the self-service website or received by email.

Note: If you experience an error when using Internet Activate, it is because you or your 
company uses a proxy server to access the Internet and/or your firewall is blocking our 
program’s access to the Internet. For proxy server users, select Advanced Options and 
enter the appropriate proxy server settings. For firewall users, open your firewall 
software and allow our software to access the Internet.

Deactivation Options
Once zMatte has been activated, you can access the Deactivation Options by 

selecting the License menu.

Internet Deactivate
Deactivates zMatte over the Internet and is only available if you initially 

activated over the Internet. Use this method to return your Product Code back 

to the activation server. You will then be able to use your Product Code to 

activate zMatte on another computer.

To deactivate zMatte:

1 Open the License menu.

• After Effects / Premiere Pro: Apply a zMatte plug-in and click on License at the 
bottom of the Effect Controls window.

• Avid: Apply a zMatte plug-in and click on License at the bottom of the Effect Editor.
atte User Guide
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• Final Cut Pro / Motion: Apply a zMatte plug-in and click on License at the bottom 
of the Inspector.

• OFX Hosts: Apply a zMatte plug-in and click on License... at the bottom of the 
zMatte effect controls.

2 Choose Internet Deactivate and click Next.

License Transfer
Your Product Code allows you to run zMatte on one computer at a time. 

However, you may transfer the license by deactivating on one computer and 

activating on another.

Internet Deactivate / Internet Activate is the preferred method of license 

transfer between computers, but is only available if you initially activated over 

the Internet and currently have Internet access. If you do not have Internet 

access, you will need to contact customer support to assist you in transferring 

the license.

To transfer a license:

1 Open the License menu.

• After Effects / Premiere Pro: Apply a zMatte plug-in and click on License at the 
bottom of the Effect Controls window.

• Avid: Apply a zMatte plug-in and click on License at the bottom of the Effect Editor.

• Final Cut Pro / Motion: Apply a zMatte plug-in and click on License at the bottom 
of the Inspector.

• OFX Hosts: Apply a zMatte plug-in and click on License... at the bottom of the 
zMatte effect controls.

2 Choose Internet Deactivate and click Next.

zMatte is now deactivated.

3 On the target computer, apply a zMatte plug-in, click License... at the bottom of the 
zMatte parameters and a dialog box pops up. 

4 Select Activate zMatte and follow the instructions.

zMatte will then activate on the new computer.
zMatte User Guide    
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 COMPOSITING ISSUES

With zMatte plug-ins that take over compositing in After Effects, Premiere Pro 

and Final Cut Pro, there are certain situations to be aware of.

After Effects
1 Holdout Composite and Light Wrap crop or pad the background input to the 

foreground resolution. The work around is:

• Solution: Precompose the layer that will be used as the foreground into a composition 
whose image size matches that of the layer to be used as the background or vise-versa.

2 Placing a Holdout Composite plug-in at the top of a composition will cover up 
anything going on below it. The work arounds are:

• Solution #1: Position Holdout Composite and its associated layers at the bottom of the 
layer stack.

• Solution #2: Precompose the layers being covered up into their own composition and 
use this new composition as the Background input to Holdout Composite.

3 If you have other plug-ins applied to a layer that you want to use in one of the 
input selectors, they will not be recognized. The work around is:

• Solution: Precompose the layer and its associated plug-ins into it’s own composition. 
The precomposed layer can then be used in one of the zMatte input selectors.

Premiere Pro and Final Cut Pro
1 Holdout Composite, Keyer, and Light Wrap require that the background image be 

the same resolution as the image they are being applied to. Otherwise, the color 
orange will be displayed in the viewer in Premiere Pro and in Final Cut Pro. The 
work around is:

• Solution: Create a new sequence that has the same settings as the footage, apply the 
effect within that intermediate sequence and then drop that sequence into the main 
editing timeline.
atte User Guide
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 ZMATTE TUTORIALS

Keyer

Applying the Keyer
After Effects / Avid / Final Cut Pro / Motion / Premiere Pro / Vegas

• To use the zMatte Keyer in layer based systems, the layers/tracks should be 
stacked in the following order from bottom to top: background and then 
foreground. 

• Apply the zMatte Keyer to the top foreground layer / track.

• In Vegas, the Keyer is accessed through the Composite Mode icon in the track 
controls and then navigating to the Custom > zMatte v4.0 group.

Note: The layer/track below the one that you applied zMatte to is automatically used 
as the background.

Nuke

• In Nuke, apply the Keyer to the foreground clip and then hook up the background.

Basic Blue and Green Screen Keying
1 Apply the zMatte Keyer.

2 Start by selecting Primary Matte from the View pop-up menu.

3 Set the Primary Matte > Extract On to Blue or Green Screen.

Vegas Composite Mode Icon
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4 Adjust the Primary Matte > Background slider so that the background areas are 
completely black.

5 Set the Primary Matte > Foreground slider so that the foreground areas are 
completely white.

6 When using DV or HD footage, it is useful to enable DeArtifact located at the top 
of the Keyer controls and then adjust the Horizontal Blur control.

DeArtifact is handy for cleaning up aliased or jaggy edge compression artifacts 

caused by DV and HD video footage.

7 If the edges of your matte need smoothing, use the Primary Matte > Shrink/Grow, 
Blur or Wrap parameters to take care of them.

8 Change the View menu to Output.

In Nuke, View > Output renders RGBA which by default is premultiplied. You can also 
use View > Composite to see the foreground composited over the background.
atte User Guide
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If you see any color spill from the blue or green screen, it can be eliminated 

using the Color Suppress controls.

9 In the Color Suppress group, adjust the Color Suppress > Amount, Range and 
Edge controls as needed.

Using Light Wrap
Light Wrap helps blend the foreground into the background by making the color 

of the background wrap into the foreground edges without completely losing 

the edge.

1 Apply the zMatte Keyer and create a blue or green screen key by adjusting the 
Primary Matte > Extract On, Background and Foreground sliders.

2 Assign the source for the Light Wrap:

After Effects / Premiere Pro

• Using the Light Wrap > Background pop-up menu, choose the layer/track to be 
used for the Light Wrap source.

Avid / Vegas

• The track below the current track is automatically used as the source for the Light 
Wrap.

Green Color Spill

Green Suppressed
zMatte User Guide    
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Final Cut Pro

• Click the drop zone to the right of the Light Wrap Background parameter, choose 
a clip, and press Apply Clip below the Viewer.

Motion

• Drag the image to be used as the Light Wrap source and place it onto the drop 
zone to the right of the Background parameter.

Nuke

• The background clip is automatically used as the source for the Light Wrap.

3 Adjust the Light Wrap > Brightness setting to the appropriate brightness.

4 Change the View to Light Wrap.

5 Using the Light Wrap > Wrap control, set the thickness of the Light Wrap.

6 Switch the View back to Output.

Inner / Outer Keying Technique
We like to use an inner / outer keying method that involves creating a Primary 

Matte which has gray values in the foreground’s edge. This will give a nice, 

smooth edge in the final composite. Next, the trick is to use the Secondary 

Matte to fill in any gray areas of the Primary Matte while retaining the gray 

Light Wrap Source

No Light Wrap With Light Wrap
atte User Guide
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values in the edge. You can do this by adjusting the Blur, Shrink/Grow and/or 

Wrap parameters of the Secondary Matte to retain the Primary Matte’s edge 

values.

1 Apply the zMatte Keyer.

2 Start by selecting Primary Matte from the View pop-up menu.

3 Set the Primary Matte > Extract On to Blue or Green Screen.

4 Adjust the Primary Matte > Background slider so that the background areas are 
completely black.

5 Set the Primary Matte > Foreground slider so that the matte has gray values, 
especially in the edges.

This Primary Matte will be used for the edges.

6 From the View menu, select Secondary Matte.

You can now see the Secondary Matte in the Viewer.

7 In the Secondary Matte group, click on the Enable checkbox.

8 Set the Secondary Matte > Extract On to the same setting as the Primary Matte.

9 Adjust the Secondary Matte so that the foreground is completely white and the 
background is completely black.

10 Switch the View menu to Combined Matte.

The Combined Matte view shows the combination of the two mattes.
zMatte User Guide    
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11 Adjust the Secondary Matte > Wrap parameter to pull back the hard edges of the 
Secondary Matte to reveal the gray edges of the Primary Matte.

Note: You could also use Secondary Matte > Shrink/Grow and Blur instead of or in 
conjunction with Wrap to blend the two mattes together.

12 Change the View menu to Output.

13 Use the Color Suppress, Light Wrap and Edge controls as needed to finish off 
your key.

Go to the Keyer plug-in for more information.
atte User Guide
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Color Suppress
1 Apply Color Suppress.

2 Choose either Blue or Green from the Suppress pop-up menu.

3 Adjust the Amount to set the proper level of color suppression.

 If color you want to suppress is still evident, increase the Range slider.

4 Set the Range control to your liking.

5 For edges that contain a lot of transparency like hair or reflections, you may want 
to suppress the color spill of the foreground edge to the color gray using the 
Edge parameter.

Note: The Edge control requires an Alpha channel.

Go to the Color Suppress plug-in for more information.
zMatte User Guide    
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DeArtifact
1 Apply DeArtifact.

Note: The DeArtifact parameters default to settings that are good for DV footage. If you 
are working at higher HD resolutions, you will want to increase the Horizontal and 
Vertical Blur settings.

2 Adjust Blur-Horizontal to remove any artifacting.

It is usually best to blur mostly on the horizontal axis.

3 Adjust Blur-Vertical if needed.

Go to the DeArtifact plug-in for more information.
atte User Guide
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Edge Composite
1 Apply Edge Composite:

After Effects / Final Cut Pro / Motion / Premiere Pro / Vegas

• To use Edge Composite, the layers/tracks should be stacked in the following 
order from bottom to top: background and then a foreground that is a RGB+Alpha 
image.

• Apply Edge Composite to the top foreground layer/track.

Avid

• To use Edge Composite in Avid Editing Systems, you can work with either two or 
three video tracks. When working with three tracks, the video tracks should be 
stacked in the following order from bottom to top: background, foreground and 
matte. When working with two tracks, the top track must contain a Matte Key 
(RGB+Alpha image).

• For a two track effect, apply Edge Composite to the track that contains the Matte 
Key. For a three track effect, apply Edge Composite to the track that has the 
matte.

• Depending on what is black and white in your matte, you may need to set the 
Alpha pop-up menu to a non-inverted selection. By default, Edge Composite 
inverts the matte to be compatible with the way Avid treats matte values in a Matte 
Key.

Nuke

• Apply Edge Composite to a RGB+Alpha clip and use a Merge node to put it over a 
background clip.

2 Change the View to Edge Matte. 

3 Using the Size control, set the thickness of the Edge Matte.

4 Switch the View back to Output.

5 Adjust the Color Correction, Blur and Opacity of the edge.

Go to the Edge Composite plug-in for more information.
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Frame Averager
1 Apply Frame Averager.

2 Set the Frames parameter to the amount of frames that you want to blend.

3 Set the Frame Window to either Past, Centered or Future to determine the 
positioning of the frame averaging window.

Go to the Frame Averager plug-in for more information.
atte User Guide
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Holdout Composite
Holdout Composite creates a luminance matte of the foreground and pastes it 

as black (or optionally as another color) over the background. You can adjust 

Black and White Clip of this luminance matte using the Matte controls.

1 Apply Holdout Composite:

After Effects / Premiere Pro

• To use Holdout Composite, the layers/tracks should be stacked in the following 
order from bottom to top: background and then foreground.

• Apply Holdout Composite to the top foreground layer/track.

• Using the Background pop-up menu, choose the layer/track to be used as the 
background.

Avid / Vegas

• To use Holdout Composite, the video tracks should be stacked in the following 
order from bottom to top: background and then foreground.

• Apply Holdout Composite to the top foreground track.

• In Vegas, Holdout Composite is accessed through the Composite Mode icon in the 
track controls and then navigating to the Custom > zMatte v4.0 group.

Final Cut Pro

• Apply Holdout Composite to a clip.

• Click the drop zone to the right of the Background parameter, choose a clip, and 
press Apply Clip below the Viewer.

Motion

• Apply Holdout Composite to a clip.

• Drag the image to be used as the background and place it onto the drop zone to 
the right of the Background parameter. 

Nuke

• Apply Holdout Composite to a foreground clip and then hook up a background 
clip.

2 Change the View to Matte.

Vegas Composite Mode Icon
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3 If needed, adjust the Matte > Black Clip to make blacks in the matte blacker.

4 If needed, adjust the Matte > White Clip to make whites in the matte whiter.

5 Change the View back to Output.

6 Choose either the Add, Screen or Lighten Blend mode. Add or Screen usually 
work best.

7 Set the Level control to your liking.

If the blacks in your composite look milky, it is usually because the foreground 

blacks are not entirely black. These impure black areas will be added to the 

background image as part of the Holdout Composite causing the final result to 

have milky blacks. You can improve milky blacks using Black Clip.

8 Use Black Clip if the composite’s blacks look milky.

Go to the Holdout Composite plug-in for more information.
atte User Guide
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Light Wrap
1 Apply Light Wrap:

After Effects / Premiere Pro

• To use Light Wrap, the layers/tracks should be stacked in the following order from 
bottom to top: background and then a foreground that is a RGB+Alpha image.

• Apply Light Wrap to the top foreground layer/track.

• Using the Background pop-up menu, choose the layer/track to use for the Light 
Wrap source.

Avid

• To use Light Wrap, you can work with either two or three video tracks. When 
working with three tracks, the video tracks should be stacked in the following 
order from bottom to top: background, foreground and matte. When working with 
two tracks, the top track must contain a Matte Key (RGB+Alpha image).

• For a two track effect, apply Light Wrap to the track that contains the Matte Key. 
For a three track effect, apply Light Wrap to the track that has the matte.

• Depending on what is black and white in your matte, you may need to set the 
Alpha pop-up menu to a non-inverted selection. By default, Light Wrap inverts the 
matte to be compatible with the way Avid treats matte values in a Matte Key.

Final Cut Pro

• Apply Light Wrap to a RGB+Alpha image.

• Click the drop zone to the right of the Background parameter, choose a clip, and 
press Apply Clip below the Viewer.

Motion

• Apply Light Wrap to a RGB+Alpha image.

• Drag the image to be used as the Light Wrap source and place it onto the drop 
zone to the right of the Background parameter.

Nuke

• Apply Light Wrap to a RGB+Alpha clip, hook up a background and then use a 
Merge node to composite the result.

Vegas

• To use Light Wrap, the layers/tracks should be stacked in the following order from 
bottom to top: background and then a foreground that is a RGB+Alpha image.
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• Apply Light Wrap to the top foreground layer/track. In Vegas, Light Wrap is 
accessed through the Composite Mode icon in the track controls and then 
navigating to the Custom > zMatte v4.0 group.

2 Change the View to Light Wrap.

3 Using the Wrap control, set the thickness of the Light Wrap.

4 Switch the View back to Output.

5 Adjust the Brightness setting to the appropriate brightness.

Go to the Light Wrap plug-in for more information.

Vegas Composite Mode Icon
atte User Guide
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Matte Generator
1 Apply the Matte Generator:

After Effects / Avid / Final Cut Pro / Motion / Premiere Pro / Vegas

• To use the Matte Generator, the layers/tracks should be stacked in the following 
order from bottom to top: background and then foreground.

• Apply the Matte Generator plug-in to the top foreground layer/track.

• The foreground items that you extract with the Matte Generator will automatically 
be composited over the background.

Note: The layer/track below the one that you applied the Matte Generator to is 
automatically used as the background.

Nuke

• Apply the Matte Generator to a clip and then use a Merge node to put it over a 
background.

2 Change your View to Matte 1 to see the matte values.

Whatever is white in the matte will be considered as foreground areas to be 

extracted and whatever is black will show through to the background.

3 Change the Matte 1 > Extract On parameter to create a matte based on a whatever 
image values you choose.

Extract On determines the image values that will be used to generate the matte.

4 Change the Matte 1 > Position parameter if you want to select different values to 
be used for the matte.

The Position control selects the image values to be used in the matte based on 

the Extract On setting. If the selection is created using Luminance, a high 

Position value shows the brightest image values as white values in the matte. 

A low Position value shows the darkest image values as white values in the 

matte.

5 Increase the Matte 1 > Range control to add more values to the matte. Decrease 
for less values.

Range increases or decreases the range of values in the matte. A low Range 

value indicates a narrow range of values. A high Range value indicates a large 

range of values included in the matte.

6 Adjust the Matte 1 > Black Clip and White Clip if you want to make the blacks 
blacker and the whites whiter.
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7 If the edges of your matte need smoothing, use the Matte 1 > Shrink/Grow, Blur 
or Wrap parameters to take care of them.

Up to five mattes can be extracted and combined. After extracting the first 

matte, you can extract new mattes with the controls in Matte sections 2-5 and 

choose the Blend mode by which they will be combined.

8 Change the View to Output to see the composite created with the generated 
matte.

Go to the Matte Generator plug-in for more information.
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Matte Repair
1 Apply Matte Repair:

After Effects / Final Cut Pro / Motion / Premiere Pro / Vegas 

• To use Matte Repair, the layers/tracks should be stacked in the following order 
from bottom to top: background and then a foreground that is a RGB+Alpha 
image.

• Apply Matte Repair to the top foreground layer/track.

Avid

• To use Matte Repair, you can work with either two or three video tracks. When 
working with three tracks, the video tracks should be stacked in the following 
order from bottom to top: background, foreground and matte. When working with 
two tracks, the top track must contain a Matte Key (RGB+Alpha image).

• For a two track effect, apply Matte Repair to the track that contains the Matte Key. 
For a three track effect, apply Matte Repair to the track that has the matte.

• Depending on what is black and white in your matte, you may need to set the 
Alpha pop-up menu to a non-inverted selection. By default, Matte Repair inverts 
the matte to be compatible with the way Avid treats matte values in a Matte Key.

Nuke

• Apply Matte Repair to a RGB+Alpha clip and then use a Merge node to put it over 
a background.

2 Change your View to Matte to see the matte values.

3 Set the Use pop-up menu for the image channel you want to repair.

Note: The Use parameter is not available in Avid Editing Systems. When applied to a 
Matte Key, the Alpha Channel is used, otherwise it uses the luminance of the RGB 
channels.

4 Adjust Black Clip if you want to make the blacks blacker.

5 Adjust White Clip if you want to make the whites whiter.

6 If the edges of your matte need smoothing, use the Shrink/Grow, Blur or Wrap 
parameters to take care of them.

If you applied Matte Repair to a RGB+Alpha image and there is a background 

layer/track below it, you can make adjustments and see the effect it has on your 

composite when the View is set to Output.

7 Change the View back to Output.

Go to the Matte Repair plug-in for more information.
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Screen Smoother
1 Apply Screen Smoother to a blue or green screen.

2 Choose either Blue Screen or Green Screen from the Matte > Extract On pop-up 
menu.

By default, darker screen areas are brightened.

3 Adjust the Color Correct > Brightness to smooth out the screen.

4 Set the other Color Correct parameters as needed.

5 If you would like to adjust different areas of the screen, move the Matte > Position 
and Range sliders.

The Position value pinpoints the exact blue or green screen values to be used 

in the matte, while the Range increases or decreases the range of values.

6 If you see noise developing as a result of the color correction, raise the Matte > 
Blur sliders.

Go to the Screen Smoother plug-in for more information.
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 GENERAL CONTROLS

There are some general controls that are common to all of the zMatte plug-ins. 

For simplicity they will be listed here.

View
The View pop-up menu chooses what image to view. The View menu choices 

below are from the Keyer and will change depending on the selected plug-in.

Output
The viewer displays the output of zMatte.

Foreground
The viewer displays the foreground clip.

Background
The viewer displays the background clip.

Combined Matte
The viewer displays the result of all mattes. 

Primary Matte
The viewer displays the Primary Matte.

Secondary Matte
The viewer displays the Secondary Matte.

Light Wrap
The viewer displays the background through the Light Wrap matte.

Edge Matte
The viewer displays the edge matte.

Note: When using zMatte with Avid editing systems and setting individual keyframes, 
the View menu is keyframed along with any other parameter that is set. Make sure that 
the View menu is set to Output before moving on to the next keyframe.
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Alpha (Avid Only)
Set the Alpha parameter to match Avid’s File Pixel to Video Mapping import 

settings used when importing a file. By default, RGB (0-255) Inverted is 

selected to match Avid’s default import settings.

RGB (0-255)
RGB (0-255) Inverted
YUV (16-235)
YUV (16-235) Inverted

GPU Rendering
Controls the quality of zMatte’s GPU accelerated rendering on your graphics 

card.

Default
The rendering quality is determined by the host application. For instance, if you 

are working in a 32 bit After Effects project, zMatte will render on the GPU in 32 

bit float.

16 bit float
Sets the rendering quality to 16 bit float. Requires half the memory of 32 bit float 

with no perceptible quality difference.

32 bit float
Sets the rendering quality to 32 bit float.

Note: If your host application is using an 8 bit project, float processing can be used to 
remove banding artifacts associated with 8 bit processing.

Disabled
Disables GPU rendering and renders on the CPU instead.
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 KEYER

Description
zMatte is a full-featured keyer that is the result of our experience in creating 

hundreds of successful blue and green screen composites. Using proprietary 

matte extraction techniques, zMatte quickly and simply creates mattes with 

minimal parameters even if you are dealing with fine hair detail, smoke, or 

reflections. It is easy to use, yet provides the needed tools when faced with 

good, bad, or ugly shots — tools such as multiple matte creation, automatic spill 

suppression, sophisticated matte and edge manipulation, and color correction.

Go to the Keyer Tutorial to see how it works.

Matte
Primary

Composite

FG BG

Matte
Secondary

Matte
Edge

Wrap
Light 
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Premultiply Result
In Nuke, the Keyer premultiplies the output by default.

DeArtifact
The DeArtifact parameters are handy for cleaning up artifacts caused by DV 

and HD video footage. In fact, they are useful for cleaning up foregrounds that 

have aliased or jaggy edges. 

When activated, a RGB to YUV conversion takes place so that you can blur 

only the U and V color channels. Since this is where most of the artifacting 

shows up, this has the effect of cleaning up the ratty edges encountered when 

keying DV or HD video footage. It is usually best to blur mostly on the horizontal 

axis.

Note: The DeArtifact parameters default to settings that are good for DV footage. If you 
are working at higher resolutions, you will want to increase the Horizontal and Vertical 
Blur settings.

DeArtifact
Activates DeArtifacting.

Blur-Horizontal
Prior to pulling the matte, the U and V color channels are blurred by a fast, 

quality blur along the X-axis.

Blur-Vertical
Prior to pulling the matte, the U and V color channels are blurred by a fast, 

quality blur along the Y-axis.

Before After
atte User Guide
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Gang
The horizontal and vertical slider values can be ganged together.

Primary Matte
zMatte can utilize up to two mattes in the creation of the final composite. If only 

one matte is needed, you would use the Primary Matte. When adjusting the 

Primary Matte, you should select Primary Matte in the View pop-up menu so 

you can see what you are doing.

Note: Keep in mind when creating your matte that wherever you see black in the matte, 
you will see background in the final composite. Wherever you see white in the matte, 
you will see foreground in the final composite--foreground being anything that is 
extracted from the blue or green screen.

Extract On
Extract On selects the type of matte extraction. Select whichever type isolates 

the desired values. A matte is extracted based on one of the following:

Blue Screen
Choose blue screen if you have a blue screen.

Green Screen
Choose green screen if you have a green screen.

Luminance
A matte is extracted based on the luminance of the image.

Hue
A matte is extracted based on the hue of the image. When adjusting the 

Position parameter, you are selecting different hues.

Saturation
A matte is extracted based on the saturation of the image.

Average
A matte is extracted based on the average of the image’s RGB values.
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Red
A matte is extracted based on the image’s red values.

Green
A matte is extracted based on the image’s green values.

Blue
A matte is extracted based on the image’s blue values.

Cyan
A matte is extracted based on the image’s cyan values.

Magenta
A matte is extracted based on the image’s magenta values.

Yellow
A matte is extracted based on the image’s yellow values.

Background and Foreground
When using the Extract On > Blue Screen or Green Screen settings, the 

Background and Foreground sliders are used while all other matte extraction 

methods use Position and Range.
atte User Guide
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Background
Sets the background value. The lower the value, the harder or blacker the 

matte will become in background areas 

It is best to set the Background value as high as possible, while at the same 

time making sure that the background is completely black.

Background / Position = 40

Background / Position = 80
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Foreground
Sets the foreground value. The higher the value, the harder or whiter the matte 

will become in foreground areas.

It is best to set the Foreground value as low as possible, while at the same time 

making sure that the foreground is completely white for any areas that should 

be opaque in the final composite.

Position and Range
When using matte extraction methods other than the Extract On > Blue Screen 

or Green Screen settings, Position and Range are used instead of Foreground 

and Background.

Position
The Position value pinpoints the values to be used in the matte. For a 

luminance extraction, a Position value of 100 would make a white matte of the 

highlights and a value of 0 would make a white matte of the shadows.

Foreground / Range = 0

Foreground / Range = 17
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Range
Increases or decreases the range of values in the matte. A low Range value 

indicates a narrow range of values. A high Range value indicates a large range 

of values included in the matte

Black Clip
Blacks in the matte are made blacker by increasing the value of the slider. As 

the slider value increases, more values are clipped to black. This is helpful for 

getting rid of unwanted gray areas in what should be the black part of the matte. 

White Clip
Whites in the matte are made whiter by increasing the value of the slider. As 

the slider value increases, more values are clipped to white. This is helpful for 

getting rid of unwanted gray areas in what should be the white part of the matte. 

Shrink/Grow
Shrinks or grows the matte. Negative values shrink and positive values grow 

the matte.

Blur-Horizontal
The matte is blurred by a fast, quality blur along the X-axis.

 Blur-Vertical
The matte is blurred by a fast, quality blur along the Y-axis.

Shrink/Grow = -5
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Gang
The horizontal and vertical slider values can be ganged together.

Wrap
Helps blend the foreground into the background by making the background 

"wrap" into the foreground edges without completely losing the edge. The edge 

of the foreground starts to become transparent.

Secondary Matte
Sometimes two mattes are needed to create a good key. zMatte allows you to 

create two different mattes and combine them with various Blend modes. 

Enable
Activates the Secondary Matte.

Horizontal and Vertical Blur = 10

Wrap = 30
atte User Guide
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Blend
Once a blend mode is selected, the Secondary Matte is combined with the 

Primary Matte. See Appendix A to see visual examples of how the different 

Blend Modes work.

Add
The Secondary Matte is added to the Primary Matte.

Subtract
The Secondary Matte is subtracted from the Primary Matte.

Multiply
Produces a result where there is a union of the Primary and Secondary Mattes.

Screen
This looks kind of like the Add blend mode, but highlights are retained as 

opposed to being burnt out.

Difference
Produces a result where a value exists in the Primary and Secondary Mattes, 

but not in both.

Darken
Compares the two mattes and takes pixels with the lower value.

Lighten
Compares the two mattes and takes pixels with the higher value.

Amount
Sets the opacity of the secondary matte.

The remaining parameters for the Secondary Matte are the same as the 

Primary Matte: Extract On, Background, Foreground, Position, Range, 

Shrink/Grow, Blur, and Wrap.

Color Suppress
Removes either blue or green spill from the foreground object.
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Color
Chooses the color to be suppressed and is automatically set based on the 

Primary Matte > Extract On > Blue Screen or Green Screen selections. 

Note: You can alternatively choose Foreground in the View menu and select the 
Suppress Color with the eyedropper.

Amount
Suppresses color spill in the foreground.The default value of 100 should be 

sufficient for most situations.

Range
Increases the range of areas that are color suppressed. If color spill is still 

evident, increase this value.

Edge
Suppresses the color spill of the foreground edge to the color gray. This is very 

useful for edges that contain a lot of transparency like hair or reflections.

Color Correct
The Color Correct parameters allow you to adjust the foreground image so that 

it matches your background.

Hue
Rotates the hue of the foreground.

Amount = 0 Amount = 100
atte User Guide
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Saturation
Adjusts the saturation of the foreground. Positive values saturate, negative 

values desaturate.

Brightness
Adjusts the luminance of the foreground. Positive values brighten, negative 

values darken.

Contrast
Adjusts the contrast of the foreground. Positive values increase contrast, 

negative values decrease contrast.

Gamma 
Adjusts the gamma of the foreground. The gamma adjustment leaves the white 

and black points the same and only modifies the values in-between. Positive 

values brighten the image, negative values darken the image.

Temperature
Adjusts the color of the foreground to be either warmer or cooler. Dragging the 

slider to the right makes the foreground cooler (bluer) and dragging the slider 

to the left makes the foreground warmer (redder).

Cyan/Magenta
Adds either Cyan or Magenta to the foreground. Dragging the slider to the right 

makes the foreground more magenta and dragging the slider to the left makes 

the foreground more cyan.

Red
Adds or subtracts red from the foreground.

Green
Adds or subtracts green from the foreground.

Blue
Adds or subtracts blue from the foreground.

Flash Amount 
Sets the opacity of the Flash Color. 
zMatte User Guide    
• 
• 
•
•
•



   zM

44 Keyer

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

The Flash parameters mix a color into the foreground image through the use of 

a standard eyedropper or color picker. The default color is white. What in the 

world is this for? It is a great way to add atmosphere to an element. Flash 

comes from the film term "flashing", which describes the optical process of 

lowering the contrast of an image by flashing it with light. In terms of a 

composite, you would pick a color off of the background image and selectively 

add that color into the foreground image. This has the effect of making the 

foreground element look as if it is receding into the distance.

Flash Color
Sets the opacity of the Flash Color.

Eyedropper 
The eyedropper allows you to pick colors directly off of the screen.

Color Picker 
Colors can be selected using a standard color picker.
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Light Wrap
Helps blend the foreground into the background by making the color of the 

background “wrap” into the foreground edges without completely losing the 

edge. 

This is accomplished by placing the background layer into a special matte and 

then combining it with the foreground. You can look at the Light Wrap element 

in the View menu.

Background
Selects what image to use as the source for the Light Wrap.

After Effects / Premiere Pro
Choose the layer/track to be used for the Light Wrap source.

Avid / Vegas
The track below the current track is automatically used as the source for the 

Light Wrap.

No Light Wrap With Light Wrap

Light Wrap Source
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Final Cut Pro
Click the drop zone to the right of the Light Wrap Background parameter, 

choose a clip, and press Apply Clip below the Viewer.

Motion
Drag the image to be used as the Light Wrap source and place it onto the drop 

zone to the right of the Background parameter.

Nuke
The background clip is automatically used as the source for the Light Wrap.

Brightness
Sets the brightness of the Light Wrap.

Wrap
Sets the size of the Light Wrap.

Edge
The Edge parameters allow you to color correct or blur only the edge of the 

foreground. You can also mix the edge of the foreground with the background. 

Before using the Edge tools, it is a good idea to take a look at your Edge Matte 

in the View Menu so that you can see what your edge actually looks like.

Size
Determines the size of the edge matte.

Edge = 1
atte User Guide
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Color Correct
The edge of the key can be color corrected. See the Color Correct controls for 

parameter descriptions.

Blur-Horizontal
The edge of the foreground is blurred by a fast, quality blur along the X-axis, 

but only in areas of the edge matte.

Blur-Vertical
The edge of the foreground is blurred by a fast, quality blur along the Y-axis, 

but only in areas of the edge matte.

Gang
The horizontal and vertical slider values can be ganged together.

Opacity
Mixes the foreground back to the background, but only in areas of the edge 

matte.

DVE
The DVE allows you to transform your foreground image using Position, Scale, 

Rotation, Corner Pin, Shear and Crop controls. Why the name DVE? DVE is an 

acronym for digital video effects and refers to a real-time image manipulation 

device which does pans, rotations, flips as well as various hardware-specific 

effects such as page turns or customized wipes. In the film and video post 

production industry, DVE is frequently used in reference to transforming the 

image in some way.

Crop
Top
Crops the foreground from the top down.

Bottom
Crops the foreground from the bottom up.
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Left 
Crops the foreground from left to right.

Right
Crops the foreground from right to left.

Corner Pin
The foreground can be corner pinned by adjusting the Corner Pin sliders as 

well as dragging the four points on the corners of the screen.

Note: On some host programs, you must highlight the effect title in the Effect Controls 
window to see the on-screen controls.

Upper-Left
Controls the X and Y position of the Upper Left Point.

Upper-Right
Controls the X and Y position of the Upper Right Point.

Lower-Right
Controls the X and Y position of the Lower Right Point.

Lower-Left
Controls the X and Y position of the Lower Left Point.
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Position
Offset-X
The horizontal position of the foreground.

Offset-Y
The vertical position of the foreground.

Scale
Scale-X
The horizontal scale of the foreground.

Scale-Y
The vertical scale of the foreground.

Gang
The horizontal and vertical slider values can be ganged together.

Rotate
In addition to the standard position and scale controls, the image can be 

rotated. Positive values rotate clockwise and negative values rotate counter-

clockwise.

Shear
Shear-X
Skews the image left and right.

Shear-Y
Skews the image up and down.

Anchor
Anchor-X
Defines the point on the X axis where the foreground will be positioned, rotated, 

scaled or sheared.
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Anchor-Y
Defines the point on the Y axis where the foreground will be positioned, rotated, 

scaled or sheared.

Show Point Controls
Displays point controls in Nuke. This is to workaround a Nuke bug where it 

shows point controls for any nodes that happen to be in the Node Graph, even 

when the node isn't active.
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 COLOR SUPPRESS

Description
Removes either blue or green from an image. This is usually used to remove 

the blue or green light that commonly spills onto objects filmed in front of blue 

or green screens.

Go to the Color Suppress Tutorial to see how it works.

Suppress

Blue
Suppresses blue.

Green
Suppresses green.

Color
Chooses the color to be suppressed and is automatically set based on the 

Suppress selection.

Note: You can alternatively select the Suppress Color with the eyedropper.

Before After
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Amount
Suppresses the color chosen from the Suppress pop-up menu. The default 

value of 100 should be sufficient for most situations.

Range
Increases the range of areas that are color suppressed. If the color you want to 

suppress is still evident, increase this value.

Edge
When an Alpha channel is present, Edge suppresses the color spill of the 

foreground edge to the color gray. This is very useful for edges that contain a 

lot of transparency like hair or reflections.

Note: The Edge parameter is not available on Avid Editing Systems.

Amount = 0 Amount = 100

Range = 0 Range = 10
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 DEARTIFACT

Description
DeArtifact is handy for cleaning up artifacts caused by DV and HD video 

footage. In fact, it is useful for cleaning up images that have aliased or jaggy 

edges. 

When activated, a RGB to YUV conversion takes place so that you can blur 

only the U and V color channels. Since this is where most of the artifacting 

shows up, this has the effect of cleaning up the ratty edges encountered when 

keying DV or HD video footage. It is usually best to blur mostly on the horizontal 

axis.

Note: The DeArtifact parameters default to settings that are good for DV footage. If you 
are working at higher resolutions, you will want to increase the Blur settings.

Go to the DeArtifact Tutorial to see how it works.

DeArtifact
Activates DeArtifacting.

Blur-Horizontal
The U and V color channels are blurred by a fast, quality blur along the X-axis.

Blur-Vertical
The U and V color channels are blurred by a fast, quality blur along the Y-axis.

Before After
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Gang
The horizontal and vertical slider values can be ganged together.
atte User Guide



• 

Edge Composite  55 

• 
• 
• 
•
•
•

 EDGE COMPOSITE

Description
Edge Composite automatically generates an edge matte from an existing alpha 

channel and allows you to color correct or blur only the edge of the foreground. 

You can also mix the edge of the foreground with the background. This is very 

helpful for seamlessly integrating images as well as dealing with aliased mattes

Go to the Edge Composite Tutorial to see how it works.

Size
Determines the size of the edge matte.

Color Correct
The edge of the composite can be color corrected. See the Color Correct 

controls for parameter descriptions.

Blur-Horizontal
The edge of the composite is blurred by a fast, quality blur along the X-axis, but 

only in areas of the edge matte.

Blur-Vertical
The edge of the composite is blurred by a fast, quality blur along the Y-axis, but 

only in areas of the edge matte.

Edge Matte Edge After
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Gang
The horizontal and vertical slider values can be ganged together.

Opacity
Mixes the foreground back to the background, but only in areas of the edge 

matte.
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 FRAME AVERAGER

Description
The Frame Averager mixes frames together to create interesting motion 

effects. This plug-in is also useful for smoothing out film grain and video noise 

which can cause problems when pulling a key or generating a matte.

Go to the Frame Averager Tutorial to see how it works.

Frames
Sets the amount of frames to be blended.

Frame Window
Determines the positioning of the frame averaging window.

Past
The frame averaging window uses past frames.

Centered
Centers the frame averaging window around the current frame.

Future
The frame averaging window uses future frames.

AfterBefore
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 HOLDOUT COMPOSITE

Description
To add practical fire, explosions, smoke or other footage not containing an 

alpha channel, is normally a challenge. A normal Math Composite Add function 

would cause areas of the background to get brighter. This is bad. Using a key 

of some type would most likely generate unwanted, dark edges. This is also 

bad. Holdout is a two-layer effect that effectively composites images such as 

fire, explosions and smoke. This plug-in first creates a luminance matte of the 

foreground and pastes it as black over the background. You then use one of the 

Blend modes to place the foreground over the “held out background”. 

Go to the Holdout Composite Tutorial to see how it works.

Background
Selects what image to use as the background.

After Effects / Premiere Pro
Choose the layer/track to use as the background.

Holdout After

Background Foreground
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Avid / Vegas
The track below the current track is automatically used as the background.

Final Cut Pro
Click the drop zone to the right of the Background parameter, choose a clip, and 

press Apply Clip below the Viewer.

Motion
Drag the image to be used as the background and place it onto the drop zone 

to the right of the Background parameter.

Nuke
Hook up the background clip in the Node Graph.

Blend
This selects the type of Blend mode to use for the composite. Go to Appendix 

A to see visual examples of how the different Blend Modes work.

Add
The pixels of the one image are added to another image.

Screen
This looks kind of like the Add blend mode, but highlights are retained as 

opposed to being burnt out.

Lighten
Compares two images and takes the pixels with the higher value.

Level
Sets the level of the foreground element.
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Black Clip
Blacks are made blacker by increasing the value of the slider. As the slider 

value increases, more values are clipped to black.

Note: Often times the black portion of an image is not entirely black. This becomes an 
issue if something like fire is shot against a black background. If the black is not entirely 
black, then these impure black areas will be added to the background image causing 
the final result to have “milky” blacks. 

Matte
Holdout Composite first creates a luminance matte of the foreground and then 

pastes it as black over the background. You can see the extracted matte with 

the View set to Matte.

Black Clip
Blacks in the matte are made blacker by increasing the value of the slider. As 

the slider value increases, more values are clipped to black. This is helpful for 

getting rid of unwanted gray areas in what should be the black part of the matte.

White Clip
Whites in the matte are made whiter by increasing the value of the slider. As 

the slider value increases, more values are clipped to white. This is helpful for 

getting rid of unwanted gray areas in what should be the white part of the matte.

Matte
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Holdout
Holdout Composite takes the luminance matte of the foreground and pastes it 

as black (or other color) over the background. You can see the matte pasted 

onto the background by dragging the Opacity slider to a value of 0.

Color
The Color parameter sets the color of the Holdout matte through the use of a 

standard eyedropper or color picker. The default color is black.

Note: There may be times when you want to select a color from the background as the 
Holdout color. This will appear to give the foreground color some atmosphere.

Opacity 
The opacity of the color.

Matte Background Paste Color
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 LIGHT WRAP

Description
Light Wrap helps blend the foreground into the background by making the color 

of the background "wrap" into the foreground edges without softening the edge. 

This is accomplished by placing the background layer into a special matte and 

then combining it with the foreground. You can look at the Light Wrap element 

in the View menu.

Go to the Light Wrap Tutorial to see how it works.

Background
Selects what image to use as Light Wrap source. 

After Effects / Premiere Pro
Choose the layer/track to use as the Light Wrap source.

Before After

Light Wrap SourceForeground Matte
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Avid / Vegas
The track below the current track is automatically used as the Light Wrap 

source.

Final Cut Pro
Click the drop zone to the right of the Background parameter, choose a clip, and 

press Apply Clip below the Viewer.

Motion
Drag the image to be used as the Light Wrap source and place it onto the drop 

zone to the right of the Background parameter.

Nuke
Hook up the background clip to be used as the Light Wrap source in the Node 

Graph.

Brightness
Sets the brightness of the Light Wrap.

Wrap
Sets the size of the Light Wrap.
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 MATTE GENERATOR

Description
The Matte Generator extracts and creates mattes using advanced matte 

extraction techniques. Methods of matte extraction are luma, hue, saturation, 

average, red, green, blue, cyan, magenta, and yellow. Up to 5 mattes can be 

extracted and combined using Blend modes.

Go to the Matte Generator Tutorial to see how it works.

Premultiply Result
In Nuke, the Matte Generator premultiplies the output by default.

 Matte 1
A matte is extracted to isolate areas of the image.

Before

After
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Extract On
Extract On selects the type of matte extraction. Select whichever type isolates 

the desired values.

A matte is extracted based on one of the following:

Luminance
A matte is extracted based on the luminance of the image.

Hue
A matte is extracted based on the hue of the image. When adjusting the 

Position parameter, you are selecting different hues.

Saturation
A matte is extracted based on the saturation of the image.

Average
A matte is extracted based on the average of the image’s RGB values.

Red
A matte is extracted based on the image’s red values.

Green
A matte is extracted based on the image’s green values.

Blue
A matte is extracted based on the image’s blue values.

Cyan
A matte is extracted based on the image’s cyan values.

Hue Matte
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Magenta
A matte is extracted based on the image’s magenta values.

Yellow
A matte is extracted based on the image’s yellow values.

Warning: Some matte extraction types may yield a noisy matte. For instance, the blue 
channel from film originated images contain most of the image’s grain.

Position
The Position value pinpoints the color values to be used in the matte. For a 

luminance extraction, a Position value of 100 would make a white matte of the 

highlights and a value of 0 would make a white matte of the shadows. In our 

flower image, look at how the matte varies for different Position values in a red 

matte extraction. When the Position is at a value of 100, the red flowers are 

shown as white in the matte..

When the Position is moved to 50, the red flowers turn black.

Position=100, Range=25

Position=50, Range=25
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Range
Increases or decreases the range of values in the matte. A low Range value 

indicates a narrow range of values. A high Range value indicates a large range 

of values included in the matte.

Black Clip
Blacks in the matte are made blacker by increasing the value of the slider. As 

the slider value increases, more values are clipped to black. This is helpful for 

getting rid of unwanted gray areas in what should be the black part of the matte.

Position=100, Range=50

Matte with No Black Clip                                 Black Clip=50
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White Clip
Whites in the matte are made whiter by increasing the value of the slider. As 

the slider value increases, more values are clipped to white. This is helpful for 

getting rid of unwanted gray areas in what should be the white part of the matte.

Shrink/Grow
Shrinks or grows the matte. Negative values shrink and positive values grow 

the matte.

Blur-Horizontal
The matte is blurred by a fast, quality blur along the X-axis.

Matte with No White Clip                               White Clip=50

Original

                    Shrink=-2                                              Grow=1.5
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Blur-Vertical
The matte is blurred by a fast, quality blur along the Y-axis.

Gang
The horizontal and vertical slider values can be ganged together.

Wrap
Wrap retains the definition of the matte edges while creating a smooth blend of 

transparency starting at the edge of the matte changing to fully opaque moving 

inward.

Invert
Off
Does nothing to the matte.

No Blur                                                   Blur=10 

No Wrap                                                 Wrap=15 
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On
Inverts the luminance values of the matte.

Matte’s 2-5
Up to five mattes can be extracted and combined. After extracting the first 

matte, extract new mattes with the controls in Matte sections 2-5 and choose 

the method by which they will be combined with a Blend mode. Matte’s 2-5 

share similar controls, so they will only be described once.

Enable
Activates Matte’s 2-5.

Blend
Select a Blend mode to combine each successive matte that is generated. Go 

to Appendix A for to see how the different Blend Modes work.

Note: You must first select a Blend mode before you can create a new matte in Matte’s 
2-5. 

Amount
Sets the opacity of the matte element.

The remaining parameters for Matte’s 2-5 are the same as Matte 1: Extract On, 

Position, Range, Clip, Shrink/Grow, Blur, Wrap and Invert.

Invert Off                                                 Invert On
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 MATTE REPAIR

Description
Matte Repair grows, shrinks or blurs a matte. It also is handy for cleaning up 

impurities in the black or white areas. Matte Repair has the same functionality 

as Matte Generator except it doesn’t have any parameters dealing with matte 

extraction.

Go to the Matte Repair Tutorial to see how it works.

Premultiply Result
In Nuke, Matte Repair premultiplies the output by default.

Use
Chooses the channel from the input image to use for the Matte Repair.

Alpha Channel
The Alpha Channel is used for the Matte Repair.

Red Channel
The Red Channel is used for the Matte Repair.

Green Channel
The Green Channel is used for the Matte Repair.

AfterBefore
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Blue Channel 
The Blue Channel is used for the Matte Repair.

Luminance
The average luminance of the RGB channels is used for the Matte Repair.

Note: The Use parameter is not available in Avid Editing Systems. When applied to a 
Matte Key, the Alpha Channel is used, otherwise it uses the luminance of the RGB 
channels.

Matte
Go to the Matte section in the Matte Generator plug-in to see how the Matte 

controls work.
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 SCREEN SMOOTHER

Description
Smooths out unevenly lit blue and green screens. By default, darker screen 

areas are brightened. 

When working with poorly lit blue and green screens, it is useful to apply the 

Screen Smoother prior to using the zMatte Keyer. This will result in a better key.

Go to the Screen Smoother Tutorial to see how it works.

Color Correct
The Color Correct parameters allow you to adjust the color of the blue or green 

screen based on an extracted matte.

Hue
Rotates the hue of the blue or green screen.

Saturation
Adjusts the saturation of the blue or green screen. Positive values saturate, 

negative values desaturate.

Brightness
Adjusts the luminance of the blue or green screen. Positive values brighten, 

negative values darken.

AfterBefore
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Contrast
Adjusts the contrast of the blue or green screen. Positive values increase 

contrast, negative values decrease contrast.

Gamma 
Adjusts the gamma of the blue or green screen. The gamma adjustment leaves 

the white and black points the same and only modifies the values in-between. 

Positive values darken the image, negative values lighten the image.

Red
Adds or subtracts red from the blue or green screen.

Green
Adds or subtracts green from the blue or green screen.

Blue
Adds or subtracts blue from the blue or green screen.

Matte

Extract On
Extract On selects the type of matte extraction.

Blue Screen
Choose blue screen if you have a blue screen.

Green Screen
Choose green screen if you have a green screen.

Position
The Position value pinpoints the blue or green screen values to be used in the 

matte. White values in the matte are the areas that will be adjusted by the color 

correction.

Range
Increases or decreases the range of values in the matte. A high Range value 

indicates a large range of values included in the matte.
atte User Guide



• 

Screen Smoother  75 

• 
• 
• 
•
•
•

Blur-Horizontal
The matte is blurred by a fast, quality blur along the X-axis resulting in a 

smoother, more even color correction.

Blur-Vertical
The matte is blurred by a fast, quality blur along the Y-axis resulting in a 

smoother, more even color correction.

Gang
The horizontal and vertical slider values can be ganged together.
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 APPENDIX A - BLEND MODES

Blend modes are used to combine images in a variety of different ways.

Add
The pixels of one image are added to another image.

Subtract
The pixels of one image are subtracted from another image.

Multiply
Produces a result where there is a union of pixels from two images.

Background                  Foreground                        Result

Background                  Foreground                        Result

Background                  Foreground                        Result
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Screen
This looks kind of like the Add blend mode, but highlights are retained as 

opposed to being burnt out.

Difference
Produces a result where a value exists in each image, but not in both.

Darken
Compares two images and takes the pixels with the lower value.

Background                  Foreground                        Result

Background                  Foreground                        Result

Background                  Foreground                        Result
zMatte User Guide    
• 
• 
•
•
•



   zM

78 Appendix A - Blend Modes

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Lighten
Compares two images and takes the pixels with the higher value.

Background                  Foreground                        Result
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