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 ABOUT THIS GUIDE

This User Guide is a reference for Silhouette and is available as an Acrobat 

PDF file. You can read from start to finish or jump around as you please.

Copyright
No part of this document may be reproduced or transmitted in any form or by 

any means, electronic or mechanical, including photocopying and recording, 

for any purpose without the express written consent of SilhouetteFX, LLC.

Copyright © SilhouetteFX, LLC 2011. All Rights Reserved

November 9, 2012

About Us
SilhouetteFX brings together the unbeatable combination of superior software 

designers and visual effects veterans. Add an Academy Award for Scientific 

and Technical Achievement, 3 Emmy Awards and experience in creating visual 

effects for hundreds of feature films, commercials and television shows and you 

have a recipe for success.
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 SILHOUETTE FEATURES

Roto
Silhouette allows you to quickly create sophisticated animated mattes using B-

Spline, Bézier or X-Spline shapes. Intelligent design and easy-to-use tools, 

such as variable edge softness on a point by point basis and realistic motion 

blur, assist you in creating complicated shape animations. Integrated motion 

tracking makes the normally tedious task of rotoscoping a breeze. 

Where did the term Rotoscope come from? A rotoscope was a mechanical 

device patented by Max Fleischer in 1917. It projected single frames of live 

action footage onto the animators drawing board. By simply tracing the 

projected shape, the animator could quickly produce incredibly lifelike 

drawings. With the passage of time, Rotoscoping or “Roto” for short has 

become a generic term for drawing shapes to extract, isolate or affect a portion 

of an image. It is tedious work, but it’s one of the most important parts of the 

visual effects process.

Roto Features
• Unlimited number of animated B-spline, X-Spline or Bézier shapes

• Stereoscopic rotoscoping workflow and tools

• Integrated Motion Tracker that can apply motion data to points or shapes

• Planar tracker provides automatic, markerless motion analysis and tracking

• Support for open or closed shapes

• Move, scale, rotate, shear, and corner-pin shapes and groups of shapes

• Point-by-Point variable edge softness 

• Realistic motion blur 

• Animation changes for one point or selected points across all keyframes

• Independent shape viewing and hiding

• User-definable names, colors, blurs and blend modes for each shape 

• Preview shape animation over image

• Shape import and export
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• Composite preview and rendering

• Support for video fields and 3:2 Pulldown

Paint
Paint is a high dynamic range 2D raster based paint system designed from the 

ground up to handle the demands of feature film and television production. 

Whether it’s image restoration, dustbusting, wire and rig removal or just plain 

paint, Silhouette provides simple and sensible tools to get the job done.

Paint Features
• Innovative non-destructive raster paint allows rotoscoping and keying changes 

without having to re-paint

• Paint on both stereo images simultaneously using an adjustable interocular offset 

• Black and White, Blemish, Blur, Clone, Color, Color Correct, Drag, Eraser, Grain, 
Mosaic, Repair and Scatter brushes

• Stereoscopic paint workflow and tools

• Sophisticated cloning interface

• Motion track, position, scale, rotate and corner-pin Clone sources

• Onion-Skin, Split Screen and Align tools to match up elements

• High dynamic range painting in Float, 16 bit and 8 bit

Effects
The Effects node allows you to apply the brushes available in the Paint node 

as filter effects to shapes or layers. Paint and shape features are tightly 

integrated to form an extremely powerful shape based effects tool. Not only can 

filters be animated, but they can be combined with animated shapes to take the 

drudgery out of everyday jobs.

Effects Features
• Black and White, Blemish, Blur, Color, Color Correct, Grain, Mosaic, Scatter and 

Scratch filters

• Assign filters to shapes and layers

• Animateable filter parameters
lhouette 4.5 User Guide
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Keying
Using proprietary matte extraction techniques, Silhouette’s Keyer and Power 

Matte modules are capable of extracting almost any object in an image quickly 

and simply even if you are dealing with fine hair detail, smoke, or reflections. 

They are easy to use, yet provide the needed tools when faced with good, bad, 

or ugly shots.

Keying Features
• Interactive image matting tool capable of extracting almost any object in an image

• DV/HD deartifacting

• Multiple matte creation

• Color suppression

• Sophisticated matte manipulation

• Generate mattes without blue or green screens

Architecture
• Node based workflow

• Stereoscopic viewing and editing

• Command-Line Rendering

• Scripting and Actions

• OpenColorIO Color Management

• OpenGL® accelerated animation engine

• Multi-processor support

• Proxy management for large image sizes

Compatibility
• File Formats: Cineon, DPX, IFF, JPEG, OpenEXR, PNG, SGI/RGB, QuickTime, TIFF 

and TARGA

• Export Autodesk®/Discreet® gMask, Elastic Reality®, Eyeon Fusion®, Nuke® and 
Shake® 4.x SSF shapes

• Import Commotion, Elastic Reality and Shake 4.x SSF shapes
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• Mask interchange with After Effects® using the Silhouette Shape Import/Export 
Plug-in

• Export After Effects, Autodesk/Discreet, Nuke and Shake 4.x trackers

• Import After Effects Corner-Pin, Nuke and Shake 4.x trackers

• Macintosh®, Windows®, Linux®
lhouette 4.5 User Guide
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 INSTALLATION AND LICENSING

Windows / Macintosh Standalone
1 Download the Silhouette software at www.silhouettefx.com

2 Double-click on the Silhouette installer file that you downloaded to begin the 
installation process.

The default installation folder on Windows systems is C:\Program 

Files\SilhouetteFX\Silhouette4. On Macintosh systems, the default installation 

folder is /Applications/SilhouetteFX/Silhouette4.

3 Start Silhouette on Windows systems by selecting Programs > SilhouetteFX > 
Silhouette4 > Silhouette v4 in the Windows Start menu.

or

4 Start Silhouette on Macintosh systems by going to the 
/Applications/SilhouetteFX/Silhouette4 folder and double-clicking on Silhouette.

5 A dialog box pops up when you run Silhouette.

6 If you purchased the software, select Activate Silhouette and follow the 
instructions.

or 

7 Select Request Trial Activation (Internet Required) and click Next to receive a 
fully functioning version of Silhouette for the specified trial period. At the end of 
the trial period, Silhouette reverts to a limited demo mode.

or

8 Select Run in Demo Mode and click Finish.

Note: In Demo Mode, a watermark is superimposed over the image and you will not be 
able to save projects or export shapes.
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Linux Standalone
1 Download the Silhouette software at www.silhouettefx.com

2 Open a Terminal window and change to the directory where you downloaded the 
file.

3 Type tar xvzf <name of file>

4 Change to the new directory that is created.

5 To install the Silhouette software, become root and run the “install.py” script by 
typing: ./install.py

Note: A Python installation is required to run the script.

The default installation folder on Linux systems is 

/opt/SilhouetteFX/silhouette4.

6 Open a new Terminal window and type silhouette to start the application.

7 A dialog box pops up when you run Silhouette.

8 If you purchased the software, select Activate Silhouette and follow the 
instructions.

or 

9 Select Request Trial Activation (Internet Required) and click Next to receive a 
fully functioning version of Silhouette for the specified trial period. At the end of 
the trial period, Silhouette reverts to a limited demo mode.

or

10 Select Run in Demo Mode and click Finish.

Note: In Demo Mode, a watermark is superimposed over the image and you will not be 
able to save projects or export shapes.
lhouette 4.5 User Guide
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Linux Modifier Key Configuration
When using the KDE or GNOME desktops, by default there is a Move Window 

modifier key combination set up, so that if you Alt-drag a window, it will move. 

This interferes with our Alt-drag capability in some tools, so you will want to 

disable this desktop feature.

KDE Desktop
1 Run the KDE Control Center.

2 Go to the Desktop/Window Behavior panel and select the “Actions” tab.

3 Down in the Inner Window, Titlebar & Frame area, change the “Modifier Key 
option from Alt to Meta.

GNOME Desktop
1 Run the Control Center in Preferences.

2 Select Windows.

3 Select Super (or “windows logo”). 

Linux Tablet Configuration
We require that proper tablet support is enabled in the X server. This part is left 

up to the user, as it is very distribution and version specific. This site can be 

used for more information: http://linuxwacom.sourceforge.net/index.php/all
Silhouette 4.5 User Guide    
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Activation

Internet Activate (Recommended)
Activates Silhouette over the Internet.

Request License from Self-Service Website
If you do not have an Internet Connection on the computer where you want to 

run Silhouette, use this option. The self-service website will generate a license 

file which you can then transfer to the desired computer.

Install a License File
Loads a license file obtained from the self-service website or received by email.

Note: If you experience an error when using Internet Activate, it is because you or your 
company uses a proxy server to access the Internet and/or your firewall is blocking our 
program’s access to the Internet. For proxy server users, select Advanced Options and 
enter the appropriate proxy server settings. For firewall users, open your firewall 
software and allow our software to access the Internet.

Deactivation
Once Silhouette has been activated, you can access the deactivate option by 

selecting the Help > License menu.

Internet Deactivate (Recommended)
Deactivates Silhouette over the Internet. Use this method to return your 

Product Code back to the activation server. You will then be able to use your 

Product Code to activate Silhouette on another computer.

Note: Internet Deactivate is only available if your computer was activated using 
Internet Activate. If the deactivate option is grayed out, please contact customer 
support.
lhouette 4.5 User Guide
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License Transfer
Your Product Code allows you to run Silhouette on one computer at a time. 

However, you may transfer the license by deactivating on one computer and 

activating on another.

Internet Deactivate / Internet Activate is the preferred method of license 

transfer between computers, but is only available if you initially activated over 

the Internet and currently have Internet access. If you do not have Internet 

access, you will need to contact customer support to assist you in transferring 

the license.

To transfer a license:

1 Select License from the Help menu.

2 Choose Internet Deactivate (Recommended) and click Next.

Silhouette is now deactivated.

3 On the target computer, select Activate Silhouette and follow the instructions.

Silhouette will then activate on the new computer.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

12 Installation and Licensing

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Floating License Installation
Silhouette can utilize either nodelocked or floating licenses. Nodelocked 

licenses are locked to a particular machine in contrast to floating licenses which 

can be used on different machines. A floating license is checked out of a 

dedicated license server when Silhouette is started and checked back in to the 

server when Silhouette is closed.

In order to connect to your license server, you will need to know the port 
number and hostname or IP address. This information is entered into the 
Silhouette Activation window > Advanced Options > License Server field.

Note: Please contact your system administrator if you do not know the port number and 
hostname or IP address. Silhouette ships with a default port of 4313, but you would use 
a different port number if you have defined a custom port.

Floating License Installation
1 Start Silhouette.

A dialog box pops up.

2 Select Advanced Options and click Next.

3 In the License Server field, type your port@host information and press Finish. 
Examples of how to enter the port@host would be 4313@big-server or 
4313@192.168.1.50.

Note: Silhouette now checks the SFX_LICENSE_SERVER environment variable 
before checking the state of the Advanced Options > License Server entry. If you have 
a large number of client machines that connect to a floating license server, you can now 
set the SFX_LICENSE_SERVER environment variable with the port@host as the 
value. Doing this will eliminate the need to enter the port@host in the Advanced 
Options window for each client machine.
lhouette 4.5 User Guide
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 TUTORIALS

Starting Silhouette
1 Start Silhouette on Windows systems by selecting Programs > SilhouetteFX > 

Silhouette4 > Silhouette v4 in the Windows Start menu.

or

2 Start Silhouette on Macintosh systems by going to the 
/Applications/SilhouetteFX/Silhouette4 folder and double-clicking on Silhouette.

or

3 Start Silhouette on Linux systems by opening a Terminal window and typing: 
silhouette 
Silhouette 4.5 User Guide    
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Importing and Replacing Media
Before you can start using Silhouette, media or footage has to be imported.

Importing Media
1 Select File > Import > Media.

or 

2 Double-click on an open space in the Project window. 

3 When the File Browser opens, navigate to the location of your image sequence.

We currently support the following file formats: Cineon, DPX, IFF, JPEG, 

OpenEXR, PNG, SGI/RGB, QuickTime, TIFF and TARGA.

Note: QuickTime is only available on operating systems that support it.

4 Select the first frame in the sequence and click on Open.

The entire sequence is imported into Silhouette.
lhouette 4.5 User Guide
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Replacing Media
1 In the Project window, right-click on a clip and choose Replace from the pop-up 

menu.

The File Browser opens.

2 Navigate to your clip, select it and hit the Open button.

The old clip is replaced with the new clip.

File Path Environment Variables
The Edit Source > Path and Result fields allow you to specify the file path with 

environment variables. You can replace parts of the Path field with a new path 

and/or environment variables, while the read-only Result field shows you the 

resulting path. If you don’t know what an environment variable is, skip this 

section as fast as you can.

Ok, now for some examples. Say you have some common media on a file 

server and you want to share the media between various OS types.

1 On my Windows computer, I would import the following media located at:    
C:\Media\footage\station\station.[0001-0032].tiff

To make my project cross-platform, I need to replace the C:\Media prefix with 

an environment variable which points to my “network media location”.

2 To do this, I right-click on the media in the Project window and select Edit 
Source.

3 In the Path field, I replace “C:\Media” with “$(MY_MEDIA)”, where MY_MEDIA is 
an environment variable I set using normal environment variable methods. 

On my Windows computer, MY_MEDIA points to C:\Media.

4 When I hit the Tab key, the Result field will expand the path string and show you 
the result, and in this case, the resulting path is the same one I started with.
Silhouette 4.5 User Guide    
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It scans that location for all 32 frames and finds them all, so it shows a green 

check. Now, let’s say I screw up. It wouldn’t be the first time.

5 I change $(MY_MEDIA) to $(YOUR_MEDIA), and YOUR_MEDIA isn't set as an 
environment variable. 

The Result field will change to “/footage\station\station.[0001-0032].tiff” and a 

yellow warning icon is displayed, because that path doesn't exist and the 

frames can't be found. Now, say my administrator has set up a new 

environment variable for this project, and defined “STATION_MEDIA” to be 

“C:\Media\tracking\station”. 

6 I type this into the Path field: $(STATION_MEDIA)\station.[0001-00032].tiff which 
would expand in the Result field to the same as before.

You can essentially replace your source footage path with pretty much anything 

you want, using environment variables.
lhouette 4.5 User Guide



• 

Tutorials  17 

• 
• 
• 
•
•
•

Creating Sessions
Once media is imported into Silhouette, a session has to be created. A session 

in Silhouette is where you do your work, whether it be rotoing shapes, creating 

mattes or painting images.

1 Highlight an image sequence in the Project window.

2 Choose File > New > Session or press Ctrl(Win)/Cmd(Mac)-N.

The image sequence settings are automatically imported into the Session 

settings.
Silhouette 4.5 User Guide    
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3 Activate the nodes that you would like to work with in your Silhouette session.

Silhouette internally is a node based system and different nodes are used for 

various functions. Currently, you can choose from Keyer, Roto, Paint, Effects 

and Composite nodes. By default, the Roto node is selected. Activate 

whichever nodes you will be using in your session. You can always add 

additional nodes to a session after it has been created by selecting Session > 

Settings from the pull-down menu at the top of the screen.

4 If you’d like, rename the session in the Name field and click OK.

Editing Sessions
Once you have created a session, you can change its settings at any time by 

using one of the three methods listed below. You will most likely edit a session 

to add additional nodes or change duration.

1 From the pull-down menu at the top of the screen, select Session > Settings.

or

2 Right-click on the name of the session in the Project window and choose Edit 
Session.

or

3 Press Ctrl(Win)/Cmd(Mac)-Shift-S. 

In either case, the Session window opens and you can change the settings. 

When the Edit Session window opens, make the desired changes.

4 In the Available Nodes area of the Edit Session window, add a unselected node 
to the session, for instance a Paint node.
lhouette 4.5 User Guide
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Cineon/DPX Log Session Workflow
To ensure that Cineon/DPX images display correctly, use the workflow outlined 

below.

Note: Silhouette tries to figure out whether a DPX file is logarithmic or linear based on 
the file’s header information. Sometimes the program used to create the DPX file writes 
the wrong information into the header causing Silhouette to think it is Logarithmic when 
it is Linear and vice versa. To explicitly set whether or not the file is Logarithmic or 
Linear, see Edit Source > Interpretation for more information.

Working in Linear Space
Our preferred Cineon/DPX Log workflow is to use linearized Cineon/DPX Log 

images in a Float session.

1 Load a Cineon or DPX image sequence and create a Float session.

2 Use the default Color Management > Cineon/DPX Working Space preference 
setting of Linear.

This converts log Cineon/DPX files to scene linear.

3 Make sure that the Display Options icon is enabled in the Viewer.

Silhouette automatically tries to determine the colorspace based on the data in 

the file and other information from the header. If a colorspace can’t be detected, 

Linear will be selected.

4 In the Color Management toolbar located below the Display Options icon, make 
sure that the Colorspace is Linear and the View Xform is sRGB.

These settings will ensure that the linearized Cineon/DPX images will look 

correct in the Viewer. If you’d like, you can also adjust the Gain (exposure) and 

Gamma of the image.

5 To adjust the brightness of the image in the Viewer, use the Viewer > Display > 
Gain and Gamma settings.
Silhouette 4.5 User Guide    
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Working in Log Space
If you would like to work with Cineon/DPX images in log space, you can bypass 

Silhouette’s Cineon conversion. This allows you to work with the raw 

Cineon/DPX files without a conversion.

1 Load a Cineon or DPX image sequence and create a Float session.

2 Set the Color Management > Cineon/DPX Working Space preference setting to 
Log.

This keeps the Cineon/DPX files in log space.

3 Make sure that the Display Options icon is enabled in the Viewer.

Silhouette automatically tries to determine the colorspace based on the data in 

the file and other information from the header. If a colorspace can’t be detected, 

Linear will be selected. 

4 In the Color Management toolbar located below the Display Options icon, make 
sure that the Colorspace is Cineon and the View Xform is sRGB.

These settings will ensure that the log Cineon/DPX images will look correct in 

the Viewer. If you’d like, you can also adjust the Gain (exposure) and Gamma 

of the image.

5 To adjust the brightness of the image in the Viewer, use the Viewer > Display > 
Gain and Gamma settings.
lhouette 4.5 User Guide
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Video Fields and 3:2 Pulldown
When working with footage that contains video fields, you have the option of 

either deinterlacing or removing 3:2 Pulldown.

Working with Video Fields
1 Import some video media that contains fields and create a session.

2 Right-click on the imported clip in the Project window and select Edit Source.

3 Select Deinterlace from the Field Handling pop-up menu.

4 Choose Even (NTSC) or Odd (PAL) deinterlacing from the Field Dominance pop-
up menu.

5 Press the F button in the Timebar located at the bottom right of the Viewer to 
expand the Timeline and increment in half fields.
Silhouette 4.5 User Guide    
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6 Roto, paint or key objects while in field mode.

7 When it is time to render, select Field Handling > Interlace and Field Dominance 
> Even (NTSC) or Odd (PAL) in the Render Options window.

Working with 3:2 Pullup / Pulldown
1 Import some 3:2 based media and create a session.

2 Step through the beginning of your clip and determine the first field blended 
frame using the 3:2 Pullup setting in the chart below.

3 Right-click on the imported clip in the Project window and select Edit Source.

4 Select the appropriate 3:2 setting from the Field Handling pop-up menu.

First frame with field blending 3:2 Setting

1 BC

2 BB

3 AA

4 DD

5 CD
lhouette 4.5 User Guide
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5 Choose Even (NTSC) or Odd (PAL) deinterlacing from the Field Dominance pop-
up menu.

6 When you choose the 3:2 value, the length of your clip changes in the Project 
Window.

7 Change the Session > Settings to reflect the new clip length.

8 When it is time to render, select the desired Field Handling > 3:2 setting and Field 
Dominance > Even (NTSC) or Odd (PAL) in the Render Options window.
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Using the Node List
Silhouette internally is a node based system and different nodes are used for 

various functions. Currently, there are Keyer, Power Matte, Roto, Paint, Effects, 

Composite, Output and Source nodes. The Node List is used to select nodes 

for editing, viewing, enabling or disabling.

1 Create a session with Keyer and Roto nodes.

The Keyer node is selected by default since it is first in the order of processing.

2 Click on or near the Roto node’s icon to make it the active node. You can tell 
which node is active by its highlighted state.

Once active, the Roto node’s parameters appear in the Node window and the 

appropriate tools show up in the Toolbar.

The nodes that you see in the Node List are those that were previously selected 

when creating the session. You can always add additional nodes to a session 

after it has been created by selecting Session > Settings from the pull-down 

menu at the top of the screen.

3 Select the View icon for the Keyer. 

The Viewer switches to show the output of the Keyer, but the tools and controls 

remain for the Roto node since it is the active node.

4 Reactivate the View icon for the Roto node.
lhouette 4.5 User Guide
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You may want to selectively disable certain nodes to speed up your interaction. 

If you will be rotoing for an extended period of time and don’t what the speed 

hit of the Keyer processing on every frame, you can disable it.

5 Click on the Enabled icon for the Keyer to disable it.

6 When you are ready to render, enable the Keyer.
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Shifting a Source Node in Time
You can shift a Source node in time. This is useful for lining up frames that are 

numbered differently.

1 In the Node List window, select the Source node.

Once active, the Source node’s parameters appear in the Node window.

2 Drag the Time Shift slider to the desired value or enter a number in the field on 
the right.

The start frame for the node is adjusted by the Time Shift value.
lhouette 4.5 User Guide
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Viewer

Color Management
Silhouette uses the OpenColorIO standard originally developed by Sony 

Pictures Imageworks for it’s color management. You can load custom color 

configuration files and custom LUTs, apply colorspace conversions, as well as 

use other controls for fine tuning.

1 Make sure that the Display Options icon is enabled in the Viewer.

Silhouette automatically tries to determine the colorspace based on the data in 

the file and other information from the header.

2 If not set correctly, change the input colorspace of the current scene using the 
Colorspace pop-up menu.

When using Cineon/DPX images with the Color Management > Cineon/DPX 

Working Space preference set to Linear, the input colorspace should be set to 

Linear. When the preference is set to Log, the Cineon colorspace should be 

used.

3 If you are using a custom OCIO configuration, set the Display used to view the 
scene with the Display pop-up menu.
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4 Select the colorspace transform to apply to the scene from the View Xform pop-
up menu.

5 To adjust the brightness of the image in the Viewer, use the Viewer > Display > 
Gain and Gamma settings.

You can select a custom OpenColorIO (.ocio) configuration file by choosing it 

in the Color Management > OCIO Configuration preference.

For more information on OpenColorIO, including the OCIO file format, please 

visit http://opencolorio.org/.

Using the RGBA buttons in the Viewer
1 Click on the Red, Green, Blue or Alpha buttons to solo that channel as a gray 

scale image.

2 Ctrl(Win)/Cmd(Mac)-click the Red, Green or Blue channels to toggle the display 
of each component.

If only one component is selected, it is displayed in gray scale. The horizontal 

white bar above the RGBA buttons quickly toggles the display of the image 

back to full color mode.

3 Select the horizontal white bar above the RGBA buttons to quickly toggle the 
display of the image back to full color mode.

4 Either press the Alpha button (to the right of the blue button) or the A key to cycle 
the state of the Alpha display.

Note: To view a shape’s Alpha channel, you must first set the View to Output before 
pressing the Alpha button or A key.

Hitting the Alpha button or A key once superimposes the Alpha channel over 

the image. Pressing a second time displays the Alpha channel over black. 

Hitting again shows only the color image. 
lhouette 4.5 User Guide

http://opencolorio.org/


• 

Tutorials  29 

• 
• 
• 
•
•
•

Shift-A activates RGBA mode which does the following: Toggles the View to 

Output, superimposes the Alpha channel over the image and deactivates the 

Overlay. Pressing Shift-A again returns the Viewer to its previous state.

Viewer Navigation
Zooming

1 Select a value between 25% and 200% in the Zoom pop-up menu.

or

2 Use the scroll wheel on your mouse to zoom in and out of the image.

or

3 Press Space Bar-Shift and drag left or right.

or

4 Use the I key to zoom in and the O key to zoom out.

Zoom and Centering Presets
1 Press the F keyboard shortcut or select Fit from the zoom pop-up window to 

display the image as large as possible within the Viewer window.

2 Press the H keyboard shortcut or double-click the middle mouse button to set 
the image to a 100% zoom level and center it in the Viewer.

3 Press Ctrl(Win)/Cmd(Mac)-F to center the selection in the Viewer.
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Optimizing Playback
There are number of ways to increase the amount of frames that can be played 

back in real time.

1 Select File > Preferences on Windows and Linux or Silhouette > Preferences on 
Mac.

2 Increase the %Total Physical RAM parameter in the Cache preferences (requires 
a restart of Silhouette to take effect). Please note that setting the % Total Physical 
RAM too high could cause instability if running other memory intensive 
programs.

and / or

3 Change your View from Output to Foreground.

and / or

4 Shorten the length of the clip by adjusting the First and Last Frame in the 
Timebar.

and / or

5 Change the proxy setting to 2:1, 3:1 or 4:1.

and / or

6 If you are working with film resolution files in a Float session, change the session 
depth to 8 bits while you work, then switch back to Float for rendering.

Note: When painting, do not use a proxy setting other than 1:1 and make sure that you 
remain at the Sessions original bit depth. Do not use steps 5 and 6 when painting.
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Roto Tips
Rotoscoping or “Roto” for short has become a generic term for drawing shapes 

to extract, isolate or affect a portion of an image. It is tedious work, but it’s one 

of the most important parts of the visual effects process. Within the Roto node, 

there are all the tools needed to make quick work of any Roto job.

Creating usable shape animations can be a bit tricky with the most common 

problem being edge chatter. Here’s a few tips to help you on your way.

Analyze the Sequence
View your sequence to determine the frame that requires the greatest number 

of points to create the shape. It is easier to draw your shape on the most 

complex frame as opposed to starting on a simpler frame and adding points 

later.

Select a Spline Type
In Silhouette, you can create B-Splines (also known as natural splines), X-

Splines, Bézier splines, Circles and Squares.

Create Shapes with Less Points 
Use as many points as needed to create the shape, but avoid using more than 

is necessary. The fewer the points, the easier it is to successfully animate the 

shape. Unnecessary shape complexity inevitably leads to inconsistency when 

editing points.

Create Multiple Shapes
Create multiple shapes to Roto complex objects. Drawing separate shapes for 

the major parts of an object give you finer control over motion especially when 

separate objects intersect with each other.

Edit the Shape in Groups
Try not to individually move points in a shape unless absolutely necessary. 

Moving points in groups will maintain consistency and eliminate edge chatter.
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Keyframe, Keyframe, Keyframe
By editing your shape at various frames in the sequence, Silhouette animates 

the shape in between those keyframes. This saves you work. Make as few 

keyframes as possible, but as many as needed so the shape properly follows 

the object that you are rotoing. For instance, on a 80 frame clip, start by adding 

keyframes at 1, 20 and 40. If more animation is needed, add keyframes at 10 

and 30. Get the idea? Creating too many keyframes will cause the shape to 

jitter or chatter.
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Roto Quick Start
For the inpatient among you, here’s a Roto quick start. For all others, Roto 

features are covered in more detail after this exercise.

1 Create a session that includes a Roto node and make sure that it is selected in 
the Node List.

When the Roto node is selected, a number of different tools are selectable from 

the Toolbar to the left of the Viewer.

2 View your sequence to determine the frame that requires the greatest number of 
points to create the shape. It is easier to draw your shape on the most complex 
frame as opposed to starting on a simpler frame and adding points later.

3 Select the B-Spline tool (B) from the Toolbar.

4 Click on the screen to create a control point.

A control point is created.

5 Add as many points as you like.

Transform

Reshape

B-Spline

Square

Circle

Feather

Tracker

X-Spline

Bézier

MultiFrame
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6 When finished adding points, click the first control point that you added to close 
the shape.

Use as many points as needed to create the shape, but avoid using more than 

is necessary. The fewer the points, the easier it is to successfully animate the 

shape.

Now that you have a shape, you can use either the Reshape or Transform tool 

to perform editing functions.

7 Select the Reshape tool (R).

The Reshape tool modifies shapes by adjusting their control points and 

tangents.

8 To move points, select one or more control points and drag the point or points to 
a new location. 

9 To add a new control point, Alt-click on a selected shape. 

10 To delete control points, select them and press the Delete key.

11 Go to various frames in your sequence and edit the shape using the Reshape 
tool.

As the shape is edited on different frames, a keyframe marker is shown in the 

Timebar to provide a visual display of where there are shape keyframes. The 

color of the markers is determined by the shape color. If multiple selected 

shapes have a keyframe on the same frame, the most recently selected 

object's color has precedence. 

Next, instead of modifying the shape’s control points, try modifying the entire shape.

12 Click on the Transform tool (T) in the Toolbar.

The Transform tool affects an entire shape or a group of shapes
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13 Select a shape and use one of the on-screen controls to modify it.

The Q, W and E keys allow you to quickly translate, rotate or scale selected 

shapes while using the Transform tool.

14 Press the Q key to activate translation mode, the W key for rotation mode or the 
E Key for Scale mode and click and drag to transform the selected shape. You 
must press the Q, W or E key, whichever one was selected, a second time to 
deactivate the mode.

Shortcut Action

Drag within large center circle Moves the layer

Shift-drag within large center circle Constrain layer movement horizontally or vertically

Drag the center square horizontal and 
vertical halfway points

Scales the layer horizontally or vertically

Drag a center square corner Proportionally scale the layer

Drag large center circle Rotate the layer

Ctrl(Win)/Cmd(Mac)-drag large center circle Rotates the layer with finer control

Drag small center circle Moves the Anchor point

Q Activates / Deactivates translation of selected layers

W Activates / Deactivates rotation of selected layers

E Activates / Deactivates scaling of selected layers

Q, W, E then Ctrl(Win)/Cmd(Mac) Translates, Rotates or Scales in finer increments
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Using the Bézier Tool
Bézier splines are defined by control points and tangents. The position of the 

two tangent handles control the amount of a point's curvature.

1 Select the Bézier tool (Shift-B) from the Toolbar.

2 Click on the image to place the first control point.

The starting control point is created and sets the direction of the shape’s path.

3 To extend the control point’s tangents, drag the cursor while keeping the mouse 
pressed.

Although you can use the Reshape tool to later change a shape’s look after 

drawing it, you can also use the same Reshape tool keyboard shortcuts to 

modify a shape while drawing it. See Adjusting Bézier Curves for more 

information on the various ways to change a control point’s tangents.

4 Click on the screen to add more control points.

5 When finished adding points, click the first control point that you added to close 
the shape.

Use as many points as needed to create the shape, but avoid using more than 

is necessary. The fewer the points, the easier it is to successfully animate the 

shape.
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Using the B-Spline Tool
In contrast to Béziers, B-Splines don’t use tangents and are created by only 

using control points. The position of the points, their intensity settings as well 

as their proximity to each other determine the curvature of the shape.

1 Select the B-Spline tool (B) from the Toolbar.

2 Click on the screen to create a control point.

A control point is created.

3 Add as many points as you like.

4 When finished adding points, click the first control point that you added to close 
the shape.

Use as many points as needed to create the shape, but avoid using more than 

is necessary. The fewer the points, the easier it is to successfully animate the 

shape.
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Using the X-Spline Tool
A X-Spline is an intuitive and easily editable spline format whereby it’s points 

can be of three different types: Cardinal, Corner or B-Spline.

1 Select the X-Spline tool (S) from the Toolbar.

2 Click on the screen to create a control point.

A control point is created.

3 Add as many points as you like.

4 When finished adding points, click the first control point that you added to close 
the shape.

Use as many points as needed to create the shape, but avoid using more than 

is necessary. The fewer the points, the easier it is to successfully animate the 

shape.

Cardinal Corner B-Spline
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Using the Square Tool
1 Select the Square tool (Shift-S) from the Toolbar.

2 Do one of the following:

• Click and drag in the shape of a square.

• To create a perfect square, hold down the Shift key while clicking and dragging in 
the shape of a square.

3 When you release the mouse button, a square shape appears.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

40 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Using the Circle Tool
1 Select the Circle tool (Shift-C) from the Toolbar.

2 Do one of the following:

• Click and drag in the shape of a circle.

• To create a perfect circle, hold down the Shift key while clicking and dragging in 
the shape of a circle.

3 When you release the mouse button, a circular shape appears.
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Working with Open Shapes
Open shapes are good for rotoscoping strands of hair or thin objects.

1 Select either the Bézier, B-Spline or X-Spline tool from the Toolbar.

2 Click on the screen to create a control point.

A control point is created.

3 Add as many points as you like.

4 When finished adding points, press the Esc key or switch to a different tool to 
finish the shape.

5 Select the open shape and in the Object window, adjust the Stroke Width to set 
it’s thickness.

Note: Open shapes can not be exported.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

42 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Using the Transform Tool
Once you draw a shape, there are various ways to modify it. As the object that 

you are attempting to Roto changes over time, you will need to adjust the shape 

so that it exactly matches the object. The Transform tool affects an entire shape 

or a group of shapes.

Shape Mode
The Transform tool Shape Mode allows you to position, move, scale, rotate, 

shear or corner-pin a shape or selection of shapes using the on-screen 

controls.

1 Click on the Transform tool (T) in the Toolbar.

2 Select a shape.

3 Use one of the on-screen controls to modify the shape. See the following 
tutorials for more detail on using the On-screen controls.
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Points Mode
The Transform tool Points Mode allows you to position, move, scale, rotate, 

shear or corner-pin a selection of points using the on-screen controls.

1 Using the Reshape tool (R), select multiple points on the shape.

2 In the Toolbar, click on the Transform tool twice (TT).

A bounding box with on-screen controls appears around the selected points 

instead of around the entire shape.

3 Use one of the on-screen controls to modify the shape. See the following 
tutorials for more detail on using the On-screen controls.

Moving Shapes
Shapes can be moved horizontally or vertically.

Note: The remainder of the Transform tutorials assume that the Transform tool Shape 
Mode is enabled in the Toolbar.

1 Make sure that the Transform tool (T) Shape Mode is enabled.

2 Select a shape or series of shapes.
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3 Drag on the outline of one of the shapes.

or

4 Press the Q key to activate translation mode and click and drag to move the 
shapes.

5 You must press the Q key a second time to deactivate translation mode.

To constrain movement along an axis:

1 Select a shape or series of shapes.

2 Press the Shift key while dragging the outline of a shape. The movement is 
constrained by the first direction (horizontal or vertical) that you drag in.

Nudging Shapes
Shapes can be nudged horizontally or vertically using the Arrow keys. One 

press of the Arrow key moves the shapes 1 pixel. Using the Shift key in 

conjunction with the Arrow keys moves the shapes 10 pixels.

1 Select a shape or series of shapes.

2 Use the Arrow keys to nudge the shapes.

Scaling Shapes
Scaling changes the size of the shapes.

1 Select a shape or series of shapes.

2 Drag any of the points on the shape bounding box.

or
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3 Press the E key to activate scaling mode and click and drag to scale.

Note: The position of the cursor when E is pressed sets the anchor point for the 
scaling.

To proportionately scale, hold down the Shift key when scaling.

4 You must press the E key a second time to deactivate scaling mode.

Rotating Shapes
Rotating changes the angle of the shapes.

1 Select a shape or series of shapes.

2 Ctrl(Win)/Cmd(Mac)-drag on a shape bounding box corner handle.

or

3 Press the W key to activate rotation mode and click and drag to rotate.

Note: The position of the cursor when W is pressed sets the anchor point for the 
rotation.

4 You must press the W key a second time to deactivate rotation mode.

Corner-Pinning Shapes
The corner points of a shape’s bounding box can be corner-pinned. For 

instance, you could fit the corners of a shape into the corners of a billboard.

1 Select a shape.

2 Alt-drag the corners of the shape’s bounding box.
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Shearing Shapes
Shapes can be sheared resulting in the shape being skewed horizontally or 

vertically.

1 Select a shape.

2 Ctrl(Win)/Cmd(Mac)-drag on the midpoints of a shape bounding box on either the 
horizontal or vertical axis.

Anchor Point
A shape rotates around its center point, but scales from the opposite handle. 

Moving the anchor point changes the center of rotation and scaling when using 

the on-screen controls.

1 Press the . (period key).

The Anchor Point is displayed on the screen.

2 Click and drag the Anchor Point to the desired location.

3 Select your shape and then rotate or scale it.

Notice how the shape rotates and scales around the Anchor Point.

Note: If more than one shape is selected, they will both rotate and scale around the 
Anchor Point. Turning off the Anchor Point with the . (period key) will cause the shapes 
to revert to rotating and scaling around their center points.

Copying and Pasting Shapes
Shapes can be cut(Ctrl(Win)/Cmd(Mac)-X), copied(Ctrl(Win)/Cmd(Mac)-C) 

and pasted(Ctrl(Win)/Cmd(Mac)-V).
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Deleting Shapes
A shape or selection of shapes can be easily deleted using none other than the 

Delete key.

1 Select a shape or set of shapes.

2 Hit the Delete key.
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Using the Reshape Tool
The Reshape tool (R) modifies shapes by adjusting their control points and 

tangents.

Note: The following tutorials assume that the Reshape tool has been enabled in the 
Toolbar.

Adding Control Points
Adding control points assists in tracing more detailed images.

1 Alt-click on a selected shape to add a new control point. 

Don’t click on an existing control point because it will move it instead.

Deleting Control Points
1 Select the control points and press the Delete key.

or

2 Right-click on a control point and select Delete from the Reshape pop-up menu.

Moving Control Points
1 Select one or more control points.

2 Drag the point or points to a new location. 

Nudging Points
Points can be nudged using the Arrow keys. One press of the Arrow key 

moves the points 1 pixel. Using the Shift key in conjunction with the Arrow 

keys moves the points 10 pixels.

1 Select a point or series of points.

2 Use the Arrow keys to nudge the points.

Numbering Points
All points or a selection of points can be numbered.

Numbering All Points
1 Go to File > Preferences > Shape on Windows and Linux or Silhouette > 

Preferences > Shape on Mac.
lhouette 4.5 User Guide



• 

Tutorials  49 

• 
• 
• 
•
•
•

2 Set the Number Points preference to All.

3 Click OK.

Numbers are now displayed next to all points.

Number One Point or a Selection of Points
1 In the Reshape tool, select one or more points.

2 Right-click on one of the selected control points and select Tag.

The points are now tagged for numbering.

3 Go to File > Preferences > Shape on Windows and Linux or Silhouette > 
Preferences > Shape on Mac.

4 Set the Number Points preference to Tagged.

5 Click OK.

Numbers are now only displayed next to tagged points.

Adjusting Bézier Curves
The length and direction of a control point’s tangents direct the curve through 

that control point.

Control points have two tangents that can extend from it. The path of the curve 

through the control point is determined by the length and orientation of the 

tangents. When you drag one tangent’s handle, the adjacent tangent moves as 

well.

1 Select a control point on a Bézier shape.

Tangent Handle

Tangent

Curve Join

Control Point
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2 Click and drag a tangent handle.

This adjusts the length of one tangent while retaining a fixed angle between the 

two tangents.

3 Ctrl(Win)/Cmd(Mac)-drag a tangent.

This adjusts both tangents simultaneously while retaining a fixed angle 

between the two tangents.

4 Alt-drag a tangent.

Only one tangent is moved which is useful for creating corners.

5 Right-click over a control point and select Linear, Corner or Cardinal.

Linear adjusts both tangents one quarter the distance and in the direction of 

their adjoining control points. Corner collapses both tangents to create a corner 

point. Cardinal creates a smooth point where the curve passes smoothly 

through it.

Extending Short Tangents 
Sometimes a control point’s tangents are so close together that trying to modify 

the tangent results in movement of the control point. If this is the case, you can 

force the tangents to move without affecting the control point.

1 Press the Alt key while dragging the tangent.

Only the tangent will move, leaving the control point unaffected.

Moving Curve Segments
Normally, you move control points to adjust the form of a shape, but you can 

also move the portion of the curve between control points.

1 Deselect all control points by clicking somewhere off the shape.
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2 Ctrl(Win)/Cmd(Mac)-drag a Bézier curve segment between control points.

Once you start dragging, the Ctrl(Win)/Cmd(Mac) key can be released.

Note: The surrounding tangents remain smooth, but if you want to keep adjacent 
tangents from moving, hold down the Alt key while dragging.

Adjusting B-Splines
B-Splines are created by only using control points and are simple to adjust. The 

position of the points, their weight settings as well as their proximity to each 

other determine the curvature of the shape. The weight (amount of pull on a 

point) decides how sharp or smooth it is. Silhouette employs variable weight 

intensities on a point by point basis.

1 Select a control point on a B-Spline shape.

2 Alt-drag the point to the right to create a corner point or Alt-drag to the left to 
create a smooth point.

or 

3 Alt-click to cycle through the preset weight settings of the point.

or

4 Right-click over a control point and select Corner or B-Spline.

Note: The Alt-click and pop-up menu preset weight settings for Corner and B-Spline 
can’t be animated.

Adjusting X-Splines
X-Splines are created by using control points and then adjusting their weight to 

coincide with one of the point types: Cardinal, Polygon or B-Spline. The point 

type can even be somewhere in between one point type and another.

1 Select a control point on a X-Spline shape.
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2 Alt-drag the point to the right. The tension of the point goes from Cardinal to 
Corner to B-Spline.

or 

3 Alt-click to cycle through the different point types.

or

4 Right-click over a control point and select Corner, Cardinal or B-Spline.

Converting B-Splines or X-Splines to Bézier Splines
You may convert your B-Splines or X-Splines to Bézier Splines at any time.

1 Select a B-Spline or X-Spline shape.

2 Select Edit > Spline > Convert to Bézier.

Once you select Convert to Bézier, a couple of things happen. The visibility of 

the B-Spline or X-Spline is toggled to off. A new Bézier Spline is created and is 

named the same as the B-Spline or X-Spline but has an * at the end of the 

name.

Note: The Bézier conversion of B-Splines that use extreme, variable weight 
adjustments will not exactly match the original B-Spline. Do not use extreme, variable 
weight adjustments if you are planning on converting the B-Spline to a Bézier.

Copying and Pasting Shapes
Selected shapes can be cut(Ctrl(Win)/Cmd(Mac)-X), 
copied(Ctrl(Win)/Cmd(Mac)-C) and pasted(Ctrl(Win)/Cmd(Mac)-V).

Breaking Shapes
In the Reshape tool, closed shapes can be opened using the Break option from 

the control point pop-up menu.

1 Select and right-click on a control point.

2 Choose Break from the pop-up menu.

The shape opens at the selected control point.

Note: Feather information will be removed once you break a shape.

Closing and Extending Shapes
Shapes can be closed or extended with just a few mouse clicks. It is necessary 

to use the Reshape tool to perform the following actions.
lhouette 4.5 User Guide



• 

Tutorials  53 

• 
• 
• 
•
•
•

Closing Shapes
1 Select one of the control points at the end of the shape.

2 Alt-click on the other end point to close the shape.

Extending Shapes
1 Select a control point at either end of an open shape.

2 Alt-click somewhere off the shape.

Joining Open Shapes
In the Reshape tool, open shapes can be joined together.

1 Select two open shapes.

2 Select one of the end points of the source shape by clicking on it.

3 Alt-click on one of the end points of the target shape.

The two shapes are now joined together as one.

4 Repeat steps 2 and 3 for the two remaining end points to close the shape.

Note: The target shape inherits the attributes of the source shape.
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Using the Feather Tool
The Feather tool creates variable edged blurs on a point by point basis.

1 Select the Feather tool (Shift-F) from the Toolbar.

2 To create a feather point, Alt-click on a selected shape and drag. 

3 To create a second feather point, Alt-click on the original curve and drag. 

4 To edit the feather point, click and drag on one of the outer points.

5 To delete a feather point, select it and press the Delete key.
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Using the MultiFrame Tool
The MultiFrame tool modifies the Transform and Reshape tools to allow you to 

make adjustments across all previously set keyframes or a selection of 

keyframes.

1 Select the MultiFrame tool (M) in the Toolbar.

A red outline is drawn around the Viewer to let you know that the MultiFrame 

tool is active. 

2 Drag the red ends of the MultiFrame range bar at the top of the Timeline to limit 
the keyframes affected by the MultiFrame tool.

3 Select either the Transform or Reshape tools, make a selection and modify the 
shape.

Only keyframes defined in the MultiFrame range are adjusted.
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Rendering Shapes to Channels
Shapes can be assigned to different channels of an image when rendering.

1 Create four shapes.

2 Select a shape and in the Object window, set the Channel parameter to Red.

3 Assign the other three shapes as Green, Blue and Alpha.

Now that you have assigned the shapes to different channels, you can visualize 

the results prior to rendering using View > Channels in conjunction with the Alt-

R, G, B and A shortcut keys.

4 Choose View > Channels.

5 Use the Alt-R, G, B and A shortcut keys to see which shapes are assigned to 
the various channels.

6 When ready, render shapes into the assigned channels with the Actions > 
Render Shapes to Channels action.

7 When the Render window opens, choose a file format that supports RGBA and 
set Save to Color+Alpha.
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Importing and Exporting Shapes

Exporting Shapes from Silhouette
Silhouette, Elastic Reality, Fusion, gMask (Combustion, Flint, Flame, Inferno), 

Nuke and Shake 4.x SSF shapes can all be exported. 

Notes
• To export shapes for use in After Effects, use the Silhouette Shape format. The 

Silhouette Shape Import/Export Plug-in is then required to import Silhouette 
Shapes into After Effects.

• If you are exporting using Nuke 6.2+ Shapes, there is an Input/Output > Nuke 6.2+ 
Shapes preference that allows you to change the behavior of how the nodes are 
created in Nuke. You can choose from: Embed all shapes in one node, Embed 
each shape in its own node, Embed each layer in its own node, and Embed each 
layer in its own node fully baked. For more information, see the Nuke 6.2+ Shapes 
preference.

1 Select the shapes that you want to export.

If you are exporting using the Silhouette Shapes format, you can also export 

layers.

Note: Open shapes can only be exported using the Silhouette shape format.

2 Choose File > Export and select the shape format that you would like to export to.

3 When the file browser opens, type a name and click OK to save the file.

A file is saved with the appropriate file extension.

After Effects Import and Export
Importing Silhouette Shapes into After Effects
The Silhouette Shape Import/Export Plug-in for After Effects is required to 

import Silhouette Shapes.

1 Start Adobe After Effects, open a project and select a layer in the Timeline.

2 From the After Effects File menu, select Import > Silhouette Shapes.

A file browser opens.
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3 Select the shape file to import and click OK.

The Silhouette Shape Import/Export Plug-in will import the shapes and convert 
them to After Effects masks. When importing Silhouette Shapes, the following 
shape parameters transfer into After Effects: opacity, blur, shape color, shape 
name, invert and locked states, transfer mode and per-shape motion blur state.

Exporting After Effects Masks to Silhouette Shapes
The Silhouette Shape Import/Export Plug-in for After Effects is required to be 

able to convert After Effects masks to Silhouette Shapes.

1 Start Adobe After Effects, open a project and select a layer in the Timeline that 
contains After Effects masks.

2 From the After Effects File menu, choose Export > Silhouette Shapes.

A file browser opens.

3 Type a name and press OK to save the file.

All After Effects masks from the selected layer are exported and a file is saved 

with a .fxs file extension. When exporting After Effects masks, the following 

shape parameters transfer into Silhouette: opacity, blur, shape color, shape 

name, invert and locked states, transfer mode and per-shape motion blur state.

Importing Shapes
Importing Shapes into Silhouette
Silhouette, Commotion, Elastic Reality and Shake 4.x SSF shapes can all be 

imported into Silhouette.

1 Choose File > Import and select the shape format that you would like to import.

A file browser opens.

2 Select the shape file to import and click OK.

The shapes are added to the current session.

• Commotion Import Notes

When importing Commotion shapes, the following shape parameters transfer into 
Silhouette: shape visibility, shape locked state, shape motion blur on / off state. If the 
shape is invisible in Commotion, it will start out invisible in Silhouette, so it might not 
look like it was imported unless you have the Object List open.
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• Shake Import Notes

Shake 4.x shapes are imported but attributes such as feathering, color and opacity are 
ignored.

Importing Shapes into Other Programs
Instructions for importing shapes into the programs that Silhouette supports 

can be found below. 

Combustion

Import Shapes into Combustion

1 In a Mask operator, click on the Settings tab.

2 Under Mask Setups, click on Import and select the gMask file that you saved from 
Silhouette.

Elastic Reality

Import Shapes into Elastic Reality

1 With an Elastic Reality project open, select Shape >Import.

2 When the File Browser opens, choose the .ers file that you saved from 
Silhouette.

Flint / Flame / Inferno

Importing Shapes into Flint / Flame / Inferno

1 Open the Garbage Mask Setup menu.

2 Click Load Setup.

3 When the File Browser opens, select the gMask file that you saved from 
Silhouette.

Fusion

Importing Shapes into Eyeon Fusion

1 From a file browser window, drag the .setting file that you saved from Silhouette 
and drop it into a Fusion flow.

Nuke
There are two Nuke shape export options--Nuke Shapes and Nuke 6.2+ 

Shapes. Nuke 6.2+ Shapes exports substantially more shape attributes than 

Nuke Shapes. Of course, the Nuke 6.2+ Shapes option requires that you are 

using Nuke 6.2 and above.
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Nuke 6.2+ Shapes

Nuke 6.2 and above will import the shape opacity, blend mode, invert, motion 

blur, outline color, shape blur (if outside) as well as the layer and node blur and 

motion blur. When exported, tracker data is kept separate from shape data.

Nuke Shapes

For Nuke 5.1v3 and above, Silhouette shapes and their blend modes are 

imported. Nuke will also import Hold and Linear key frames for Opacity. When 

exported, tracker and shape data are baked together.

Importing Shapes into Nuke

1 Select File > Open and choose the .nk file that you saved from Silhouette.

Note: The imported shapes are set to render into the alpha channel only.

Shake 4.x
Shake 4.x will import the shape name, locked/unlocked state, opacity, visibility, 

motion blur on/off, shutter angle, and shutter phase. In addition, subtractive 

shapes import as black in the RGB channels with a white alpha channel.

Importing Shapes into Shake 4.x

1 Create a RotoShape node.

2 Click on the Import Shape Data from File icon.

3 When the File Browser opens, select the .ssf file that you saved from Silhouette.

4 Drag the slider in the Timebar to see your shape.
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Using the Planar Tracker
The Planar tracker generates and tracks several points on the image while 

automatically handling partial occlusions of the tracked object.

Note: The Tracker tool is available in both the Roto and Effects nodes.

Planar Tracking
1 Go to the frame where you want to start tracking.

2 Set the View to Foreground for the fastest speed when tracking. In the 
Foreground view, no shape processing occurs and therefore it is faster than 
View > Output.

3 Create a layer in the Object List using the Add Layer icon. 

4 Inside of the new layer, create a shape around the object that you would like to 
track and make sure that there is some detail inside of the shape. It does not have 
to be exact and it is best to leave a little extra room around the object. In addition, 
you can use more than one shape as long as they are on the same geometric 
plane.

Note: When a layer is selected, the per-shape blend mode, invert state, on/off state 
and opacity are all obeyed. This allows you to use shapes to subtract out areas of 
unwanted motion that may interfere with tracking.

5 Choose the Tracker tool (Shift-T) in the Toolbar.

6 In the Tracker tab located at the bottom of the screen, select the Planar Tracker 
tab.
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7 Enable Preview in Pre-Processing.

The image in the Viewer becomes black and white and displays the color space 

that you will track in.

8 Select the color space to track with in the Channel pop-up menu. 

Pick the color space that displays the best contrast in the object you are 

tracking.

9 Disable Preview in Pre-Processing.

10 Make sure that the layer containing your shape is selected. Otherwise, the 
Tracker Direction controls will be grayed out. 
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11 Hit either the forward or backward track button.

12 When the tracking is done, that’s it, you're done.

The tracking data is automatically applied to the selected layer.

13 After tracking, if you are not happy with the results, try the different techniques 
listed at Planar Tracker Tips and Tricks.

14 If you want to use Stabilization, click the Stabilize icon above the Viewer to 
stabilize the image.

15 Make shape adjustments and keyframe it as necessary using the Reshape and 
Transform tools.

16 When shape editing is complete, click on the Stabilize icon (if it was activated) 
above the Viewer to turn off the stabilization.
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Planar Tracker Tips and Tricks
If you have trouble tracking a shot using the Planar Tracker, here are some tips 

and tricks:

• When creating a shape around the area you want to track, make sure that 
there is some detail inside of the shape. Also, leave a little extra room around 
the object you are trying to track.

• Change the Channel parameter from Luminance to Red, Green or Blue. The 
Channel parameter determines which image value the tracking algorithm uses.

• Use the Blur, Sharpen, Contrast, De-Noise or Remove Flicker pre-processing 
parameters.

• Stop the tracker if it fails and go back a few frames before it messed up. Reposition 
your shape and hit the tracking button again. You don't need to go back to your 
start frame.

• Depending on the motion of the object to be tracked, you may get better results if 
you track from the end to the beginning. You may also track from the middle to the 
beginning and then from the middle to the end.

• In the Layer you are tracking, create shapes to subtract out areas of unwanted 
motion that may interfere with tracking and select the layer prior to tracking.

• Set the View to Foreground for the fastest speed when tracking. In the Foreground 
view, no shape processing occurs and therefore it is faster than View Output.

• You can use shapes for tracking purposes only and once the track is completed, 
you can hide or delete them.
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Using the Point Tracker
The Point tracker uses trackers which are placed on distinguishable image 

features.

Creating a Tracker
1 Select the Tracker tool (Shift-T) in the Toolbar.

Note: The Tracker tool is available in both the Roto and Effects nodes

2 Go to the frame where you want to start tracking.

3 Set the View to Foreground for the fastest speed when tracking. In the 
Foreground view, no shape processing occurs and therefore it is faster than 
View > Output.

4 In the Tracker tab located at the bottom of the screen, select the Point Tracker 
tab.

5 Press the Create button and a tracker is placed in the center of the image.

or

6 Alt-click on an open space in the image.
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As you pass your cursor over the image with the Alt key depressed, a zoomed 

region to the right of the tracker aids in selecting your Match Area.

Moving Tracker Components
1 Clicking and dragging directly on the Track point will move all components of the 

Tracker: Match Area, Search Region and Track Point simultaneously.

2 Clicking and dragging somewhere in the area of the Search Region will move 
only the Search Region.
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3 Clicking and dragging somewhere in the area of the Match Area will move both 
the Search Region and Match Area simultaneously, leaving the Track Point at its 
current location. This would be used for Offset Tracking when the original track 
point becomes obscured.

Scaling Tracker Components
1 Clicking and dragging on the corners of the Match Area bounding box scales 

both the Match Area and Search Region.

2 Clicking and dragging on the corners of the Search Region bounding box scales 
only the Search Region.

Tracking an Image
1 Adjust the size and position of the Match Area and Search Region.

2 Right-click on the tracker and select the color space to use in the Channel sub-
menu.

3 Hit either the forward or backward track button.

Silhouette will analyze the motion for each frame in the sequence.
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Offset Tracking
There are times when your original Match Area gets obscured, and in these 

instances, you can offset the Match Area and Search Region from the Track 

Point.

1 Create a tracker and track a portion of the sequence until the Match Area 
becomes obscured.

2 Hit the Stop button in the Tracker Progress window.

3 Back up to the last properly tracked frame.

4 Click and drag somewhere within the Match Area and both the Match Area and 
Search Region will move simultaneously, leaving the Track Point at its current 
location.

5 Click the forward tracking button to continue tracking.

The Track Point follows the same path, but the new Match Area is used to 

acquire the tracking data.

Tracking Difficult Shots
Some sequences are difficult to track because of erratic motion or the occlusion 

of the feature that you are attempting to track. In these cases, you can do a bit 

of hand tracking using one of two methods: 

• By pre-keyframing the tracker at various frames throughout the sequence.

• Keyframing a shape and then creating tracker keyframes based on the shape’s 
motion.

Keyframing the Tracker
1 Create a tracker.
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2 Adjust the tracker to match the object at various frames throughout the 
sequence.

3 In the Tracker tab, change the Behavior to Key Frames.

The Tracker Match Area will now use these keyframes as a reference while 

tracking.

Create Tracker from Shape Center
1 Create a shape around the feature that you would like to track. Go to various 

frames throughout the sequence and adjust the shape to match the feature.

2 Select the Tracker tool and right-click on the shape. 

3 From the pop-up menu, select Create Tracker from Shape Center.

A tracker is automatically created around the center point of the shape and any 

shape keyframes are automatically applied to the Tracker. 

4 In the Tracker tab, change the Behavior to Key Frames.

The Tracker Match Area will now use these keyframes as a reference while 

tracking.
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Modifying Tracking Data
Averaging Trackers
Averages multiple tracks into a new destination track. A common technique is 

to track forwards from the first frame to the last, and then create a second track, 

tracking backwards from the last frame to the first. These two trackers are then 

averaged together to derive a more accurate track. 

1 Select more than one tracker.

2 In the Tracker tab, choose Average.

A new averaged tracker is created.

Smoothing Trackers
Smoothing trackers removes inaccuracies in the tracking data caused by film 

grain or video noise.

1 Select a tracker to smooth.

2 In the Tracker tab, choose Smooth and adjust the slider when it pops-up.
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Applying Trackers

Match Moving and Stabilizing Layers
In general, tracking data should be applied to layers instead of individual 

shapes. The tracking data is placed into the transform of a selected layer 

(containing shapes) allowing you to have separate keyframes for both the layer 

transformation and for the shapes. This results in far fewer shape keyframes 

than other methods and is the preferred way of working with clips in motion. 

The result is a very flexible method for discrete editing of layer and shape 

transformations.

Once applied to a layer, the tracking data can be used in Match Move or 

Stabilize mode. In Match Move mode, the clip moves as normal and the shape 

follows along according to the tracking data. In Stabilize mode, the clip is locked 

in place by stabilizing the Viewer. In either mode, you only need to keyframe 

the shape when it changes form. After shape editing is complete in Stabilize 

mode, the Viewer can be returned to its normal state and the shapes will match 

the motion of their respective objects.

1 Create a layer in the Object List using the Add Layer icon. 

The new layer is active and you can tell by the check mark icon in the box to 

the right of the layer name in the Object List. 

Note: Point tracking data is only applied to the active layer.

2 Select the trackers that you would like to use.

3 Press the Apply button.
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You have a choice of applying position, scaling and/or rotation. However, 

scaling and rotation require two trackers. 

4 Select Position, Rotation and/or Scaling and click OK.

The tracking data is applied to the Transform > Matrix parameter of the selected 

layer.

5 Create a shape inside of the selected layer.

If you look at various frames in the sequence, you’ll see that the shape is match 

moved to the motion of the image. 

6 If you want to use Stabilization, click the Stabilize icon above the Viewer to 
stabilize the image.

The Viewer is now stabilized.

7 Keyframe your shapes as necessary.

8 When shape editing is complete, click on the Stabilize icon (if it was activated) 
above the Viewer to turn off the stabilization.

The Viewer is returned to its normal state and the shapes match the motion of 

their respective objects. You can return to stabilization mode at any time by 

clicking the Stabilize icon.

Other layers can be match moved or stabilized using different trackers. Just go 

to the Tracker tab and apply the motion from different trackers to other layers.
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Four Point Corner-Pin Tracking
Four-point tracking is traditionally used to match the perspective of a square or 

rectangular shape by tracking it’s four corners and applying a corner-pin 

transformation.

1 Create four trackers on the corners of a square or rectangular object and track 
the motion.

2 Create a layer in the Object List using the Add Layer icon. 

The new layer is active and you can tell by the check mark icon in the box to 

the right of the layer name in the Object List. 

Note: Point tracking data is only applied to the active layer.

3 Select the four trackers.

4 Press the Apply button.

The corner-pin data from the four trackers is applied to the layer.

5 Create a square shape inside of the selected layer. When drawing the shape, it 
should be placed near the location of the four trackers.

If you look at various frames in the sequence, you’ll see that the shape’s motion 

is matched to the motion of the image. 

Match Moving Points
Match moving applies the motion of a tracker to individual points on a shape. 

Note: Match moving individual points results in keyframes being set on every frame of 
the shape and can make it cumbersome to later edit those points. This functionality has 
been added to Silhouette as some users prefer to work with this way.

1 Select a tracker.
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2 Click on a shape to select it and then select a point.

Note: To select points on a shape, you must first select the shape by clicking on the 
shape outline. Then, Ctrl(Win)/Cmd(Mac)-click each point that you would like to 
select. Also, when a tracker overlaps a point, it will be difficult to select the point while 
in the Tracker tool. To select a point that overlaps a tracker, switch to the Reshape tool, 
select the point and switch back to the Tracker tool.

3 Right-click over a selected point and choose Apply from the pop-up menu.

The tracking data is applied to the point.
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Point Tracker Tips and Tricks
If you have trouble tracking a shot using the Point tracker, here are some tips:

• Set the View to Foreground for the fastest speed when tracking. In the Foreground 
view, no shape processing occurs and therefore it is faster than View Output.

• Stop the tracker, go to the bad frame and reposition the Track Point, and hit the 
tracking button again. You don't need to go back to your start frame. 

• Lower the Tolerance value, and track again from the beginning, or the frame 
before the bad frames. The lower the Tolerance, the more forgiving the tracker will 
be--but also less accurate.

• Start over and switch Behavior from Start Frame to Every Frame. This means that 
instead of trying to compare the tracking region with the first “pure” frame, it will 
try to match to the previous frame. If you re-track from the middle of a sequence, 
it will consider your new start frame as your reference frame with either setting.

• Use the Blur, Sharpen, Contrast, De-Noise or Remove Flicker pre-processing 
parameters.

• At any time, you can manually adjust the Track Point by simply grabbing it and 
putting it where you need to.

• Change the Channel parameter from RGB to Luminance, Red, Green or Blue and 
re-track. The Channel parameter determines which image value the tracking 
algorithm uses.

• A technique you can use to assist with difficult shots is to manually insert tracking 
keyframes. For example, if you have 100 frames to track, you can put in a keyframe 
every 5 or 10 frames by repositioning the Tracker. Once your keyframes are 
manually entered, return to frame 1 and set the Behavior to Key Frames. The 
tracker searches along the tracker's pre-existing motion path to find matching 
patterns.

• You can use the same technique as in the previous tip, but with the following 
differences. Create a shape around the feature that you would like to track. Go to 
various frames throughout the sequence and adjust the shape to match the 
feature. Select the Tracker tool and right-click on the shape. From the pop-up 
menu, select Create Tracker from Shape Center. A tracker is automatically created 
around the center point of the shape and any shape keyframes are automatically 
applied to the tracker. In the Tracker window, change the Behavior to Key Frames. 
The tracker Match Area will now use these keyframes as a reference while 
tracking.
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Importing and Exporting Tracking Data

Exporting Tracking Data
Trackers can be exported to the After Effects, Discreet, Nuke and Shake 

tracker formats. In addition, the tracking data applied to a layer, either by Point 

trackers or Planar tracking, can be exported as a four point corner-pin track.

Prepping Trackers for Export
In most cases, trackers are ready to be exported as is. However, trackers can 

be created based on a shape’s points, the center point of a shape or the 

shape’s bounding box using the Tracker on-screen pop-up menu. Trackers 

created in this manner are a concantenation of the shape and layer 

transformation data. So, why do this? Because, it is a handy way of creating 

trackers with all of this combined data for use in other programs.

Creating Trackers from Shapes
1 With the Tracker tool (Shift-T) enabled, right-click over a shape to open the 

Tracker pop-up menu.

2 Choose either Create Corner Trackers from Shape Bounds or Create Tracker 
from Shape Center.

The resulting trackers are a concantenation of the shape and layer 

transformation data.

Creating Trackers from Points
1 Select the Tracker tool (Shift-T) in the Toolbar, right-click over a point and choose 

Create Tracker from Points.

The resulting tracker is a concantenation of the shape and layer transformation 

data.
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Exporting One to Two Trackers
1 Press the Tracker tool (Shift-T) in the Toolbar.

2 Select the trackers that you want to export.

3 Choose Export in the Tracker tab and select the tracker format.

4 When the window pops-up, type in a name and click Save.

Currently, you can export to the After Effects, Discreet, Nuke and Shake tracker 

formats.

Exporting Four Trackers for Corner-Pinning
1 Press the Tracker tool (Shift-T) in the Toolbar.

2 Using the Shift key, select the four trackers that you want to export in a Z pattern: 
Upper Left, Upper Right, Lower Left and Lower Right.

3 Choose Export in the Tracker tab and select the tracker format.

4 When the window pops-up, type in a name and click Save.

Exporting a Layer as a Four Point Corner-Pin
1 Select the layer that you want to export.

2 Press the Tracker tool (Shift-T) in the Toolbar, Choose Export in the Tracker tab 
and select the tracker format. 

3 When the window pops-up, type in a name and click Save.

Note: When exporting a four point corner-pin track to Discreet products, it is better to 
use four trackers instead of the tracking information from a layer.

Importing Tracking Data
After Effects Corner-Pin, Nuke, Shake or Simple Format formatted trackers can 

be imported into Silhouette. If you would like to import trackers from non-

supported applications, simply export a Silhouette tracker in Simple Format to 

see how it should be formatted.

Importing Trackers into Silhouette
1 Select the Tracker tool (Shift-T) in the Toolbar.

2 Choose Import in the Tracker tab.
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3 Select the After Effects Corner Pin, Nuke, Shake or Simple Format tracker file 
that you would like to import and click Open.

Note: If you select multiple trackers in the import dialog, more than one tracker can be 
imported at a time.

Importing Silhouette Trackers into other Programs

After Effects
1 Double-click on the tracker text file that you exported from Silhouette.

The value of the Comp Pixel Aspect Ratio line at the top of the exported tracker 

file must match the Pixel Aspect Ratio in the After Effects Composition settings. 

Edit the exported tracker file as needed.

2 Press Ctrl(Win)/Cmd(Mac)-A to select all and Ctrl(Win)/Cmd(Mac)-C to copy.

3 In After Effects, select a layer in the Timeline and press Ctrl(Win)/Cmd(Mac)-V to 
paste the Tracker Data.

Note: If you exported a limited work range in Silhouette, go to the start frame of the 
work range in After Effects before pasting. 

4 Open the Window > Tracker controls.

5 In the Motion Source pop-up, select the layer where you pasted the tracking data.

6 From the Current Tracker pop-up, select the Tracker that you just pasted. If you 
only have one tracker, this would be Tracker 1.

7 Change the Track Type from Raw to one of the available options.

8 Click Edit Target and choose the layer that you would like to apply the motion to.

9 Hit Apply.

Combustion

Importing One to Two Trackers into Combustion

1 Click on the Tracker tab.

2 In the Source pop-up, choose your layer.

3 Select the Track type: Position, Scale or Rotate.

4 Click on the Import Data button and pick Discreet Tracker Setup.

5 Load the tracker file that you saved from Silhouette.

Importing Four Trackers into Combustion

1 Create a 3D Workspace.
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2 Import two layers into your Composite workspace.

3 Click and select the layer that you want to corner-pin and make sure it is at the 
top of the stack.

4 In the Composite Controls > Layer Tab, activate Four Corner.

In your Viewport, the layer will have a point on each corner of the image. 

5 Click and drag each corner point to the position where you want your layer 
placed after the trackers are imported.

6 Using the Shift key, select the four corner points.

The points turn yellow when they are selected.

7 Click on the Tracker tab.

8 In the Source pop-up, choose the layer the tracking data was derived from.

9 Select the Position Track type.

10 Click on the Import Data button and pick Discreet Tracker Setup.

11 Load the tracker file that you saved from Silhouette.

Note: When importing a four point corner-pin track in Combustion, it is better to use 
four trackers instead of the tracking information from a layer.

Flint / Flame / Inferno
1 Select the Stabilizer.

2 Click on the Imp button below the Track fields and select the tracker file that you 
saved from Silhouette.

Note: When importing a four point corner-pin track in Flint, Flame and Inferno, it is 
better to use four trackers instead of the tracking information from a layer.

Nuke
1 Choose File > Import Script and select the tracker file that you saved from 

Silhouette.

Shake
1 Add a Tracker, Match Move or Stabilize node.

2 In the Tracker node, click the Load button in the Parameter tab and select the 
tracker file that you saved from Silhouette.

3 For the Match Move and Stabilize nodes, right-click on one of the trackName's in 
the Parameter tab and choose Load Track File.

4 Select the tracker file that you saved from Silhouette.
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Using Motion Blur
Motion blur is the directional blurring of rapidly moving shapes. To use Motion 

Blur, it must be activated for each individual shape as well as in the Node 

window.

1 Select one or more shapes and enable Motion Blur in the Object window.

2 Click on the Node tab to display the Node parameters.

3 In the Node window, enable Motion Blur and adjust the Shutter Angle, Shutter 
Phase and Samples as desired.

When working with motion blur, it is best to keep your View set to Foreground. 

This way editing your shape will be quick and interactive.

4 Set your View to Foreground.

When you need to view the motion blurred Alpha channel, use Shift-A. Shift-

A toggles the View to Output, superimposes the Alpha channel over the image 

and deactivates the Overlay. Pressing Shift-A again returns the Viewer to its 

previous state.

5 To view the motion blurred Alpha channel, press Shift-A.
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Renaming Objects
You can rename a shape, layer or tracker by either:

1 Click on the object once to select it, hit the Enter key, type in the new name and 
press Enter again.

or

2 Double-click the object, type in a new name and hit the Enter key.

or

3 Right-click on the object, select Rename and type in a new name.
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Adding Notes
You can type an arbitrary length note for selected objects. Currently, only 

shapes, trackers and layers are supported.

1 Select a shape, tracker or layer.

2 In the Object List, click the Notes icon.

The Notes window comes forward above the Object List.

3 Click in the Notes window and type your note.

Because you can type multiple paragraphs into the Notes window, you must 

press Apply to assign the note.

4 Click Apply in the notes window.

The Notes icon changes once a note is applied to the object.

5 Hover over the Note icon in the Object List and the note is displayed as a tool tip.
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Timebar Keyframes
Colored markers in the shuttle area signify where selected objects have 

keyframes. These keyframes can be moved to a new position. Objects that 

display keyframes in the Timebar are shapes, trackers and painted frames. 

Path keyframes are shown for shapes, position keyframes for trackers and 

painted frames when in the Paint node.

The color of the markers is determined by the object color. If multiple selected 

objects have a keyframe on the same frame, the most recently selected 

object's color has precedence.

1 Press Shift and hover over one of the colored markers.

2 When the cursor changes to a double arrow, click and drag the marker to a new 
location.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

84 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Using the Timeline

Zooming the Timeline In or Out 
1 Use the scroll wheel to zoom the Timeline in and out.

or

2 Shift-Middle-mouse drag in the Timeline.

Panning the Timeline 
1 Use the Spacebar and click and drag to pan horizontally or vertically in the 

Timeline.

Moving One Keyframe
1 Click on a keyframe to select it. 

2 Drag the selected keyframe to its new time.

Moving a Selection of Keyframes
1 Click on the starting keyframe to select it. 

2 Shift-click on the ending keyframe.

A range of keyframes is selected.

3 Click and drag one of the selected keyframes to the new location.

All selected keyframes move to the new location.
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Paint
Paint is a high dynamic range 2D raster based paint system designed from the 

ground up to handle the demands of feature film and television production.

Note: Before Paint can be available for use, it must be enabled in the Session Settings 
and selected in the Node List.

Using Paint
1 Create a session that includes a Paint node and make sure that it is selected in 

the Node List.

When the Paint node is selected, various non-animateable controls appear in 

a Paint window located at the bottom portion of the screen. Silhouette provides 

a wide variety of paint tools that are organized into Brush, Profile and Paint 

categories.
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In addition, a number of different brushes are selectable from the Paint Toolbar 

to the left of the Viewer.

Once a brush is selected, it’s controls appear on the left side of the Paint 

window.

Black and White

Blemish

Blur

Color Correct

Drag

Eraser

Grain

Clone

Color

Mosaic

Repair

Scatter
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2 The Color brush (Shift-C) is selected by default and is preset to white. Select the 
Color brush if it is not selected.

3 Paint on the image in the Viewer by pressing and dragging with your pen or 
clicking and dragging with your mouse.

4 In the Paint window’s Profile group, adjust some of the settings to see how it 
changes your brush. 

In addition to the Profile > Size control, the brush can also be resized in the 

Viewer by holding Ctrl(Win)/Cmd(Mac) and dragging the brush outline.

5 Experiment with some of the other brushes in the Brush Toolbar.

6 Adjusting the brush parameters located on the left side of Paint window will 
change the effect of the brush when you paint. 

By default, you are painting on the RGB channels of the image. However, you 

can paint individually on the Red, Green, Blue or Alpha channels as well as 

simultaneously paint on the RGB and Alpha channels using the Paint settings.

7 Make sure that the Color brush (Shift-C) is selected.

8 In the Paint window’s Paint group, click on R to paint only the Red channel.

9 Paint on the image.
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10 If you view the individual Red, Green and Blue channels using the RGBA buttons 
in the Viewer, you will see that only the Red channel is affected.

11 Select the horizontal white bar above the RGBA buttons to quickly toggle the 
display of the image back to full color mode.

At any time, you can clear all paint strokes and restore the original unpainted 

frames by using the Paint > Restore pop-up menu. You can restore the Current 

Frame, All Frames or the Work Range.

12 Select Restore > All Frames to clear all paint strokes on all frames.

13 Go to frame 1 of the sequence and paint on the image.

14 Advance to frame 2.

As you change frames in the sequence, the painted frames are stored to disk. 

Paint on the current frame is also saved with File > Save.

15 Go back to frame 1 and you will see that your paint stroke has been recorded.

16 Paint some more frames in the sequence.

As frames are painted, a marker is shown in the Timebar to provide a visual 

display of which frames are painted.

Using the Clone Brush
The Clone brush paints the image using another part of the image/or other 

image as defined by the settings in the Clone controls.

Quickly Set the Clone Offset
1 Choose the Clone brush (C) from the Toolbar.
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2 Press and hold down the Shift key. In the Viewer, click, drag and release the 
mouse and then the Shift Key to set the Clone offset.

The first click sets the Clone source and where you drag and release is the 

Clone destination.

3 Alternatively, you can set the Clone offset by pressing and holding down the 
Shift key. Tap once to set the Clone source and tap once again to set the Clone 
destination.

Quickly Reset the Clone Offset
1 Press Shift and without moving the cursor, click your mouse or tap your pen on 

the screen once.

The Clone offset is quickly set to a 0,0 offset.

Using the Clone Brush
1 In the Clone controls, select Output, Foreground or Clone 1-4 in the Source pop-

up menu.

Output is the painted output of the Paint node and when selected, clones from 

previously painted areas. Foreground clones from the foreground image, while 

Clone 1-4 are additional clone sources that clips can be assigned to in the 

Viewer > Inputs menu.

2 If you’d like, set the Frame parameter to choose which source frame to paint 
from.

3 Set your Clone source offset by one of the following methods: 

• Shift-clicking, dragging and releasing in the Viewer.

• Press and hold down the Shift key. Click once to set the Clone source and click 
once again to set the Clone destination.

• Press Q (Translate), W (Rotate) or E (Scale) and click and drag to translate, rotate 
or scale the Clone source. Onion Skin mode is automatically activated once the Q, 
W or E key is pressed. Press whatever key you pressed (Q, W or E) again to 
deactivate the mode.

• Turn on Interactive mode and use the up, down, left and right arrow keys to nudge 
the Clone source.

• Turn on Interactive mode and adjust the X and Y (position), Z (rotate), and H and V 
(scale) parameters.
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• Turn on Interactive mode and use the on-screen controls. For instance, to corner-
pin the Clone source, drag the handles on the corners of the image.

4 Activate Onion Skin or Align mode if you need to line up the Clone source and 
target images.

• Select the Onion Skin icon to activate it and then align the Clone source.

or

• Select the Align icon to activate it and then align the Clone source.

5 Once the Clone source offset is set, deactivate Onion Skin or Align mode if they 
are activated.

Very often, you will encounter two images from the same location that are not color 

matched.

6 If the Clone source needs to be color corrected to match the image to be painted, 
select the Grade tab and adjust the various sliders.

If you need to do exacting color correction, follow the steps below.

7 Choose the Vertical Split icon to compare the Clone source and target using a 
split screen.

The split is handy when using the Grade controls to color match the Clone 

source to the target.

8 Move your cursor into the image area over the split line and when the cursor 
changes to a double-arrow, click and drag to move the split line to the location 
where you will be painting and where you want to do the color matching. The 
split line may not be obvious, so white triangles on the edge of the Viewer will 
help you find it.

By isolating individual color channels, it is easier to match the colors.

9 In the Viewer, look only at the Red channel (Alt-R).
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10 Ctrl(Win)/Cmd(Mac)-drag (for finer accuracy) the Gain > Red slider so that the 
luminance values on either side of the split line match.

Tip: Set your Update mode to Always. As you drag a parameter, Silhouette is 
constantly rendering. This makes the color adjustments more interactive.

11 In the Viewer, look only at the Green channel (Alt-G).

12 Ctrl(Win)/Cmd(Mac)-drag (for finer accuracy) the Gain > Green slider so that the 
luminance values on either side of the split line match.

13 In the Viewer, look only at the Blue channel (Alt-B).

14 Ctrl(Win)/Cmd(Mac)-drag (for finer accuracy) the Gain > Blue slider so that the 
luminance values on either side of the split line match.

15 Press Alt-B again to toggle off the Blue channel and to display the RGB channels 
in the Viewer at the same time.

Your Clone source and target should now be color matched.

16 Toggle off the Vertical Split and paint the image.

Tracking the Clone Source
1 Using a Roto node, create a tracker and apply it to a layer.

2 Select the Paint node in the Node List.

3 Choose the Clone Brush in the Toolbar.

4 Select the tracked Roto node layer in the Paint > Tracking menu.

5 Make sure that the Clone > Match Move control is activated. It is normally on by 
default.

Selecting a layer in the Paint > Tracking menu and activating Clone > Match 

Move allow you to apply the tracking or transformation data of a Roto node 

layer to the Clone source.

6 If you would like to Stabilize instead, click the Stabilize icon at the top of the 
Viewer.
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Aligning Features from Different Images
Oftentimes, you need to align the same feature in two different images of a 

sequence when painting with the Clone brush.

1 In the Clone controls, select Output, Foreground or Clone 1-4 in the Source pop-
up menu and then set the Frame parameter to choose which source frame to 
paint from.

2 Press the ‘ key (located to the left of 1 key).

The Clone source image automatically appears in the Viewer.

3 Set the Onion-Skin mix to 100.

4 Click on the Clone source feature that you want to paint from.

The Clone destination image automatically appears in the Viewer.

5 Click on the Clone destination feature that you want to paint on.

The Clone offset is set.

Dual Clone Brush
Two Clone presets can be activated at once. This allows you to paint from two 

different frames, using separate transforms and/or color corrections.

1 Select one of the 0-9 Clone presets.

2 Set the Clone source transform, timing and grade controls.

3 Choose a second Clone preset and set it’s Clone source transform, timing and 
grade controls.

4 Choose the first preset and press Shift to select the second one. 
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The second preset will light up red and there will be a Mix control that appears 

at the top right of the Clone controls.

5 Change the Mix parameter to set the relative opacity of the two Clone sources.

Mix adjusts the opacity of the first Clone preset. The opacity of the second 

Clone preset is 1.0 - Opacity.

6 When you paint, both Clone presets will contribute to the painted result.
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Using Effects
The Effects node allows you to apply the brushes available in the Paint node 

as filter effects to shapes or layers.

Note: Before the Effects node can be available for use, it must be enabled in the 
Session Settings and selected in the Node List.

Applying Filters
1 Create a session that includes an Effects node and make sure that it is selected 

in the Node List.

2 Using one of the shape tools, draw a shape.

3 Make sure that the shape is selected and choose an effect from the Filter menu. 
For instance, apply the Mosaic filter.

Once applied, the filter appears in the Object List within an Effects group.

When added to a layer, the effect is applied based on the alpha of the layer. The 

idea is to allow shapes with various Blend modes to contribute to or limit where 

the effect will be applied.
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Mosaic filter applied to the Face shape 

When you click on one of the filters in the Object List, its editable parameters 

show up in the Object window and can be keyframed like any other attribute.

4 Click on the Mosaic filter in the Object List if it is not selected.

5 Adjust the filter parameters in the Object window if you’d like.

Obeying Alpha Channels from Upstream Nodes
The incoming Alpha channel generated by previous nodes can be utilized when 

applying a filter.

1 Click on the Effects node in the Node List and select Alpha Behavior > Obey Input 
in the Node window.

The Alpha channel generated from previous nodes will now be used when 

applying a filter.

2 Using one of the shape tools, draw a shape around the area where you want the 
filter applied. The shape must contain areas of Alpha channel from a previous 
node.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

96 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

3 Make sure that the shape is selected and select a filter from the Filter menu.

Using the Scratch Filter
The Scratch filter Removes vertical scratches by averaging in the surrounding 

pixels.

1 Using one of the shape tools, draw a shape around the scratch.

2 Make sure that the shape is selected and choose Scratch from the Filter menu.

3 Set the Width parameter in the Object tab.
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Using the Keyer
Using proprietary matte extraction techniques, the Keyer quickly and simply 

creates mattes with minimal parameters even if you are dealing with fine hair 

detail, smoke, or reflections.

Inner / Outer Keying
We like to use an inner / outer keying method that involves creating a Primary 

Matte which has gray values in the foreground’s edge. This will give a nice, 

smooth edge in the final composite. Next, the trick is to use the Secondary 

Matte to fill in any gray areas of the Primary Matte while retaining the gray 

values in the edge. You can do this by adjusting the Blur, Shrink/Grow and/or 

Wrap parameters of the Secondary Matte to retain the Primary Matte’s edge 

values.

Note: Before the Keyer can be available for use, it must be enabled in the Session 
Settings and selected in the Node List.

1 Create a session that includes a Keyer node and make sure that it is selected in 
the Node List.

2 Start by selecting Primary Matte from the View pop-up menu.

3 Set the Primary Matte > Extract On to Blue or Green Screen.

4 Adjust the Background slider so that the background areas are completely black.

5 Set the Foreground slider so that the Primary Matte has gray values, especially 
in the edges.

This Primary Matte will be used for the edges.

Note: If you are not going to use the Inner / Outer Keying method, you would adjust the 
Foreground slider so that the foreground values would be completely white in the 
Primary Matte. In this case, a Secondary Matte would not be used.

6 From the View menu, select Secondary Matte.
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The screen is black, because you must first enable it.

7 Expand the Secondary Matte group and click on the Enable checkbox.

You can now see the Secondary Matte in the Viewer.

8 Set the Secondary Matte > Extract On to the same setting as the Primary Matte.

9 Adjust the Secondary Matte so that the foreground is completely white and the 
background is completely black.

10 Switch the View menu to Combined Matte.

The Combined Matte view shows the combination of the two mattes.

11 Adjust the Secondary Matte > Wrap parameter to pull back the hard edges of the 
Secondary Matte to reveal the gray edges of the Primary Matte.

Note: You could also use Secondary Matte: Shrink/Grow and Blur instead of or in 
conjunction with Wrap to blend the two mattes together.

12 Change the View menu to Composite.

If you have not selected a Background input, the Foreground will be 

composited over a gray color by default. This color can be changed using the 

Composite > Background Color preference.

13 If you have a clip that you would like to use for the background instead of a color, 
select it from the Input > Background pop-up menu.
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The foreground will then be composited over the background.

If you see any color spill from the blue or green screen, it can be eliminated 

using the Color Suppression controls.

14 Expand the Color Suppression group and click the Enable check box.

15 Adjust the Color Suppression > Foreground and Range controls as needed.
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Using Power Matte

Open Shape Method
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown. Partial opacity values 

are then computed only for pixels inside the unknown region. Two trimap 

methods can be used: Open Shape or Closed Shape. This tutorial will use the 

Open Shape Method.

Unlike previous approaches, our trimaps can be relatively sparse consisting of 

open foreground and background shapes. All pixels left unmarked will be 

treated as unknown.

A good Open Shape technique is to draw an inner and outer outline around the 

object you are extracting using open shapes. Shapes should be near the 

boundary of the foreground or background, but not right up against the edge. 

Also, if the foreground or background has varying colors, the shapes should 

cross over these colors.

Note: The general rule is to not put foreground and background shapes too close 
together unless you need to.

1 Define foreground area (what you want to cut out) by drawing an open shape 
around the inner edge of the object.

2 Start by selecting either the Bézier, B-Spline or X-Spline tool from the Toolbar.

3 Click on the screen to create a control point.

A control point is created.

Original Shapes
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4 Add as many points as you like.

5 When finished adding points, press the Esc key to finish the open shape.

6 Now, draw shapes to define background areas (what you want to get rid of). 
Press the Esc key each time you want to finish an open shape.

If the background has varying colors, the shapes should cover these colors.

7 Choose the Reshape tool when you are done drawing open shapes.

Warning: If you only provide a few sparse shapes, the Open Shape Method will take 
longer to process with a less accurate result than the Closed Shape Method.

Good Shape Example Bad Shape Example
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8 In the Object List, feel free to change the name and color of your shapes. In the 
example below, I named the inner shape Foreground and changed the color to 
green. Also, I named all of the outer shapes Background and left their color set 
to red. Although this is not a necessary step, it is helpful to identify what the 
shapes are being used for.

Power Matte won’t process until you assign the shapes as either foreground or 

background.

9 Select the inner, foreground shape and in the Object window, set the type to 
Foreground.

10 Select all the outer, background shapes and in the Object window, set the type 
to Background.

Once a foreground and background shape are assigned, Power Matte 

processes the matte.The viewer displays the composite of the foreground over 

the background based on your shapes. If “None” is selected for the Background 

input, the foreground will be composited over a color. The default color is gray, 

but can be changed by going to File > Preferences > Composite on Windows 

and Linux or Silhouette > Preferences > Composite on Mac. If you add a 

Composite node in the Session Settings, the composite will be rendered.
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Now that you have foreground and background shapes, animate them over 

time so that they follow the motion of what you are cutting out. However, since 

you already assigned the shapes as foreground and background, Power Matte 

will try and update every time you adjust the shapes.

11 Set the View to Foreground. This way Power Matte is not constantly trying to 
update when you change a parameter.

12 Animate the foreground and background shapes over time so that they follow 
the motion of what you are cutting out.

It is best to use the Tracker (Shift-T) to animate the motion of your shapes as 

it will most likely ensure that the motion is consistent from frame to frame.

13 Play through the clip to make sure that the shapes are properly following your 
object.

14 Use View > Matte to display the generated matte.

15 Hit the Play button to check your results so far. When you hit the Play button, 
Power Matte renders each frame.

16 If at any time you want to turn off the display of the shapes, click the Overlay icon 
above the Viewer or press 0 (the number zero) shortcut key.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can either adjust the shapes or add additional 

shapes near the region where the matte is not accurate. 

17 If you see gray areas in the foreground object that should be completely white, 
make additional foreground shapes in those areas.

18 If you see gray areas in the background that should be completely black, make 
additional background shapes in those areas.
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19 Gray values in Unknown areas can be reduced by increasing the Deartifact value 
located in the Node window.

If you need to adjust the shapes after they have been created and assigned in 

Power Matte, you can enhance performance by either: 

• Set the View to Foreground while editing shapes.

• Set the Update mode to Manual and hit the Enter key when you want to process. 
This way Power Matte is not constantly trying to update when you change a 
parameter. 

• Use a lower quality proxy image by using the Proxy pull-down menu above the 
Viewer.

20 Choose View > Composite to display the Composite.

If you look closely at the edges of our dog example, you will see some white 

fringing created by the sky from the original image. By activating Power Matte’s 

Color Estimation feature, the fringing can be removed by estimating the color 

of the foreground in unknown and semi-transparent areas.

Note: Color Estimation can cause color flickering in edge areas of partial opacity if your 
shape position is not constant from frame to frame or if your source footage is grainy. 
Disable Color Estimation if you see flickering in the edge areas.

Color Estimation Off Color Estimation On
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21 To remove fringing around the object being cutout, go to the Node window and 
turn on Color Estimation.

22 When you press the Play button while viewing the Composite, you will see the 
result in full color.

Now that I have shown you how to generate a matte using open shapes, an 

alternative method is to use a mix of open and closed shapes. If you have large 

contiguous areas of background, surrounding the background with a closed 

shape and enabling Filled in the Object window will speed up Power Matte’s 

processing.

Original Composite

Open Shape Example Open/Closed Shape Example

Closed
Shape
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Closed Shape Method
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown.

The Closed Shape Method uses closed shapes to mark definite foreground and 

background areas of the image. Any unmarked areas are considered unknown 

and partial opacity values are then computed for the pixels inside the unknown 

region. So, make sure that any hair detail, transparent or blurry portions fall 

within the unknown areas 

Note: The Closed Shape method does not handle a foreground object with background 
holes in it, and therefore the Open Shape method would be a better choice when 
extracting an object with holes.

1 Define foreground area (what you want to cut out) by drawing a closed shape.

2 Start by selecting either the Bézier, B-Spline or X-Spline tool from the Toolbar.

3 Draw a shape around the inner edge of the object, in this case, the hiker.

Original Shapes
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4 To close the shape, click on the first point that you created.

5 To tell Power Matte that you are using a closed shape, enable Filled in the Object 
window.

6 Now, draw closed shapes to define background area (what you want to get rid 
of). If your foreground object is completely surrounded by background, like the hiker 
example below, a quick way to define the background area is to first draw a closed 
shape around the outside of the foreground and then invert it in the Object window. 
The areas outside of the background shape are then considered as background.

7 After drawing the background shape, enable Filled in the Object window. Invert 
the shape as well if you drew around the boundary of your foreground object as 
in the example above.

Once a foreground and background shape are assigned, Power Matte 

processes the matte. The viewer displays the composite of the foreground over 

the background based on your shapes. If “None” is selected for the Background 

Input, the foreground will be composited over a color. The default color is gray, 
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but for the example below I changed it to black by going to File > Preferences 

> Composite on Windows and Linux or Silhouette > Preferences > Composite 

on Mac.

Now that you have a foreground and background shape, animate them over 

time so that they follow the motion of what you are cutting out. However, since 

you already assigned the shapes as foreground and background, Power Matte 

will try and update every time you adjust the shapes.

8 Set the View to Foreground. This way Power Matte is not constantly trying to 
update when you change a parameter.

9 Animate the foreground and background shapes over time so that they follow 
the motion of what you are cutting out.

It is best to use the Tracker (Shift-T) to animate the motion of your shapes as 

it will most likely ensure that the motion is consistent from frame to frame.

10 Play through the clip to make sure that the shapes are properly following your 
object.
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11 Use View > Matte to display the generated matte.

12 Hit the Play button to check your results so far. When you hit the Play button, 
Power Matte renders each frame.

13 If at any time you want to turn off the display of the shapes, click the Overlay icon 
above the Viewer or press 0 (the number zero) shortcut key.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can adjust the shapes. 

14 If you see gray areas in the foreground object that should be completely white, 
adjust the foreground shape in those areas.

15 If you see gray areas in the background that should be completely black, adjust 
the background shape in those areas.

16 Gray values in Unknown areas can be reduced by increasing the Deartifact value 
located in the Node window.

If you need to adjust the shapes after they have been created and assigned in 

Power Matte, you can enhance performance by either: 

• Set the View to Foreground while editing shapes.

• Set the Update mode to Manual and hit the Enter key when you want to process. 
This way Power Matte is not constantly trying to update when you change a 
parameter. 
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• Use a lower quality proxy image by using the Proxy pull-down menu above the 
Viewer.

17 Choose View > Composite to display the Composite.

If you look closely at the edges of our hiker example, you will see some white 

fringing created by the sky from the original image. By activating Power Matte’s 

Color Estimation feature, the fringing can be removed by estimating the color 

of the foreground in unknown and semi-transparent areas.

18 To remove fringing around the cutout object, go to the Node window and turn on 
Color Estimation.

Note: Color Estimation can cause color flickering in edge areas of partial opacity if your 
shape position is not constant from frame to frame or if your source footage is grainy. 
Disable Color Estimation if you see flickering in the edge areas after a preview or 
render.

Color Estimation Off Color Estimation On
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19 When you press the Play button while viewing the Composite, you will see the 
result in full color.

Original Result
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

112 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Blue/Green Screen Keying
Keying is a technique for blending two images, in which a color from one image 

is removed, or made transparent, revealing another image behind it. Either the 

Open or Closed Shape Method can be used when creating mattes for Blue or 

Green screen photography. Power Matte doesn’t require any specific color for 

the object to be photographed against, but blue and green screens will be 

referred to as these are the most common.

Let’s start by creating some open shapes. The shapes should be near the 

boundary of the foreground or background, but not right up against the edge. 

Also, if the foreground or background has varying colors, the shapes should 

cross over these colors.

1 Define foreground area (what you want to cut out) by drawing a open shape.

2 Start by selecting either the Bézier, B-Spline or X-Spline tool from the Toolbar.

Original

Shapes
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3 Draw a shape around the edge of the object that you want to cutout, in this case, 
the television screen. When done adding points, press the Esc key to finish the 
open shape. 

4 Next, draw a shape to define background areas. In the example below, this would 
be the blue area within the television screen. Press the Esc key when you want 
to finish the open shape.

5 Choose the Reshape tool when you are done drawing the open shapes.

Power Matte won’t process until you assign the shapes as either foreground or 

background.

6 Select the foreground shape and in the Object window, set the type to 
Foreground.

7 Select the background shape and in the Object window, set the type to 
Background.

Once a foreground and background shape are assigned, Power Matte 

processes the matte. The viewer displays the composite of the foreground over 

the background based on your shapes. If “None” is selected for the Background 

Input, the foreground will be composited over a color. The default color is gray, 
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but for the example below I changed it to black by going to File > Preferences 

> Composite on Windows and Linux or Silhouette > Preferences > Composite 

on Mac.

Now that you have foreground and background shapes, animate them over 

time so that they follow the motion of what you are cutting out. However, since 

you already assigned the shapes as foreground and background, Power Matte 

will try and update every time you adjust the shapes.

8 Set the View to Foreground. This way Power Matte is not constantly trying to 
update when you change a parameter.

9 Animate the foreground and background shapes over time so that they follow 
the motion of what you are cutting out.

It is best to use the Tracker (Shift-T) to animate the motion of your shapes as 

it will most likely ensure that the motion is consistent from frame to frame.

10 Play through the clip to make sure that the shapes are properly following your 
object.

11 Use View > Matte to display the generated matte.

12 Hit the Play button to check your results so far. When you hit the Play button, 
Power Matte renders each frame.
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13 If at any time you want to turn off the display of the shapes, click the Overlay icon 
above the Viewer or press 0 (the number zero) shortcut key.

In the generated matte, white is foreground, black is background and any gray 

areas in between represent a level of transparency. If the matte is not 

acceptable after processing, you can adjust the shapes.

14 If you see gray areas in the foreground object that should be completely white, 
adjust the foreground shape in those areas.

15 If you see gray areas in the background that should be completely black, adjust 
the background shape in those areas.

16 Gray values in Unknown areas can be reduced by increasing the Deartifact value 
located in the Node window.

If you need to adjust the shapes after they have been created and assigned in 

Power Matte, you can enhance performance by either: 

• Set the View to Foreground while editing shapes.

• Set the Update mode to Manual and hit the Enter key when you want to process. 
This way Power Matte is not constantly trying to update when you change a 
parameter. 

• Use a lower quality proxy image by using the Proxy pull-down menu above the 
Viewer.

17 Choose View > Composite to display the Composite.
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When a foreground object has been photographed against a solid blue or green 

backdrop, the blue or green color can have a tendency to spill onto the 

foreground object. When extracting an object photographed against one of 

these colors, you may find it necessary to remove the blue or green spill. This 

is a process called Color Suppression.

18 To remove color spill from your object, go to the Node window and change the 
Color Suppression > Type parameter from None to Blue or Green.

19 Click Play button to see the RGB image results.

Color Suppression Off Color Suppression Off

Result

Original
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Working with Stereoscopic Images

Creating a Session Using Left and Right Sequences
1 Import left and right sequences into Silhouette.

2 Create a session with Roto and Paint nodes based on the left sequence.

3 Select the left sequence Source node in the Node List.

4 In the Node window, expand the View group and select the right sequence in the 
Secondary/Right pop-up menu.

5 Select the Roto node in the Node List.

You are now ready to create shapes.

Creating a Session Using Stereoscopic EXR Files
1 Import a stereoscopic EXR file into Silhouette.

2 Create a session with Roto and Paint nodes based on the stereoscopic EXR file.

Since stereoscopic EXR files contain both the Left and Right Views within one 

file, they are automatically connected to the Primary/Left and Secondary/Right 

views.
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3 Select the Roto node in the Node List.

You are now ready to create shapes.

Rotoscoping
1 Above the Viewer, make sure that the L icon (Shift-1) is highlighted. L stands for 

Left View. 

When using a stereoscopic EXR file or when left and right sequences have 

been assigned in the Source node’s View > Primary/Left and Secondary/Right 

parameters, the Viewer displays additional view modes.

The L icon displays the Left View in the Viewer, the R icon displays the Right 

View, and the LR icon displays both the Left and Right Views simultaneously. 

When shapes and layers are created, they will be associated with either the 

Left or Right View.

2 Create a shape around an object and keyframe as necessary.
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Since the Left View is selected, the shape is automatically associated with the 

Left View and an L is displayed for it in the Object List’s View icon.

3 Select the shape if it is not already selected and from the Edit > Stereoscopic 
menu, choose Duplicate > New Layer.

The shape and all of it’s keyframes from the Left View are duplicated to the 

Right View in a new layer and the two shapes are linked together. The newly 

duplicated shape and layer have a R displayed for it in the Object List’s View 

icon signifying that it is associated with the Right View.

Note: Clicking on the View icon in the Object List toggles which view the object is 
located in.

When using shapes inside of a transformed layer, you can duplicate the layer 

instead. This will copy the layer along with it’s transform data into the other 

view, copy any unlinked stereoscopic children into it and then link the shapes. 

You can stereo duplicate one layer at a time using this method.

4 Select the Right View (Shift-2).

You probably noticed that the shape from the Left View does not line up with 

the object it is associated with. This is because the Right View is offset from the 

Left View to create the stereoscopic effect. However, you can use the 

Stereoscopic Align tool in conjunction with a layer to negate the offset between 

the Left and Right Views.

5 In the Object List, click on the Layer that was created for the duplicated shape.

Clicking on the layer makes it the Active Layer and a check appears.

You are now ready to align the two views.
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6 Select the Stereoscopic Align icon (Shift-4) above the Viewer.

When activated, Stereoscopic Align uses a negative mode which inverts one of 

the views and mixes it with the other. This creates an embossed effect when 

similar image areas are not aligned.

7 Click and drag the move cursor that appears to align the views in the area of your 
shape. You can also Ctrl-drag for finer accuracy. When similar image features are 
perfectly aligned for the object you are rotoscoping, you will see a solid gray 
color.

If you need to align vertically (not common), you can either use the Up/Down 

Arrow keys or press the Shift key while clicking and dragging the move cursor 

in the Viewer.

The amount you move the view in Stereoscopic Align mode is stored in the 

Stereo Offset parameter of the active layer which is set to animate by default. 

8 Deactivate Stereoscopic Align mode and the shape will be aligned in the Right 
View.

If the object you are rotoscoping moves through various depths, you will want 

to keyframe the Stereo Offset using the Stereoscopic Align mode at various 

frames.

Note: If you are rotoscoping objects at different depths, place them in separate layers 
so that different Stereo Offsets can be set on a per layer basis.

Not Aligned Aligned
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9 Adjust the shape keyframes as needed for the shape in the Right View.

10 Select the Left/Right View (Shift-3).

In the Left/Right View, the Viewer displays both the left and right sequences.

11 To change whether the Left and Right Views are arranged either horizontally or 
vertically in the Viewer, press the Stereoscopic Split Mode icon.

In the Left/Right View, selecting one of the linked shapes in the Viewer selects 

the other as well and you can edit both shapes at once. If you only want to work 

on one shape at a time in the Left/Right View, just make sure that only one of 

them is selected in the Object List.

Linking Shapes
As an alternative to using Edit > Duplicate or Edit > Duplicate > New Layer as 

outlined in the previous exercise, shapes of the same type and the same 

number of control points can be linked together for stereoscopic rotoscoping. 

Once linked, the two shapes can be simultaneously selected and edited in the 

Left/Right View.
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1 Select the Left View (Shift-1) and create a shape.

2 Choose the Right View (Shift-2) and create a shape of the same type and number 
of control points as the one you just created in the Left View.

3 Press the Left/Right View icon (Shift-3) above the Viewer.

4 Select both shapes in either the Object List or directly in the Viewer.

5 From the Edit > Stereoscopic menu, choose Link.

The two linked shapes can now be simultaneously selected and edited when in 

the Left/Right View.

Paint
In general, painting on stereoscopic images is the same as painting with single 

images.

1 Select the Paint node in the Node List.

The Stereoscopic View mode determines whether you are painting on the Left 

View, Right View or both the Left and Right Views at the same time.

2 Select the Left View (Shift-1).

3 Choose the Color brush (Shift-C).

4 Paint on the image in the Viewer by pressing and dragging with your pen or 
clicking and dragging with your mouse.
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5 Select the Right View (Shift-2) and paint on the image.

6 Select the Left/Right View (Shift-3).

7 To change whether the Left and Right Views are arranged either horizontally or 
vertically in the Viewer, press the Stereoscopic Split Mode icon.

8 Paint on the image.

Paint is applied to both the left and right images simultaneously. However, the 

location of the paint on the Left View will be offset slightly from the Right View. 

To paint on both the Left and Right Views at the same time and in the same 

location, you will need to use the Stereoscopic Align mode to line up the two 

views.

9 Select the Stereoscopic Align icon (Shift-4) above the Viewer.

When activated, Stereoscopic Align uses a negative mode which inverts one of 

the views and mixes it with the other. This creates an embossed effect when 

similar image areas are not aligned.
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10 Click and drag the move cursor that appears to align the views in the area where 
you will be painting. You can also Ctrl-drag for finer accuracy. When similar image 
features are perfectly aligned for the object you are painting, you will see a solid 
gray color.

If you need to align vertically (not common), you can either use the Up/Down 

Arrow keys or press the Shift key while clicking and dragging the move cursor 

in the Viewer.

If the object you are painting moves through various depths, you will want to set 

the Stereoscopic Align setting on each frame.

Note: The amount you move the view in Stereoscopic Align mode is stored in the Paint 
> Stereo Offset parameter which can also be used to adjust the offset.

11 Deactivate Stereoscopic Align mode.

12 Paint on the image again.

Once aligned, painting with the Left/Right View activated will paint on the same 

location of the image in both views.

13 Paint some more frames in the sequence.

As frames are painted, markers are shown in the Timebar to provide a visual 

display of which frames are painted. Red markers are displayed for painted 

frames in the Left View, blue markers for the Right View and green markers for 

frames painted in both the Left and Right View.

Not Aligned Aligned
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Using the Stereo Viewer
A stereo Viewer window can be used to display the stereoscopic image in either 

Anaglyph or Interlaced modes on a 3D monitor.

1 In Preferences, set the Viewer > Stereo View Mode to either Anaglyph or 
Interlaced.

2 If you are using interlaced mode, set the Viewer > Stereo First Field preference 
to match the requirements of your 3D monitor.

3 Click the Stereo Viewer icon.

4 When the Stereo Viewer opens, drag it over to your 3D monitor.

5 Right-click in the Stereo Viewer and select Fullscreen.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

126 Tutorials

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Using the Composite Node
The Composite node renders a composite of the foreground over the 

background based on the generated Alpha channel.

1 From the pull-down menu at the top of the screen, select Session > Settings and 
activate Composite in the Available Nodes.

If “None” is selected for the Background Input, the foreground will be 

composited over a color. The default color is gray, but can be changed using 

the Composite node’s Background Color parameter.

2 If you have a clip that you would like to use for the background instead of a color, 
select it from the Input > Background pop-up menu.

The foreground will then be composited over the background.

3 If you choose to continue editing another node, just select it from the Node List.
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Rendering
When you have you completed your work in Silhouette, you will need to render 

the final result. Rendering takes place in the Render Options window.

1 Select Session > Render.

The Render Options window opens.

2 Choose a Range, File Format and Save mode.

Save sets how the file will be rendered. You can choose from 

Color+Alpha(RGBA), Color Only(RGB), Alpha Only and Paint Only. With Paint 

Only, only the painted portions of the frame along with the Alpha channel 

(where the brush painted) are exported as a premultiplied RGBA file. This 

feature is handy for adding only the painted portions in your compositing 

application.
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3 Select a directory to save your files and change the filename if you don’t like the 
default name.

4 If you are rendering a stereoscopic project, select whether you want to render 
the Left, Right or Both the Left and Right Views simultaneously using the View 
pop-up menu. If you are using the EXR file format to render a stereoscopic 
project, select View > Both and activate Combined to render both the Left and 
Right stereoscopic views into one file. 

At this point, you could just hit the Render button to render the sequence to 

disk. Alternatively, you could open a Preview window that displays each 

rendered image as well as render statistics while rendering.

5 Enable Preview and select Render.

The Preview window opens. Pressing the R, G, B, and A buttons toggles 

viewing of the respective channels while C displays the RGB channels.
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Keyboard Customization
Keyboard shortcuts can be customized by using a text editor to modify a Python 

script located in the scripts folder of your Silhouette installation.

To modify your Silhouette keyboard shortcuts:

1 Go to the scripts folder of your Silhouette installation. 

2 For Windows, go to C:\Program 
Files\SilhouetteFX\Silhouette4\resources\scripts.

or

3 For Linux, go to /opt/SilhouetteFX/silhouette4/resources/scripts.

or

4 For Macintosh, go to /Applications/Silhouette4, right-click on Silhouette and 
select Show Package Contents.

A new Browser window opens.

5 In the new Browser window, go to Contents/Resources/scripts.

Inside the scripts folder, you will find a keybinds.py file. As a precaution, it would 

be a good idea to make a backup of this file.

6 Make a copy of the keybinds.py file and rename the copy keybinds.py.bak.

7 Using a text editor, open the keybinds.py file.

8 Scroll down and replace the existing shortcuts with those of your choosing.

9 Save the file.

10 Restart Silhouette for the new keyboard shortcuts to be active.
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Using the Command-Line
Silhouette on the command-line allows you to execute projects with a variety of 

commands to control the rendering process.

1 Open a Terminal window.

The Silhouette command-line program is named sfxcmd and is located in the 

following locations depending on your operating system:

• Linux: /opt/SilhouetteFX/silhouette4

• Macintosh: /Applications/SilhouetteFX/Silhouette4

• Windows: C:\Program Files\SilhouetteFX\Silhouette4

2 Use the cd command to navigate to the location of the sfxcmd command-line 
program.

3 Type: sfxcmd

The Silhouette command-line options are displayed in the Terminal window. 

Command-line options are of the form: -option value, where value may be 

optional. Required arguments are in brackets (<>) and optional arguments are 

in braces ([]). If the value must be from a list of possible values, the available 

values are separated by |. The basic form of the sfxcmd argument is: sfxcmd 

<projectname> [options]

4 To render a project called vfx-125-02.sfx located at D:/SFX/projects, type: sfxcmd 
D:/SFX/projects/vfx-125-02.sfx

By default, the project is rendered using the settings in the project unless 

changed by command-line options.

5 To render every other frame, use the -step command as follows: sfxcmd 
D:/SFX/projects/vfx-125-02.sfx -step 2

Use -range or -f to specify single or multiple ranges of frames to render and -

start to override the starting frame number of the rendered frames. 

6 The vfx-125-02 session starts at frame 4000 and you want to render 50 frames, 
but you want the rendered files to start at 1. To do this, type: sfxcmd 
D:/SFX/projects/vfx-125-02.sfx –range 4000-4049 –start 1
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If your project has multiple sessions, you would need to target one of the 

sessions to render. If you are too lazy to open up the Silhouette user interface 

to determine the session name, you can use the -info command. 

7 To print information about the overall project, type: sfxcmd D:/SFX/projects/vfx-
125-02.sfx -info

When –info is used, rendering is disabled and the project information is 

displayed.

Project: vfx-125-02.sfx
FileSource: 125-02.[4000-4351].exr
Session: Session1
        Size: (2048, 1556)
        Aspect: 1.0
        Duration: 352.0
        Start: 4000.0
        Rate: 24.0
        Work Range: (4000.0, 4351.0)
        Node: Roto
        Node: 125-02.[4000-4351].exr
        Node: Output
        Node: Keyer
Session: Session2
        Size: (2048, 1556)
        Aspect: 1.0
        Duration: 352.0
        Start: 4000.0
        Rate: 24.0
        Work Range: (4000.0, 4351.0)
        Node: Output
        Node: 125-02.[4000-4351].exr
        Node: Effects
        Node: Power Matte

8 To render Session2 from the vfx-125-02 project, type the following: sfxcmd 
D:/SFX/projects/vfx-125-02.sfx -session Session2

It is also possible to render only a specific node.

9 To render only the Power Matte node in Session2 of the vfx-125-02 project, you 
would type: sfxcmd D:/SFX/projects/vfx-125-02.sfx -session Session2 -node 
“Power Matte”

Quotes are used around Power Matte because there is a space in the node 

name.
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There are lots of possibilities, so see the Command-Line section for a 

complete list of options and descriptions.
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 USER INTERFACE

Silhouette uses a combination of traditional pull-down menus, toolbars and 

pop-up menus. Quick keys are provided for most functions and are shown next 

to the pull-down menu equivalent. Pop-up tool tips describe the function of 

buttons when the cursor is dragged over them. Pop-up and floating windows 

are used where appropriate.

The Silhouette interface is comprised of a Project window, Viewer, Toolbar, 

Timebar, Timeline, Parameters, Node and Object Lists.

Toolbar

Timebar

Object List

Timeline

Parameters

Project
Window

Viewer

Node List
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Concepts

Projects
A project contains sessions and media.

Sessions
A session in Silhouette is where you create your Roto shapes, create mattes or 

paint images. It describes the resolution, bit depth, duration, frame rate and 

aspect ratio as well as what nodes you will be using. More on nodes below. 

Typically, you may have a job that requires you to work on multiple shots. A 

session would be created for each shot that you will work on. You can have as 

many sessions as you want, but can only work on one session at a time. 

Media
Media is a sequence of images. The location, frame rate, raster type, image 

size, and other information about the media is stored for your reference.

Objects
Objects are items such as shapes, trackers and brushes.

Layers
Layers are used to organize shapes, but more importantly they are used to 

contain the motion information from trackers.

Nodes
Silhouette internally is a node based system and different nodes are used for 

various functions. Currently, there are Keyer, Roto, Paint, Effects, Composite, 

Output and Source nodes.
lhouette 4.5 User Guide



• 

User Interface  135 

• 
• 
• 
•
•
•

Windows and Adjustments
The Silhouette interface contains multiple windows. Windows can be closed, 

torn off to be a floating window, or moved to a new location. The upper right 

portion of the window has two icons: a Minimize/Maximize and a Close icon.

Opening and Closing Windows:

• Click the Close icon to close a window. 

• Once a window has been closed, it can be reopened by selecting it from the View 
pull-down menu.

Creating Floating Windows:

• Click the Minimize/Maximize icon to make the window a floating window.

Moving Windows:

• Click and drag a docked window’s title bar and place it in a new location in the user 
interface. Note how the interface adjusts to accommodate the moved window.

• Click and drag a floating window’s title bar and place it in a new location.

Minimize/Maximize Close

Title Bar
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• If you drop the window in the center of an existing window, a tab will be created 
so that both windows will share the same space. This is the same as the Object, 
Node and Notes windows sharing the same location.

Sashes
By clicking and dragging the sashes, dividing lines between areas of the 

screen, you can customize the Silhouette interface.

Status Bar
The Status Bar is located at the bottom left of the User Interface and displays 

various messages.
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Tool Tips
Hovering the cursor over an icon will pop up a tool tip that displays its function.

Twirly Icons
Parameter groups in the Object and Node windows can be expanded and 

collapsed using the Twirly icons located to the left of the group.
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Animate Icons
Animateable parameters in the Object and Node windows have an Animate 

icon to the left of them. Keyframes are set when the Animate icon is enabled 

(highlighted).

Reset Icons
Individual parameters as well as parameter groups can be reset to their default 

settings using the Reset icon.

Off        On
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Slider Precision
You can adjust any slider with finer precision by pressing Ctrl(Win)/Cmd(Mac) 

while dragging the slider.

Spin Boxes

Spin boxes change values according to the following key strokes:

• Click = change by 1 pixel.

• Shift-click = change by 10 pixels.

• Ctrl-click = change by 0.1 pixel.
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Pull-Down Menus

File
New

Project
Create a new project by selecting File > New.

Session
Create a new session by selecting File > Session.

Open
Open projects with File > Open.

Save and Save As
Projects can be saved by choosing File > Save and File Save As.

Revert
You can revert to the last saved version by selecting File > Revert.

Close
File > Close closes the current project.

Recent Projects
The last five recently opened or saved projects can be selected and opened in 

File > Recent Projects.

Import

Media
Imports media into the project.

Shapes
Imports shapes into the project.

Export
Exports selected shapes from the project.
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Edit
Undo
Undo operations.

Redo
Redo operations.

Cut
Cuts the selected object.

Copy
Copies the selected object.

Paste
Pastes the selected object.

Select All
Selects all shapes.

Deselect All
Deselects all shapes.

Spline
Convert to Bézier

Converts the select shapes to Bézier shapes.

Stereoscopic
This is where you can link, unlink and duplicate shapes for stereoscopic 

rotoscoping. 

Link

Links two selected shapes of the same type and the same number of control 

points for stereoscopic rotoscoping. Linking allows the two shapes to be 

simultaneously selected and edited in the Left/Right View.

Note: Linked shapes are bolded in the Object List when one or both of a linked pair is 
selected.

Unlink

Unlinks selected shapes.
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Duplicate

Duplicates a selected shape or a single layer containing shapes to the other 

view and automatically links it. When a layer is duplicated, all of it’s transform 

data is copied as well.

Duplicate > New Layer

Duplicates a selected shape to the other view, automatically links it and places 

it in a new layer.

Note: Duplicate > New Layer is not available if you are in the Left/Right View.

Session
Session Settings
Opens the session settings.

Render Settings
Opens the render settings.

View
Maximize Viewer
Only the Viewer is shown.

Viewer + Timeline
Only the Viewer and Timeline are shown.

Windows
The various Silhouette interface windows are displayed with checkboxes next 

to them. When the box is checked next to an item, that particular window is 

displayed in the user interface.

Actions
The Actions menu executes various scripts located in 

Silhouette/resources/scripts/actions. For information on how to create custom 

scripts that show up in the Silhouette > Actions menu, see the Silhouette 4 

Scripting Guide for more information.

Select
Various selection actions are provided.
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All
Selects all items.

Hidden Objects
Selects hidden objects.

Layers
Selects all layers.

Siblings
Selects all siblings of a selected object in the current layer. For any selected 

objects, add all similar objects in that object's layer to the selection. 

Transparent Shapes
Selects all transparent shapes.

Time

Jump to Transparent
Looks at the selected shapes and jumps the Timebar to the first entirely 

transparent opacity keyframe it finds. 

Render Active Node
Renders the active node.

Render Layer's Shapes in Folders
Renders the layer's shapes in folders.

Render Layers to Separate Files
Renders layers to separate files.

Render Shapes to Channels
Renders shapes to different channels of an RGBA image as defined by the 

Shape > Channel parameter.

Render Shapes to Separate Files
Renders shapes to separate files.
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Help
About
Shows the Silhouette version.

User Guide
Opens the Silhouette User Guide in HTML format.

Scripting Guide
Opens the Silhouette Scripting Guide in HTML format.

What’s New
Opens the Silhouette What’s New document.

License
Opens the Deactivate window which has three choices: Internet Deactivate 

(Recommended), Remove License and Advanced Options.
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Project Window
A project contains sessions and media. When you open Silhouette, a new 

Project window automatically opens.

Import Media
Footage is imported by selecting File > Import > Media or by double-clicking on 

an open space in the Project window. When the File Browser opens, you can 

import a single frame, the entire clip or a range of frames.
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Table 1: Import Options

We currently support the following file formats: Cineon, DPX, IFF, JPEG, 

OpenEXR, PNG, SGI/RGB, QuickTime, TIFF and TARGA.

Note: QuickTime is only available on operating systems that support it.

Open
Loads the selected media into the Project window.

Cancel
Cancels the import operation.

Go to Importing Media to see how it works.

When media is imported into Silhouette, it is automatically plugged into a 

Source node. When one of the image sources is selected in the Node List, it’s 

parameters can be set in the Node window.

See Source Nodes for more information.

Replacing Media
If the media is moved from its location on disk after you have imported it, 

Silhouette will no longer be able to find it. However, you can easily relink the 

media using the Replace feature which lets you replace your existing clip with 

a new one. You can replace footage by going to the Project window, right-

clicking the media and choosing Replace from the pop-up menu.

Go to Replacing Media to see how it works.

Relinking Painted Frames
When activating the Paint node, a scan for the painted images takes place. If it 

detects anything missing, it will ask you want to relink or just ignore. The paint 

resides in a directory named with a GUID (globally unique identifier), such as 

Selection Action

Select the first frame in a sequence Imports the entire sequence

Select a range of frames Imports the selected range of frames

Select any single frame other than the first frame Imports only that frame
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71e58332-2a34-4292-b828-6fa8c4b2bed3. This directory with the same name 

must exist somewhere, and you will be allowed to point to the folder that 

contains that GUID directory for the relink to happen.

Edit Source
The settings of the source media can be modified using the Edit Source 

window. You can access these settings by right-clicking on media in the Project 

window and selecting Edit Source from the pop-up menu.

Environment Variables
The Path and Result fields allow you to specify the file path with environment 

variables.

Path
You can replace parts of the Path field with a new path and/or environment 

variables. 

Result
The Result field is read-only and shows you what your path expands to if you 

have environment variables. A green check or yellow warning icon to the right 

shows you whether or not all of the images in your path are actually present. A 

green check means the path is valid while a yellow warning icon indicates an 

invalid path.

Go to File Path Environment Variables to see how it works.
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Video Fields
When working with footage that contains video fields, you have the option of 

either deinterlacing or removing 3:2 Pulldown. What are video fields and 3:2 

Pulldown, you ask? Well, a review of the mechanics of video frames and fields 

is in order, so listen up. 

The resolution of video images is 525 lines for NTSC and 625 lines for PAL. 

NTSC video runs at 30 frames per second and PAL at 25 frames per second. 

Each video frame is made of two separate subframes called fields. Each of 

these fields is an individual snapshot in time. By using fields, the viewer sees 

twice as many frames and smoother motion. Even though the fields represent 

different points in time, they occupy the same video frame. This is achieved 

through a process called interlacing.

Here comes the fun part. Interlacing weaves together the two fields by starting 

at the top of the image and taking one line from field 1 (the odd field) and 

another line from field 2 (the even field) until all 525 or 625 lines are interlaced 

together. Temporally, the fields always occur in the following order: field 1 and 

then field 2. Spatially, the ordering is different for NTSC and PAL. For NTSC, 

the spatial field order starts with field 2, or the even field. For PAL, it is the exact 

opposite with field 1, or the odd field, being the first spatial field.

Therefore, the interlace process produces two fields of half-height for every 

broadcast frame. When a television displays these images, it quickly shows the 

first field only, and then the second field only, and then proceeds to the next 

frame. Each field sacrifices vertical resolution for the benefit of temporal quality.

Deinterlacing
When deinterlacing is enabled, it strips out the two fields from each other, 

placing field 1 at frame 1, and field 2 at frame 1.5. Each field is then copied and 

moved into the empty spatial place of the removed field. This ensures that all 

spatial effects are properly handled when rendering fields. This strategy is 

clever because it doubles the number of frames you have, but keeps the frames 

within the same duration.
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3:2 Pullup / Pulldown
What in the blazes does 3:2 Pullup / Pulldown mean? This is a technique to 

temporally convert (resolution not being considered here) film footage to video 

footage and back again. Given that film uses solid frames and video uses 

interlaced fields, and that film runs at 24 fps and NTSC runs at 30 fps, you split 

the film footage into fields and double up 2 out of 5 frames to increase your 

frames to fill the 30 fps. Pullup is the conversion of film footage from 30fps to 

24fps while Pulldown is the conversion of 24fps film footage to 30fps.

Let's use the classic diagram: 

We see that the third and fourth video frames have field blending in them to 

stretch time out. It's therefore called 3:2 because you have three solid frames 

and two mixed frames.

3:2 Pullup
We can fully reconstruct our original four film frames by extracting the field data 

from the five video frames. Here comes the odd bit. When you receive your 

footage, it has probably been edited, so it is not necessarily the case that 

frames three and four are the mixed frames because all of the clips have been 

shifted around in the edit. We therefore need to figure out what the first frame 

is before we attempt to remove the extra fields. To do this, you would go to your 

first five frames in the sequence. If the first frame to have field blending is frame 

three, you know your first frame should be set to AA. If the first frame to have 

field blending is frame two, then you know your first frame is BB. You would 

then set your 3:2 parameter accordingly. If your first frames are a solid color and 

you can't figure it out, you have to jump to a time range of frames that display 

the blending and start guessing what the first frame is until the fields go away. 

Very scientific, isn’t it?

AA BB BC CD DD
5 Video Frames

A B C D
4 Film Frames
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Use the 3:2 setting in the chart below that corresponds to your first frame with 

field blending.

Table 2: 3:2 Pullup

Field Handling
You can choose from either Deinterlace or one of the 3:2 settings.

None
No field processing takes place.

Deinterlace
Deinterlaces the video frame into two separate fields.

3:2 AA
Removes 3:2 Pulldown based on the AA frame being the first frame.

3:2 BB
Removes 3:2 Pulldown based on the BB frame being the first frame.

3:2 BC
Removes 3:2 Pulldown based on the BC frame being the first frame.

3:2 CD
Removes 3:2 Pulldown based on the CD frame being the first frame.

First frame with field blending 3:2 Setting

1 BC if followed by a blended frame / CD if followed by a solid frame

2 BB

3 AA

4 DD
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3:2 DD
Removes 3:2 Pulldown based on the DD frame being the first frame.

Field Dominance
Select either Even or Odd field dominance depending on whether you are 

working with NTSC or PAL images.

Even
Use for NTSC images.

Odd
Use for PAL images.

Go to Working with Video Fields and Working with 3:2 Pullup / Pulldown 

to see how they work.

Interpretation
Interpretation is only displayed in the Edit Source menu when using DPX files. 

It detects and sets whether DPX files are Logarithmic or Linear. Sometimes the 

program used to create the DPX files writes the wrong header information into 

the file causing Silhouette to think it is Logarithmic when it is Linear and vice 

versa. The controls below allow you to explicitly set whether or not the file is 

Logarithmic or Linear.

Auto
Automatically figures out whether the DPX file is Logarithmic or Linear.

Log
Manually sets the DPX file to Logarithmic.

Lin
Manually sets the DPX file to Linear.
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Autosaving and Backups
A numbered autosave and backup system ensures that you will not lose any of 

your work. Autosaves and backups are stored in $HOME/Silhouette4 for 

Windows and Linux. HOME on Windows is by default in the user's profile 

directory, usually C:\Documents and Settings\UserName on XP and 

C:\Users\UserName on Vista. On Macintosh, the autosaves and backups are 

stored in your HOME directory in Library/Application 

Support/Silhouette4/autosaves.

Autosaves
The Auto Save > Maximum # of Saves preference specifies how many 

autosave files will be stored at once. The most recent autosave is autosave.sfx, 

the second most recent is autosave.1.sfx, then the next is autosave.2.sfx, etc., 

up to the maximum number of 5. As each new autosave is added, the files are 

rotated upward. When a project is opened or created, a lock file is created. This 

file is deleted when the current project is closed. If Silhouette crashes, the lock 

file will remain. The next time Silhouette starts up, it checks for the lock file as 

well as the presence of any autosave files, and lets the user choose one. If an 

autosave file is chosen, the path is cleared, so the user will be asked to choose 

a filename at the next save. 

Backups
The Auto Save > Maximum # of Backups preference controls how many 

backup files are created. Each time a project is saved, a backup copy is stored. 

These files are rotated exactly like the autosave files each time the project is 

saved. The backup files are named with the same name as the project. 

Note: Like autosaves, the most recent backup is project_name.sfx, the second most 
recent is project_name.1.sfx, then the next is project_name.2.sfx, etc., up to the 
maximum number of 5.
lhouette 4.5 User Guide



• 

User Interface  153 

• 
• 
• 
•
•
•

Sessions
A session in Silhouette is where you do your work, whether it be rotoing 

shapes, creating mattes or painting images. Typically, you may have a job that 

requires you to work on multiple shots. A session would be created for each 

shot that you will work on. You can have as many sessions as you want, but 

can only work on one session at a time.

Go to Creating Sessions to see how it works.

New Session
You must create a session before you can start working with your footage. It 

describes the resolution, bit depth, duration, frame rate and aspect ratio as well 

as what nodes you will be using. You create a new session by highlighting an 

image sequence in the Project window and pressing either 

Ctrl(Win)/Cmd(Mac)-N or selecting File > New > Session.

Editing Sessions
Once you have created a session, you can change its settings at any time by 

either 1) Selecting Session > Settings, 2) Right-clicking on the name of a 

session in the Project window and choosing Edit Session or 3) Pressing 

Ctrl(Win)/Cmd(Mac)-Shift-S. In either case, the Session window opens and 

you can change the settings.
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Switching Sessions
To switch between sessions, double-click on the name of the session in the 

Project window.

Session Window
The Session window has a variety of settings for format, image size, pixel type, 

and frame rate. You can choose one of the preset formats or create a custom 

format.

Available Nodes
Silhouette internally is a node based system and different nodes are used for 

various functions. Currently, there are Keyer, Roto, Paint, Effects and 

Composite nodes. By default, the Roto node is selected. Activate whichever 

nodes you will be using in your session. You can always add additional nodes 

to a session after it has been created by selecting Session > Settings.
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Keyer
Activates the Keyer node for the session.

Power Matte
Activates the Power Matte node for the session.

Roto
Activates the Roto node for the session.

Paint
Activates the Paint node for the session.

Effects
Activates the Effects node for the session.

Composite
Activates the Composite node for the session.

Name
Determines the name of the session.

Format
A number of preset formats can be selected from the Format pop-up menu. 

When one of the options is selected, the session fields are preset with the 

appropriate data. See Appendix C - Session Formats for a complete listing of 

all format presets.

Format Presets
• Custom

• Film Full Aperture (4K: 4096x3112)

• Film Full Aperture (4K: 4096x3072)

• Film Full Aperture (2k: 2048x1556)

• Film Full Aperture (2k: 2048x1536)

• Film Cinemascope Full (3656x2664)

• Film Cinemascope Half (1828x1556)

• Film Academy (1828x1332)

• HDTV 24p (1920x1080)
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• HDTV 1080i (1920x1080)

• HDTV 720p (1280x720)

• NTSC (640x480)

• NTSC (648x486)

• NTSC DV 720x480)

• NTSC DV Widescreen (720x480)

• NTSC D1 (720x486)

• NTSC D1 Square Pixels (720x540)

• PAL D1/DV (720x576)

• PAL D1/DV Square Pixels (768x576)

• PAL D1/DV Widescreen (720x576)

Size

Width
Sets the width of the image.

Height
Sets the height of the image.

Pixel Aspect
Sets the pixel aspect ratio of the image.

Duration
Sets the length of the session.

FPS
Sets the frame rate of the session.

Start Frame
Sets the start frame for the session. The Player, Timeline and Render Options 

incorporate this value into their numbering. 

Depth
Sets the bit depth of the session.
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8 bit
Sets the bit depth to 8 bits per channel.

Float
Sets the bit depth to floating point. Use for film sessions using OpenEXR, DPX 

and Kodak Cineon files.

OK
Creates a new session in the Project window. The name, New Session, is 

highlighted waiting for you to name it. When you click OK, the session is 

automatically created.
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Toolbar
Along the left side of the Viewer is the Toolbar. It contains icons that select 

various tools. The contents of the Toolbar will change depending upon the node 

that is selected.

Black and White

Blemish

Blur

Color Correct

Drag

Eraser

Grain

Clone

Color

Mosaic

Repair

Scatter

Paint Toolbar
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Viewer
Silhouette uses a Viewer for image editing as well as for clip playback. Some 

features include: viewing individual color channels, the simultaneous display of 

RGB and Alpha channels, the selection of stereoscopic views as well as the 

superimposition of shapes over images. 

View
Offers various View options for the selected node. The View choices will 

depend on the node.
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Inputs
Roto, Effects, Keyer and Power Matte Node Inputs
Selects clips from the Project window to be used as the foreground and 

background.

Foreground
Selects a clip from the Project window to be used as the foreground.

Background
Selects a clip from the Project window to be used as the background.

Paint Node Inputs
Selects clips from the Project window to be used as clone sources and the 

foreground.

Foreground
Selects a clip from the Project window to be used as the foreground. The 

foreground input in Paint is the image you will paint on.
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Clone 1-4
Selects clips from the Project window to be used as clone sources.

Update
Determines when processing takes place. The ! key cycles through the Update 

modes.

Drag
Tries to process as fast possible.

Release
Processes once the mouse or pen is released. This the default setting.

Manual
Silhouette does not process. If you place the cursor within the Viewer window 

and hit the Enter key, Silhouette will manually process any changes.

Stereoscopic View Modes
The Stereoscopic View modes, which only show up when using stereoscopic 

sources, determine whether you are working on the Left View, Right View or 

both the Left and Right Views at the same time.
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L (Shift-1)
Left View displays the left sequence in the Viewer.

R (Shift-2)
Right View displays the right sequence in the Viewer.

LR (Shift-3)
Left/Right View displays both the left and right sequences in the Viewer at the 

same time.

Stereoscopic Split Mode
Only available once the Left/Right View is active, Stereoscopic Split Mode 

determines whether or not the Left and Right Views are arranged horizontally 

or vertically.

Horizontal
Arranges the Left and Right Views horizontally.

Vertical
Arranges the Left and Right Views vertically.
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Stereoscopic Align (Shift-4)
Stereoscopic Align utilizes layers to line up two stereoscopic sequences which 

will effectively negate the offset between them. Aligning the sequences in this 

manner allows painting on the same location of the Left and Right Views 

simultaneously, while for rotoscoping, it means shapes created for the Left 

View can be easily duplicated to the Right View in the proper position.

Note: Stereoscopic Align can only be selected and used once a layer is active.

When activated, Stereoscopic Align uses a negative mode which inverts one of 

the views and mixes it with the other. This creates an embossed effect when 

similar image areas are not aligned. By dragging the move cursor that appears, 

you can drag on the Viewer to align the views. When similar image features are 

perfectly aligned, you will see a solid gray color. The amount you move the view 

in Stereoscopic Align mode is stored in the Stereo Offset parameter of the 

active layer which is set to animate by default. Animation of this parameter is 

needed for image sequences that contain depth changes.

Table 3: Stereoscopic Align Keyboard Shortcuts

Shortcut Action

Click and drag in Viewer Moves the Stereo Offset horizontally

Shift-click and drag in Viewer Moves the Stereo Offset horizontally and vertically

Ctrl-drag in Viewer Moves the Stereo Offset in finer increments

Alt-click in Viewer Resets the Stereo Offset

Arrow keys Moves the Stereo Offset by 1 pixel

Shift-Arrow keys Moves the Stereo Offset by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the Stereo Offset by one tenth of a pixel

Hold down Arrow keys Moves the Stereo Offset continuously
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Anaglyph Preview (Shift-5)
Activates Anaglyph Preview mode so that you can check your stereoscopic 

image in 3D using red-blue glasses.

Stereo Viewer (Shift-6)
Opens a stereo Viewer window for displaying the stereoscopic image in either 

Anaglyph or Interlaced modes on a 3D monitor. The default mode is defined in 

the Viewer > Stereo View Mode preference.

Interlaced mode requires a 3D monitor that uses interlacing like the Zalman 

passive display. When in Interlaced mode, the Stereo First Field viewer 

preference controls which eye comes first--Left or Right. This needs to match 

up with how the monitor does the 3D effect. You can also right-click and select 

Zoom > Fit, Zoom > 1:1 or Fullscreen to completely fill the screen with the 

Stereo Viewer.

Note: On a single monitor system, the Esc key will close the Stereo Viewer.

Table 4: Stereoscopic View Shortcuts

Shortcut Action

Shift-1 Selects the Left View

Shift-2 Selects the Right View

Shift-3 Selects the Left/Right View

Shift-4 Selects Stereoscopic Align

Shift-5 Anaglyph Preview

Shift-6 Stereo Viewer
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Display Options
The Display Options icon reveals the color management options which remain 

visible as long as it is enabled.

Silhouette uses the OpenColorIO standard originally developed by Sony 

Pictures Imageworks for it’s color management. You can load custom color 

configuration files and custom LUTs, apply color space conversions, as well as 

use other controls for fine tuning. Silhouette includes a set of preset color 

profiles, plus you can configure and use your own by specifying one in the Color 

Management > OCIO Configuration preference.

For a more detailed explanation of OpenColorIO, including generating LUT’s 

and suggested workflows, please visit http://opencolorio.org/.

Note: The color management functionality provided in the Display Options is for display 
purposes only. The color profiles, LUTs, and colorspace conversions applied in the 
Viewer do not affect the rendered image.

Color Management

Colorspace
Set the input colorspace of the scene. The following colorspaces are provided: 

Linear, sRGB, rec709, Cineon, Gamma 1.8, Gamma 2.2, Panalog, REDlog, 

ViperLog, AlexaV3LogC, PLogLin, SLog, Raw.

Silhouette automatically tries to determine the colorspace based on the data in 

the file and other information from the header. If a colorspace can’t be detected, 

Linear will be selected. 

Display
Set the colorspace of the display device used to view the scene. The default 

OCIO configuration only has one display option. Additional devices can be 

added in a custom configuration and will show up in this menu.
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View Xform
Select a colorspace transform to apply to the scene. You can select from sRGB, 

rec709 or None.

LUT
Select a custom LUT to apply to the scene. A number of LUT formats are 

supported including: Flame, Lustre, Color Correction Collection, Color 

Correction, Cinespace, Houdini, Iridas itx, Iridas cube, Pandora mga, Pandora 

m3d, Sony Pictures Imageworks 1D, Sony Picture Imageworks 3D, Sony 

Picture Imageworks mtx, Truelight and Nuke vf.

Note: Selecting a LUT disables the Colorspace, Display and View Xform controls.

Gain
Adjusts the brightness of the image in F-stops. Gain is applied before the 

display transform.

Gamma
Adjusts the gamma of the image. Gamma is applied after the display transform.

Go to Color Management Tutorial to see how it works.

Proxy
Sets the resolution at which the clip will be played and viewed. The higher the 

number, the lower the resolution.

The higher the proxy setting, the more frames you can play.

1:1
1:1 keeps the image quality at full resolution.

2:1
2:1 lowers the image resolution by 1/2. 
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3:1
3:1 lowers the image resolution by 1/3.

Magnify
Magnify opens a magnification window at the bottom right corner of the Viewer 

and displays a zoomed area around the cursor location. It is useful for precise 

control point/tracker placement and while painting when the Viewer is zoomed 

out. Magnify is available in the Roto > Reshape and Tracker tools.

Masks
Masks aid you in determining what will be projected on film or shown on 

television by adding reticles and or a variable opacity mask to the Viewer.
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The following aspect ratio’s are supported: 1:66, 1:78, 1:85, 2:35 as well as 

Safe Action for video. When an aspect ratio is selected from the Mask pull-

down menu, the mask settings defined in the Viewer Preferences are activated. 

See the Viewer Preferences for more information.

Creating Custom Masks
In the Silhouette/resources folder of your installation, there are two files: 

formats.xml and masks.xml.

You can add your own custom masks to the masks.xml file. The rectangle 

values are multiplied by the image width/height to figure out where the mask 

should be placed. For example, Safe Action is a 90% rectangle, so the border 

is .1, .1, .9, .9 (i.e. 10%, 10%, 90% 90%) of the image size.

You associate certain masks with certain formats by adding a “Mask” entry to 

the formats in formats.xml. You can add any number of masks to each format. 

These masks will be available in the mask selector in the Viewer, depending on 

the session format.

Note: You can't associate masks with “custom” session formats. Instead, you should 
add a new format to your formats.xml file if you have an odd format you want to use 
with masks. 

Stabilize
The Viewer is stabilized based on the active layer’s tracking data.
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Overlay
Toggles the display of overlays which are lines, shapes or objects that 

Silhouette superimposes over the image. 0, the number zero, toggles the 

overlay.

RGBA
Displays various combinations of the Red, Green, Blue and Alpha channels.

Selecting Channels
Clicking on the Red, Green, Blue or Alpha buttons solo that channel as a gray 

scale image. Ctrl(Win)/Cmd(Mac)-clicking the Red, Green, Blue or Alpha 

buttons toggles the display of each component. The horizontal white bar above 

the RGBA buttons quickly toggles the display of the image back to full color 

mode.

Solo Channels
Alt-R/G/B/A toggles the Red, Green, Blue and Alpha channels on and off.

Alpha Display
Cycle Alpha

Either press the Alpha button (to the right of the blue button) or the A key to 

cycle the state of the Alpha display. Pressing once superimposes the Alpha 

channel over the image. Pressing a second time displays the Alpha channel 

over black. Hitting it again shows only the color image. 

Note: To view a shape’s Alpha channel, you must first set the View to Output before 
pressing the Alpha button or the A key.

Display Alpha - No Overlay

Shift-A toggles the View to Output, superimposes the Alpha channel over the 

image and deactivates the Overlay. Pressing Shift-A again returns the Viewer 

to its previous state.
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Display Output Node’s Alpha

You can quickly view the Output node’s Alpha channel from any other node by 

using the Alt+o shortcut key. Pressing Alt-o again views the previous node.

Alpha Mix

The numeric entry box next to the RGBA buttons controls the opacity of the 

Alpha channel when it is superimposed over the image.

Go to Using the RGBA buttons in the Viewer to see how it works.

AR
Activates pixel aspect ratio correction in the Viewer as defined in the session 

settings. For instance, this lets you view Cinemascope ratio images as they 

would appear when projected.

Zooming and Panning
Sets the zoom factor for the image.

25%-200%
100% displays the image at it’s actual size at a ratio of one image pixel to one 

screen pixel.

You can also zoom the image using the scroll wheel on your mouse, the I key 

to zoom in and the O key to zoom out or press Space Bar-Shift and drag left 

or right.

Fit
Either pressing the F keyboard shortcut or selecting Fit from the zoom pop-up 

window will display the image as large as possible within the Viewer window.
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Home
You can either press the H keyboard shortcut or double-click the middle mouse 

button to set the image to a 100% zoom level and center it in the Viewer.

Center Selection
Press Ctrl(Win)/Cmd(Mac)-F to center the selection in the Viewer.

Go to Viewer Navigation to see how to zoom and pan the Viewer.
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Table 5: Viewer Keyboard Shortcuts

Shortcut Action

F1 Only the Viewer is shown in the interface

F2 Only the Viewer and Timeline are shown in the interface

0 Toggles the display of overlays which are lines, shapes or objects

Number Keys (1-6) Switches the Viewer > View menu

~ Cycles through the update modes

A Cycles the display between the full color image, the Alpha channel 
superimposed over the image and the Alpha channel by itself

Shift-A Toggles the View to Output, superimposes the Alpha channel over 
the image and deactivates the Overlay

Alt-R/G/B/A Toggles the Red, Green, Blue and Alpha channels on and off

Alt-o Toggles the display to/from the Output node’s Alpha channel from 
any other node. Pressing Alt-o again views the previous node.

Ctrl(Win)/Cmd(Mac)-click 
RGB buttons

Toggles the display of each component on or off

Middle-mouse drag Pans the image

Space Bar-drag Pans the image

I Zooms the image in

O Zooms the image out

Shift-Middle-mouse drag Zooms the image in and out

Scroll wheel Zooms the image in and out

Space Bar-Shift-drag Zooms the image in and out

F Fits the image in the Viewer

H or Middle-mouse double 
click

Centers the image in the Viewer at 100%

Ctrl(Win)/Cmd(Mac)-F Centers selection in the Viewer

‘ Opens a context menu over pen/mouse location
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Timebar / VTR Controls
The Timebar below the Viewer provides you with controls to play your clips as 

well as navigate your sequence.

Timebar
Keyframe Markers
Colored markers in the Timebar shuttle area signify where selected objects 

have keyframes. Objects that display keyframes in the Timebar are shapes, 

trackers and painted frames. Path keyframes are shown for shapes, position 

keyframes for trackers and painted frames when in the Paint node.

The color of the markers is determined by the object color. If multiple selected 

objects have a keyframe on the same frame, the most recently selected 

object's color has precedence. A white marker is used to signify the current 

frame and hovering over a marker displays a tool tip showing the keyframe 

time.

Shift-Alt-clicking and dragging a marker will move the keyframe in time.

First Frame
The numeric entry box on the left displays the first frame of the clip being 

viewed. Enter a new number in the numeric entry box to change the start frame 

and hit Enter. 

First Frame Last Frame

Frame Rate

Increment

VTR Controls

Current Frame

FieldsPlay Menu

Current Frame

Keyframes

Shuttle Area
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Last Frame
The numeric entry box to the right of the shuttle slider displays the last frame of 

the clip being viewed. Enter a new number in the numeric entry box to change 

the last frame and hit Enter. 

Current Frame
The second numeric entry box to the right of the shuttle slider displays the 

current frame of the clip being viewed. Enter a new number in the numeric entry 

box and hit Enter to move directly to that frame in the clip.

Increment
The far right numeric entry box controls the amount of frames that the Viewer 

increments from frame to frame.

Fields
When selected, the Fields button changes the Timebar and Timeline to 

advance and display in half frame increments.

Play Menu
Change how the clip is played. The Play menu is located at the bottom-left of 

the Viewer.

Once
Plays the clip once when you press the Play button.

Loop
Plays the clip in a continuous loop when you press the Play button.

Swing
Plays the clip continuously, alternately forwards, then backwards when you 

press the Play button.
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VTR Controls
The VTR controls control clip playback.

Shuttle
Clicking and dragging in the shuttle area shuttles through the clip.

Previous Key
Moves to the previous keyframe.

Next Key
Moves to the next keyframe.

Home
Moves to the first frame of the sequence.

Previous Frame
Step backward 1 frame.

Play Backward
Plays the sequence backwards.
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Stop
Stops playing the sequence.

Play
Plays the sequence forward.

Next Frame
Step forward 1 frame.

End
Moves to the last frame of the sequence.
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Table 6: VTR Controls Keyboard Shortcuts

Frame Rate
Sets the frame rate for the clip in the Viewer. Enter the desired frame rate, for 

instance: 24 fps (film), 25 fps (PAL), 29.97 fps (NTSC DF) or 30 fps (NTSC 

NDF).

Real-Time Playback
Silhouette can cache frames into RAM to guarantee real-time playback. When 

you hit the play button, each frame is cached into RAM. Once the clip is played 

through once, it will then play in real-time. At the bottom right corner of the 

Shortcut Action

Z Step backward 1 frame

Shift-Z Moves to the previous keyframe

X Step forward 1 frame

Shift-X Moves to the next keyframe

J Plays the sequence backwards

K Stops or starts playback

L Plays the sequence forwards

Space Bar Stops playback

Home Moves to the first frame of the sequence

End Moves to the last frame of the sequence

Click and drag in the shuttle area Shuttles through the clip

Shift-Alt-click and drag a keyframe marker Moves the keyframe in time
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interface, there is a numeric readout (Cache Display). It displays the length of 

your clip, the maximum frames that can be cached into RAM, the percentage 

of RAM currently being used as well as the session’s bit depth.

If your clip is longer than the maximum frames that can be cached into RAM, 

the clip will not play in real-time.

Note: Hovering over the Cache Display will reveal a tool tip that shows the maximum 
cache size and total available physical memory in megabytes.

Go to Optimizing Playback to see how you can playback the maximum 

amount of frames.

Purge Cache
Right-clicking on the Cache Display (numeric readout at the bottom right corner 

of the interface) pops up a Purge Cache option. If selected, this will clear out 

currently cached frames.
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Node List
Silhouette internally is a node based system and different nodes are used for 

various functions. Currently, there are Keyer, Roto, Paint, Effects, Composite, 

Output and Source nodes. The nodes that you see in the Node List are those 

that were selected when creating the session. You can always add additional 

nodes to a session after it has been created by selecting Session > Settings 

from the pull-down menu at the top of the screen.

The Node List is used to select nodes for editing, viewing, enabling and 

disabling.

Clicking on or near a node’s icon makes it the active node. You can tell which 

node is active by its highlighted state.

Once active, the node’s parameters appear in the Node window and the 

appropriate tools show up in the Toolbar.

Go to Using the Node List to see how it works.

Icons
There are two icons directly to the right of a node’s name that are used to 

change which node is viewed and whether nodes are enabled or disabled.
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View
Chooses which node or source to show in the Viewer. Normally, you are 

viewing the active node, but there are times when you may want to view one 

node while editing another. Double-clicking the active node will return the view 

to the active node if a different node was selected for viewing.

Note: The tools and controls are shown for the active node (the node that is 
highlighted) and not the node that is being viewed.

Enabled
Enables or disables the node. When disabled, the node does not render.
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Parameters
Parameters for selected objects such as shapes, layers, and trackers are set 

in the Object window while nodes like Keyer, Power Matte, Roto, Paint, Effects, 

Composite, Output and Sources are set in the Node window. In addition, notes 

can be assigned to shapes, layers and trackers in the Notes window.

Note: When dragging sliders, press the Ctrl(Win)/Cmd(Mac) key while dragging for 
finer control.

Object Parameters
All of the editable parameters of a shape, layer or tracker can be adjusted in the 

Object window. When a shape is selected, you will see the parameters listed 

below.

Shape Parameters
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Node Parameters
The Node window allows you to adjust parameters for the selected node in the 

Node List. The nodes that can be currently selected are Keyer, Power Matte, 

Roto, Paint, Effects, Composite, Output and Sources.

Notes
The Notes window allows you to type an arbitrary length note for selected 

objects.

Output Node Parameters
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Object List
The Object List is where you can select, lock, combine, rename or delete 

shapes, layers and trackers. Layers are containers for shapes and have their 

own individual transforms.

Add Layer
Located at the bottom of the Object List, this icon creates a new layer. Layers 

are used to organize shapes, but more importantly they are used to contain the 

motion information from trackers.

Note: Dragging objects onto the New Layer icon will create a new layer and move the 
objects into it in one operation.

Deleting
Select the shape, layer or tracker in the list and press Ctrl(Win)/Cmd(Mac)-X, 

hit the Delete key or use the Delete icon at the bottom of the Object List.

Renaming
You can rename a shape, layer or tracker by either:

• Clicking on the object once to select it, hitting the Enter key, typing in the new 
name and pressing Enter again.

• Double-clicking the object, typing in a new name and hitting the Enter key.

Layer

Objects

Layer Icons

Shape Icons
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• Right-clicking on the object, selecting Rename and typing in a new name.

Selecting
Clicking the name of a shape, layer or tracker selects it. Multiple shapes, layers, 

and trackers can be selected by Shift-clicking on them. Ctrl-clicking will add to 

the selection of objects that are located at different levels of the Object List 

while Ctrl-clicking an object after it is selected will deselect it. In addition, if you 

Shift-click a color pot in the Object List, you select all objects of the same type 

and color.

Note: In File > Preferences > Shape on Windows and Linux or Silhouette > 
Preferences > Shape on Mac, there is a Template Color setting that sets the color and 
opacity of unselected shapes. This feature is enabled by using Shift-W.

Moving
Shapes, layers or trackers can be moved by dragging and dropping them to a 

new position in the list or within another layer.

Expanding / Collapsing Layers
Expand All
Shift-clicking the +/- icon expands or collapses all nested layers inside that 

layer.

Expand or collapse multiple layers at once 
If expanding or collapsing a selected layer using +/- icon, then any other 

selected layers with the same parent will also expand or collapse. This can be 

combined with Shift to expand or collapse children as well.
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Icons
Shape Icons
There are number of icons directly to the right of a shape’s name that can be 

used to modify shapes. The Opacity, Blend Mode, Invert, Motion Blur and Color 

icons duplicate the functionality of the Shape parameters in the Object window 

and does so because it is often easier to change these settings in the Object 

List when multiple shapes are selected.

View
The View icon, which only shows up when using stereoscopic sources, displays 

either a L for Left View or R for Right View to the left of the Opacity icon and 

indicates which view the shape or layer is assigned to. Clicking on the View 

icon toggles which view the shape or layer is located in.

Opacity
Indicates the opacity level of a shape. It is white when opacity is 100%, black 

when 0% and a shade of gray when somewhere in between. When keyframing 

is activated for Opacity in the Shape parameters, you can quickly keyframe the 

opacity of a shape from 100% to 0% by toggling this icon.

Note: In File > Preferences on Windows and Linux or Silhouette > Preferences on Mac, 
there is a Shape > Fade Outline with Opacity setting that draws unselected/inactive 
shape outlines using the Opacity value. This preference can be toggled using the V key 
so that you can easily see any shapes that are at 0% opacity.

View

Blend Mode

Motion
Blur

Color
Lock

Notes

Invert

Opacity Visibility
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

186 User Interface

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Blend Mode
Controls how shapes are blended together. Each click of the icon cycles 

through the blend modes. See Blend Mode for information.

Invert
Inverts selected shapes.

Motion Blur
Turns Motion Blur on or off for selected shapes.

Outline Color
Sets the color of selected shape’s outlines.

Left-clicking the color pot opens a standard color picker while right-clicking on 

the color pot opens a pop-up color menu with 16 primaries. 

Lock
Locks/Unlocks selected objects. A locked shape cannot be edited or changed 

and is italicized in the Timeline. 
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Visibility
Click the Visibility icon to hide or show selected objects. Only visible shapes are 

rendered. To solo an object, Alt-click on it’s Visibility icon. Alt-Ctrl-click to force 

the visibility of all objects to the on position. 

Notes
Select an object and click the Notes icon to bring the Notes window forward 

above the Object List.

You can type an arbitrary length note for selected objects. Currently, only 

shapes, trackers and layers are supported. Because you can type multiple 

paragraphs into the Notes window, you must press Apply to assign the note. 

The Notes icon changes once a note is applied to the object.

• Hovering over the Notes icon displays the note, if there is one, as a tool tip.

• The Status Bar displays the object name and the note for the selected object.

Layer Icons
There are few icons directly to the right side of a layer’s name that can be used 

to modify layers.

Active Layer
Lock

Visibility
Blend Mode

Invert

View Notes
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The Layer View, Blend Mode, Invert, Lock, Visibility and Notes icons have 

similar functionality to the ones used by shapes.

Active Layer
The Active Layer box displays a checkbox when the layer is selected. Clicking 

the checkbox will toggle the state of the Active Layer.

Table 7: Object List Shortcuts

Shortcut Action

Click on an object Selects the object

Shift-click an object Adds an object to the current selection

Ctrl(Win)/Cmd(Mac)-click on an object Toggles the object selection

Shift-click color pot Selects shapes of same color

Alt-click the Visibility icon Solos an object

Alt-Ctrl-click the Visibility icon Forces the visibility of all objects to the on position

Shift-click the +/- icon Expands or collapses all nested layers inside that layer

Double-click an object Selects the object so it can be renamed
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Timeline
The Timeline is an overall view of all animated parameters. Animation is the 

process of setting values at various frames, or keyframes as they are called. 

These keyframes transition from one to another over time. The Timeline 

provides you with the tools necessary to view, edit, move or delete keyframes.

The Timeline is divided in two parts:

• Parameter List: lists all animateable parameters for a particular process.

• Timeline: displays keyframes over time.

Go to Using the Timeline to see how it works.

Parameter List 
The Parameter list shows all objects in the current session. This list is arranged 

in a collection of shapes, filters, trackers and their associated parameters. Click 

the twirly to the left of the parameter to either show or hide parameters of a 

particular object.

Timeline 
The Timeline is an overview of your shapes, filters, trackers and keyframes. In 

the Timeline, you can edit a keyframe's position in time, but not its value.

Current Time Indicator 
The vertical line in the Timeline is the current time that you are parked at. To 

move the Current Time Indicator, just click and drag the shuttle slider below the 

Viewer or in the top line of the Timeline.
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Zooming and Panning the Timeline
The Timeline shows the duration specified for the current session. You can 

zoom in or out using the mouse scroll wheel to see the Timeline in more or less 

detail and can pan horizontally or vertically using the Spacebar while clicking 

and dragging.

Timeline Pop-up Menu
Right-click over a selected keyframe or property in the Timeline to open the 

Timeline pop-up menu.

Add Key
Right-click over the property you are interested in at the desired frame in the 

Timeline and select Add Key. Keyframes will be added to that property for all 

selected objects.

Note: You can also Alt-click in the Timeline to add a keyframe.

Cut
Deletes the currently selected keyframe or keyframes.

Copy
Copies the currently selected keyframe or keyframes.

Paste
Pastes the currently selected keyframe or keyframes.

Delete
Deletes the currently selected keyframe or keyframes.

Note: Individual shape points can be copied and pasted between keyframes using 
Ctrl(Win)/Cmd(Mac)-Alt-C to copy and Ctrl(Win)/Cmd(Mac)-Alt-V to paste.
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Interpolation
• Hold

There is no interpolation and abrupt switches in value occur at keyframes.

• Linear

When values change, a straight line with sharp, abrupt angles from one 

keyframe to the next is drawn.

Ease
Ease allows you to smoothly transition in or out of a keyframe.

• Ease In

Eases in to the selected keyframe.

• Ease Out

Eases out of the selected keyframe.

• Ease In/Out

Eases in and out of a selected keyframe.

Moving One Keyframe in Time
A single keyframe can be moved by selecting it and then dragging it to a new 

location.

Moving a Selection of Keyframes in Time
Multiple keyframes can be moved by first selecting a range using the Shift key 

and then dragging on them to a new location.

Selecting Shapes and Trackers
Objects can be selected within the Timeline. Clicking the name of an object 

selects it. Multiple objects can be selected by Shift-clicking on them. Ctrl-

clicking an object after it is selected will deselect it.
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Table 8: Timeline Keyboard Shortcuts

Shortcut Action

Scroll wheel Zooms the Timeline in and out

Shift-Middle-mouse drag Zooms the Timeline in and out

Space Bar-drag Pans the Timeline

Middle-mouse drag Pans the Timeline

Single-click keyframe Selects one keyframe

Ctrl(Win)/Cmd(Mac)-click 
keyframe

Toggle the keyframe selection

Shift-click keyframes Selects a range of keyframes

Alt-click Inserts a keyframe 
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 ROTO NODE

Rotoscoping or “Roto” for short has become a generic term for drawing shapes 

to extract, isolate or affect a portion of an image. It is tedious work, but it’s one 

of the most important parts of the visual effects process. Within the Roto node, 

there are all the tools needed to make quick work of any Roto job.

Roto Node Parameters
When Roto is selected in the Node List, parameters specific to the Roto node, 

such as Motion Blur, can be adjusted in the Node window.

Alpha
Invert
Inverts the Alpha channel.

Blur
Blurs the Alpha Channel. The blur range is from 0-100 and defaults to 0.

Motion Blur
Motion blur is the directional blurring of rapidly moving shapes.

Go to Using Motion Blur to see how it works.
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Enable
Turns Motion Blur on or off. The default is off. Leave this turned off for faster 

interaction while editing shapes.

Note: The Motion Blur parameters will not affect shapes unless you first activate Motion 
Blur for each shape in the Object window. See Motion Blur in the Shape Parameters 
for more information.

Shutter Angle
Determines how long the camera shutter stays open when a picture is taken-- 

higher values create more motion blur. The range of the Shutter Angle is 0-720 

and defaults to 180. Measured in degrees, it simulates the exposure of a 

rotating camera shutter. The shutter angle uses the footage frame rate to 

determine the simulated exposure. For example, a shutter angle of 180 

degrees (50% of 360 degrees) for 24fps footage creates an effective exposure 

of 1/48 of a second. Typing 1 degree applies almost no motion blur, and typing 

720 degrees applies a high degree of motion blur.

Shutter Phase
Offsets the point in time, either forward or reverse, when the shutter opens. The 

range of the Shutter Phase is -360 to 360 and defaults to -90.

Motion Samples
Renders intermediate frames equal to the Motion Samples value and 

accumulates them, one over the other, on a single frame. The higher the 

number, the smoother the motion. The Motion Samples range is from 1-256 

and defaults to 16.

Roto View Menu
When Roto is selected in the Node List, the View menu displays either the 

shape Output, the Foreground, Background or a Composite of the foreground 

over the background based on your shapes.
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The 1, 2, 3 and 4 keys can quickly switch the view: 1 is Output, 2 is Foreground, 

3 is Background and 4 is Composite.

Output
Output allows you to see the output of your shapes in the form of an Alpha 

channel, but will slow down shape editing. To view the Alpha, click either the A 

key or the Alpha channel button at the top right of the Viewer.

Note: Output is the default setting, but switch to Foreground for faster interaction and 
less memory usage.

Foreground
Display the Foreground clip in the Viewer.

Background
Display the Background clip in the Viewer.

Composite
Display the composite of the foreground over the background based on your 

shapes. If “None” is selected for the Background Input, the foreground will be 

composited over a color. The default color is gray, but can be changed by going 

to File > Preferences > Composite on Windows and Linux or Silhouette > 

Preferences > Composite on Mac. If you add a Composite node in the Session 

Settings, the composite will be rendered.
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Roto Toolbar
When the Roto node is selected, a number of different tools are selectable from 

the Toolbar to the left of the Viewer.

Transform

Reshape

B-Spline

Square

Circle

Feather

Tracker

X-Spline

Bézier

MultiFrame
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Table 9: Toolbar Keyboard Shortcuts

Shortcut Action

T Selects the Transform tool Shape Mode

TT Selects the Transform tool Points Mode

R Selects the Reshape tool

B Selects the B-Spline tool

S Selects the X-Spline tool

Shift-B Selects the Bézier tool

Shift-S Selects the Square tool

Shift-C Selects the Circle tool

Shift-F Selects the Feather tool

Shift-T Selects the Tracker tool

M Selects the MultiFrame tool
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Bézier Tool (Shift-B)
Creates a new Bézier spline.

To draw a Bézier spline, click on the image to place the first control point and 

drag the cursor while keeping the mouse pressed to extend the control point’s 

tangents. Click on the screen to add more control points and when finished 

adding points, click the first control point that you added to close the shape. 

When creating an open shape, press the Esc key or switch to a different tool to 

finish the shape.

Originally developed by Pierre Bézier in the 1970's for CAD/CAM operations, 

Bézier splines became the foundation of the entire Adobe drawing model. If 

you're a user of Adobe products, you've probably used Bézier’s. Bézier splines 

are defined by control points and tangents. The position of the two tangent 

handles control the amount of a point's curvature.
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A shape is created by drawing a Bézier curve path. This path contains control 

points and tangents that define the form of the curve.

Control Points
Control points are locations on the curve that determine its shape. When a 

control point is selected, two tangents extend from the control point. These 

tangents guide the shape of the curve.

Joins
The area of the curve at the control point is called the curve join.

Joins can either be corner or cardinal (smooth) joins. When control point 

tangents are positioned in opposite directions, the join is cardinal. In contrast, 

corner joins have their tangents positioned at an angle to each other.

Go to Using the Bézier Tool to see how it works. 

Control Point

Tangent Handle

Tangent

Curve Join

Cardinal Join Corner Join
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B-Spline Tool (B)
Creates a new B-Spline shape.

To create a B-Spline, click on the screen to create a control point and add as 

many points as you like. When you are finished adding points, click the first 

control point that you added to close the shape. When creating an open shape, 

press the Esc key or switch to a different tool to finish the shape.

In contrast to Béziers, B-Splines don’t use tangents and are created by only 

using control points. The position of the points, their intensity settings as well 

as their proximity to each other determine the curvature of the shape. B-Splines 

are somewhat similar to NURBS (non-uniform rational B-Splines) that are used 

in many 3D modeling packages.

The images below show how the same shape can be created with either Bézier 

splines or B-Splines.

Because the two spline types of have significant strengths and differences, 

artists are religiously loyal to one or the other. B-Splines create natural curves 

but are terribly inefficient at defining square corners and require more points to 

define a similar Bézier shape. On the other hand, Bézier splines can easily 

create corners and use fewer points, but can have an unnatural curved path 

caused by overly malleable “split” handles. The best approach is to use both 

spline types depending on the shape and complexity of the object that you are 

trying to Roto. Depending upon your expertise, you may find Bézier splines are 

more appropriate for square and angular shapes while B-Splines will work 

B-SplineBézier
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better for objects with a lot of curves like a person’s face. Just to upset the 

status quo, there is a new kid on the block called X-Splines which is explained 

in the next section. This spline type brings together the best of both B-Splines 

and Béziers.

Go to Using the B-Spline Tool to see how it works. 
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X-Spline Tool (S)
Creates a new X-Spline shape.

To create a X-Spline, click on the screen to create a control point and add as 

many points as you like. When you are finished adding points, click the first 

control point that you added to close the shape. When creating an open shape, 

press the Esc key or switch to a different tool to finish the shape.

A X-Spline is an intuitive and easily editable spline format whereby it’s points 

can be of three different types: Cardinal, Corner or B-Spline.

• Cardinal creates a path that passes smoothly through each point.

• Corner makes a path that consists of angular corner points.

• B-Spline creates a smooth path that is determined by the surrounding points.

Look at how the same set of points can yield entirely different shapes based on 

the point type setting.

The point type can be changed at anytime as well as animated from one type 

to another. You’ll find that the beauty of X-Splines is that the shape’s points can 

be a mix of Cardinal, Corner or B-Splines.

Cardinal Corner B-Spline
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The images below show how the same shape can be created with either Bézier 

splines, B-Splines or X-Splines.

Go to Using the X-Spline Tool to see how it works. 

Bézier X-SplineB-Spline
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Square Tool (Shift-S)
Creates a new square or rectangle Bézier spline.

To create a Square, click and drag in the shape of a square and release the 

mouse.

Go to Using the Square Tool to see how it works. 
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Circle Tool (Shift-C)
Creates a new circle or ellipse Bézier spline.

To create a Circle, click and drag in the shape of a circle and release the mouse.

Go to Using the Circle Tool to see how it works. 
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Shape and Layer Parameters

Shape Parameters
All of the editable parameters of a shape can be adjusted in the Object window. 

When a shape is selected, you will see the parameters listed below.

Blend Mode
Controls how shapes are blended together.

Add
Adds the shape to other shapes.

Shape Parameters

Shape 1                          Shape 2                           Result
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Subtract
Subtracts the shape from other shapes.

Multiply
Produces a result where there is a union of pixels from two shapes.

Difference
Produces a result where a value exists in each shape, but not in both.

Blur
Sets the blur level of the selected shape or shapes. The Blur slider range is 

from 0-100 and defaults to 0.

Blur Type
Determines the type of blur.

Shape 1                          Shape 2                           Result

Shape 1                          Shape 2                           Result

Shape 1                          Shape 2                           Result
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• Centered

The blur is centered on the edge of the shape, equally blurring inward and 

outward.

• Inner

The shape is blurred inward from the edge of the shape.

• Outer

The shape is blurred outward from the edge of the shape.

Shrink/Grow
Shrinks or grows the shape’s alpha channel. Negative values shrink and 

positive values grow.

Opacity
Sets the opacity of the selected shape. The opacity range is from 0-100 and 

defaults to 100. The interpolation type is set to Hold by default making it easy 

to turn shapes on and off at particular frames.

Note: You can change the Opacity interpolation type from Hold to Linear at any time. 
To do so, select the shape’s Opacity keyframes in the Timeline, right-click and select 
Interpolation > Linear.

Invert
Inverts the shape values. The default is off.

Motion Blur
Motion blur is the directional blurring of rapidly moving shapes. This parameter 

turns Motion Blur on or off. The default is off.

Note: The Motion Blur parameters will not affect a shape unless Motion Blur is enabled 
in the Node window. See Motion Blur in the Roto Node Parameters for more 
information.
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Outline Color
Sets the color of the shape outline. Left-clicking the color pot opens a standard 

color picker while right-clicking on the color pot opens a pop-up color menu with 

16 primaries. 

Stroke Width
Sets the thickness of an open shape. When used on a closed shape, an outline 

is created.

Note: Open shapes can not be exported.

Channel
Determines what channel the shape is rendered into. You can set each shape 

to Red, Green, Blue, or Alpha. To visualize the results prior to rendering, use 

View > Channels in conjunction with the Alt-R, G, B and A shortcut keys. When 

ready, render shapes into the assigned channels with the Actions > Render 

Shapes to Channels action. 

Go to Rendering Shapes to Channels to see how it works. 

Reset All
Resets all parameters to their default state.
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Layer Parameters
Layers are used to organize shapes, but more importantly they are used to 

contain the motion information from trackers. All of the editable parameters of 

a layer can be adjusted in the Object window. When a layer is selected, you will 

see the parameters listed below. The Transform, Stereo Offset, Blend Mode, 

Blur and Invert state of a layer can be adjusted.

Transform
The Position, Scale, Rotation and Anchor Point can be adjusted and animated.

Anchor
Sets the anchor point for the layer transformation. Scaling and rotation 

operations center around the anchor point.

Position
Sets the horizontal and vertical position of the layer.

Scale
Sets the horizontal and vertical scale of the layer. Typing in a negative value will 

flip or flop the shapes in the layer.
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Rotate
Sets the rotation of the layer.

Matrix
When tracking data is applied to a layer, the Matrix parameter is used to store 

the tracker keyframes.

Stereo Offset
Stereo Offset, which only shows up when using stereoscopic sources, is used 

to align the offset between Left and Right Views of stereoscopic sequences and 

is set to animate by default. This value is automatically set when using the 

Viewer’s Stereoscopic Align mode’s on-screen control.

Blend Mode
Controls how layers are blended together. See Blend Mode for more 

information.

Blur
Sets the blur level of all shapes within the layer. The Blur slider range is from 

0-100 and defaults to 0.

Blur Type
Determines the type of blur.

• Centered

All shapes in the layer are blurred equally inward and outward centered on the 

edge of the shapes.

• Inner

All shapes in the layer are blurred inward from the edge of the shapes.

• Outer

All shapes in the layer are blurred outward from the edge of the shapes.

Invert
Inverts all shapes within the layer. The default is off.
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Channel
Determines which channel the shapes in the layer are rendered into. You can 

set a layer to Red, Green, Blue, or Alpha. To visualize the results prior to 

rendering, use View > Channels in conjunction with the Alt-R, G, B and A 

shortcut keys. When ready, render layers into the assigned channels with the 

Actions > Render Shapes to Channels action.

Note: This overrides the Shape > Channel setting, except when set to Alpha, in which 
case the shape’s Channel setting is obeyed instead.

Go to Rendering Shapes to Channels to see how it works. 

Reset All
Resets all parameters to their default state.
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Nudging Layers
Layers can be nudged using the Arrow keys. One press of the Arrow key 

moves the layer 1 pixel. Using the Shift key in conjunction with the Arrow keys 

moves the layer 10 pixels. Ctrl plus the Arrow keys moves the layer one tenth 

of a pixel. These nudge values can be changed in the Preferences menu 

located in File > Preferences > Nudging on Windows and Linux or Silhouette > 

Preferences > Nudging on Mac. Holding the Arrow keys down slides the layer.

Table 10: Layer Nudging Keyboard Shortcuts

Note: Nudging of the layer transform is only available if one layer is selected, and no 
shapes are selected. This is to avoid confusion in case nested layers or objects in them 
are also selected.

Shortcut Action

Arrow keys Moves the layer by 1 pixel

Shift-Arrow keys Moves the layer by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the layer by one tenth of a pixel

Hold down Arrow keys Moves the layer continuously

Q, W, E then Ctrl(Win)/Cmd(Mac)-drag Translates, Rotates or Scales in finer increments

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Q, W, E then Shift-Arrow keys Translates, Rotates or Scales by 10 pixels

Q, W, E then Ctrl(Win)/Cmd(Mac)-Arrow keys Translates, Rotates or Scales by 1/10 of a pixel
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Transform Tool
Once you draw a shape, there are various ways to modify it. As the object that 

you are attempting to Roto changes over time, you will need to adjust the shape 

so that it exactly matches the object. While the Transform tool affects an entire 

shape or a group of shapes, you can use the Reshape tool to modify individual 

points on a shape. See the Reshape Tool for more information.

Go to Using the Transform Tool to see how it works.

Transform Tool - Shape Mode (T)
The Transform tool Shape Mode allows you to position, move, scale, rotate, 

shear or corner-pin a shape or selection of shapes using the on-screen 

controls. To enter this mode, press either the Transform tool in the Toolbar or 

the T key once. Then, select a shape and use the on-screen controls to modify 

it.
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Table 11: Transform Tool On-Screen Controls

If there are any selected layers while in Transform mode, pressing Q, W or E 

and then clicking and dragging will translate, rotate or scale the selected layers. 

If there are no selected layers, you must select a shape or group of shapes 

before clicking and dragging. Also, the position of the cursor when W or E is 

pressed sets the anchor point for the rotation or scale operation.

Shortcut Action

Drag shape Moves the shape

Shift-drag shape Constrain shape movement horizontally or 
vertically

Drag bounding box corner or edge handle Scales a shape

Shift-drag bounding box corner or edge handle Proportionally scale a shape

Ctrl(Win)/Cmd(Mac)-drag on a bounding box 
corner handle

Rotate a shape

Alt-drag on a bounding box corner handle Corner-pin a shape

Alt-Shift-drag on a bounding box corner handle Constrains the corner-pin movement to one axis

Ctrl(Win)/Cmd(Mac)-drag on a bounding box 
edge handle

Shear a shape

. (period key) Turns the Anchor Point on or off

Drag on Anchor Point Moves the Anchor Point

Shift-. (period key) Moves the Anchor Point to the mouse location

Q Activates / Deactivates translation of selected 
shapes or layers

W Activates / Deactivates rotation of selected 
shapes or layers

E Activates / Deactivates scaling of selected 
shapes or layers

Q, W, E then Ctrl(Win)/Cmd(Mac) Translates, Rotates or Scales in finer increments
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Transform Tool - Points Mode (TT)
The Transform tool Points Mode allows you to position, move, scale, rotate, 

shear or corner-pin a selection of points using the on-screen controls. To utilize 

this mode, use the Reshape tool to first select some points

and then press either the Transform tool twice in the Toolbar or the T key twice. 

Instead of a bounding box with on-screen controls around the shape, the 

bounding box is around the selected points.
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Transform Tool - Layers
When a layer is selected and the Transform tool is active, you can position, 

move, scale and rotate the layer using the on-screen controls.
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Table 12: Layer Transform On-Screen Controls.

Moving Shapes
Selected shapes are moved using one of two methods: 1) Drag on the outline 

of a shape or 2) Press the Q key to activate translation mode and click and drag 

to move the selected shapes. You must press the Q key a second time to 

deactivate translation mode.

In either case, you can constrain movement along an axis by pressing the Shift 

key while dragging the outline of a shape. The movement is constrained by the 

first direction (horizontal or vertical) that you drag in.

Shortcut Action

Drag within large center circle Moves the layer

Shift-drag within large center circle Constrain layer movement horizontally or vertically

Drag the horizontal and vertical lines Scales the layer horizontally or vertically

Drag the upper diagonal line Proportionally scale the layer

Drag the lower diagonal line Rotate the layer

Ctrl(Win)/Cmd(Mac)-drag the lower 
diagonal line

Rotates the layer with finer control

Drag small center circle Moves the Anchor point

Q Activates / Deactivates translation of selected layers

W Activates / Deactivates rotation of selected layers

E Activates / Deactivates scaling of selected layers
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Nudging Shapes
Shapes can be nudged using the Arrow keys. One press of the Arrow key 

moves shapes 1 pixel. Using the Shift key in conjunction with the Arrow keys 

moves the shapes 10 pixels. Ctrl plus the Arrow keys moves shapes one tenth 

of a pixel. These nudge values can be changed in the Preferences menu 

located in File > Preferences > Nudging on Windows and Linux or Silhouette > 

Preferences > Nudging on Mac. Holding one of the Arrow keys down slides the 

shapes in that direction.

Table 13: Shape Nudging Keyboard Shortcuts

Scaling Shapes
Scaling changes the size of the shapes. Selected shapes are scaled using one 

of two methods: 1) Drag any of the points on the shape bounding box or 2) 

Press the E key to activate scaling mode and click and drag to scale the 

selected shapes. You must press the E key a second time to deactivate 

translation mode.

Note: The position of the cursor when E is pressed sets the anchor point for the 
scaling.

To proportionately scale, hold down the Shift key when resizing.

Shortcut Action

Arrow keys Moves shapes by 1 pixel

Shift-Arrow keys Moves shapes by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves shapes by one tenth of a pixel

Hold down Arrow keys Moves shapes continuously
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Rotating Shapes
Rotating changes the angle of the shapes. Selected shapes are rotated using 

one of two methods: 1) Ctrl(Win)/Cmd(Mac)-drag on a shape bounding box 

corner handle or 2) Press the W key to activate rotation mode and click and 

drag to rotate the selected shapes. You must press the W key a second time to 

deactivate translation mode.

Note: The position of the cursor when W is pressed sets the anchor point for the 
rotation.

Corner-Pinning Shapes
The corner points of a shape’s bounding box can be corner-pinned. For 

instance, you could fit the corners of a shape into the corners of a billboard. Alt-

drag the corners of the shape’s bounding box to corner-pin the shape.

Shearing Shapes
Shapes can be sheared resulting in the shape being skewed horizontally or 

vertically. To shear a shape, Ctrl(Win)/Cmd(Mac)-drag on the midpoints of a 

shape bounding box on either the horizontal or vertical axis.
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Anchor Point
A shape rotates around its center point, but scales from the opposite handle. 

Moving the anchor point changes the center of rotation and scaling when using 

the on-screen controls. To position the Anchor Point, press the . (period key) 

and the Anchor Point is displayed on the screen. Then, click and drag the 

Anchor Point to the desired location.

Now, when you rotate or scale the shape, notice how the shape rotates and 

scales around the Anchor Point.

Note: If more than one shape is selected, they will both rotate and scale around the 
Anchor Point. Turning off the Anchor Point with the . (period key) will cause the shapes 
to revert to rotating and scaling around the default Anchor Points.

Cutting, Copying and Pasting Shapes
Shapes can be cut(Ctrl(Win)/Cmd(Mac)-X), copied(Ctrl(Win)/Cmd(Mac)-C) 

and pasted(Ctrl(Win)/Cmd(Mac)-V).

Deleting Shapes
A shape or selection of shapes can be easily deleted using none other than the 

Delete key.

Selecting Shapes
Table 14: Shape Selection Keyboard Shortcuts

Shortcut Action

Click on a shape Selects the shape

Shift-click a shape or drag select multiple shapes Selects multiple shapes

Ctrl(Win)/Cmd(Mac)-click on a shape Toggles the shape selection

Click anywhere off the shape Deselects all shapes

Shift-click color pot in the Object List Selects shapes of same color
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Reshape Tool (R)
The Reshape tool modifies shapes by adjusting their control points and 

tangents. In this mode, the shape’s control points and tangents are visible.

You must first select a control point before it can be modified. The following 

table lists the methods for selecting and deselecting points.

Table 15: Control Point Selection Keyboard Shortcuts 

Go to Using the Reshape Tool to see how it works.

Adding Control Points
Adding control points assists in tracing more detailed images. To add a control 

point, Alt-click on the selected shape. Don’t click on an existing control point 

because it will move it instead.

Deleting Control Points
You can delete control points in one of two ways. Select the control point and 

press the Delete key or right-click on the control point and select Delete from 

the Reshape pop-up menu.

Moving Control Points
Control points are easily moved. Just select one or more control points and 

drag one of the selected points to a new location.

Shortcut Action

Click on a control point. If the control point is part of a Bézier 
curve, its tangents appear

Selects the control point

Shift-click the control points or drag select multiple control points Selects multiple control points

Ctrl(Win)/Cmd(Mac)-Alt-I Inverts the point selection

Alt-Shift-A Selects all control points

Alt-Ctrl-A Deselects all control points

Ctrl(Win)/Cmd(Mac)-click on a control point Toggles the point selection

Click anywhere off the shape Deselects all control points
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Nudging Points
Points can be nudged using the Arrow keys. One press of the Arrow key 

moves the points 1 pixel. Using the Shift key in conjunction with the Arrow 

keys moves the points 10 pixels. Ctrl plus the Arrow keys moves shapes one 

tenth of a pixel. These nudge values can be changed in the Preferences menu 

located in File > Preferences > Nudging on Windows and Linux or Silhouette > 

Preferences > Nudging on Mac. Holding the Arrow keys down slides the 

points.

Table 16: Point Nudging Keyboard Shortcuts

Numbering Points
All points or a selection of points can be numbered. To number one point or a 

selection of points, right-click on a selected control point and select Tag. To see 

all points numbered, go to File > Preferences > Shape on Windows and Linux 

or Silhouette > Preferences > Shape on Mac and set the Number Points 

preference to All.

Shortcut Action

Arrow keys Moves points by 1 pixel

Shift-Arrow keys Moves points by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves points by one tenth of a pixel

Hold down Arrow keys Moves points continuously
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Adjusting Bézier Curves
The length and direction of a control point’s tangents direct the curve through 

that control point.

Control points have two tangents that can extend from it. The path of the curve 

through the control point is determined by the length and orientation of the 

tangents. When you drag one tangent’s handle, the adjacent tangent moves as 

well. Using keyboard shortcuts while dragging allows you to control how the 

curve passes through a control point.

Tangent Handle

Tangent

Curve Join

Control Point
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Table 17: Bézier Keyboard Shortcuts

Shortcut Action Curve

No key needed Adjust the length of one tangent while 
retaining a fixed angle between two 
tangents

Ctrl(Win)/Cmd(Mac) Adjust both tangents simultaneously 
while retaining a fixed angle between 
two tangents

Alt Adjusts only one tangent to create 
corners

Shift Adjusts only the length of one tangent 
(similar to the “No key needed” 
shortcut)

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-2 Sets the point tension to Cardinal
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Reshape Tool: Bézier Pop-up Menu
Right-click over a control point to open the Bézier Reshape pop-up menu and 

select one of the options.

To modify multiple selected points simultaneously, do not right-click on one of 

the selected points. Right-click on an open area of the Viewer instead.
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Table 18: Bézier Pop-up Menu

Extending Short Tangents
Sometimes a control point’s tangents are so close together that trying to modify 

the tangent results in movement of the control point. If this is the case, you can 

force the tangents to move without affecting the control point by pressing the 

Alt key while dragging the tangent. Only the tangent will move, leaving the 

control point unaffected.

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Linear Both tangents are adjusted to one quarter the distance and in the 
direction of their adjoining control points

Corner Creates a corner point

Cardinal Creates a smooth point where the curve passes smoothly through it

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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Moving Curve Segments
Normally, you move control points to adjust the form of a shape, but you can 

also move the portion of the curve between control points. To move a curve 

segment, deselect all control points by clicking somewhere off the shape and 

then Ctrl(Win)/Cmd(Mac)-drag a curve segment between control points.

Once you start dragging, the Ctrl(Win)/Cmd(Mac) key can be released.

Note: The surrounding tangents remain smooth, but if you want to keep adjacent 
tangents from moving, hold down the Alt key while dragging.

Adjusting B-Splines
In contrast to Béziers, B-Splines don’t use tangents and are created by only 

using control points and are simple to adjust. The position of the points, their 

weight settings as well as their proximity to each other determine the curvature 

of the shape. The weight (amount of pull on a point) decides how sharp or 

smooth it is. Silhouette employs variable weight intensities on a point by point 

basis. The weight can be adjusted by hovering over a point and Alt-dragging to 

the right to create a corner point or Alt-dragging to the left to create a smooth 

point. Alternatively, you can Alt-click on one of the selected points to cycle 

through the preset weight settings.

Note: Do not use extreme, variable weight adjustments if you are planning on 
converting the B-Spline to a Bézier Spline.
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Table 19: B-Spline Keyboard Shortcuts

Reshape Tool: B-Spline Pop-up Menu
Right-click over a control point to open the B-Spline Reshape pop-up menu and 

select one of the options.

To modify multiple selected points simultaneously, do not right-click on one of 

the selected points. Right-click on an open area of the Viewer instead.

Shortcut Action

Alt-drag control point right Creates a corner point

Alt-drag control point left Creates a smooth point

Alt-clicking control point Cycles through the preset weight settings of the point

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-3 Sets the point tension to B-Spline
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Table 20: B-Spline Pop-up Menu

Note: The Alt-click and pop-up menu preset weight settings for Corner and B-Spline 
can’t be animated.

Adjusting X-Splines
X-Splines are created by using control points and then adjusting their weight to 

coincide with one of the point types: Cardinal, Corner or B-Spline. The point 

type can even be somewhere in between one point type and another. The 

weight can be adjusted by hovering over a selected point and Alt-dragging to 

the right. The weight of the point goes from Cardinal to Corner to B-Spline. 

Alternatively, you can Alt-click to cycle through the different point types.

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Corner Creates a corner point

B-Spline Creates a smooth point that is determined by the surrounding points

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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Table 21: X-Spline Keyboard Shortcuts

Reshape Tool: X-Spline Pop-up Menu
Right-click over a control point to open the X-Spline Reshape pop-up menu and 

select one of the options.

To modify multiple selected points simultaneously, do not right-click on one of 

the selected points. Right-click on an open area of the Viewer instead.

Shortcut Action

Alt-drag control point right Adjusts the weight of the point from Cardinal to Corner to B-Spline

Alt-drag control point left When the weight is set to B-Spline, it adjusts the weight of the point 
from B-Spline to Corner to Cardinal

Alt-clicking control point Cycles through preset weight settings of the point

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-2 Sets the point tension to Cardinal

Ctrl(Win)/Cmd(Mac)-Alt-3 Sets the point tension to B-Spline
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Table 22: X-Spline Pop-up Menu

Converting B-Splines or X-Splines to Bézier Splines
You may convert your B-Splines or X-Splines to Bézier splines at any time. To 

convert a B-Spline to a Bézier spline, select a B-Spline or X-Spline and choose 

the Edit > Spline > Convert to Bézier menu item.

Once you select Convert to Bézier, a couple of things happen. The visibility of 

the B-Spline or X-Spline is toggled to off. A new Bézier spline is created and is 

named the same as the B-Spline or X-Spline but has an * at the end of the 

name.

Note: The Bézier conversion of B-Splines that use extreme, variable weight 
adjustments will not exactly match the original B-Spline. Do not use extreme, variable 
weight adjustments if you are planning on converting the B-Spline to a Bézier.

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Corner Creates a corner point

Cardinal Creates a smooth point where the curve passes smoothly through it

B-Spline Creates a smooth point that is determined by the surrounding points

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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Breaking Shapes
In the Reshape tool, closed shapes can be opened using the Break option from 

the control point pop-up menu. To break a shape, select a point and right-click 

on it to open the pop-up menu. Choose Break and the shape opens at the 

selected control point.

Note: Feather information will be removed once you break a shape.

Closing and Extending Shapes
Shapes can be closed or extended with just a few mouse clicks. It is necessary 

to use the Reshape tool to perform the following actions.

Closing Open Shapes
Select one of the control points at the end of the shape and Alt-click on the 

other end point to close the shape.

Extending Shapes
Select a control point at either end of the shape and Alt-click somewhere off 

the shape.

Joining Open Shapes
In the Reshape tool, open shapes can be joined together. To join open shapes, 

first select two open shapes. Next, select one of the end points of the source 

shape by clicking on it and then Alt-click on one of the end points of the target 

shape. The two shapes are now joined together as one.

Note: The target shape inherits the attributes of the source shape.
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Feather Tool (Shift-F)
Creates variable edged blurs on a point by point basis.

 The Feather points can be placed either inside or outside the shape.

To use the Feather tool, select it from the Toolbar and Alt-click on a selected 

shape and drag. Additional feather points are added by Alt-clicking on the 

original curve and dragging. Feather points are edited by clicking and dragging 

on one of the outer points.

Note: Feather points can only be added when the Feather tool is activated, but can be 
edited and manipulated using the Reshape tool.

Go to Using the Feather Tool to see how it works.

Table 23: Feather Tool Keyboard Shortcuts

Shortcut Action

Alt-drag on shape Adds and pulls out a feather point

Click-drag a feather point Changes the length and position of the feather point

Shift-drag a feather point Constrains the length of the point

Hover over feather point and hit the 
Delete key

Deletes the feather point
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MultiFrame Tool (M)
Normally, adjusting a shape or points on a shape are keyframed only on that 

particular frame. When the MultiFrame tool is activated, it modifies the 

Transform and Reshape tools to allow you to make adjustments across all 

previously set keyframes or a selection of keyframes. A red outline is drawn 

around the Viewer to let you know that the MultiFrame tool is active.

To use the MultiFrame tool, select it in the Toolbar. Then, drag the red ends of 

the MultiFrame range bar at the top of the Timeline to limit the keyframes 

affected by the MultiFrame tool.

The Transform or Reshape tools will now only affect keyframes within the 

MultiFrame selection.

Go to Using the MultiFrame Tool to see how it works.

Note: When using the MultiFrame tool, attempts to edit a shape outside the MultiFrame 
work range will be ignored. If you try to, for example, transform a shape and nothing 
happens, check to see if the MultiFrame range is active at that particular point in time.
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Shape Import and Export
Shapes can be imported and exported using File > Import > Shapes and File > 

Export > Shapes.

Shape Import/Export Notes
After Effects

1 When importing and exporting Silhouette Shapes using the Silhouette Shape 
Import/Export Plug-in for After Effects, the general rule is that the After Effects 
Composition size must match the Silhouette Session size for shapes to import 
and export properly. However, as long as the ratio of the sizes between the After 
Effects Composition and the Silhouette Session match, you can successfully 
import and export shapes between them. For instance, you could import or 
export shapes from a 2000x1000 Silhouette Session to a 1000x500 After Effects 
Composition with no problems, as long as the pixel aspects were the same.

2 When After Effects has the Preserve Constant Vertex Count in the General 
Preferences dialog deactivated, it is possible for a differing number of control 
points to occur on different keyframes. These type of shapes can’t be imported 
into Silhouette.

Commotion
1 You can’t import Commotion B-Splines made with just 3 points.

Nuke
1 If you are exporting using Nuke 6.2+ Shapes, there is an Input/Output > Nuke 6.2+ 

Shapes preference that allows you to change the behavior of how the nodes are 
created in Nuke. For more information, see the Nuke 6.2+ Shapes preference.

2 X-Splines are converted to Bezier's in Nuke.

3 Only Blurs set to Outside will transfer to Nuke.

4 Multiply mode is not guaranteed to work if the opacities involved are not 0 and 
100%. Nuke and Silhouette’s notion of multiply is different.

5 Layer blend modes are not implemented as Nuke does not support them.

6 Nested transformations are exported fully baked because Nuke does not actually 
nest transformations in its layers.

7 If the top or bottom of a Bezier rectangle is perfectly parallel to the screen edge, 
the resulting shape export will do poorly. This is because the points used for the 
homography are the four bounding box points which for the Bezier described 
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above are the same as the four points in the shape, adding no information. If you 
make a rectangle with more than four points then the shape export will work fine. 
For instance, add points between each corner.

General
1 The resulting export of B-Splines that use extreme, variable weight adjustments 

will not exactly match the original B-Spline. Do not use extreme, variable weight 
adjustments if you are planning on exporting B-Splines.

2 Open shapes can only be exported using the Silhouette shape format.

3 Shapes with variable edge blurs created with the Feather tool can be exported, 
but only the original spline without the variable edge feather is used.

4 B-Spline, X-Spline and Bézier splines can all be exported, but B-Splines and X-
Splines are first converted to Bézier splines.

Note: B-Splines exported to Nuke 6.2 and above are not converted to Bézier splines.

After Effects Import and Export
Importing Silhouette Shapes into After Effects
The Silhouette Shape Import/Export Plug-in for After Effects is required to be 

able to convert Silhouette Shapes into After Effects masks.

Go to Importing Silhouette Shapes into After Effects to see how it works.

Exporting After Effects Masks to Silhouette Shapes
The Silhouette Shape Import/Export Plug-in for After Effects is required to be 

able to convert After Effects masks to Silhouette Shapes.

Go to Exporting After Effects Masks to Silhouette Shapes to see how it 

works.

Importing Shapes
Silhouette, Commotion, Elastic Reality and Shake 4.x SSF shapes can all be 

imported into Silhouette.

Go to Importing Shapes to see how it works.

Exporting Shapes
Silhouette, Fusion, gMask (Combustion, Flint, Flame, Inferno), Nuke and 

Shake 4.x SSF shapes can all be exported.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

238 Roto Node

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Go to Exporting Shapes to see how it works.
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 TRACKER

Tracking is a technique that involves analyzing the motion of an image over 

time. In Silhouette, images can be tracked using an automatic image tracking 

system called Planar tracking, or Point tracking which utilizes either one, two or 

four track points. One point tracking obtains horizontal and vertical movement. 

Two point tracking analyzes scaling and rotation in addition to horizontal and 

vertical movement. Lastly, four point tracking evaluates and applies 

perspective movement using a corner-pin transformation.

However the tracking data is obtained, it can then be applied in one of two 

ways: match moving or stabilization. Match moving applies the motion of the 

trackers to a layer so that it’s shapes follow the motion of the clip. Stabilization 

inverts the tracking data so that the clip appears to be stable. 

Selecting the Tracker (Shift-T) gives you access to the various tracking 

features and controls.

When the Tracker tool is selected, various non-animateable controls appear in 

a Tracker window located at the bottom portion of the screen. You have the 

choice of using either the Planar Tracker or Point Tracker.
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Planar Tracker
The Planar tracker generates and tracks several points on the image while 

automatically handling partial occlusions of the tracked object.

Go to Using the Planar Tracker to see how it works.
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Tracker Direction
The Tracker Direction buttons are used to track backwards and forwards and 

are enabled when a layer has been selected.

Note: In a Stereo project, the Tracker Direction buttons are grayed out in the L/R View. 
You must be in either the Left or Right View to track.

Track Backward One Frame
Tracks backward one frame at a time.

Track Backward
Tracks backward to the beginning of the sequence.

Track Forward
Tracks forward to the end of the sequence.

Track Forward One Frame
Tracks forward one frame at a time.

As you track, the tracker’s transform data is automatically applied to the 

selected layer.

Note: When a layer is selected, the per-shape blend mode, invert state, on/off state 
and opacity are all obeyed. This allows you to use shapes to subtract out areas of 
unwanted motion that may interfere with tracking.

Reset
Resets the tracking points.
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Channel
Determines which image channel the tracker uses to analyze the image.

Luminance
The tracker analyzes the luminance or brightness of the image.

Red
The tracker analyzes the image’s red channel.

Green
The tracker analyzes the image’s green channel.

Blue
The tracker analyzes the image’s blue channel.

Valid Tracks
The number next to Valid Tracks is a running total of the number of trackers that 

are viable as the tracker progresses.

Reference Frame
Displays the reference frame number. The reference frame is the frame you 

first started tracking on and it locks in the picked set of track points at that 

frame.

Jump to Reference Frame
When clicked, the Timebar is positioned at the reference frame.
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Point Tracker
The Point tracker uses trackers which are placed on distinguishable image 

features.

Go to Using the Point Tracker to see how it works.

Tracker Components
Each tracker has a Match Area, Search Region, and Track Point.

Match Area
The inner box is the Match Area. It defines a pattern that will be searched for 

from frame to frame. It's a good idea to choose a region with good contrast and 

detail. Corners with sharp contrast are usually good areas to track as 

movement can easily be detected in any direction. The Match Area can be 

scaled to the desired size.

Search Region
Match Area

Track Point
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Search Region
The outer, dashed box is the Search Region, which should be the maximum 

amount your tracking point will move between frames. The larger the size, the 

slower the processing. The trick is to make the Search Region as small as 

possible, yet still large enough to cover the area the tracker will move from 

frame to frame. The Search Region can be sized in the same fashion as the 

Match Area. 

Track Point
The center cross is the track point. It represents the position of the motion track. 

Normally, the Track Point is at the center of the tracker, but can be offset if the 

Match Area becomes obscured.

Tracker Direction
The tracker can track both forward and backward one frame at a time or for the 

entire sequence and are enabled when a tracker has been selected.

Note: In a Stereo project, the Tracker Direction buttons are grayed out in the L/R View. 
You must be in either the Left or Right View to track.

Track Backward One Frame
Tracks backward one frame at a time.

Track Backward
Tracks backward to the beginning of the sequence.

Track Forward
Tracks forward to the end of the sequence.
lhouette 4.5 User Guide



• 

Tracker  245 

• 
• 
• 
•
•
•

Track Forward One Frame
Tracks forward one frame at a time.

Behavior
Behavior decides what frame should be used as the reference to check the 

accuracy of the Match Area. By default, the reference is the first frame at which 

you started the track.

Start Frame
At each frame, the Match Area is compared to the first frame at which you 

started tracking. If you stop tracking halfway through your sequence, and start 

up again at a later frame, the later frame will be used as the reference.

Every Frame
The Match Area is compared to the previous frame. This method will cause 

inherent drift in your track, but is useful for sequences that have drastic 

changes in perspective and scale.

Key Frames
For difficult shots, it is helpful to preset keyframes for the tracker at various 

points in the sequence. The Match Area will use these keyframes as a 

reference while tracking.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

246 Tracker

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Tolerance
Describes the level of accuracy between the Match Area that the Tracker is 

searching for and the area it actually finds when searching from frame to frame. 

A prefect match would be a value of 100. If the error that is calculated is below 

the Tolerance value, no keyframe will be set on that particular frame. The 

Tolerance is preset to a value of 75.

Create
Clicking on the Create button places a new tracker in the center of the screen. 

You can also add a new tracker at any time by Alt-clicking the image when the 

Track tool is activated.

Apply
Selecting the Apply button opens the Match Move window where you 

determine how the tracking data will be applied to a selected layer.

When OK is clicked, the tracking data is transferred to the Transform > Matrix 

parameter of the selected layer.

Note: The Apply button is only available when trackers and a layer are selected.

Position
Applies X/Y position data to the layer.
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Scaling
Applies X/Y scaling data to the layer. Requires two trackers.

Rotation
Applies rotation data to the layer. Requires two trackers.

Average
Averages multiple tracks into a new destination track. A common technique is 

to track forwards from the first frame to the last, and then create a second track, 

tracking backwards from the last frame to the first. These two trackers are then 

averaged together to derive a more accurate track.

To average trackers, select more than one tracker and click the Average button. 

A new averaged tracker is created.

Smooth
Smooths out the inaccuracies in the tracking data caused by film grain or video 

noise.

To smooth, select a tracker and click the Smooth button. Adjust the slider when 

it pops-up and adjust it to the desired level of smoothing.
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Tracker Parameters
Most tracker parameters are interactively set while moving the tracker in the 

Viewer. When a point tracker is selected, its parameters are displayed in the 

Object window.

Magnify Window

A magnified version of the Match Area is displayed to aid in the placement of a 

tracker. It is activated when you click the Create button or when you move an 

existing tracker. The magnified area is displayed in the color space selected 

from the Mode pop-up menu.

Position
Sets the position of the Track Point. This parameter is automatically set when 

using the on-screen tracker controls.
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Nudging Trackers
Trackers can be nudged using the Arrow keys. One press of the Arrow key 

moves the tracker 1 pixel. Using the Shift key in conjunction with the Arrow 

keys moves the tracker 10 pixels. Ctrl plus the Arrow keys moves the tracker 

one tenth of a pixel. These nudge values can be changed in the Preferences 

menu located in File > Preferences > Nudging on Windows and Linux or 

Silhouette > Preferences > Nudging on Mac. Holding the Arrow keys down 

slides the tracker.

Table 24: Tracker Nudging Keyboard Shortcuts

Channel
Determines which image channel the tracker uses to analyze the image.

RGB
The tracker analyzes the red, green and blue channels of the image.

Luminance
The tracker analyzes the luminance or brightness of the image.

Red
The tracker analyzes the image’s red channel.

Shortcut Action

Arrow keys Moves the tracker by 1 pixel

Shift-Arrow keys Moves the tracker by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the tracker by one tenth of a pixel

Hold down Arrow keys Moves the tracker continuously
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Green
The tracker analyzes the image’s green channel.

Blue
The tracker analyzes the image’s blue channel.

Match Offset
Offsets the Match Area from the tracker. This parameter is automatically set 

when using the on-screen tracker controls.

Search Offset
Offsets the Search Region from the tracker. This parameter is automatically set 

when using the on-screen tracker controls.

Match Size
Sets the size of the Match Area. This parameter is automatically set when using 

the on-screen tracker controls.

Search Size
Sets the size of the Search Region. This parameter is automatically set when 

using the on-screen tracker controls.

Path Color
Sets the color of the tracker’s path. Left-clicking the color pot opens a standard 

color picker while right-clicking on the color pot opens a pop-up color menu with 

16 primaries. 
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Tracker Pop-Up Menu
With the Tracker tool enabled, right-click over a shape or a selected control 

point to open the Tracker pop-up menu.

Trackers can be created based on a shape’s points, the center point of a shape 

or the shape’s bounding box. Trackers created in this manner are a 

concantenation of the shape and layer transformation data. So, why do this? 

Because, it is a handy way of creating trackers with all of this combined data 

for use in other programs.

Create Corner Trackers from Shape Bounds
Creates four trackers around the four corners of the shape bounding box.

Create Tracker from Shape Center
Creates one tracker in the center of the shape.

Create Tracker from Points
Creates trackers from selected points.
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Pre-Processing
Images that contain film grain or video noise, lack contrast or sharpness as well 

as images that have flicker can be tracked more accurately by applying certain 

filters during the tracking process. Filters such as Blur, Sharpen, Contrast, De-

Noise and Remove Flicker will increase tracker accuracy for problematic 

images.

Blur
Applies a blur to the image features.

Sharpen
Sharpens image features.

Contrast
Increases contrast so that the features being tracked are more apparent.

De-Noise
Applies a de-noise algorithm to smooth out noise will retaining detail.

Remove Flicker
Corrects image flicker or brightness variation over time, which has a habit of 

interfering with tracker accuracy.

Preview
Shows the effect of the Pre-Processing parameters on the entire image in the 

Viewer.
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I/0
Importing and exporting tracking data takes place in the I/0 section of the 

Tracker tab.

Import
After Effects Corner-Pin, Nuke, Shake or Simple Format formatted trackers can 

be imported into Silhouette. If you would like to import trackers from non-

supported applications, simply export a Silhouette tracker in Simple Format to 

see how it should be formatted.

Go to Importing Tracking Data to see how it works.

Export
Trackers can be exported to the After Effects, Discreet, Nuke and Shake 

tracker formats. In addition, the tracking data applied to a layer, either by the 

Point tracker or Planar tracker, can be exported as a four point corner-pin track.

To create trackers for export that are a concatenation of the shape and layer 

transformation data, see the Tracker Pop-Up Menu for more information.

Go to Exporting Tracking Data to see how it works.
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View
Either shapes or tracker vectors can be toggled on or off.

Shapes
Toggles the display of shapes in the Viewer.

Points
Toggles the display of Planar Tracker track points in the Viewer.

Vectors
Toggles the display of tracking vectors in the Viewer. This option is not available 

for use with the Planar Tracker.

Tracker Preferences
Seldom adjusted tracker controls can be accessed by clicking the Tracker 

Preferences icon.

See the Tracker Preferences for information on their use.
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 PAINT NODE

Paint is a high dynamic range 2D raster based paint system designed from the 

ground up to handle the demands of feature film and television production. 

Whether it’s image restoration, dustbusting, wire and rig removal or just plain 

paint, Silhouette provides simple and sensible tools to get the job done.

Note: Before Paint can be available for use, it must be enabled in the Session Settings 
and selected in the Node List.

Warning: To store painted frames to disk, you must change frames in the sequence. 
The current frame’s paint is also saved with a save operation or an autosave.

Go to Using Paint to see how it works.

Paint View Menu
When Paint is selected in the Node List, the View menu displays either the 

Output, Foreground or Clone 1-4.

The 1-7 keys can quickly switch the view: 1 is Output, 2 is Foreground, 3 is 

Clone 1, 4 is Clone 2, 5 is Clone 3, 6 is Clone 4 and 7 is Paint.

Output
The viewer displays the output of the Paint node. This view mode shows the 

painted frames.

Foreground
The viewer displays the foreground clip.

Clone 1-4
The viewer displays the clips assigned to the Clone 1-4 inputs.
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Paint
The viewer displays what would be exported when rendering paint only. 

Paint Tools
When the Paint node is selected, various non-animateable controls appear in 

a Paint window located at the bottom portion of the screen. Silhouette provides 

a wide variety of paint tools that are organized into Brush, Profile and Paint 

categories.
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In addition, a number of different brushes are selectable from the Paint Toolbar 

to the left of the Viewer.

Once a brush is selected, it’s controls appear on the left side of the Paint 

window.

Black and White

Blemish

Blur

Color Correct

Drag

Eraser

Grain

Clone

Color

Mosaic

Repair

Scatter
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B/W (B)
The B/W brush converts color images to black and white simulating the look of 

Black and White photographic filters.

Mode
Selects the method by which the color image is converted to a monochrome 

image.

Luminance
Creates a monochrome image using the brightness of the image.

Average
Creates a monochrome image using the average of the red, green and blue 

channels.

Red
Simulates a red filter in black and white photography.

Green
Simulates a green filter in black and white photography.

Blue
Simulates a blue filter in black and white photography.

Yellow
Simulates a yellow filter in black and white photography.

Orange
Simulates a orange filter in black and white photography.

Blemish (Shift-B)
The Blemish brush is useful for removing facial blemishes on film originated 

footage. It combines the Blur and Grain brushes.
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Blur (Ctrl-B)
Blurs the image.

Radius
Sets the amount of blur to be applied.

Clone (C)
Paints the image using another part of the image/or other image with the ability 

to grade (color correct) the clone source.

Go to Using the Clone Brush to see how it works.

The controls for the Clone brush are split into two tabs: Clone and Grade. The 

Clone tab deals with the timing and transformation of the Clone source while 

the Grade tab contains color correction controls.

Clone

Setting the Clone offset on the same image:

1 Press and hold down the Shift key. Next, click, drag and release the mouse and 
then the Shift key. The first click sets the Clone source and where you drag and 
release is the Clone destination.

or
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2 Press and hold down the Shift key. Click once to set the Clone source and click 
once again to set the Clone destination.

To reset the Clone offset, press Shift and without moving the cursor, click your 

mouse or tap your pen on the screen once.

Setting the Clone offset on different images:

Oftentimes, you need to align the same feature in two different images of a 

sequence when painting with the Clone brush.

1 In the Clone controls, select Output, Foreground or Clone 1-4 in the Source pop-
up menu and then set the Frame parameter to choose which source frame to 
paint from.

2 Press the ‘ key (located to the left of 1 key).

The Clone source image automatically appears in the Viewer.

3 Set the Onion-Skin mix to 100.

4 Click on the Clone source feature that you want to paint from.

The Clone destination image automatically appears in the Viewer.

5 Click on the Clone destination feature that you want to paint on.

The Clone offset is set.

Source Controls
The Source controls are where you select the Clone source as well as which 

frame to paint from.

Source

Picks which image will be used as the Clone source.

• Output

Clones from the previously painted areas.

• Foreground

Clones from the foreground image.
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• Clone 1-4

Clones from the clips assigned to Clone 1-4 in the Viewer > Inputs menu.

View

The View pop-up menu, which only shows up when using stereoscopic 

sources, determines which view the Clone source will come from.

• Auto

The Clone source is determined by the stereoscopic View mode that has been 

selected at the top of the Viewer.

For instance, if the Left View is selected above the Viewer, the Clone source 

comes from the Left View. If the Right View is selected, the Clone source comes 

from the Right View. If the Left/Right View is selected, the Clone source comes 

from both the Left and Right Views so you can simultaneously Clone on both 

the views at the same time.

• Left

The Clone source comes from the Left View.

• Right

The Clone source comes from the Right View.

Frame

Choose which frame number of the Clone source to paint from. By default, the 

Frame field displays the actual frame number that you are cloning from. 

Alternatively, a frame offset can be displayed instead. This behavior is 

controlled with the Paint > Clone > Absolute Frame Numbers preference.
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• Relative

When the Relative box is checked, the Clone source Frame value remains 

relative to the current frame. So, if the Frame value is different than the current 

frame, the offset between the two is maintained.

When Relative is unchecked, the Clone source is painting from a single frame 

defined by the value entered in the Frame field.

Match Move

Match Move allows you to apply the tracking or transformation data of a Roto 

node layer to the Clone source. To do so, select the desired Roto node layer in 

the Paint > Tracking menu and your Clone source will be Match Moved. If you 

would like to Stabilize instead, click the Stabilize icon at the top of the Viewer.

Transform Controls
The Transform Controls allow you to position, scale, rotate and corner-pin the 

Clone source.

X

Sets the horizontal position of the Clone source.

Y

Sets the vertical position of the Clone source.

Subpixel

When activated, subpixel positioning is used when moving the Clone source.

Z

Sets the rotation of the Clone source.

H

Sets the horizontal scale of the Clone source. Typing in a negative value will 

flop the Clone source.
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V

Sets the vertical scale of the Clone source. Typing in a negative value will flip 

the Clone source.

Nudging the Clone Source

The Clone source can be nudged using the Arrow keys. One press of the 

Arrow key moves the Clone source 1 pixel. Using the Shift key in conjunction 

with the Arrow keys moves the Clone source 10 pixels. Ctrl plus the Arrow 

keys moves the Clone source one tenth of a pixel. These nudge values can be 

changed in the Preferences menu located in File > Preferences > Nudging on 

Windows and Linux or Silhouette > Preferences > Nudging on Mac. Holding the 

Arrow keys down slides the Clone source.

Interactive

Activates the on-screen controls. Turn off Interactive mode when you want to 

Paint. When Interactive is selected, you can position, move, scale, rotate and 

corner-pin the Clone source using the on-screen controls.
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Table 25: Clone Source Transform On-Screen Controls

Shortcut Action

Drag within large center circle Moves the Clone source

Shift-drag within large center circle Constrain Clone source movement horizontally or 
vertically

Drag the center square horizontal and vertical 
halfway points

Scales the Clone source horizontally or vertically

Drag a center square corner Proportionally scale the Clone source

Drag large center circle Rotate the Clone source

Ctrl-drag large center circle Rotates the Clone source with finer control

Drag handles on corners of image Corner-pins the Clone source

Q Activates / Deactivates translation of the Clone 
source

W Activates / Deactivates rotation of the Clone 
source

E Activates / Deactivates scaling of the Clone source

Q, W, E then Ctrl(Win)/Cmd(Mac) Translates, Rotates or Scales in finer increments
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Corner-Pin

When Interactive mode is enabled, you can corner-pin the Clone source by 

dragging the handles on the corners of the image. Alternatively, you can select 

and move the corner points without being in Interactive mode by using 

Ctrl(Win)/Cmd(Mac)-1,2,3 or 4 to select the top left, top right, bottom right and 

bottom left corner points. Then, use the Arrow keys to move the points. This is 

great way to select and move the corner points without having to zoom in or out 

to find the points. 

Filter

Chooses the filtering method when transforming the Clone source. Mitchell is 

the default.

• Triangle

The Triangle filter is not the highest quality, but fine for scaled images. 

• Quadratic

Quadratic is like triangle, but more blur with fewer artifacts. It offers a good 

compromise between speed and quality.

• Cubic

Cubic is the default filter in Photoshop. It produces better results with 

continuous tone images, but is slower than Quadratic. If the image contains fine 

details, the result may be blurrier than desired.

• Catmull-Rom

This produces good results with continuous tone images which are scaled 

down, producing sharp results with fine detailed images.

• Gaussian

Gaussian lacks in sharpness, but is good with ringing and aliasing.

• Mitchell

A good balance between sharpness and ringing, Mitchell is a good choice when 

scaling up.

• Sinc

Keeps small details when scaling down with good aliasing.
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Reset

Resets all Clone brush transform controls.

Q (Translate), W (Rotate), E (Scale)

Pressing Q, W or E and then clicking and dragging will translate, rotate or scale 

the Clone source. Pressing Q, W or E a second time deactivates the mode. 

Also, the position of the cursor when W or E is pressed sets the anchor point 

for the rotation or scale operation.

Note: Onion Skin mode is automatically activated once the Q, W or E key is pressed.

Table 26: Clone Source Nudging Keyboard Shortcuts

Shortcut Action

Arrow keys Moves the Clone source by 1 pixel

Shift-Arrow keys Moves the Clone source by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the Clone source by one tenth of a pixel

Hold down Arrow keys Moves the Clone source continuously

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Q, W, E then Shift-Arrow keys Translates, Rotates or Scales by 10 pixels

Q, W, E then Ctrl(Win)/Cmd(Mac)-Arrow keys Translates, Rotates or Scales by 1/10 of a pixel

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Ctrl(Win)/Cmd(Mac)-1 then Arrow Keys Nudges the top left corner point

Ctrl(Win)/Cmd(Mac)-2 then Arrow Keys Nudges the top right corner point

Ctrl(Win)/Cmd(Mac)-3 then Arrow Keys Nudges the bottom right corner point

Ctrl(Win)/Cmd(Mac)-4 then Arrow Keys Nudges the bottom left corner point
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Grade
The Clone source can be graded (color corrected) using the various 

parameters.

Gain
Red

Multiplies red values.

Green

Multiplies green values.

Blue

Multiplies blue values.

Note: The parameters are ganged together by default. To deactivate Gang, press the 
Lock icon located at the top right of each parameter group.

Gamma
Red

Adjusts red gamma values.
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Green

Adjusts green gamma values.

Blue

Adjusts blue gamma values.

Lift
Red

Adds red values.

Green

Adds green values.

Blue

Adds blue values.

Reset All
Resets all grade controls.

Clone Viewing Options
Four Clone viewing options will aid you in positioning the Clone source. They 

are: Onion Skin, Align, Vertical Split and Horizontal Split. 

Onion Skin
Onion Skin does a mix, as defined by the slider to the right, between the Clone 

source and target. It is useful when aligning elements and painting with the 

Clone brush. In addition to the icon, pressing the Caps Lock key toggles Onion 

Skin mode on and off.
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Align
Align inverts the clone source and mixes it with the foreground, as defined by 

the slider to the right, creating an embossed effect when similar images are not 

aligned. When perfectly aligned, the Viewer appears gray or black depending 

on the state of the Paint > Clone > Alignment Type preference.

Vertical Split
Compares the Clone source and target using a Vertical Split. Move your cursor 

into the image area over the split line and when the cursor changes to a double-

arrow, click and drag to move the split line. The split line may not be obvious, 

so white triangles on the edge of the Viewer will help you find it.

The split is handy when using the Grade controls to color match the Clone 

source to the target.

Not Aligned Aligned
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Horizontal Split
Compares the Clone source and target using a Horizontal Split. Move your 

cursor into the image area over the split line and when the cursor changes to a 

double-arrow, click and drag to move the split line. The split line may not be 

obvious, so white triangles on the edge of the Viewer will help you find it.

The split is handy when using the Grade controls to color match the Clone 

source to the target.

Clone Presets

0-9 Presets
The 0,1, 2, 3, 4, 5, 6, 7, 8 and 9 buttons on the left side of the window allow you 

to save all of the Clone parameters as a preset. This includes the Clone source, 

Frame Offset, Transform, Grade controls, and Brush Size/Opacity/Spacing. To 

save a preset, click on one of the numbered presets and adjust the transform 

controls. You can also use Alt-0 through Alt-09 keyboard shortcuts to quickly 

select one of the presets.

Dual Clone
Two Clone presets can be activated at once. This allows you to paint from two 

different frames, using separate transforms and/or color corrections.

After you have set up two Clone presets, choose the first preset and press Shift 

to select the second one. The second preset will light up red and there will be 

a Mix control that appears at the top right of the Clone controls. Mix sets the 

relative opacity of the two Clone sources.

When you paint, both Clone presets will contribute to the painted result.

Note: The first preset is dominant and any transform changes will affect it instead of 
the second preset.
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Color (Shift-C)
Paints the image with the current color.

Picking Colors from the Screen
Colors can be picked off of the screen using a couple of different techniques.

1 Hover over an area in the Viewer and press the . (period key). The area inside the 
brush diameter is sampled and averaged when choosing the color.

2 Right-click picks a color from a single pixel.

3 Right-click-drag draws a box and averages the colors within it.

Color Palette
Colors can be selected using the Color Palette.

The Hue, Sat, Value and Sliders tabs provide you with four different methods 

for selecting a color.

Hue
The hue is selected from the hue picker while the saturation and value are 

chosen from the large square color palette.

Hue, Sat or Value Picker

Color Palette

Alpha

Paint Pots

Current Color

Mode
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Sat
The saturation is selected from the saturation picker while the hue and value 

are chosen from the large square color palette.

Value
The value is selected from the value picker while the hue and saturation are 

chosen from the large square color palette.

Sliders
Use the Red, Green, Blue, Hue, Sat, Value and Alpha sliders to set a color.

Hue, Sat or Value Picker
Depending on which tab is selected in the Color Palette, the vertical color bar 

to the right of the Color Palette controls the hue, saturation or value of the 

selected color.

Alpha
The second vertical color bar slider to the right of the Color Palette controls the 

level of the painted Alpha when Paint > A (Alpha) is selected. An Alpha value 

of 0 paints black, a value of 100 paints white while a value in between paints a 

level of gray.

Current Color
Displays the currently selected color.

Mode
Selects how color is applied to the image.

Normal
The Current Color is added to the image.

Tint
The Current Color is used to tint the image by replacing hue and saturation.

Hue
The Current Color is used to tint the image by only replacing hue.
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Luminance
Replaces the luminance of the image while leaving hue and saturation 

unaffected.

Lighten
Pixels darker than the paint color are replaced, and pixels lighter than the paint 

color do not change.

Darken
Pixels lighter than the paint color are replaced, and pixels darker than the paint 

color do not change.

Paint Pots
Favorite colors can be stored in the paint pots by dragging and dropping from 

the Current Color. Click on one of the paint pots to make it the current color.

Color Correct (Alt-C)
The image is painted using color adjustments.

Hue
Rotates the hue.

Saturation
Adjusts saturation. Positive values saturate, negative values desaturate.

Brightness
Adjusts brightness. Positive values brighten, negative values darken.

Contrast
Adjusts contrast. Positive values increase contrast, negative values decrease 

contrast.

Center
Adjusts the contrast curve to weight it more towards shadows or highlights. A 

lower value means a brighter range.
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Gamma 
Adjusts gamma. The gamma adjustment leaves the white and black points the 

same and only modifies the values in-between. Positive values darken the 

midtones, negative values lighten the midtones.

Red
Adds or subtracts red.

Green
Adds or subtracts green.

Blue
Adds or subtracts blue.

Drag (D)
Smudge or smear an area of the image. When the brush first starts, it makes a 

copy of the area under the brush, then on subsequent samples it stamps that 

area down in the new location with a blend.

Mix
Mix is the initial blend amount of the smudged area.

Decay
Determines how much of the Mix to use on the next stamp and reduces the Mix 

percentage with each sample.

The defaults are Mix = 50% and Decay = 90%. So, the first stamp will be a 

50/50 mix of the brush start sample and the new sample, then the next will be 

50% * 90% of it, etc. until it eventually fades away entirely.

Eraser (Shift-E)
Erases previously painted brush strokes.
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Grain (G)
Paints grain onto the image.

Size
Sets the size of the grain.

Red Size
Controls the size of the red grain.

Green Size
Controls the size of the green grain.

Blue Size
Controls the size of the blue grain.

Amount
Sets the intensity of the grain.

Red Amount
Controls the intensity of the red grain.

Green Amount
Controls the intensity of the green grain.

Blue Amount
Controls the intensity of the blue grain.

Softness
Sets the softness of the grain.

Red Softness
Controls the softness of the red grain.

Green Softness
Controls the softness of the green grain.

Blue Softness
Controls the softness of the blue grain.
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Mono
When checked, the grain is monochrome. In this mode, only the Red Size, Red 

Amount and Red Softness sliders are active.

Mosaic (M)
Divides the picture up into square tiles.

Size
Controls the size of the square tiles. A small size value will create many square 

tiles.

Repair (R)
Paints the image with the color level sampled at the beginning of each stroke.

Scatter (S)
Scatters pixels in a random fashion.

Radius
Sets the amount of scattering.
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Profile
You can customize your brush settings in the Profile section.

Profile
A soft, hard or square brush can be selected from the pop-up menu.

Hard
The brush profile is hard.

Soft
The brush profile is soft.

Square
The brush profile is set to a hard square.

Airbrush
When on, brush samples are generated at 30 samples/sec as long as the 

mouse button or pen is held down.

Size
Sets the size of the brush. The brush can also be resized in the Viewer by 

holding Ctrl(Win)/Cmd(Mac) and dragging the brush outline.

Opacity
Sets the opacity or transparency of the brush.
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Softness
Sets the brush softness. The brush softness can be changed in the Viewer by 

holding Ctrl(Win)/Cmd(Mac)-Shift and dragging the brush outline.

Flatness
Sets the flatness of the brush.

Angle
Sets the angle of the brush.

Spacing
Sets the brush spacing.
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Paint
The Paint settings affect how paint is applied to the image.

RGB
The selected brush paints on the RGB channels.

R
The selected brush paints on the Red channel.

G
The selected brush paints on the Green channel.

B
The selected brush paints on the Blue channel.

A
The selected brush paints on the Alpha channel.

Obey Alpha
The intensity of the Alpha channel controls how much the image will be affected 

by a particular paint operation. At any given pixel in the image, the more 

transparent the value in the Alpha channel, the more transparent the 

application of the paint operation. 

Invert Alpha
Inverts the Alpha channel.
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Opaque
Enabled once the “A” button is turned on, the Opaque control ensures that a 

solid paint stroke is created when painting into the Alpha channel. When 

Opaque is off, the brush will also affect the Alpha channel. So now, it's possible 

to blur and drag the Alpha channel, for instance.

Clear Alpha
Wipes any painted portions of the Alpha channel.

Restore
Clears all paint strokes and restores the original unpainted frames.

Current Frame
Clears all paint strokes on the current frame.

All Frames
Clears all paint strokes on all frames.

Work Range
Clears all paint strokes for the Timebar work range.

Tracking
Chooses a Roto node layer’s tracking or transformation data to be applied to 

the Clone source. The Clone source will then be automatically set according to 

the selected layer’s tracking or transformation data.

Note: Match Move in the Clone controls must be activated to use the selected layer’s 
tracking or transformation data.

Stereo Offset
The Stereo Offset control, which only shows up when using stereoscopic 

sources, is used to align the offset between Left and Right Views of 

stereoscopic sequences. These values are automatically set when using the 

Stereoscopic Align mode’s on-screen control.
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Table 27:  Paint Keyboard Shortcuts

Shortcut Action

B Selects the Black and White brush

Shift-B Selects the Blemish brush

Ctrl-B Selects the Blur brush

C Selects the Clone brush

Shift-C Selects the Color brush

Alt-C Selects the Color Correct brush

Shift-E Selects the Eraser brush

D Selects the Drag brush

G Selects the Grain brush

M Selects the Mosaic brush

R Selects the Repair brush

S Selects the Scatter brush

Ctrl(Win)/Cmd(Mac)-drag brush outline Sizes the brush

Ctrl(Win)/Cmd(Mac)-Shift-drag brush outline Sets the brush softness

Shift-click-drag with Clone brush Sets the Clone offset

Shift-click-click with Clone brush Sets the Clone offset

Shift-click or tap Resets the Clone offset

‘ (located to the left of 1 key) Displays the Clone source and then the Clone 
destination so that you can click on each to set the 
Clone offset

Caps Lock Toggles Onion Skin mode on and off

. (period key) Picks colors off of the screen

Right-click Picks a color off of the screen from a single pixel

Right-click-drag Picks a color off of the screen by drawing a box and 
averaging the colors within it

Alt-1 through Alt-5 Selects one of the Clone brush setups
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 EFFECTS NODE

The Effects node allows you to apply the brushes available in the Paint node 

as filter effects to shapes or layers. Paint and shape features are tightly 

integrated to form an extremely powerful shape based effects tool. Not only can 

filters be animated, but they can be combined with animated shapes to take the 

drudgery out of everyday jobs.

Since shapes are needed for the filters, the Effects node has it’s own shape 

tools similar to those in the Roto node. See the Roto Node for more 

information.

Effects Node Parameters
When the Effects node is selected in the Node List, parameters specific to the 

Effects node can be adjusted in the Node window.

Alpha Behavior
Determines how incoming and outgoing Alpha channel’s are handled. The 

default is None.

None
The incoming Alpha channel generated by previous nodes is not used for filter 

applications nor are the Effects node’s shapes rendered to the Alpha channel.

Obey Input
The incoming Alpha channel generated by previous nodes is considered when 

applying a filter.

Obey Inverted Input
The incoming Alpha channel generated by previous nodes is inverted and 

considered when applying a filter.
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Write Output
When enabled, shapes with effects applied to them are rendered to the Alpha 

channel.

Effects View Menu
When Effects is selected in the Node List, the View menu displays either the 

Foreground or Output.

The 1 and 2 keys can quickly switch the view: 1 is Foreground and 2 is Output.

Foreground
The viewer displays the foreground clip.

Output
The viewer displays the output of the Effects node.
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Applying Filters

Using Shapes or Layers
Filters can be applied to shapes or layers. Simply select a shape, a selection of 

shapes or a layer and choose an effect from the Filter menu. When added to a 

layer, the effect is applied based on the alpha of the layer. The idea is to allow 

shapes with various Blend modes to contribute to or limit where the effect will 

be applied.

Mosaic filter applied to the Face shape

Once applied, the filter appears in the Object List within an Effects group. 

In addition, if you click on one of the filters in the Object List, its editable 

parameters show up in the Object window and can be keyframed like any other 

attribute.
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Here’s an example of the Color Correct filter parameters:

Go to Applying Filters to see how it works.

Obeying Alpha Channels from Upstream Nodes
The incoming Alpha channel generated by previous nodes can be utilized when 

applying a filter. All you need to do is click on the Effects node in the Node List 

and select Alpha Behavior > Obey Input in the Node window. Now, when a filter 

is added to a shape, it is only applied to the areas of input Alpha contained 

within the shape.

Go to Obeying Alpha Channels from Upstream Nodes to see how it works. 
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Filters Menu
When the Effects node is selected in the Node List, a Filter menu appears in 

the Title bar. This is where you select filters to be applied to shapes or layers. 

A number of different effects are selectable from the Filters menu.

B/W
The B/W filter converts color images to black and white simulating the look of 

Black and White photographic filters.

Opacity
Sets the opacity of the B/W filter.

Mode
Selects the method by which the color image is converted to a monochrome 

image.

Luminance
Creates a monochrome image using the brightness of the image.

Average
Creates a monochrome image using the average of the red, green and blue 

channels.

Red
Simulates a red filter in black and white photography.
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Green
Simulates a green filter in black and white photography.

Blue
Simulates a blue filter in black and white photography.

Yellow
Simulates a yellow filter in black and white photography.

Orange
Simulates a orange filter in black and white photography.

Blemish
The Blemish filter is useful for removing facial blemishes on film originated 

footage. It combines the Blur and Grain filters.

Blur
Adds blur to the image.

Opacity
Sets the opacity of the Blur filter.

Radius
Sets the amount of blur to be applied.

Color
Adds color to the image.

Opacity
Sets the opacity of the Color filter.

Color Picker
The Color parameter sets the color through the use of a standard color picker.

Blend Mode
Selects how color is applied to the image.

Normal
The current color is added to the image.
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Tint
The current color is used to tint the image by replacing hue and saturation.

Hue
The current color is used to tint the image by only replacing hue.

Luminance
Replaces the luminance of the image while leaving hue and saturation 

unaffected.

Lighten
Pixels darker than the paint color are replaced, and pixels lighter than the paint 

color do not change.

Darken
Pixels lighter than the paint color are replaced, and pixels darker than the paint 

color do not change.

Color Correct
Manipulates the image using hue, saturation, brightness, contrast, gamma, 

red, green and blue values.

Opacity
Sets the opacity of the Color Correct filter.

Hue
Rotates the hue.

Saturation
Adjusts saturation. Positive values saturate, negative values desaturate.

Brightness
Adjusts brightness. Positive values brighten, negative values darken.

Contrast
Adjusts contrast. Positive values increase contrast, negative values decrease 

contrast.
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Center
Adjusts the contrast curve to weight it more towards shadows or highlights. A 

lower value means a brighter range.

Gamma 
Adjusts gamma. The gamma adjustment leaves the white and black points the 

same and only modifies the values in-between. Positive values darken the 

midtones, negative values lighten the midtones.

Red
Adds or subtracts red.

Green
Adds or subtracts green.

Blue
Adds or subtracts blue.

Grain
Adds grain to the image.

Opacity
Sets the opacity of the Grain filter.

Size
Sets the size of the grain.

Red Size
Controls the size of the red grain.

Green Size
Controls the size of the green grain.

Blue Size
Controls the size of the blue grain.

Amount
Sets the intensity of the grain.
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Red Amount
Controls the intensity of the red grain.

Green Amount
Controls the intensity of the green grain.

Blue Amount
Controls the intensity of the blue grain.

Softness
Sets the softness of the grain.

Red Softness
Controls the softness of the red grain.

Green Softness
Controls the softness of the green grain.

Blue Softness
Controls the softness of the blue grain.

Mono
When checked, the grain is monochrome. In this mode, only the Red Size, Red 

Amount and Red Softness sliders are active.

Mosaic
Divides the image up into square tiles.

Opacity
Sets the opacity of the Mosaic filter.

Size
Controls the size of the square tiles. A small size value will create many square 

tiles.

Scatter
Scatters pixels in a random fashion.

Opacity
Sets the opacity of the Scatter filter.
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Radius
Sets the amount of scattering.

Scratch
Removes vertical scratches by averaging in the surrounding pixels.

Opacity
Sets the opacity of the Scratch filter.

Width
Controls the strength of the Scratch filter.

Go to Using the Scratch Filter to see how it works. 
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 KEYER NODE

Using proprietary matte extraction techniques, the Keyer quickly and simply 

creates mattes with minimal parameters even if you are dealing with fine hair 

detail, smoke, or reflections. It is easy to use, yet provides the needed tools 

when faced with good, bad, or ugly shots — tools such as DV/HD deartifacting, 

multiple matte creation, color suppression and sophisticated matte 

manipulation.

Go to Using the Keyer to see how it works. 

Note: Before the Keyer can be available for use, it must be enabled in the Session 
Settings and selected in the Node List.

Matte
Primary

Composite

FG BG

Matte
Secondary
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Keyer View Menu
When the Keyer is selected in the Node List, the View menu displays either the 

Composite, Foreground, Background, Combined Matte, Primary Matte, 

Secondary Matte or Output.

The 1, 2, 3, 4, 5, 6, and 7 keys can quickly switch the view: 1 is Composite, 2 

is Foreground, 3 is Background, 4 is Combined Matte, 5 is Primary Matte, 6 is 

Secondary Matte and 7 is Output.

Composite
The viewer displays the composite of the foreground over the background 

based on your matte. If “None” is selected for the Background Input, the 

foreground will be composited over a color. The default color is gray, but can 

be changed by going to File > Preferences > Composite on Windows and Linux 

or Silhouette > Preferences > Composite on Mac. If you add a Composite node 

in the Session Settings, the composite will be rendered.

Foreground
The viewer displays the foreground clip.

Background
The viewer displays the background clip.

Combined Matte
The viewer displays the final matte. If the Primary and Secondary Mattes are 

utilized, this option will show you the combined matte. 

Primary Matte
The viewer displays the Primary Matte.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

294 Keyer Node

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Secondary Matte
The viewer displays the Secondary Matte if it is enabled.

Output
The viewer displays the output of the Keyer node which is the modified 

foreground and Alpha channel.
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Deartifact
The Deartifact parameters are handy for cleaning up artifacts caused by DV 

and HD video footage. In fact, they are useful for cleaning up foregrounds that 

have aliased or jaggy edges. 

When activated, a RGB to YUV conversion takes place so that you can blur 

only the U and V color channels. Since this is where most of the artifacting 

shows up, this has the effect of cleaning up the ratty edges encountered when 

keying DV or HD video footage. It is usually best to blur mostly on the horizontal 

axis.

Note: The Deartifact parameters default to settings that are good for DV footage. If you 
are working at higher resolutions, you will want to increase the Horizontal and Vertical 
Blur settings.

Enable
Activates Deartifacting.

Horizontal Blur
Prior to pulling the matte, the U and V color channels are blurred by a fast, 

quality blur along the X-axis.

Vertical Blur
Prior to pulling the matte, the U and V color channels are blurred by a fast, 

quality blur along the Y-axis.

Gang
The horizontal and vertical slider values can be ganged together.

Deartifact off Deartifact on 
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Primary Matte
The Keyer can utilize up to two mattes in the creation of the final composite. If 

only one matte is needed, you would use the Primary Matte. When adjusting 

the Primary Matte, you should select Primary Matte in the View pop-up menu 

so you can see what you are doing.

Note: Keep in mind when creating your matte that wherever you see black in the matte, 
you will see background in the final composite. Wherever you see white in the matte, 
you will see foreground in the final composite--foreground being anything that is 
extracted from the blue or green screen.

Extract On
Extract On selects the type of matte extraction. Select whichever type isolates 

the desired values. A matte is extracted based on one of the following:

Blue Screen
Choose blue screen if you have a blue screen.

Green Screen
Choose green screen if you have a green screen.

Luminance
A matte is extracted based on the luminance of the image.

Hue
A matte is extracted based on the hue of the image. When adjusting the 

Position parameter, you are selecting different hues.

Saturation
A matte is extracted based on the saturation of the image.

Average
A matte is extracted based on the average of the image’s RGB values.

Red
A matte is extracted based on the image’s red values.
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Green
A matte is extracted based on the image’s green values.

Blue
A matte is extracted based on the image’s blue values.

Alpha
A matte is extracted based on the image’s alpha values.

Cyan
A matte is extracted based on the image’s cyan values.

Magenta
A matte is extracted based on the image’s magenta values.

Yellow
A matte is extracted based on the image’s yellow values.

Background/Foreground
When using the Extract On > Blue Screen or Green Screen settings, 

Background and Foreground are used while all other matte extraction methods 

use Position and Range.
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Background
Sets the background value. The lower the value, the harder or blacker the 

matte will become. 

It is best to set the Background value as high as possible, while at the same 

time making sure that the background is completely black.

Background = 40

Background = 80
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Foreground
Sets the foreground value. The higher the value, the harder or whiter the matte 

will become. 

It is best to set the Foreground value as low as possible, while at the same time 

making sure that the foreground is completely white for any areas that should 

be opaque in the final composite.

Position and Range
When using matte extraction methods other than the Extract On > Blue Screen 

or Green Screen settings, Position and Range are used instead of Foreground 

and Background.

Position
The Position value pinpoints the values to be used in the matte. For a 

Luminance extraction, a Position value of 100 would make a white matte of the 

highlights and a value of 0 would make a white matte of the shadows.

Foreground = 0

Foreground = 17
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Range
Increases or decreases the range of values in the matte. A low Range value 

indicates a narrow range of values. A high Range value indicates a large range 

of values included in the matte.

Black Clip
Blacks in the matte are made blacker by increasing the value of the slider. As 

the slider value increases, more values are clipped to black. This is helpful for 

getting rid of unwanted gray areas in what should be the black part of the matte. 

White Clip
Whites in the matte are made whiter by increasing the value of the slider. As 

the slider value increases, more values are clipped to white. This is helpful for 

getting rid of unwanted gray areas in what should be the white part of the matte. 

Shrink/Grow
Shrinks or grows the matte. Negative values shrink and positive values grow 

the matte.
Shrink/Grow = -5
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Blur
The matte is blurred by a fast, quality blur.

Wrap
Helps blend the foreground into the background by making the background 

“wrap” into the foreground edges without completely losing the edge. The edge 

of the foreground starts to become transparent.

Blur = 10

Wrap = 30
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Secondary Matte
Sometimes two mattes are needed to create a good key. The Keyer allows you 

to create two different mattes and combine them with various Blend modes.

With the exception of those listed below, the remaining parameters for the 

Secondary Matte are the same as the Primary Matte: Extract On, Background, 

Foreground, Position, Range, Shrink/Grow, Blur, and Wrap.

Enable
Activates the Secondary Matte.

Note: You must first enable the Secondary Matte before it can be seen in the View pop-
up menu.

Blend
Once a blend mode is selected, the Secondary Matte is combined with the 

Primary Matte.

Add
The Secondary Matte is added to the Primary Matte.

Subtract
The Secondary Matte is subtracted from the Primary Matte.

Primary Matte            Secondary Matte                  Result

Primary Matte            Secondary Matte                  Result
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Multiply
Produces a result where there is a union of the Primary and Secondary Mattes.

Screen
This looks kind of like the Add blend mode, but highlights are retained as 

opposed to being burnt out.

Difference
Produces a result where a value exists in the Primary and Secondary Mattes, 

but not in both.

Primary Matte            Secondary Matte                  Result

Primary Matte            Secondary Matte                  Result

Primary Matte            Secondary Matte                  Result
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Darken
Compares the two mattes and takes pixels with the lower value.

Lighten
Compares the two mattes and takes pixels with the higher value.

Opacity
Sets the opacity of the Secondary Matte.

Primary Matte            Secondary Matte                  Result

Primary Matte            Secondary Matte                  Result
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Color Suppress
Removes either blue or green spill from the foreground object.

Note: Color Suppress is only available when using Extract On > Blue or Green Screen 
in the Primary Matte.

Enable
Activates color suppression.

Foreground
Suppresses color spill in the foreground.The default value of 100 should be 

sufficient for most situations.

Range
Increases the range of areas that are color suppressed. If color spill is still 

evident, increase this value.

Edge
Suppresses the color spill of the foreground edge to the color gray. This is very 

useful for edges that contain a lot of transparency like hair or reflections.

Foreground = 0 Foreground = 100
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 POWER MATTE NODE

Power Matte is an easy to use interactive image matting tool capable of 

extracting almost any object in an image--even if you are dealing with fine hair 

detail, smoke, or reflections.

To work this magic, Power Matte iteratively estimates the transparency value 

for every pixel in the image, based on a small sample of foreground (what you 

want to cut out) and background (what you want to get rid of) pixels marked by 

defining simple shapes on the image. Results show that compared with 

previous approaches, our method is more efficient and requires minimal effort 

to extract high quality mattes for foregrounds with significant semi-transparent 

regions. In addition, the foreground edge colors can be estimated in the semi-

transparent areas to create a seamless composite.

Before After

Matte Shapes
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Go to Using Power Matte to see how it works. 

Note: Before Power Matte can be available for use, it must be enabled in the Session 
Settings and selected in the Node List.

Since shapes are required for Power Matte, it has it’s own shape tools similar 

to those in the Roto node. See the Roto Node for more information.

Matte Creation
Power Matte uses open or closed shapes to define the object you would like to 

isolate or extract. The shapes can be loose--they don’t need to follow exactly 

around the edges. Areas not defined by shapes are considered unknown areas 

and are automatically computed by Power Matte.

Trimaps
Power Matte creates mattes by using a trimap--a pre-segmented image 

consisting of three regions of foreground (what you want to cut out), 

background (what you want to get rid of) and unknown. Partial opacity values 

are then computed only for pixels inside the unknown region. Two trimap 

methods can be used: Open Shape or Closed Shape. When creating mattes, 

start with the Open Shape Method and move on to the Closed Shape Method 

if the results are not satisfying.
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Open Shape Method
Power Matte only requires a few open shapes to define foreground and 

background areas of the image when using the Open Shape Method. Areas not 

defined by shapes are considered unknown areas with partial opacity values 

being computed between the areas marked by foreground and background 

shapes.

Using the shapes, Power Matte generates an intermediate matte result called 

a Trimap. White signifies solid foreground, black is complete background and 

gray is unknown area where Power Matte will compute partial opacity.

The Open Shape Method requires little user input, but when color ambiguity 

exists between the foreground and background, the Closed Shape Method 

may create a more accurate matte. In addition, the Open Shape Method will 

also take slightly longer to render as it requires an extra calculation step.

Shapes Matte

Trimap
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Open Shape Method Tips & Tricks
• Make sure you draw enough foreground (what you want to cut out) and 

background (what you want to get rid of) shapes. A good technique is to draw an 
open inner shape within the object you are extracting and an outer, open shape 
outside the object.

• The shapes should be near the boundary of the object, but not right up against the 
edge. 

• If the foreground or background has varying colors, the shapes should cover 
these colors.

• When viewing the matte, if you see gray areas in the foreground object that should 
be completely white, make additional foreground shapes in those areas. If you see 
gray matte areas in the background that should be completely black, make 
additional background shapes.

• The general rule is to not put different foreground and background shapes too 
close together unless you need to.

Warning: If you only provide a few sparse shapes, the Open Shape Method will take 
longer to process with a less accurate result than the Closed Shape Method.

Good Shape Example Bad Shape Example
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

310 Power Matte Node

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Closed Shape Method
The Closed Shape Method uses closed shapes to mark definite foreground and 

background areas of the image. Any unmarked areas are considered unknown 

and partial opacity values are then computed for the pixels inside the unknown 

region. So, make sure that any hair detail, transparent or blurry portions fall 

within the unknown areas.

Closed Shape trimaps process slightly faster than Open Shape trimaps and 

can result in extracting a more accurate shape, most notably when color 

ambiguity exists between the foreground and background. However, they can 

be tedious to create and tend to fail for images with large portions of semi-

transparent foreground where the trimap is difficult to create manually. The 

Closed Shape method does not handle a foreground object with background 

holes in it, and therefore the Open Shape method would be a better choice 

when extracting an object with holes

Shapes Matte

Trimap
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Closed Shape Method Tips & Tricks
• First, define foreground areas by drawing a closed shape around the inside edges 

of the foreground (what you want to cut out).

• Next, define background areas (what you want to get rid of) by drawing a closed 
shape around the background areas. 

• If your foreground object is completely surrounded by background, a quick way 
to define the background area is to first draw a closed shape around the outside 
of the foreground and then invert the shape in the Object window. 

• Ideally, the unknown region, the regions not defined with foreground or 
background shapes, should only cover transparent pixels whose actual values are 
not completely foreground or background. In other words, the unknown region 
should include hair detail, transparent or blurry portions of the image.

Note: Large foreground objects take longer to process than small ones.
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Power Matte View Menu
When Power Matte is selected in the Node List, the View menu displays either 

the Composite, Foreground, Background, Trimap, Matte or Output.

The 1, 2, 3, 4 , 5 and 6 keys can quickly switch the view: 1 is Composite, 2 is 

Foreground, 3 is Background, 4 is Trimap, 5 is Matte and 6 is Output.

Composite
The viewer displays the composite of the foreground over the background 

based on your shapes. If “None” is selected for the Background Input, the 

foreground will be composited over a color. The default color is gray, but can 

be changed by going to File > Preferences > Composite on Windows and Linux 

or Silhouette > Preferences > Composite on Mac. If you add a Composite node 

in the Session Settings, the composite will be rendered.

Foreground
The viewer displays the foreground clip.

Background
The viewer displays the background clip.

Trimap
The viewer displays the trimap matte.

Matte
The viewer displays the generated matte.
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Output
The viewer displays the output of the Power Matte node which is the modified 

foreground and Alpha channel. 

Note: If Color Estimation is enabled, the edges of the foreground element will look a bit 
odd in the Output View.

Power Matte Node Parameters
When Power Matte is selected in the Node List, parameters specific to Power 

Matte can be adjusted in the Node window.

Source Alpha
Controls how the incoming Alpha channel is blended with the Power Matte 

Alpha channel.

Ignore
The incoming Alpha channel is not used.

Add
Adds the incoming Alpha channel to the Power Matte Alpha channel.

Subtract
Subtracts the incoming Alpha channel from the Power Matte Alpha channel.

Multiply
Produces a result where there is a union of pixels from the incoming Alpha 

channel and Power Matte Alpha channel.
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Difference
Produces a result where a value exists in the incoming Alpha channel and 

Power Matte Alpha channel, but not in both.

Color Estimation
Estimates the color of the foreground in unknown and semi-transparent areas. 

Color Estimation is off by default and when activated, prevents fringing to 

create a seamless composite. When disabled, a foreground object with 

transparent edges against a bright or dark background will have bright or dark 

edges in the composite.

Note: Color Estimation can cause color flickering in edge areas of partial opacity if your 
shape position is not constant from frame to frame or if your source footage is grainy. 
Disable Color Estimation if you see flickering in the edge areas after a preview or 
rendering.

Sensitivity
Sets the sensitivity of the Unknown areas. The higher the value, the more 

details are brought out.

Deartifact
Blurry artifacts can be generated while attempting to extract objects that have 

drop shadows, similar colors to the background or out of focus edges. 

Deartifact can be used to limit these artifacts.

Off On
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Accuracy
The accuracy of the generated matte can be increased with this control. When 

foreground and background shapes are close together, setting the Accuracy to 

Higher or Full will result in a more accurate matte. 

Note: It is best to work with Power Matte at the Accuracy setting that you will be 
rendering at.

Normal
Normal will work for most images and will render faster than the other settings.

Higher
Higher results in better accuracy than the Normal setting, but not quite as good 

as Full.

Full
Full will result in the most accurate matte, but will take longer to render.

Color Suppression
When a foreground object has been photographed against a solid blue or green 

backdrop, the blue or green color can have a tendency to spill onto the 

foreground object. When extracting an object photographed against one of 

these colors, you may find it necessary to remove the blue or green spill. This 

is a process called Color Suppression.

Off On
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Type
Selects whether blue or green is suppressed from the foreground image.

Foreground
Suppresses color spill in the foreground.The default value of 100 should be 

sufficient for most situations.

Range
Increases the range of areas that are color suppressed. If color spill is still 

evident, increase this value.

Edge
Suppresses the color spill of the unknown edge areas to the color gray. This is 

useful for edges that contain a lot of neutral transparency like glass reflections.

Reset All
Resets all parameters to their default state.
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Power Matte Shape Parameters

Type

Foreground
Assigns the shape to be used as foreground (what you want to cut out).

Background
Assigns the shape to be used as background (what you want to get rid of).

Filled
Determines whether or not the shape is filled.

Invert
Inverts a filled shape. This option is only available if Filled is enabled.
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 STEREOSCOPIC

Traditional stereoscopic photography consists of creating a 3-D illusion from a 

pair of 2-D images. The easiest way to create depth perception in the brain is 

to provide the eyes of the viewer with two different images, representing two 

perspectives of the same object, with a minor deviation similar to the 

perspectives that both eyes naturally receive in binocular vision.

Silhouette provides stereoscopic viewing and editing tools to handle dual 

images from different perspectives.

Go to Working with Stereoscopic Images to see how it works.

Stereoscopic Workflow

Creating Sessions
• Load a stereoscopic EXR file or left and right sequences into Silhouette.

• Create a Session.

• If you are not using a stereoscopic EXR file, the left and right sequences have to 
be linked together using the Source node’s View > Primary/Left and 
Secondary/Right parameters.

Roto
• Use the Stereoscopic View modes to determine whether you are rotoscoping on 

the Left View, Right View or both the Left and Right Views at the same time.

• Create a shape around an object in either the Left or Right View and keyframe it as 
needed.

• Use Edit > Stereoscopic > Duplicate > New Layer so that the shape and all of it’s 
keyframes from the Left View are duplicated to the Right View in a new layer and 
the two shapes are linked together. When using shapes inside of a transformed 
layer, you can duplicate the layer instead. This will copy the layer along with it’s 
transform data into the other view, copy any unlinked stereoscopic children into 
it and then link the shapes. You can stereo duplicate one layer at a time using this 
method.

• Go to the view that contains the duplicated shape and layer and click on the layer 
in the Object List to make it active.
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• Activate the Stereoscopic Align mode and click and drag in the Viewer to align the 
two views in the area of your shape. The views are aligned when there is a solid 
gray color.

• If the object you are rotoscoping moves through various depths, you will want to 
keyframe the Stereoscopic Align setting at various frames.

• Deactivate Stereoscopic Align mode.

• Once aligned, the duplicated shape is aligned to the rotoscoped object using the 
offset created when adjusting the Stereoscopic Align mode.

• Adjust the duplicated shape as needed.

Paint
• Use the Stereoscopic View modes to determine whether you are painting on the 

Left View, Right View or both the Left and Right Views at the same time.

• To paint on both the Left and Right Views at the same time and in the same 
location, you will want to use Stereoscopic Align mode to line up the two views.

• Activate the Stereoscopic Align mode and click and drag in the Viewer to align the 
two views in the area where you will be painting. The views are aligned when there 
is a solid gray color.

• Deactivate Stereoscopic Align mode.

• Once aligned, painting in the Left/Right View will paint on the same location of the 
image in both views. 

Keying
• Use the Stereoscopic View modes to view the result of the keyer in the Left View, 

Right View or both the Left and Right Views at the same time.

Note: The Keyer applies the same setting to both the Left and Right Views.

Effects
• Use the Stereoscopic View modes to determine whether you are creating effects 

on the Left View, Right View or both the Left and Right Views at the same time.
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Source Node > View
The stereoscopic tools in Silhouette only show up in the user interface when 

using a stereoscopic EXR file or when left and right sequences have been 

assigned in the Source node’s View > Primary/Left and Secondary/Right 

parameters.

In the Source node parameters, you will find View controls. This is where you 

identify which sequences are used for the left and right views of stereoscopic 

sessions.

Primary/Left
Sets which sequence is used for the left view.

Secondary/Right
Sets which sequence is used for the right view.

Note: Stereoscopic EXR files which contain both the Left and Right Views within one 
file are automatically connected to the Primary/Left and Secondary/Right views.
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Stereoscopic View Modes
The Viewer’s Stereoscopic View modes determine whether you are working on 

the Left View, Right View or both the Left and Right Views at the same time.

L (Shift-1)
Left View displays the left sequence in the Viewer.

R (Shift-2)
Right View displays the right sequence in the Viewer.

LR (Shift-3)
Left/Right View displays both the left and right sequences in the Viewer.

Stereoscopic Split Mode
Only available once the Left/Right View is active, Stereoscopic Split Mode 

determines whether or not the Left and Right Views are arranged horizontally 

or vertically.

Horizontal
Arranges the Left and Right Views horizontally.

Vertical
Arranges the Left and Right Views vertically.
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Stereoscopic Align (Shift-4)
Stereoscopic Align utilizes layers to line up two stereoscopic sequences which 

will effectively negate the offset between them. Aligning the sequences in this 

manner allows painting on the same location of the Left and Right Views 

simultaneously, while for rotoscoping, it means shapes created for the Left 

View can be easily duplicated to the Right View in the proper position.

Note: Stereoscopic Align can only be selected and used once a layer is active.

When activated, Stereoscopic Align uses a negative mode which inverts one of 

the views and mixes it with the other. This creates an embossed effect when 

similar image areas are not aligned. By dragging the move cursor that appears, 

you can drag on the Viewer to align the views. When similar image features are 

perfectly aligned, you will see a solid gray color. The amount you move the view 

in Stereoscopic Align mode is stored in the Stereo Offset parameter of the 

active layer which is set to animate by default. Animation of this parameter is 

needed for image sequences that contain depth changes.

Table 28: Stereoscopic Align Keyboard Shortcuts

Shortcut Action

Click and drag in Viewer Moves the Stereo Offset horizontally

Shift-click and drag in Viewer Moves the Stereo Offset horizontally and vertically

Ctrl-drag in Viewer Moves the Stereo Offset in finer increments

Alt-click in Viewer Resets the Stereo Offset

Arrow keys Moves the Stereo Offset by 1 pixel

Shift-Arrow keys Moves the Stereo Offset by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the Stereo Offset by one tenth of a pixel

Hold down Arrow keys Moves the Stereo Offset continuously
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Anaglyph Preview (Shift-5)
Activates Anaglyph Preview mode so that you can check your stereoscopic 

image in 3D using red-blue glasses.

Stereo Viewer (Shift-6)
Opens a stereo Viewer window for displaying the stereoscopic image in either 

Anaglyph or Interlaced modes on a 3D monitor. The default mode is defined in 

the Viewer > Stereo View Mode preference.

Interlaced mode requires a 3D monitor that uses interlacing like the Zalman 

passive display. When in Interlaced mode, the Stereo First Field viewer 

preference controls which eye comes first--Left or Right. This needs to match 

up with how the monitor does the 3D effect. Right-clicking on the Stereo Viewer 

gives you the choice to Zoom > Fit, Zoom > 1:1 or to go Fullscreen.

Note: On a single monitor system, the Esc key will close the Stereo Viewer.

Table 29: Stereoscopic View Shortcuts

Shortcut Action

Shift-1 Selects the Left View

Shift-2 Selects the Right View

Shift-3 Selects the Left/Right View

Shift-4 Selects Stereoscopic Align

Shift-5 Anaglyph Preview

Shift-6 Stereo Viewer
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Layer > Stereo Offset
The Layer > Stereo Offset control is used to align the offset between Left and 

Right Views of stereoscopic sequences and is set to animate by default. This 

value is automatically set when using the Stereoscopic Align mode’s on-screen 

control.
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Stereoscopic Roto

Shape and Layer Creation
When in the Left or Right View, creating a shape or layer will create it in either 

the Left or Right View. In the Left/Right View, a shape or layer is created in both 

the Left and Right Views.

Switching the View Assignment for Shapes and Layers
Whichever view is selected when the shape or layer is created, a L for Left View 

or R for Right View appear to the left of the Object Lists’s Opacity icon and 

indicates which view the shape or layer is assigned to. Clicking on this View 

icon toggles which view the shape or layer is located in.

Link, Unlink and Duplicate Shapes
In the Edit menu, you will find a Stereoscopic entry. This is where you can link, 

unlink and duplicate shapes for stereoscopic rotoscoping. 

Link
Links two selected shapes of the same type and the same number of control 

points for stereoscopic rotoscoping. Linking allows the two shapes to be 

simultaneously selected and edited in the Left/Right View.

Note: Linked shapes are bolded in the Object List when one or both of a linked pair is 
selected.

Unlink
Unlinks selected shapes.

Duplicate
Duplicates a selected shape or a single layer containing shapes to the other 

view and automatically links it. When a layer is duplicated, all of it’s transform 

data is copied as well.
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Duplicate > New Layer
Duplicates a selected shape to the other view, automatically links it and places 

it in a new layer.

Note: Duplicate > New Layer is not available if you are in the Left/Right View.

Selection
Selecting Shapes
• When in the Left/Right View, selecting a shape also selects its linked shape.

• While in the Left/Right View, in the Transform and Reshape tools, changing the 
selection state of a stereoscopic linked shape will do the same to the linked shape.

• It is possible to only select one of the two linked objects:
1 In the Left/Right View by using the Object List.

2 In the Transform tool by Alt-clicking a shape. 

3 In the Reshape tool by Alt-clicking an unselected shape.

• An Alert icon appears over the Left or Right View icons if there is a selected shape 
in the other view.

Selecting Points
When in the Left/Right View, changing point selection on one shape will match 

the point selection on the linked shape

Editing
Points

Moving Points
When in the Left/Right View, selected points on both shapes are moved by the 

same amount.

Adding Points
Adding points is only allowed while in the Left/Right View, so you can see the 

change to both linked shapes.

Deleting Points
Deleting points is only allowed while in the Left/Right View, so you can see the 

change to both linked shapes.

Note: Adding and deleting points is only allowed when in the Left/Right View when both 
shapes are selected and when both shapes have the same selected control points.
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Shapes

Deleting Shapes
Deleting a linked shape will sever its link.

Cutting Shapes
Cutting a single linked shape will sever its link, unless both linked shapes are 

cut.

Copying Shapes
Copying a single linked shape will sever its link, unless both linked shapes are 

copied.

Pasting Shapes
If both linked shapes are in the copy buffer, the new pasted shapes will be 

linked to each other.
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Stereoscopic Paint

Painting
In general, painting on stereoscopic images is the same as painting with single 

images. The Stereoscopic View mode determines whether you are painting on 

the Left View, Right View or both the Left and Right Views at the same time.

In the Timebar, red markers are displayed for painted frames in the Left View, 

blue markers for the Right View and green markers for frames painted in both 

the Left and Right View.

Clone > View
The View menu determines which view the Clone source will come from.

Auto
The Clone source is determined by the Stereoscopic View mode that has been 

selected at the top of the Viewer.

For instance, if the Left View is selected above the Viewer, the Clone source 

comes from the Left View. If the Right View is selected, the Clone source comes 

from the Right View. If the Left/Right View is selected, the Clone source comes 

from both the Left and Right Views so you can simultaneously Clone on both 

the views at the same time.

Left
The Clone source comes from the Left View.
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Right
The Clone source comes from the Right View.

Paint > Stereo Offset

The Stereo Offset controls are used to align the offset between Left and Right 

Views of stereoscopic sequences. These values are automatically set when 

using the Stereoscopic Align mode’s on-screen control.
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Stereoscopic Rendering
The View and Dominant View pop-up menus appear in the Render Options 

window when using stereoscopic sources.

View
The View pop-up allows you to control whether you render the Left, Right or 

both the Left and Right stereoscopic views simultaneously.

Both
Renders both the Left and Right stereoscopic views with a _L and _R 

appended to the filenames. 

Left
Renders only the Left stereoscopic view with a _L appended to the filename.
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Right
Renders only the Right stereoscopic view with a _R appended to the filename.

Combined
Renders both the Left and Right stereoscopic views into one file when using the 

EXR file format. 

Note: View > Both must be selected before the Combined button is active.

Dominant View
The Dominant View, which is only available when rendering stereoscopic EXR 

files, determines the view that non-stereoscopic aware applications will display.

Left
Sets the Left stereoscopic view as the dominant view.

Right
Sets the Right stereoscopic view as the dominant view.
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 SOURCE NODES

When media is imported into Silhouette, it is automatically plugged into a 

Source node.

Source Node Parameters
When one of the image sources is selected in the Node List,

parameters specific to that Source node can be adjusted in the Node window.

Preserve Alpha
Determines whether or not to use the input clip’s Alpha channel. The default is 

off.
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View
The View parameters are where you identify which sequences are used for the 

Left and Right Views when working on stereoscopic sessions. The 

stereoscopic tools in Silhouette only show up in the user interface when using 

a stereoscopic EXR file or when left and right sequences have been assigned 

in the View > Primary/Left and Secondary/Right parameters.

Note: Non-stereoscopic sources only use the Primary/Left view.

Primary/Left
Sets which sequence is used for the Left View.

Secondary/Right
Sets which sequence is used for the Right View.

Note: Stereoscopic EXR files which contain both the Left and Right Views within one 
file are automatically connected to the Primary/Left and Secondary/Right views.

Time Shift
Shifts the source node in time.

Extend Duration
When enabled, the last frame of the sequence will repeat if the Session 

duration is longer.

Flip Vertical
Flips the sequence vertically.

Flip Horizontal
Flops the sequence horizontally.

Renaming Source Nodes
You can rename a Source node by either:

• Clicking on the Source node once to select it, hitting the Enter key, typing in the 
new name and pressing Enter again.

• Right-clicking on the Source node, selecting Rename and typing in a new name.
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

334 Composite Node

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

 COMPOSITE NODE

The Composite node renders a composite of the foreground over the 

background based on the generated Alpha channel. If “None” is selected for 

the Background Input, the foreground will be composited over a color. The 

default color is gray, but can be changed using the Composite node’s 

Background Color parameter.

Note: Before the Composite node can be available for use, it must be enabled in the 
Session Settings.

Both the position and scale of the foreground element can be adjusted in the 

Composite node.

Go to Using the Composite Node to see how it works. 

Composite View Menu
When Composite is selected in the Node List, the View menu displays either 

the Composite, Foreground or Background.

The 1, 2 and 3 keys can quickly switch the view: 1 is Composite, 2 is 

Foreground and 3 is Background.

Composite
The viewer displays the composite of the foreground over the background 

based on your matte. If “None” is selected for the Background Input, the 

foreground will be composited over a color.

Foreground
The viewer displays the foreground clip.

Background
The viewer displays the background clip.
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Composite Node Parameters

Transform
Transforms the foreground and matte.

Position
Sets the horizontal and vertical position of the foreground and matte.

Scale
Sets the horizontal and vertical scale of the foreground and matte.

Background Color
Changes the background color which is only used if “None” is selected as the 

Background Input.
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 OUTPUT NODE

The Output node is the result of all enabled nodes and is what Silhouette 

actually renders.

Tip: You can quickly view the Output node’s Alpha channel from any other node by 
using the Alt+o shortcut key. Pressing Alt-o again views the previous node.

Alpha

Blur
Blurs the final Alpha channel.
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 RENDER

When you have you completed your work in Silhouette, you will want to render 

the final result. Rendering takes place in the Render Options window and is 

accessed by selecting Session > Render.

Go to Rendering to see how it works.

Additional rendering options are available in the Actions menu such as: Render 

Active Node, Render Layer's Shapes in Folders, Render Layers to Separate 

Files, Render Shapes to Channels, and Render Shapes to Separate Files. Go 

to Actions for more information.
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Render Options

Range
Range determines which frames will be rendered. The numeric entry fields to 

the right of the range pop-up display the frame range to be rendered, but can 

also be used to enter a specific frame range if Custom has been selected.

All
Renders the entire frame range.

Work Range
Renders the frame range in and out points in the Timebar.

Current Frame
Renders the current frame.

Custom
Renders a custom frame range as defined by the numeric entry fields. 

Format
The format setting allows you to select from various file formats. We currently 

can save to the following file formats: Cineon, DPX, IFF, JPG, OpenEXR, PNG, 

SGI/RGB, QuickTime, TIFF and TARGA.

Note: QuickTime is only available on operating systems that support it.

Options
Adjusts options for the selected file format.

Save
Save sets how the file will be rendered.

Color+Alpha
Renders a single RGB+Alpha file.

Premultiply
Premultiplies the RGB channels by the Alpha channel.
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External Alpha
Renders two separate files: an RGB file and an Alpha file. The Alpha file has 

alpha appended to the filename.

Color
Renders the foreground image into the RGB channels.

Alpha Only
Renders an Alpha only file.

Paint Only
Only the painted portions of the frame along with the Alpha channel (where the 

brush painted) are exported as a premultiplied RGBA file. This feature is handy 

for adding only the painted portions in your compositing application.

Note: If you paint into individual R, G or B channels, or paint Alpha only, this Paint Only 
feature will not work properly.

Resolution
Lowers the image resolution for faster rendering.

Full
Full keeps the image quality at full resolution.

Half
Half lowers the image resolution by 1/2.

Quarter
Quarter lowers the image resolution by 1/4.

Custom
Allows you to choose a custom resolution.

Field Handling
None
No field processing takes place.

Deinterlace
Deinterlaces the video frame into two separate fields.
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3:2 AA
Removes 3:2 Pulldown based on the AA frame being the first frame.

3:2 BB
Removes 3:2 Pulldown based on the BB frame being the first frame.

3:2 BC
Removes 3:2 Pulldown based on the BC frame being the first frame.

3:2 CD
Removes 3:2 Pulldown based on the CD frame being the first frame.

3:2 DD
Removes 3:2 Pulldown based on the DD frame being the first frame.

Field Dominance
Select either Even or Odd field dominance depending on whether you are 

working with NTSC or PAL images.

Even
Use for NTSC images.

Odd
Use for PAL images.

View
The View pop-up menu, which only shows up when using stereoscopic 

sources, allows you to control whether you render the Left, Right or both the 

Left and Right stereoscopic views simultaneously.

Both
Renders both the Left and Right stereoscopic views with a _L and _R 

appended to the filenames. 

Left
Renders only the Left stereoscopic view with a _L appended to the filename.
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Right
Renders only the Right stereoscopic view with a _R appended to the filename.

Combined
Renders both the Left and Right stereoscopic views into one file when using the 

EXR file format. 

Note: View > Both must be selected before the Combined button is active.

Go to the Render Preferences to see how to modify the default suffixes 
appended to the filename. 

Dominant View
The Dominant View, which is only available when rendering stereoscopic EXR 

files, determines the view that non-stereoscopic aware applications will display.

Left
Sets the Left stereoscopic view as the dominant view.

Right
Sets the Right stereoscopic view as the dominant view.

Slap Comp
Renders out the Alpha channel overlayed on the image as a color with opacity. 

This is useful for showing your handiwork to a supervisor for approval. When 

activated, color and opacity parameters appear.
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Output
The Output options control where the file is rendered and how it is named.

Directory
Selects the directory where the rendered files will be stored.

Filename
By default, the name of the session is used for the filename. Type in a new 

name if you don’t like the default.

Output Start Frame
The rendered frames will start with this number.

Padding
Sets how many numbers are in the filename. The default is 4.

Prefix
Adds a prefix symbol before the file numbers. Allowed values are . - _ and 

nothing with . being the default.

Template
Shows you where the file will be stored and how it will be named.

Filename Customization
You can add environment variables to the filename using the sfx $(VARNAME) 

format. Two internal variables are defined for rendering, VIEW and ALPHA. 

$(ALPHA) expands to _alpha, but only when it is needed for naming external 

alpha. $(VIEW) expands to L or R, when appropriate.

The default filename expansion, when $(VIEW) and $(ALPHA) are not typed 

manually (i.e. by default), is this:

$(FILENAME_TYPED_BY_USER)_$(VIEW)$(ALPHA)

If not doing multiple view stereo rendering, it is:

$(FILENAME_TYPED_BY_USER)$(ALPHA)

Remember that $(ALPHA) expands to nothing when not needed.
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Miscellaneous

Preview
Opens a Preview window that displays each rendered image as well as render 

statistics. With the Preview window open, press the R, G, B, and A buttons to 

toggle viewing of the respective channels or C to view the RGB channels.

Render
Renders using the current settings.

Cancel
Closes the Render Options window.

Apply
Saves the current settings and closes the Render Options window without 

rendering.
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Table 30: Render > Preview Shortcuts

Shortcut Action

R Displays the Red channel

G Displays the Green channel

B Displays the Blue channel

A Displays the Alpha channel

C Displays the RGB channels
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 COMMAND-LINE

Silhouette on the command-line allows you to execute projects with a variety of 

commands to control the rendering process. Further customization is 

accomplished via scripting as much of the Silhouette object model is exposed 

to the Python scripting language.

General Options
Command-line options are of the form: -option value, where value may be 

optional. Required arguments are in brackets (<>) and optional arguments are 

in braces ([]). If the value must be from a list of possible values, the available 

values are separated by |.

The basic form of the sfxcmd argument is: sfxcmd <projectname> [options]

where options are from the list below. By default, the project is rendered using 

the settings in the project unless changed by command-line options. Rendering 

can be disabled with the –render 0 option (see below). Certain options, such 

as format conversion, will implicitly disable rendering as well.

-options <options file>
Load the options file and treat each line of the file as a command-line option. 

For instance, instead of writing this:

sfxcmd project.sfx –log –info project

You can write this:

sfxcmd project.sfx –options options.txt

Where options.txt contains:

-log

-info project

-version
Print the sfxcmd version.
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-log
Enable log messages. For example, use -log to display module load messages 

and other non-critical informational messages.

-info[project|session|node|render]
Print information about the overall project, the active session, active node or 

active session rendering information. Enabling this option loads the info.py 

script in the Silhouette scripts directory, and calls the appropriate function to 

dump basic information. This file can be modified by the user to alter how the 

information is presented. If just –info is used, the default is to display project 

information. Multiple options can be supplied, separated by commas, to print 

multiple types of information. For instance, -info session,render will print 

session and rendering information. When –info is used, rendering is implicitly 

disabled, unless the –render 1 option is also used. 

The information displayed by -info can be customized by editing the info.py 

Python script located in Silhouette/resources/scripts.

-session <name>
Make the specified session active in the project. This is only useful if the project 

contains more than one session. To print a list of sessions in the project, use 

the –info option.

-node <name>
Target the specified node in the active session for output. By default, the Output 

node is used. The node name (ie. RotoNode, KeyerNode, etc) or the user-

defined node label (as displayed in the node list) can be used. To print a list of 

nodes in the active session, use the –info session option.

-script <scriptfile>
Run the specified Python script after the project is loaded. The script has 

access to the active project, session, and node, as specified by the –session 

and –node options. Scripts can walk the object model, manipulate the object 

state such as visibility, and print information, limited only by the Silhouette 

scripting API. 
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-action <actionName>
Run the specified Action after the project is loaded, where actionName is an 

action class name for one of the actions found in 

Silhouette/resources/scripts/actions. When –action is used, rendering is 

implicitly disabled, unless the –render 1 option is also used. Any rendering 

done by the action itself is not disabled.

-render <0|1>
Rendering can be disabled by using –render 0. Use this if you only want to print 

information about the project or run a script that does other things with the 

project. Rendering is enabled by default if a project is specified.

Note that when –info or -action are used, -render 0 is implicitly set unless the 

–render 1 option is also set.

Rendering options
-write <0|1>
Disable frame writing by using –write 0. This is useful for doing test runs to 

verify that options are set properly.

-dir <path>
Specifies the output directory where files should be written to.

-file <name>
Use –file to specify the root filename for output files.

-padding <number>
Sets the number of digits of padding for frame numbers. Use –padding 0 to 

disable padding.

-range <all|work|start#-end#x#>
Specifies the range of frames to render. A specific range is set by passing two 

numbers. A step factor can be introduced by using x# after the range. Some 

examples are:

• -range 1-10 renders frames 1, 2, 3, 4, 5, 6, 7, 8, 9, and 10.

• -range 1-10x2 renders frames 1, 3, 5, 7, and 9.
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• -range 3 renders frame 3.

Multiple -range arguments can be used to specify multiple ranges, for instance 

-range 1-50x1 -range 51-60x2 -range 60-100x3. You can also use commas to 

separate ranges in a single -range option.

Frames are in the range of the session, and do not necessarily start at 1. If your 

session starts at frame 4000, to render the first 50 frames of the session, use –

range 4000-4049.

-f
Same as -range.

-step <number>
Specifies the number to add to get to the next frame. The default is 1. Note that 

-step will override whatever step factor is used in -range or -f.

-start <number>
Use –start to override the starting frame number of the output frames. For 

example, if your session starts at 4000 and you want to render 50 frames, but 

you want the generated frame files to start at 1, use –range 4000-4049 –start 

1.

-depth <8|16|float>
Sets the render depth.

-save <rgba|rgb|alpha|paint>
Specifies the output type and the channels that are rendered. When using 

RGBA, the –extalpha option can be used to write alpha to a separate file. 

When using –save paint, a Paint Node is assumed to be present in the 

session, and will be automatically targeted.

-resolution <full|half|quarter|%>
Override the output resolution to full resolution, half resolution, quarter 

resolution, or a specific percentage of the original size (1-100%). 

Note: Half resolution is width/2*height/2, and quarter resolution is width/4*height/4.
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-extalpha <0|1>
Use –extalpha 1 to write the alpha channel to a separate, single-channel file, 

when supported by the file format. This is only useful when saving in RGBA 

mode.

-mb <0|1>
Controls the motion blur on/off state of the targeted node providing that the 

node supports motion blur. For instance, to force motion blur off in the Roto 

node, you would write this: -node Roto -mb 0

-format <name>
Specifies the output file format. For a list of supported formats, consult the 

format list in the Silhouette Render dialog.

-formatopts <options>
Specifies format specific options for the output file format. The options are a 

comma-separated list of name=value pairs. Consult the format options of the 

desired file format in the Silhouette Render dialog. To view the current set of 

format options, use the –info render option. For example, to set the SGI format 

compression option to on, use –formatops compression=1.

-fields <none|interlace|aa|bb|bc|cd|dd>
Sets the field handling to one of the supported options. The two letter options 

assume 3:2 handling.

-dominance <even|odd>
Sets the field dominance when field handling is enabled.

-view <left|right|both>
Sets the Stereoscopic view(s) to render.

-domview <left|right>
Sets the dominant Stereoscopic view when –view both is used.
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-combinestereo <0|1>(available with EXR format only)
Enables writing of both Stereoscopic views to the same file, with –view both 

when the output format is EXR. The dominant view will be the first one 

referenced in the file.

-slapcomp <r,g,b,a>
Perform a slap comp on the rendered image when the output type is RGBA or 

RGB. This will overlay the alpha channel over the RGB channels using the 

color specified as 4 floating point numbers from 0-1.

-nogui
For Linux systems without X-Windows installed, -nogui allows Silhouette to not 

use X-Windows. However, scripts that do drawing, for example Slate, will not 

work. 
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 APPENDIX A - PREFERENCES

Preferences allow you to customize default settings and can be accessed by 

selecting File > Preferences on Windows and Linux or Silhouette > Preferences 

on Macintosh.
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Autosave

Interval (minutes)
Sets the default time for autosaving the project. Set interval to 0 to disable 

autosave.

Maximum # of Backups
Controls how many backup files are created. Each time a project is saved, a 

copy is stored in $HOME/Silhouette3/backups.

Maximum # of Saves
Specifies how many autosave files will be stored at once. These files are stored 

in $HOME/Silhouette3/autosaves.
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Cache

% Total Physical RAM
Sets the amount of RAM to be used for playback. The default is 50% and the 

range is 10-90%.

Note: A program restart is needed to enable % Total Physical RAM changes.

Purge Cache on Project Load
When selected, the cache is purged when a Project is loaded.
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Color Management

Cineon/DPX Working Colorspace
Controls whether or not Cineon and DPX images are converted to scene linear.

Linear
Converts the Cineon/DPX images to scene linear.

Log
Cineon/DPX images are kept in log space.

Note: After changing this preference, you must restart Silhouette for changes to take 
effect as the value is cached.

Warning: It is not a good idea to change this preference in the middle of a paint 
Session, since when in Linear mode, it physically alters the pixels on import/export.

OCIO Configuration
This preference is a path to a global configuration file to use. The default is 

“$(OCIO)”. Silhouette will initially look for $SFX_OCIO and will use that first. 

Otherwise, it will use whatever the configuration preference is set to and finally 

it will check for $OCIO. If it still can't find a configuration, it will fall back to the 

embedded configuration in the resources/ocio folder.
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Composite

Background Color
When the View is set to Composite and no background input has been 

selected, the foreground based on it’s matte will be composited over this color 

at the percentage listed in the numeric entry box to the right.

Note: For changes to the Background Color to be seen, you will need to purge the 
cache and force an update by changing frames.
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Input/Output

Nuke 6.2+ Shapes
Connect Nodes When Embedding Layers Into Nodes
Connects layers together in Nuke using Merge nodes. However, if you set a 

layer in Silhouette to Subtract for example, you will have to manually adjust the 

corresponding Merge node in Nuke to Minus.

Note: Connecting of nodes with Merge nodes in Nuke is only supported in the layer 
based export modes: “Embed each layer in its own node” and “Embed each layer in its 
own node fully baked”.

Embed All Shapes In One Node
All selected shapes are exported into one Nuke Roto node.

Embed Each Shape In Its Own Node
Selected shapes are exported into separate, unconnected Nuke Roto nodes.

Embed Each Layer In Its Own Node
Shapes are exported into their respective layers as separate, unconnected 

Nuke Roto nodes. Shapes not located in a layer will be combined into a Nuke 

node called Roto. If a layer has blur or invert settings applied to it, blur and 

invert nodes will be created in Nuke and connected to the layer’s node.

Silhouette may break shapes in a single layer into more than one Nuke Roto 

node if these shapes are interrupted by a Silhouette sub-layer. This is 

intentional so that the correct depth order can be maintained. For example, if 

the Silhouette Roto node contained Shape 1, Shape 2, Layer 1, Shape 3: The 

“Embed each layer in its own node” mode will break Shape 3 into its own Nuke 

Roto node so that the user has the option of ordering the contents of Layer 1 in 

between Shape 1, Shape 2 and Shape 3.

Embed Each Layer In Its Own Node Fully Baked
Shape control points are fully baked on every frame of the work range. While 

this creates larger files, it works around a known Nuke motion blur problem.
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Nudging

Distance (pixels)
Sets how many pixels an object moves when the Arrow keys are used.

Extended (shift) Distance (pixels)
Sets how many pixels an object moves when the Arrow keys are used in 

conjunction with the Shift key.

Precise (control) Distance (pixels)
Sets how many fractional pixels an object moves when the Arrow keys are 

used in conjunction with the Ctrl key.
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Paint

Brush Outline Color
Sets the color of the brush outline.

Cursor
Controls the display of the cursor crosshair while painting.

Off
The cursor crosshair is not displayed.

On
The cursor crosshair is always displayed.

On/Off
The cursor crosshair disappears while painting a stroke, but is visible 

otherwise.

Default Directory
Determines how painted frames should be stored/accessed.

The first time the paint tool is activated, per session, the Default Directory 

preference is used to generate a default path. This path is shown and can be 

changed to some other path if desired. Once the path is set, Paint can be used 

and that path is then stored with the project from then on.

The default directory value is:

$(PROJECT_DIR)/painted/$(PROJECT_NAME)/$(SESSION_NAME).

Variables

PROJECT_DIR
The directory the current project is stored in.

Painted
This is the folder name for painted frames. It can be named to anything you like.

PROJECT_NAME
The name of the current project (without the extension).
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SESSION_NAME
The name of the current session.

Pressure Threshold
Controls how hard the pen has to be pressed before opacity kicks in. The 

preference is from 0-1. When the threshold has been reached, the calculated 

pressure is scaled into the new range from threshold to 1.

Use Tablet Pressure
Turn tablet pressure sensitivity on or off.

Clone
Absolute Frame Numbers
When activated (the default), displays the actual frame number in the Clone > 

Frame field. When turned off, it uses the old Silhouette v2.3 behavior where an 

offset in relation to the current frame was shown instead of the actual frame.

Alignment Type

Black
When in Align mode, the Viewer appears black when the Clone source and 

destination are perfectly aligned.

Gray
When in Align mode, the Viewer appears gray when the Clone source and 

destination are perfectly aligned.

Incremental Clone Offset
Controls whether the Clone offset starts at last offset or at click location.

Show Offset
Forces the Clone Offset connecting line to always be displayed.

Source Outline Color
Sets the color of the Clone brush outline.

Source Outline Color (Secondary)
Sets the color of the secondary Clone brush outline. This is the color of the 

second Clone source that is activated by Shift-clicking a second Clone preset.
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Render

Default Format
Sets the default file format for rendering.

Default Channels
Sets the default channels to be rendered.

Filename
Sets the default suffixes that are appended to the Filename in the Render 

Options menu.

Alpha Suffix
 Sets the default Alpha suffix to _alpha.

Format
You can now override the output filename structure. The format for the output 

name is now defined by the Format preference.

The default is: $(NAME)$(ALPHA)$(VIEW)$(PREFIX)$(FRAME).$(EXT) 

which matches the previous format.

• NAME substitutes the Filename field in Render Options

• ALPHA substitutes the Alpha suffix (_A) when saving external alpha

• VIEW substitutes the left/right suffix (_L/_R) when saving a left/right view

• PREFIX substitutes the Prefix field in Render Options

• FRAME substitutes the frame number with padding

• EXT substitutes the output module default extension

Note: This Format preference is currently system wide and cannot be used on a per 
session basis.

Left View Suffix
Sets the default Left View suffix to _L.

Right View Suffix
Sets the default Right View suffix to _R.
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Shape

Active Point Color
Sets the default color of the active point (the point that the cursor is hovering 

over) through the use of a standard color picker.

Auto Switch to Reshape Tool
After closing a new shape, you will switch to the Reshape tool automatically.

Bounding Box Color
Sets the default color of shape bounding boxes through the use of a standard 

color picker.

Control Handle Size
Sets the size of control point handles.

Control Point Color
Sets the default color of control points through the use of a standard color 

picker.

Default Interpolation
Sets the default keyframe interpolation type.

Hold
There is no interpolation and abrupt switches in value occur at keyframes.

Linear
When values change, a straight line with sharp, abrupt angles from one 

keyframe to the next is drawn.

Ease In
Eases in to the selected keyframe.

Ease Out
Eases out of the selected keyframe.

Ease In/Out
Eases in and out of a selected keyframe.
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Default Outline Color
Sets the default color of the shape outline through the use of a standard color 

picker.

Fade Outline with Opacity
Draws unselected/inactive shape outlines using the shape opacity value. The 

V key toggles this preference so that you can easily see any shapes that are at 

0% opacity.

Hide Hulls During Edit
When activated, tangents/hulls hide when editing.

Hull Color
Sets the default color of the hull (lines that connect tangents) through the use 

of a standard color picker.

Number Points
None
Control points are not numbered.

Tagged
Only numbers points that have been tagged using the Reshape tool > control 

point pop-up menu.

All
All control points are numbered.

Primitive Type
Sets what shape type is used when circles and squares are created.

Bézier
Bézier shapes are used for circle and square creation.

B-Spline
B-Splines are used for circle and square creation.

X-Spline
X-Splines are used for circle and square creation.
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Recursive Subdivide
Drastically improves the curvature of shapes and reduces artifacts when using 

feathering. You can return to the previous behavior of v4.0.4 and below which 

used a fixed-step iterator by turning this preference off, if for some reason it 

causes shape artifacts.

Selected Point Color
Sets the default color of selected points through the use of a standard color 

picker.

Show Shape Name 
Displays the shape name in the center of the shape.

Show Tangent Vectors
Turns Bézier tangents on or off. Turns B-Spline and X-Spline hull drawing on or 

off.

Template Color
Sets the color and opacity of unselected shapes. This Viewer Template feature 

is enabled by using Shift-W.

Transform from Center of Selection Bounding Box
Controls whether the automatic anchor point is set to the center of the collective 

bounding box or to the opposite handle.

X-Spline Point Type
Controls the default weighting of X-Spline points when they are created.

B-Spline
X-Spline points have B-Spline weighting.

Cardinal
X-Spline points have Cardinal weighting.

Corner
X-Spline points have Corner weighting.
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X-Spline Tension Factor
This is a weight from -10 to 10 that is multiplied by the mouse delta when 

manipulating the X-Spline point tension. You can reverse the sense of the 

weight by making this value negative. Also, you can boost the amount the 

tension is adjusted based on mouse movement by making the value larger, for 

example closer to -10 or 10.
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Tracker

Default Path Color
Sets the default color of the tracker path.

Default Point Track Tolerance
Sets the default tracker tolerance. Describes the level of accuracy between the 

Match Area that the Tracker is searching for and the area it actually finds when 

searching from frame to frame.

Point Tracking Behavior
Sets the default tracker behavior. Behavior decides what frame should be used 

as the reference to check the accuracy of the Match Area. 

Show Path Points
Displays tracker points along the path of the track.
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Undo

Max Paint Undo Events
Sets the maximum number of paint undos.

Max Undo Events
Sets the maximum number of undos.
lhouette 4.5 User Guide



• 

Appendix A - Preferences  367 

• 
• 
• 
•
•
•

User Interface

Show Sources Last in Node List
When enabled (the default), Source nodes are displayed last in the Node List.

Show Object Properties on Selection
When you select an item in the Object List, the controls for that item are 

automatically shown in the Object window. If you select an item in the Node 

List, the controls for that item are automatically shown in the Node window. This 

behavior can be disabled with this preference.
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Viewer

Alpha Overlay Color
Sets the color of the Alpha overlay.

Anchor Color
Sets the color of the Transform tool anchor point.

Background Color
Sets the border color in the Viewer.

Handle Mode
Controls how handles are drawn.

Blend
Uses a normal blend mode to display layer and shape handles.

XOR
Uses an XOR blend mode to display layer and shape handles.

Layer Transform Color
Sets the color of the layer’s on-screen controls.

Mask Fill Color
Color
Sets the color of the mask.

Opacity
Set the opacity of the Mask Fill Color by clicking on the percentage field (to the 

right of the color picker) and typing in a new number.

Mask Outline Color
Color
Sets the color of the mask outline.

Opacity
Set the opacity of the Mask Outline Color by clicking on the percentage field (to 

the right of the color picker) and typing in a new number.
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Picking Tolerance
Sets the radius of the threshold for picking points.

Stereo Alignment Type
Selects either Gray or Black for the Stereo Alignment.

Stereo First Field
When the Stereo View mode preference is set to Interlaced, Stereo First Field 

determines which eye comes first while interlacing--Left or Right. This needs to 

match up with how the monitor does the 3D effect.

Left Eye
Interlaces starting with the Left Eye.

Right Eye
Interlaces starting with the Right Eye.

Stereo View Mode
Selects the display mode to use in the Stereo Viewer.

Anaglyph
Selects Anaglyph viewing mode in the Stereo Viewer.

Interlaced
Selects Interlaced viewing mode in the Stereo Viewer. Interlaced mode 

requires a 3D monitor that uses interlacing like the Zalman passive display.

Template Mode
Turns template mode on or off. See Template Color for more information.

Zoom Factor Preference
Added a Viewer > Zoom Factor preference which controls the I/O zoom factor 

keyboard shortcuts. Default is 2. Range is 1.05 > 2.0.

Zoom Filter
Linear
Interpolates pixels when zoomed into the image. This results in a smoother, but 

softer image.
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Nearest
Replicates pixels when zoomed into the image. This results in a sharper, but 

chunkier image.
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 APPENDIX B - KEYBOARD SHORTCUTS

Bézier Splines

Shortcut Action Curve

No key needed Adjust the length of one tangent while 
retaining a fixed angle between two 
tangents

Ctrl(Win)/Cmd(Mac) Adjust both tangents simultaneously while 
retaining a fixed angle between two 
tangents

Alt Adjusts only one tangent to create corners

Shift Adjusts only the length of one tangent 
(similar to the “No key needed” shortcut)

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-2 Sets the point tension to Cardinal
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Bézier Control Point Pop-up Menu

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Linear Both tangents are adjusted to one quarter the distance and in the 
direction of their adjoining control points

Corner Creates a corner point

Cardinal Creates a smooth point where the curve passes smoothly through it

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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B-Spline Shapes

Shortcut Action

Alt-drag control point right Creates a corner point

Alt-drag control point left Creates a smooth point

Alt-clicking control point Cycles through the preset weight settings of the point

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-3 Sets the point tension to B-Spline
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B-Spline Control Point Pop-up Menu

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Corner Creates a corner point

B-Spline Creates a smooth point that is determined by the surrounding points

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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Cut / Copy / Paste

Shortcut Action

Ctrl(Win)/Cmd(Mac)-X Cuts an object

Ctrl(Win)/Cmd(Mac)-C Copies an object

Ctrl(Win)/Cmd(Mac)-V Pastes an object
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Feather Tool

Shortcut Action

Alt-drag on shape Adds and pulls out a feather point

Click-drag a feather point Changes the length and position of the feather point

Shift-drag a feather point Constrains the length of the point

Hover over feather point and hit the 
Delete key

Deletes the feather point
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Layer Nudging

Shortcut Action

Arrow keys Moves the layer by 1 pixel

Shift-Arrow keys Moves the layer by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the layer by one tenth of a pixel

Hold down Arrow keys Moves the layer continuously

Q, W, E then Ctrl(Win)/Cmd(Mac)-drag Translates, Rotates or Scales in finer increments

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Q, W, E then Shift-Arrow keys Translates, Rotates or Scales by 10 pixels

Q, W, E then Ctrl(Win)/Cmd(Mac)-Arrow keys Translates, Rotates or Scales by 1/10 of a pixel
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Layer Transform On-Screen Controls

Shortcut Action

Drag within large center circle Moves the layer

Shift-drag within large center circle Constrain layer movement horizontally or vertically

Drag the horizontal and vertical lines Scales the layer horizontally or vertically

Drag the upper diagonal line Proportionally scale the layer

Drag the lower diagonal line Rotate the layer

Ctrl(Win)/Cmd(Mac)-drag the lower 
diagonal line

Rotates the layer with finer control

Drag small center circle Moves the Anchor point

Q Activates / Deactivates translation of selected layers

W Activates / Deactivates rotation of selected layers

E Activates / Deactivates scaling of selected layers
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Object List

Shortcut Action

Click on an object Selects the object

Shift-click an object Adds an object to the current selection

Ctrl(Win)/Cmd(Mac)-click on an object Toggles the object selection

Shift-click color pot Selects shapes of same color

Alt-click the Visibility icon Solos an object

Alt-Ctrl-click the Visibility icon Forces the visibility of all objects to the on position

Shift-click the +/- icon Expands or collapses all nested layers inside that layer

Double-click an object Selects the object so it can be renamed
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Paint

Shortcut Action

B Selects the Black and White brush

Shift-B Selects the Blemish brush

Ctrl-B Selects the Blur brush

C Selects the Clone brush

Shift-C Selects the Color brush

Alt-C Selects the Color Correct brush

D Selects the Drag brush

Shift-E Selects the Eraser brush

G Selects the Grain brush

M Selects the Mosaic brush

R Selects the Repair brush

S Selects the Scatter brush

Ctrl(Win)/Cmd(Mac)-drag brush outline Sizes the brush

Ctrl(Win)/Cmd(Mac)-Shift-drag brush outline Sets the brush softness

Shift-click-drag with Clone brush Sets the Clone offset

Shift-click-click with Clone brush Sets the Clone offset

Shift-click or tap Resets the Clone offset

‘ (located to the left of 1 key) Displays the Clone source and then the Clone 
destination so that you can click on each to set the 
Clone offset

Caps Lock Toggles Onion Skin mode on and off

. (period key) Picks colors off of the screen

Right-click Picks a color off of the screen from a single pixel

Right-click-drag Picks a color off of the screen by drawing a box and 
averaging the colors within it

Alt-1 through Alt-5 Selects one of the Clone brush setups
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Paint Clone Source Nudging

Shortcut Action

Arrow keys Moves the Clone source by 1 pixel

Shift-Arrow keys Moves the Clone source by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the Clone source by one tenth of a pixel

Hold down Arrow keys Moves the Clone source continuously

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Q, W, E then Shift-Arrow keys Translates, Rotates or Scales by 10 pixels

Q, W, E then Ctrl(Win)/Cmd(Mac)-Arrow keys Translates, Rotates or Scales by 1/10 of a pixel

Q, W, E then Arrow keys Translates, Rotates or Scales by 1 pixel

Ctrl(Win)/Cmd(Mac)-1 then Arrow Keys Nudges the top left corner point

Ctrl(Win)/Cmd(Mac)-2 then Arrow Keys Nudges the top right corner point

Ctrl(Win)/Cmd(Mac)-3 then Arrow Keys Nudges the bottom right corner point

Ctrl(Win)/Cmd(Mac)-4 then Arrow Keys Nudges the bottom left corner point
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Paint Clone Source On-Screen Controls

Shortcut Action

Drag within large center circle Moves the Clone source

Shift-drag within large center circle Constrain Clone source movement 
horizontally or vertically

Drag the center square horizontal and vertical 
halfway points

Scales the Clone source horizontally or 
vertically

Drag a center square corner Proportionally scale the Clone source

Drag large center circle Rotate the Clone source

Ctrl-drag large center circle Rotates the Clone source with finer control

Drag handles on corners of image Corner-pins the Clone source

Q Activates / Deactivates translation of the 
Clone source

W Activates / Deactivates rotation of the Clone 
source

E Activates / Deactivates scaling of the Clone 
source

Q, W, E then Ctrl(Win)/Cmd(Mac) Translates, Rotates or Scales in finer 
increments
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Render > Preview

Shortcut Action

R Displays the Red channel

G Displays the Green channel

B Displays the Blue channel

A Displays the Alpha channel

C Displays the RGB channels
Silhouette 4.5 User Guide    
• 
• 
•
•
•



   Si

384 Appendix B - Keyboard Shortcuts

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Shape & Point Nudging

Shortcut Action

Arrow keys Moves shapes or points by 1 pixel

Shift-Arrow keys Moves shapes or points by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves shapes or points by one tenth of a pixel

Hold down Arrow keys Moves shapes or points continuously
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Selecting / Deselecting Control Points

Shortcut Action

Click on a control point. If the control point is part of a Bézier curve, 
its tangents appear

Selects the control point

Shift-click the control points or drag select multiple control points Selects multiple control points

Ctrl(Win)/Cmd(Mac)-Alt-I Inverts the point selection

Alt-Shift-A Selects all control points

Alt-Ctrl-A Deselects all control points

Ctrl(Win)/Cmd(Mac)-click on a control point Toggles the point selection

Click anywhere off the shape Deselects all control points
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Selecting / Deselecting Shapes

Shortcut Action

Click on a shape Selects the shape

Shift-click a shape or drag select multiple shapes Selects multiple shapes

Ctrl(Win)/Cmd(Mac)-click on a shape Toggles the shape selection

Click anywhere off the shape Deselects all shapes

Shift-click color pot in the Object List Selects shapes of same color
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Stereoscopic Align Keyboard Shortcuts

Shortcut Action

Click and drag in Viewer Moves the Stereo Offset horizontally

Shift-click and drag in Viewer Moves the Stereo Offset horizontally and vertically

Ctrl-drag in Viewer Moves the Stereo Offset in finer increments

Alt-click in Viewer Resets the Stereo Offset

Arrow keys Moves the Stereo Offset by 1 pixel

Shift-Arrow keys Moves the Stereo Offset by 10 pixels

Ctrl(Win)/Cmd(Mac)-Arrow keys Moves the Stereo Offset by one tenth of a pixel

Hold down Arrow keys Moves the Stereo Offset continuously
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Stereoscopic View Shortcuts

Shortcut Action

Shift-1 Selects the Left View

Shift-2 Selects the Right View

Shift-3 Selects the Left/Right View

Shift-4 Selects Stereoscopic Align

Shift-5 Anaglyph Preview

Shift-6 Stereo Viewer
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Timeline

Shortcut Action

Scroll wheel Zooms the Timeline in and out

Shift-Middle-mouse drag Zooms the Timeline in and out

Space Bar-drag Pans the Timeline

Middle-mouse drag Pans the Timeline

Single-click keyframe Selects one keyframe

Ctrl(Win)/Cmd(Mac)-click 
keyframe

Toggle the keyframe selection

Shift-click keyframes Selects a range of keyframes

Alt-click Inserts a keyframe 
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Toolbar

Shortcut Action

T Selects the Transform tool Shape Mode

TT Selects the Transform tool Points Mode

R Selects the Reshape tool

B Selects the B-Spline tool

S Selects the X-Spline tool

Shift-B Selects the Bézier tool

Shift-S Selects the Square tool

Shift-C Selects the Circle tool

Shift-F Selects the Feather tool

Shift-T Selects the Tracker tool

M Selects the MultiFrame tool
lhouette 4.5 User Guide



• 

Appendix B - Keyboard Shortcuts  391 

• 
• 
• 
•
•
•

Tracker

Shortcut Action

Alt-click Alt-click on an open space in the Viewer
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Transform Tool

Shortcut Action

Drag shape Moves the shape

Shift-drag shape Constrain shape movement horizontally or 
vertically

Drag bounding box corner or edge handle Scales a shape

Shift-drag bounding box corner or edge handle Proportionally scale a shape

Ctrl(Win)/Cmd(Mac)-drag on a bounding box 
corner handle

Rotate a shape

Alt-drag on a bounding box corner handle Corner-pin a shape

Alt-Shift-drag on a bounding box corner handle Constrains the corner-pin movement to one axis

Ctrl(Win)/Cmd(Mac)-drag on a bounding box 
edge handle

Shear a shape

. (period key) Turns the Anchor Point on or off

Drag on Anchor Point Moves the Anchor Point

Shift-. (period key) Moves the Anchor Point to the mouse location

Q Activates / Deactivates translation of selected 
shapes or layers

W Activates / Deactivates rotation of selected 
shapes or layers

E Activates / Deactivates scaling of selected 
shapes or layers

Q, W, E then Ctrl(Win)/Cmd(Mac) Translates, Rotates or Scales in finer increments
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Viewer

Shortcut Action

F1 Only the Viewer is shown in the interface

F2 Only the Viewer and Timeline are shown in the interface

0 Toggles the display of overlays which are lines, shapes or objects

Number Keys (1-6) Switches the Viewer > View menu

~ Cycles through the update modes

A Cycles the display between the full color image, the Alpha channel 
superimposed over the image and the Alpha channel by itself

Shift-A Toggles the View to Output, superimposes the Alpha channel over 
the image and deactivates the Overlay

Alt-R/G/B/A Toggles the Red, Green, Blue and Alpha channels on and off

Alt-o Toggles the display to/from the Output node’s Alpha channel from 
any other node. Pressing Alt-o again views the previous node.

Ctrl(Win)/Cmd(Mac)-click 
RGB buttons

Toggles the display of each component on or off

Middle-mouse drag Pans the image

Space Bar-drag Pans the image

I Zooms the image in

O Zooms the image out

Shift-Middle-mouse drag Zooms the image in and out

Scroll wheel Zooms the image in and out

Space Bar-Shift-drag Zooms the image in and out

F Fits the image in the Viewer

H or Middle-mouse double 
click

Centers the image in the Viewer at 100%

Ctrl(Win)/Cmd(Mac)-F Centers selection in the Viewer

‘ Opens a context menu over pen/mouse location
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VTR Controls

Shortcut Action

Z Step backward 1 frame

Shift-Z Moves to the previous keyframe

X Step forward 1 frame

Shift-X Moves to the next keyframe

J Plays the sequence backwards

K Stops or starts playback

L Plays the sequence forwards

Space Bar Stops playback

Home Moves to the first frame of the sequence

End Moves to the last frame of the sequence

Click and drag in the shuttle area Shuttles through the clip

Shift-Alt-click and drag a keyframe marker Moves the keyframe in time
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X-Spline Shapes

Shortcut Action

Alt-drag control point right Adjusts the weight of the point from Cardinal to Corner to B-Spline

Alt-drag control point left When the weight is set to B-Spline, it adjusts the weight of the point 
from B-Spline to Corner to Cardinal

Alt-clicking control point Cycles through preset weight settings of the point

Ctrl(Win)/Cmd(Mac)-Alt-1 Sets the point tension to Corner

Ctrl(Win)/Cmd(Mac)-Alt-2 Sets the point tension to Cardinal

Ctrl(Win)/Cmd(Mac)-Alt-3 Sets the point tension to B-Spline
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X-Spline Control Point Pop-up Menu

Menu Option Description

Invert Selection Inverts control point selection state

Delete Deletes the selected control point

Break Breaks the shape at the selected control point

Close Closes an open shape

Corner Creates a corner point

Cardinal Creates a smooth point where the curve passes smoothly through it

B-Spline Creates a smooth point that is determined by the surrounding points

Center Centers the control point between its adjoining control points

Tag Tags control points for point numbering

Untag Untags control points when using point numbering

Tween Takes the point and “re-tweens” it using the surrounding keyframes, 
and puts them where they would be if you hadn't moved them on that 
frame. Useful for simulating an “unkey” of selected points (the shape 
remains keyed of course)
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 APPENDIX C - SESSION FORMATS

A number of preset formats can be selected from the Session Format pop-up 

menu. When one of the options is selected, the session fields are preset with 

the appropriate data.

Film Full Aperture (4K: 4096x3112)
Uses the following presets.

Width: 4096

Height: 3112

Pixel Aspect Ratio: 1

Frame Rate: 24

Film Full Aperture (4K: 4096x3072)
Uses the following presets.

Width: 4096

Height: 3072

Pixel Aspect Ratio: 1

Frame Rate: 24

Film Full Aperture (2k: 2048x1556)
Uses the following presets.

Width: 2048

Height: 1556

Pixel Aspect Ratio: 1

Frame Rate: 24

Film Full Aperture (2k: 2048x1536)
Uses the following presets.

Width: 2048

Height: 1536

Pixel Aspect Ratio: 1

Frame Rate: 24
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Film Cinemascope Full (3656x2664)
Uses the following presets.

Width: 3656

Height: 2664

Pixel Aspect Ratio: 2

Frame Rate: 24

Film Cinemascope Half (1828x1556)
Uses the following presets.

Width: 1828

Height: 1556

Pixel Aspect Ratio: 2

Frame Rate: 24

Film Academy (1828x1332)
Uses the following presets.

Width: 1828

Height: 1332

Pixel Aspect Ratio: 1

Frame Rate: 24

HDTV 24p (1920x1080)
Uses the following presets.

Width: 1920

Height: 1080

Pixel Aspect Ratio: 1

Frame Rate: 24
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HDTV 1080i, 1920x1080
Uses the following presets.

Width: 1920

Height: 1080

Pixel Aspect Ratio: 1

Frame Rate: 30

HDTV 720p, 1280x720
Uses the following presets.

Width: 1280

Height: 720

Pixel Aspect Ratio: 1

Frame Rate: 60

NTSC, 640x480
Uses the following presets.

Width: 640

Height: 480

Pixel Aspect Ratio: 1

Frame Rate: 29.97

NTSC, 648x486
Uses the following presets.

Width: 648

Height: 486

Pixel Aspect Ratio: 1

Frame Rate: 29.97
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NTSC DV, 720x480
Uses the following presets.

Width: 720

Height: 480

Pixel Aspect Ratio: .9

Frame Rate: 29.97

NTSC DV Widescreen (720x480)
Uses the following presets.

Width: 720

Height: 480

Pixel Aspect Ratio: 1.2

Frame Rate: 29.97

NTSC D1 (720x486)
Uses the following presets.

Width: 720

Height: 486

Pixel Aspect Ratio: .9

Frame Rate: 29.97

NTSC D1 Square Pixels (720x540)
Uses the following presets.

Width: 720

Height: 540

Pixel Aspect Ratio: 1

Frame Rate: 29.97
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PAL D1/DV (720x576)
Uses the following presets.

Width: 720

Height: 576

Pixel Aspect Ratio: 1.07

Frame Rate: 25

PAL D1/DV Square Pixels (768x576)
Uses the following presets.

Width: 768

Height: 576

Pixel Aspect Ratio: 1

Frame Rate: 25

PAL D1/DV Widescreen (720x576)
Uses the following presets.

Width: 720

Height: 576

Pixel Aspect Ratio: 1.42

Frame Rate: 25
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 APPENDIX D - ENVIRONMENT VARIABLES

Environment Variables
The following environment variables can be set from a shell before launching, 

and Silhouette will use those paths in respective dialog boxes instead of “the 

last used” paths.

If you have custom modules, you can set SFX_MODULE_PATH to add other 

search paths to look in for other modules.

MULTIVIEW_EXR_EXT
By default, stereoscopic (multi-view) EXR files are saved with a .sxr extension 

instead of the normal .exr extension. However, the value of the 

MULTIVIEW_EXR_EXT environment variable will be used instead if it is set.

SFX_CINEON_WORKING_SPACE
Set to either log or linear. This environment variable overrides the Color 

Management > Cineon/DPX Working Colorspace preference.

SFX_DPX_INTERPRETATION
Sets the default DPX interpretation for loading and saving to either log or linear. 

This value only gets queried when media is first imported.

SFX_DPX_LOAD_INTERPRETATION
Sets the default DPX interpretation for loading to either auto, log, or linear.

SFX_DPX_SAVE_INTERPRETATION
Sets the default DPX interpretation for saving to either log or linear.

SFX_EXPORT_PATH
Defaults to this path in the Export dialog box when set. Overrides the 

SFX_IMPORT_EXPORT_PATH.

SFX_EXR_COMMENTS
By default, the Project path, Paint path and Session name are stored in the 

comments attribute of the EXR file header.
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If the SFX_EXR_COMMENTS environment variable is set, it is appended on to 

the end of the comments string. The format of this variable should be 

name=value;name=value; etc. No $VARIABLE expansion is performed.

SFX_EXR_COMPRESSION
Set to RLE for faster saving.

SFX_IMPORT_EXPORT_PATH
Default to this path in the Import/Export dialog boxes when set.

SFX_IMPORT_PATH
Defaults to this path in the Import dialog box when set. Overrides the 

SFX_IMPORT_EXPORT_PATH.

SFX_MODULE_PATH
Semi-colon separated list of paths to search for Silhouette modules. User-

specified paths are checked before the built-in modules path. Useful for end-

users to provide custom I/O modules in a network-central location.

SFX_LICENSE_SERVER
Set to enable floating licensing. Set to port@host of the license server.

SFX_OCIO_COLORSPACE
Sets the default Viewer > Display > Colorspace.

SFX_OCIO_DISPLAY
Sets the default Viewer > Display > Display.

SFX_OCIO_LUT
SFX_OCIO_LUT can be used to set the default LUT. This will get set on the 

session when a new session is first created. The value for this variable is the 

full path to the LUT, including extension. The name is case sensitive.

SFX_OCIO_VIEW
Sets the default Viewer > Display > View Xform.

SFX_OUTPUT_PATH
Default to this path in the Render dialog when set.
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SFX_PAINT_TEMP
Define a writeable temp directory (preferably on a local disk) for storing paint 

undo data. This data is deleted when Silhouette exits.

SFX_PROJECT_PATH
Default to this path in the Project Open/Save dialog box when set.

SFX_RESOURCE_PATH
Sets path to Silhouette run-time resources. On Mac, this defaults to 

Silhouette.app/Contents/Resources on Mac, while on Windows and Linux it 

defaults to <path_to_silhouette>/resources.

SFX_TMP_PATH
SFX_TMP_PATH controls where user-specific autosaves, backups, and the 

lock file are stored. SFX_TMP_PATH defaults to SFX_USER_PATH. 

SFX_TMP_PATH should point to a user-writable directory.

SFX_VALID_XML
Silhouette shape files are not valid XML. Now, shape files can be written as 

valid XML by setting the SFX_VALID_XML environment variable to anything 

(except 0, which will disable the option). When enabled, shape files will not 

import into older versions of Silhouette.

SFX_USER_PATH
Sets the path to the user's copy of Silhouette's files. Defaults to ~/Silhouette4
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