
Silhouette 5 What’s New



   Si

2 About this Guide

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

 ABOUT THIS GUIDE

Copyright
No part of this document may be reproduced or transmitted in any form or by 

any means, electronic or mechanical, including photocopying and recording, 

for any purpose without the express written consent of SilhouetteFX, LLC.

Copyright © SilhouetteFX, LLC 2014. All Rights Reserved

August 15, 2014

About Us
SilhouetteFX brings together the unbeatable combination of superior software 

designers and visual effects veterans. Add an Academy Award for Scientific 

and Technical Achievement, 3 Emmy Awards and experience in creating visual 

effects for hundreds of feature films, commercials and television shows and you 

have a recipe for success.
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 WHAT’S NEW IN 5.2.15

Bug Fixes

Right Eye Keyframe Display
Right eye paint keyframes did not show up as blue in the player.

Tablet and Quick Modes
Tablet support for Clone quick modes was not working.
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 WHAT’S NEW IN 5.2.13

Bug Fixes

Clone Source > Interactive Mode
Interactive Clone source mode with tablet was not working. 
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 WHAT’S NEW IN 5.2

Features

Crop Node
The Crop node crops the image and session to a user defined size. This is 

especially useful when you only need to work within a smaller region of a larger 

image as it will use less memory and process faster.

Edit > Duplicate Action
Duplicates a selected object at the same level in the Object List as opposed to 

Copy/Paste which places the pasted object at the top of the Object List.

EXR 2.0 Multi-part Support
Silhouette now supports EXR 2.0 Multi-part files. When a multi-part file is 

loaded, all of the parts are loaded into the Project window.

Input/Output > EXR > Use Data Window as Display Window
The Input/Output > EXR > Use Data Window as Display Window preference 

overrides the default behavior of Silhouette automatically loading an EXR file’s 

Display Window. Reloading the project or media is required for this preference 

to be enabled.

Frame Step and Point Trackers
The point trackers now obey the Viewer > Frame Step.

Nuke Export - Inner Blur Support
Inner Blur is now supported for shapes exported to Nuke.

Paint
Duplicate Strokes From One View To Another
Duplicates strokes from one view to another. If a layer with a stereo offset is 

selected prior to duplicating, the stereo offset is taken into account when 

duplicating the strokes.
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Playback Selected Events Forward or Backward
Playback of paint strokes can now be performed forward or backward 

depending on whether you select the Play Selected Events Backward or Play 

Selected Events Forward (arrowhead) icons.

Rebuild In Paint Stroke Order
Rebuild now always rebuilds in paint stroke order, not in time order.

Render > Slap Comp > Invert
There is now an option to invert the Slap Comp in the Render Options.

Scripting
For more information on the scripting features, see the Silhouette scripting 

guide at: http://support.silhouettefx.com/mw/index.php?title=Scripting_Guide

Ability to Find a Node's Source
Added node.getInput(index=0) and node.getOutput(index=0) to allow you to 

track the primary source up the chain from a target node.

Extensions
Added an “import extensions” to the startup.py script and added a 

scripts/extensions directory to use for non-action extensions, such as the 

included rv flipbook extension.

getInput() Scripting Helper
A number of users have asked for a simple input box so the user can type 

something in as a parameter to a script.

Global Dictionary
Added fx.globals as a root-level dictionary to support a global place for scripts 

and UI elements to access shared values. This was added to facilitate startup 

scripts setting information that might be used by the UI, such as the name of an 

integrated flipbook.

Hook Improvements
Multiple hook functions can be registered and executed per hook.
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Hooks - New
Added the following scripting hooks: “frameChanged” and “selectionChanged”.

Keyframe Utilities
Previously, there wasn't an easy way to determine if a time was a key or to find 

surrounding keys. There are now new Key methods added to Property.

Pan and Zoom Keyboard Shortcuts
The Pan and Zoom keyboard shortcuts can now be reassigned.

Support Multiple Paths in SFX_SCRIPT_PATH
SFX_SCRIPT_PATH can now have a list of colon-separated paths 

(Mac+Linux) or semi-colon-separated (Windows). 

Shape > Blur Type Preference
A Shape > Blur Type preference was added to set the default blur type: Center, 

Inner, Outer.

Tweak Software > RV Integration
When a path is entered in the RV > Command preference, a “Send to RV” 

option appears at the bottom right of the Render window. If that is enabled, after 

rendering, the rendered clip will be sent to the RV playback software--if 

installed.

Changes

Replaced Edit > Spline > Convert to Bézier
Replaced Edit > Spline > Convert to Bézier with new Edit > Convert to Bézier 

Action.

Scripting > New API for File I/O
The API for file I/O has been revised. If you have built a custom C++I/O module, 

you will need to rebuild it with the 5.2 SDK.
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Bug Fixes

Blur of 16 bit Float Images Clipping Highlights
The blur was clipping highlights when using 16 bit float images.

Cache Generation - Windows
The cache generation was not working properly on Windows.

Cineon and DPX Alpha Rendering Bug
When rendering Cineon and DPX alpha channels, the alpha was not getting 

written out and the RGB, when enabled with alpha, was corrupted.

Clone > Filter > Blur & Sharpen in Float 16 Sessions
Clone > Blur & Sharpen were not working in Float 16 sessions.

First Frame of Paint Disappearing
The first frame of paint would disappear when switching back and forth from the 

Paint node to other nodes and then painting over one of the existing strokes.

gMask Module Old Version
An old version of the gMask module was mistakenly included in v5. The proper 

version is now included which fixed a bug with overlapping shapes.

Motion Blur and Transparency
When Motion Blur and transparency were used simultaneously, the resulting 

alpha did not look right.

No Way To Ignore RLM_LICENSE
If the RLM_LICENSE environment variable was set, Silhouette would still 

assume it was serving floating licenses, and would not fall back to looking for a 

local license.

Save As With An Existing Project
You can no longer Save As over an existing project as it was causing painted 

frames to be deleted.
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Scripting > project.save(...) Broken
project.save() would not save properly unless the path was of the form 

“/path/to/<bundleName>.sfx/project.sfx. Now, it will automatically append the 

“project.sfx” if only a bundle name is provided.

S3D Warp Banding
Banding occurred with certain images when one of the S3D node’s Warp types 

was selected.

Timeline Sash Could Be Made Too Large
It was possible to move the Timeline sash so far to the right that you couldn’t 

get it back again without editing the Silhouette preferences. 
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 WHAT’S NEW IN 5.1.2

Features

Installer - After Effects Creative Cloud
The Silhouette installer now automatically finds the After Effects Creative Cloud 

install location.

Nuke Exporter
The Nuke exporter now exports Silhouette’s Shape > Max blend mode.

Scripting
Script Editor Line Numbers
Added line numbers to the script editor.

Hook For Quit Notification
A new “quit” hook is called when Silhouette is about to quit. If the hook returns 

false, Silhouette will not quit.

Property SetInterpolation() Missing
Added the ability to set interpolation via scripting.

Changes

Disable Premultiply
Premultiply was disabled for formats that do not support embedded alpha.

mocha Accuracy and Speed
mocha's accuracy and speed was improved.
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Bug Fixes

Cache Generation Progress Bar (Mac Only)
The cache progress bar was not updating on Mac.

Dual-Clone Artifacts (Linux Only)
There were artifacts when using Dual Clone on Linux.

Edit Session in Floating Project Window Crash
If you edited a session in a floating Project window, Silhouette would crash.

mocha > Remove Flicker Crash
mocha would crash if you had Remove Flicker on.

Paint > Stereo Alignment
The brush cursor was not lining up on the same feature in the Left and Right 

Views after a stereo alignment.

Point Tracker > Behavior > Keyframes Crash
The Point Tracker > Behavior > Keyframes feature caused a crash.

Quicktime Load Problem (Mac Only)
Quicktime files with numbers in the name only loaded the first frame.

Right View Not Rendering in Paint Only Mode
The Right view of a stereo pair was not rendering in the Paint Only render 

mode.

Saving Project From Script Did Not Update Project Root
Using project.save() did not update the SFX_PROJECT_ROOT variable used 

by Paint. The variable is now updated in the setBundle() call.

Shape > Max Blend Mode
The Shape > Max blend mode had a bug where overlapping shapes with 

opacities below 100 didn't display the correct value in the overlapped area.
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Shape > Multiply Blend Mode
If a shape with less than 100 percent opacity is set to Multiply blend mode, the 

shape's Alpha is drawn to the border of the bounding box, not to the shape 

itself.

Object List Renaming (Mac Only)
Using a tablet and double-tapping on a list item to rename was not working on 

Mac.

Timeline 1FPS Not Working
1FPS was not working in the Timeline.

Variable Vertex After Effects Shape Crashes on Export
When using the Silhouette Shape Import/Export plug-in in After Effects, 

exporting a variable vertex shape would crash After Effects. Instead of 

crashing, an error message is displayed instead since Silhouette does not 

support variable vertex shapes.
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 WHAT’S NEW IN 5.1.1

Features

Import/Export Environment Variables
Added the ability to override Track and Shape import/export paths 

independently by setting these new variables:

Import

SFX_TRACK_IMPORT_EXPORT_PATH

SFX_TRACK_IMPORT_PATH

SFX_TRACK_EXPORT_PATH

Export

SFX_SHAPE_IMPORT_EXPORT_PATH

SFX_SHAPE_IMPORT_PATH

SFX_SHAPE_EXPORT_PATH
For example, when importing track data, the import/export dialog will default to 

the first directory it finds in this set of paths:

• SFX_TRACK_IMPORT_PATH

• SFX_TRACK_IMPORT_EXPORT_PATH

• SFX_IMPORT_PATH

• SFX_IMPORT_EXPORT_PATH

<last-used-path>

Support SFX_LICENSE
Silhouette now supports SFX_LICENSE variable as well as “sfx_LICENSE”. It 

now tries these variables in order:

• sfx_LICENSE

• SFX_LICENSE

• SFX_LICENSE_SERVER

• RLM_LICENSE
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Changes

Extend Pixel Aspect Field Precision
There is now more precision in the pixel aspect field.

Bug Fixes

mocha Tracker > Drift Compensation (Linux)
A crash would occasionally occur when using mocha’s Drift Compensation.

mocha Tracker > Track Forward One Frame Problem
If you continuously clicked the Track Forward One Frame button when using 

mocha, Silhouette would eventually crash.

Paint > Save As Problem
Paint path was not set properly after a Save As causing the paint history to not 

get copied over to the new project.

XML Doesn't Like Quotes in the Values
There was a bug in XML writer. It needed to escape quotes.
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 WHAT’S NEW IN 5.1

Features

Action > Color+Depth Side by Side
A Color+Depth Side by Side action was added to the Render group. It renders 

the color and depth channels next to each other in the same file and is useful 

for playback on autostereoscopic displays.

Blur Speed Ups
Blurs have been sped up by 30%.

Command-Line: -no_launcher
Added a -no_launcher command-line switch which prevents the launcher from 

appearing when Silhouette starts up without a project. Useful if there is an 

action/script with an alternative method of opening projects.

Display Layer > Stereo Offset Keyframes in Timebar
Layer > Stereo Offset keyframes are now displayed in the Timebar.

Feather Improvements
• Right-clicking on a feather point opens a pop-up menu with Reset and Select All 

options. Reset sets the selected feather points’ offset to 0.

• You can now select and edit multiple feather points at once, but only on one shape 
at a time.

• Dragging a point's offset adjusts the other selected points' offsets based on the 
relative change of the point being dragged.

• Pressing Delete deletes all selected points. 

mocha Drift Compensation
Enabled mocha’s drift compensation feature to the mocha tracker.

New Shape / Layer Blend Modes
Inside
Places the object inside the alpha generated by the objects below it. Inside is 

most useful in the S3D node.
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Max
Looks at the luminance information for each object and selects the value—

whichever is brighter—as the result. Darker pixels are replaced while brighter 

pixels do not change.

Rotate from Center of Selection Bounding Box > Shape 
Preference

Controls whether the automatic anchor point is set to the center of the collective 

bounding box or to the opposite handle.

S3D
Feather
The Feather tool now affects the depth channel.

Layer/Node > Near Depth / Far Depth
Added Near Depth / Far Depth parameters to the Layer > Depth controls and 

to the Node controls.

Node > 3D Preview Controls
Added a 3D Preview group in the Node controls which contains Volume, Fix 

Point and Disparity warp parameters used to set the Viewer > 3D Preview.

Node > From Stereo Source Controls
Added Quality, Iterations and Color Correct parameters available when the 

Node > Depth Mode is set to From Stereo Source.

• Quality offers two settings to compute the depth map: High and Normal.

• Iterations: Fine tunes the quality of the depth map. The higher the value, the better 
the quality.

• Color Correct matches the color between the left and right views to improve the 
depth map.

Shape > Depth > Blend Mode
Added a Shape > Depth > Blend Mode menu.

Alpha/Shape > Depth Type > Linear
Size can now be adjusted on both axes.
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Alpha/Shape > Depth Type > Radial
Added Aspect Ratio to the Radial gradient.

Alpha/Shape > Depth Type > Ramp
Added a Ramp option to the Alpha object and Shape > Depth Type menus 

which allows you to adjust three depth levels.

Shape > Depth > Wrap
Blurs the shape inward without completely losing the edge.

X/Y Tool Tips To Point Controls
Added X/Y tool tips to the point controls.

Changes

S3D Node
Depth Range Change
The depth range was changed from -1-1 to 0-1, where 0 is black and 1 white.

Min and Max Disparity Range Change
The Min and Max Disparity sliders range was changed from (-5, +10]) to (-10, 

+10). A tool tip was also added to explain the sliders.

Bug Fixes

Command-Line: Autosave With -nogui Did Not Work
Autosave with -nogui did not work. The error message wanted to print out using 

a GUI dialog.

EXR Right Side Not Rendering
If you rendered only the Right side of an EXR file, it produced the following 

error: Invalid data window in header.

Nuke Export Jittery
Nuke export of shapes that contained extreme transforms would jitter under 

certain circumstances.
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Red Text Output In Console
If an exception was thrown in the Console, the Console text stayed red.

Shape > Blur Crash
Fixed a very rare case where the blur size matched exactly the window size, 

causing a crash on Mac.

Shape Points Get Larger When Stabilizing
Shape's points would get larger when stabilizing a scale transform.

S3D
Copied Shapes from Roto Node Caused Crashes
Shapes copied from the Roto node to the S3D node could cause crashes.

Gradient Center Point Keyframes Not Setting
There was a bug in interpreting the frame range which could prevent setting 

keyframes when moving gradient center points.

Depth Preview Affected By Main Viewer Settings
The Depth Preview window was being affected by the main Viewer settings.

Transform Controls Not Available When Viewing Depth
The transform controls were not available when viewing the depth channel.

Viewing Depth And Aspect Ratio
When working with a session that had an aspect ratio correction, the depth view 

would not update properly when switching nodes.

Warper Should Not Affect Alpha Channel
The S3D Warper, when activated, was affecting the alpha channel.

Viewer Not Refreshing After Some Preference Changes
The Viewer would not update after changing some of the Viewer preferences 

like Alpha color.
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 WHAT’S NEW IN 5.0

Major Features

mocha Pro Planar Tracker
SilhouetteFX has signed a licensing agreement with Imagineer Systems 

permitting the integration of the planar tracking technology from Imagineer's 

mocha Pro™ into Silhouette V5. Silhouette V5 will continue to offers it’s own 

point and planar trackers in addition to the mocha tracker. With the inclusion of 

mocha's excellent planar tracker, Silhouette now provides artists a variety of 

different tracking technologies to complete the most demanding of shots.

Morph Node
Silhouette now includes a fully-featured shape based image warping and 

morphing system. The Silhouette Morph node provides the highest level of 

control and quality available.

Warps
Warping can be used to enhance or exaggerate image features or adjust sizing 

of image elements. Warping has also been used to create other image 

deformation techniques such as create talking animals or any other type of 

image deformation.

Morphs
Morphing is used more now than ever before as an invisible segue between live 

action and computer generated elements. The precision afforded by the 

Silhouette Morph node makes it especially useful for this purpose. The Morph 

node also provides a rich feature set for the creation of more obvious transitions 

between image elements. 

Being integrated into the existing Silhouette user interface, all Silhouette artists 

will readily take to this new capability.
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Paint 
Auto Paint
Auto Paint is a unique automated paint feature that records all paint activity with 

tight integration of both Point and Planar Trackers. Paint strokes can be match 

moved or stabilized giving Silhouette the speed of raster paint with the 

repeatability of vector paint. The beauty of the system lies in the automatic 

recording of the paint strokes and brush settings. Individual paint strokes can 

be selected and repeated over many frames, as well as deleted. If the original 

footage changes, the entire paint history can be used to rebuild the painted shot 

automatically.

Roto Node
IK (Inverse Kinematics)
Inverse kinematics (IK) simplifies the process of rotoscoping jointed, 

segmented figures by making the motion of each part related to the motion of 

the linked parts. That way, you simply have to animate the starting and ending 

joints, and the ones in between will adjust themselves and create more natural 

looking movement. Silhouette implements IK within it’s existing infrastructure 

by using layers to model joints with one or more shapes in each layer to 

represent the pieces of the object. IK greatly simplify the rotoscoping of 

humans, animals and all manner of jointed creatures.

S3D Node
The S3D node is an add-on option to Silhouette. It contains a comprehensive 

2D-3D conversion toolset for glasses-based (stereoscopic) and glasses-free 

(auto-stereoscopic) productions. The Silhouette S3D node combines cutting 

edge technology and algorithms from 3D Impact Media’s RealityTools products 

with a powerful homegrown toolset all integrated into what is already an 

industry must-have for today's stereoscopic workflow.

Shape Gradients
Silhouette's industry leading rotoscoping and shape tools have expanded 

functionality in the S3D node. New shape parameters include depth and 

gradient control.
lhouette v5 What’s New
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Depth Tools
Alongside the powerful rotoscoping tools, the S3D Node adds a number of 

depth tools that make quick work of common depth map tasks. The new time-

saving tools include Constant, Horizon, Ramp, Hall, Tunnel and an Adaptive 

filter which refines the depth map created by other objects by adding edge 

detail to it.

Depth Preview
The Depth Preview window in the S3D node displays a 3D view of the depth 

map. It is very useful for visualizing the depth and placement of objects in 3D 

space. Clicking and dragging will move the image around in a perspective view. 

Stereo Correction
The S3D node features the correction of exposition errors in stereo images that 

are caused by the misalignment of the camera pair during capturing. The 

following errors can be corrected: vertical offset, horizontal offset, zoom, 

keystone (rotation of vertical camera axis) and rotation. The correct setting of 

the correction parameters is done in a preview process. In order to make 

adjustments with high precision, a full resolution preview window can be 

activated.

Autostereoscopic Generation
The S3D node transforms stereoscopic content into autostereoscopic (glasses-

free) 3D content. With corrected stereo images, two disparity maps are 

generated which are then used to generate multiple views. The disparity maps 

can also be controlled in the 3D Geometry Preview Window, which shows the 

distribution of the depth values in two different projections.
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Features

Actions
Copy > Selection
Copies one or more selected shapes in a layer as well as the parent layer 

hierarchy and transforms. Put another way, this copies the parent layer and its 

shapes and then deletes all unselected shapes.

Create > Corner-Pin Layer
Creates a corner-pinned layer from four selected point trackers.

Edit > Propagate Blend Mode
Sets the blend mode of shapes to their parent layer's blend mode if it is not Add.

Anaglyph Modes
There are now four anaglyph viewing modes that you can choose from using 

the Viewer > Anaglyph Mode preference. This preference sets the default 

anaglyph mode when using the Anaglyph Preview in the Viewer.

Automatic Stereo Alignment
Stereo sources can be aligned instantly by pressing Shift-Alt and clicking on 

the image feature that you would like to align. Shift-Alt will function whether or 

not the Stereo Align view mode is enabled.

Note: A layer must be selected before Shift-Alt can be used.

Command-line > Override Threads
You can override the number of multi-processing threads Silhouette uses with 

the -threads <n> command line argument or the SFX_MAX_THREADS 

environment variable.

Comments and the Command-line Options File
Added #comment support to the -options file. You can now add lines that start 

with '#' to the options file, and they will be ignored.

Ctrl-W and Ctrl-E Shortcuts
Added Ctrl-W and Ctrl-E keyboard shortcuts that toggle rotate and scale 

modes without setting the anchor point. 
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Depth Channels
Silhouette now supports depth channels as a new input type which can be 

passed around, generated, displayed, and rendered. With the S3D node, depth 

channels can be generated and manipulated.

Disk Cache
Disk caching speeds up RAM image loading by pre-loading the frames into a 

local disk cache for quick playback. You can now cache the source clips used 

in the session to disk by selecting Session > Cache > Create Source Cache.

Environment Variables
EXR
Some facilities have EXR images that have a display window with the usual film 

frame size, but have a data window that is larger and contains additional 

overscaned material that may be used. We now have a way through 

environment variables to allow facilities with the above scenario to make use of 

and preserve the entire data window.

SFX_EXR_DATA_WINDOW
SFX_EXR_DATA_WINDOW can be set to four integers “xmin, ymin, xmax, and 

ymax” to set the data window in the output EXR header. The width and height 

specified must match the output image buffer size or else this window will be 

ignored.

SFX_EXR_DISPLAY_WINDOW
SFX_EXR_DISPLAY_WINDOW can be set to four integers “xmin, ymin, xmax, 

ymax” to set the display window in the output EXR header.

SFX_EXR_USE_DATA_WINDOW 
When set, Silhouette uses the data window to determine the image 

dimensions. This will only work right if the entire sequence has the entire data 

window.

SFX_MASK_PATH
Some users didn't like having to copy all of the resources tree just to override 

some masks. So, the SFX_MASK_PATH environment variable was added.
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EXR > Save Auto Data Window
The EXR Save Auto Data Window rendering option looks at the alpha channel 

and determines the data window from that. Then, it writes only the pixels in the 

data window to the file. For SXR files, it writes the combined data window 

between the two views. 

Note: This option is not compatible with the SFX_EXR_USE_DATA_WINDOW 
environment variable.

Float 32 Sessions
Float sessions can now be either 16 bit or 32 bit. Float 16 will have slightly less 

precision than Float 32, but will take up much less memory. Float 32 takes up 

twice as much memory as Float 16. Depending on the graphics card, texture 

updates could also take twice as long in Float 32. On the other hand, some 

filtering operations could be faster in Float 32 than Float 16.

Layer Color
The color pot for layers has been enabled in the Object List so layers can be 

color coded.

Lock Project
Locks a project so that it can’t be modified and displays LOCKED in the Title 

Bar.

Mouse Wheel Adjustments
Hover over a slider and use the mouse wheel to adjust it. Hold Shift for a 10 

time larger change. Hold Ctrl for 10 time smaller change.

Multiple Object Lists
Multiple Objects Lists in conjunction with filtering can now be used to organize 

left or right stereo objects, A or B morph shapes or anything else for that matter. 

Click the Add Dock (+) icon at the bottom left of the Object List to create 

additional Object Lists. Each additional Object List dock is named with a 

number and is displayed as a tab below the Object List. With two Object Lists 

open, for instance, you can filter one on /l and the other on /r for stereo projects 
lhouette v5 What’s New



• 

What’s New in 5.0  25 

• 
• 
• 
•
•
•

or filter on /a in one and /b for morphing. If you then switch an object's view 

assignment from left to right or from A to B, it will cause it to jump between the 

two lists.

Nuke 6.2+ Shapes Export > Convert Opacity to Lifetime
There is a new Input/Output > Nuke 6.2+ Shapes > Convert Opacity to Lifetime 

preference which when checked, converts opacity keyframes in Silhouette to a 

Nuke lifetime. The lifetime is enabled ending at either the work range end or the 

first transition to zero Opacity. The start of the lifetime is either the work range 

start, if the starting value was 100% opacity, or the frame on which it went from 

zero to 100% opacity.

Object List Search
Objects can now be searched for by entering text in the Search field located at 

the bottom of the Object List. Once text is entered, only matching items are 

shown.

• If you type /l or /r at the end of a query, it will filter only left or right stereo objects.

• If you type /a or /b at the end of a query, it will filter only A or B morph objects.

Paint
Brush Size Shortcut
The bracket keys, [ and ], can now be used to change the brush size.

Clone > Blur and Sharpen
The Clone source can now be blurred and sharpened. These controls are 

located in the Clone > Filter tab.

Draw Straight Line
If you press Alt, click and then click in a different location, a straight line is 

drawn. This will work with any brush type. If you keep Alt depressed while 

clicking, you will create interconnected straight lines.
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Presets
A Presets tab now contains 0,1, 2, 3, 4, 5, 6, 7, 8 and 9 buttons on the left side 

of the Paint window and allows you to save all of the brush parameters as a 

preset. To save a preset, click on one of the numbered presets and adjust the 

brush controls. You can also use the Alt-0 through Alt-09 keyboard shortcuts 

to quickly select one of the presets.

Undo
All paint state changes are now undoable.

Preferences
Render > Render Unpainted Frames Preference
By default, Silhouette only renders painted frames when using the Paint Only 

render option. There is a now a Render > Render Unpainted Frames 

preference, which when activated (the default), renders all frames in a 

sequence even if they are not painted on.

User Interface > Invert Mouse Wheel in Editors
Inverts the numerical direction when adjusting sliders with the mouse wheel.

Viewer > Auto-Show Overlay
If Overlay is turned off, Auto-Show Overlay automatically turns Overlay back on 

when clicking in the Viewer.

Project Structure
All of the project data is now stored in a project folder. This includes the project 

file, paint data, autosaves, backups, etc. Projects can now easily be archived 

and moved around. Upon creating a new project, you are now required to 

create a project name and save the project. When using File > Save As, all of 

the assets from the current project will be copied to the new location.

Reshape > Pop-up Menu > Reverse
Reverses the order of all shape control points on all keyframes. Useful for 

warping and morphing, Reverse is used when you are trying to join two shapes 

where the control points go clockwise in one and counter-clockwise in the other. 

In this case, the correspondence points would iterate in different directions and 
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the lines would cross each other. Reversing the points of one of the shapes 

would make them go in the same direction and the correspondence would be 

correct.

Roto - Filled Shapes
Added a Color group in the Roto node controls that includes Enable and 

Opacity parameters to render color filled shapes to the RGB output. The Shape 

> Outline Color was renamed to just “Color” and this sets the color of the filled 

shape when the Roto node Color > Enable parameter is on.

Scripting
Access Logs via Scripting
Added a fx.getLog() function which returns a string containing the entire log 

since Silhouette started up.

Access Persistent Object Data
Added node.getState(key) and node.setState(key, value) to provide access to 

persistent object data so a script can store data with the project. Supported 

state types are: bool, int, double, string, list, and map.

Console
The console can be used as an interactive Python interpreter. You can type 

basic python expressions, including loops, import custom Python modules and 

call custom functions, etc. The Tab key displays a completion list of available 

methods/attributes.

Dedicated Script Editor
Added a dedicated editor for testing complex scripts. It is much better than 

using direct Console entry, since it allows a script to be edited and tested 

efficiently without having to type it in each time. Hidden by default, the Script 

Editor can be opened with View > Script Editor and is displayed at the bottom 

of the Project Window. 
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Node Selected
Added a simple “node_selected” script hook when a node is selected. This 

allows a user to create a Python function that is called when a node is selected. 

Please refer to the scripting guide for information on it’s use.

Port Scripting
Ports to the nodes have been added so scripts can walk around the DAG.

• node.inputs (input port map)

• node.outputs (output port map)

• port.node (the port's node)

• port.property (the node property the port is bound to)

• port.pipes (the pipe list)

• pipe.source (the source Port)

• pipe.target (the target Port) 

Python 2.7
Moved up to Python 2.7 on Linux and Windows. This will allow compatibility 

with PySide.

Set Edit Node Via Scripting
Added a fx.viewer.node attribute/method (read/write). This returns/takes an 

actual Node object, not a node type string as does the “viewNode” and 

“setViewNode” attribute/method do.

Query Keybinds
Added the fx.getBind(key) function. It will return either the function that is called 

when the key is bound to a function, or it will return the name of the widget it is 

bound to if bound using setControlBind(). Unfortunately, there is no way to 

query if a key is bound to a tool, since these can change from node to node.

Top Level Script Menus
A way to create top level script menus has been added. There is a new "root" 

attribute to the Action initializer. The default is "Actions", but users can create 

additional root menus.
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Viewer Stream Control
fx.viewer.setStreamMask() was removed and replaced with some new 

attributes:

• fx.viewer.streamMask (read-only) returns a mask of the available streams 
(StreamMask_Left, StreamMask_Right, StreamMask_Depth)

• fx.viewer.streamMode (read/write) - the current visible stream(s). Can be 
StreamMask_Left, StreamMask_Right, StreamMask_Depth, or a combination of 
the left/right bits.

• fx.viewer.setToolTip(toolName, shortcut) - can be used to set just the tool tip of a 
tool without binding the key to the control. Use this in combination with a normal 
bind that calls a Python function to do advanced scripting.

Scripting Wiki
A scripting Wiki has been created for all things scripting. It can be accessed 

through the Help > Customization menu item. As time goes by, more 

information and examples will be added.

Source Node > Transform
Left/Right Transform controls have been added for general source 

transformations and more importantly to correct exposition errors in stereo 

images that are caused by the misalignment of the camera pair during 

capturing. The following errors can be corrected: horizontal/vertical position, 

horizontal/vertical scale, rotation and horizontal/vertical keystone (rotation of 

the camera axis). For stereo correction, setting the transform controls is done 

in a 3D preview process. In order to make adjustments with high precision, a 

full resolution 3D preview window can be activated.

Timebar
Allow any work range to be entered, even a start/end that goes beyond the 

available range of footage. This is useful when adjusting motion blur at the start 

or end of a shot.

Timeline
Highlight Selections Better
Selected items now use a blue background all the way across the timeline and 

selected keyframes are highlighted green.
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Out of Bounds Indicator
The area before the first frame and after the last frame (the area between the 

actual session range and the work range, if extended) is shaded red in the 

timeline to show the usable, but out of bounds area.

Tracker
Point Tracker > Merge
If you have multiple trackers that cover different frame ranges, they can be 

merged into one tracker, automatically compensating for the different offsets. 

Ideally, the trackers should overlap in time by at least one keyframe. 

Pre-Processing > Gamma
Added a Gamma parameter to the Tracker Pre-Processing group.

Planar Tracker
Create Point Tracker

Planar Tracker track points can be converted to point trackers which can then 

be treated like any other point tracker; they can be merged, smoothed, 

averaged, and applied to layers. Right-click on a planar track point, choose 

Create Point Tracker and a new point tracker is created.

Exclude Areas While Planar Tracking

In some cases, there are parts of an image that can interfere with the 

effectiveness of the Planar Trackers. To exclude an area while tracking, create 

a subtractive shape or layer above the layer to be tracked. Then, just select 

both the layer to be tracked as well as the subtractive object prior to tracking.

Improved Feature Selection

We improved the feature selection so the Planar Tracker generates a lot more 

features on shots that don’t have a lot of contrast.

New Controls

The following Planar Tracker controls have been added:

• Min Tracks

The minimum number of trackers to generate.

• Max Tracks
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The maximum number of trackers to generate.

• Min Dist

The minimum distance between trackers.

• Max Age

The maximum number of frames a specific tracker will live until it is removed 

and a new tracker is generated.

Note: If you have really good tracks, you can increase the Max Age to cover the entire 
sequence and the trackers will live for the entire time and will result in a smoother 
transform. However, this value has to remain low to handle automatic occlusion 
handling.

Offset Planar Tracking Using Layers

There are times when the object you are planar tracking becomes obscured, 

and in these instances, you can now animate the layer’s transform controls to 

compensate for the obscured object.

Viewer Rotation
Images in the Viewer can now be rotated to display them in an optimal 

orientation for rotoscoping and painting. The Rotate icon turns on Viewer 

rotation mode and when enabled, the Adjust Rotation editing control (hand 

icon) lights up next to it. Adjust Rotation allows you to click and drag in the 

Viewer to set the angle.

• Shift-Ctrl-R: toggles the Viewer rotation mode on/off.

• Shift-R: toggles the Viewer rotation editing mode on/off.

Viewer > Update > Adaptive
An Adaptive Viewer update mode has been added which tries to process as 

fast possible by first processing a 4:1 proxy and then full resolution.
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Changes

Color Management > Cineon/DPX Working Colorspace 
Preference 

The Cineon/DPX Working Colorspace preference is now obeyed every frame 

instead of only checking once.

Icon Changes
Stereo View Icons
• Left View

• Right View

• Left/Right View

• Stereo Split Mode

• Stereo Align

Overlay
Aspect Ratio

LUT > Clear List
There is now an option in the LUT pop-up menu to clear the LUT list.

Motion Blur at Start/End Frame Editing
Previously, the motion of the first and last keyframes were extrapolated to 

create motion blur on those frames. This automatic extrapolation has been 

removed. Now instead, you can move start/end keyframes to position shapes 

where they will generate the proper motion blur. This is made possible by the 

Timebar allowing any work range to be entered, even a start/end that goes 

beyond the available range of footage.

OCIO > Display
The OCIO > Display button is now hidden if there is less than two options.

OpenColorIO Updated
OpenColorIO has been updated to 1.0.7.
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Update OpenEXR to v1.7
The OpenEXR version used by Silhouette was updated to 1.7. In addition, 

SXRs now obey the dominant view.

Paint
Clone > Match Move
Paint > Clone > Match Move has been renamed to Source Match Move.

Clone Setups
Clone setups have been moved into a more powerful, general purpose Presets 

tab where all brushes can have presets. Two Clone presets will remain, 

however, for the purpose of dual cloning capabilities.

Dual Clone
Clone now has two Clone presets and an additional parameter to enable dual 

clone mode. 1 and 2 will switch the controls over to that bank of Clone 

parameters. Dual will enable painting in Dual Clone mode. Shift-Alt-1 and 

Shift-Alt-2 will allow switching between the two Clone presets.

Eraser Alpha Behavior
The Eraser used to paint into the alpha when opaque was on. The eraser no 

longer does this.

Layers
Layers are now available in Paint and are used to set a stereo offset between 

the left and right views as well as apply tracking data to paint strokes when 

performing Auto Paint playback.

Magnifier
The Viewer > Magnifier now works in Paint.

Profile Changes
There are now just Circle and Square brush profile options which can both be 

softened with the Softness slider.

Restore Renamed
Restore was renamed to Delete.
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Stereo Offset
The Paint > Stereo Offset controls have been removed from the Paint settings 

since layers are now available in Paint and that is where Stereo Offset resides 

for other nodes. The benefit of this is that the Stereo Offset can now be 

keyframed in Paint.

Path-Point Tool Changes
In the Correspondence, Feather and Tracker tools, Shift-clicking a shape now 

adds it to the selection.

Render Options Changes
• Save Pop-up has been changed to options with checkboxes.

• At the bottom of the Render Options window, there is now an area that previews 
what the name of the output files will look like.

• The default filename format string has been changed to: 
$(NAME)$(SUFFIX)$(VIEW)$(PREFIX)$(FRAME).$(EXT) where SUFFIX replaces 
ALPHA to fill in the appropriate suffix when saving external alpha, depth, or paint.

Source Node > View
The Source Node > View parameter has been renamed to Stream.

Stereo Display Viewer Preferences Moved
The Viewer > Stereo First Field and Stereo View Mode preferences have been 

moved into the 3D Preview pop-up menu.

Stereo Viewer Renamed
The Stereo Viewer has been renamed to 3D Preview.

Tracker - 4 Point Track Application
When applying a four point track, the frame the tracking data is applied to is 

considered the reference frame. This was changed to be consistent with one 

and two point tracker application behavior.

Viewer > Zoom Pop-up Window
You can now enter a custom value in the Viewer > Zoom field. In addition, there 

are additional preset percentages: 300, 400, and 500.
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Viewer Zooming - Mac
The following shortcuts have been enabled on the Mac version to zoom in and 

out in the Viewer: Scroll wheel, Shift-Middle-Mouse drag, and Space Bar-

Shift-drag.
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Known Issues

Paint > Auto-Paint Not Available in v4 Converted Projects
If you convert a v4 paint project to a v5 project, the Paint > Auto Paint controls 

will not be available. This is a result of the project conversion process.

S3D Node
The features provided by the S3D Node can be greatly accelerated when using 

the Preferences > GPU > Mode set to Auto or GPU. In certain cases, there are 

a few driver related issues:

NVIDIA Geforce GT 650m Mac Driver Problem
There is a driver problem with the NVIDIA Geforce GT 650m graphics card 

which may result in an error when creating an OpenCL context. If this happens, 

the machine must be rebooted. Currently, this only affects the latest MacBook 

Pro Retina 15". Apple confirmed the problem, so this might be fixed in the next 

driver update.

Sleep Mode Problems
On Mac systems with NVIDIA 320m and 330m graphics cards as well as Linux 

systems with NVIDIA GPUs, there is a problem when coming out of sleep mode 

that may lead to errors if the Preferences > GPU > Mode is set to Auto or GPU. 

If this happens, the application must be restarted.

Windows ATI GPUs - Half Resolution
There is a problem with AMD GPUs under Windows when using exactly half 

HD resolution (960x540) which will lead to visual artifacts. If this happens, the 

Preferences > GPU > Mode must be set to CPU.

Windows Watchdog Timer
On Windows, the graphics driver has a watchdog timer that kills any GPU 

programs that run for more than 5 seconds. Using adequate GPUs which are 

fast enough solves this problem. For more information on this issue, please 

visit: http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx
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