SILHOUETTE
What’s New
About this Guide

Copyright

No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying and recording, for any purpose without the express written consent of Boris FX.

Copyright © Boris FX 2020. All Rights Reserved

October 9, 2020

About Us

Founded in 1995, Boris FX is a leading developer of VFX, compositing, titling, video editing, and workflow tools for broadcast, post-production, and film professionals. Boris FX products have grown to serve over a million artists worldwide. The company’s success lies in its ability to tightly integrate and leverage technologies through strong partnerships with Adobe, Apple, Avid, Blackmagic Design, Autodesk, FilmLight, Grass Valley, Magix, SGO, and other leading developers of video editing software. In 2014, Boris FX acquired Imagineer Systems, the Academy Award-winning developer of Mocha planar tracking software. In 2016, Boris FX acquired GenArts, the developer of Sapphire, the gold standard plug-in package for high-end visual effects. In 2019, Boris FX acquired the Academy Award-winning Silhouette for advanced feature film rotoscoping, painting, and effects.
Features

User Interface > Font Size Preference
A User Interface > Font Size Preference was added to adjust the font. This aids in making the text more readable on high dpi monitors. Note: Setting a larger font size could cause the text to be cut off in certain menus.

Changes

Grain Size Smaller Than .5
The Grain > Size went no lower than .5. The minimum size is now 0.1.

Paint Source Shortcut
The paint source shortcut used to select either Foreground or Output as the paint source has been changed to Alt-P.

Bug Fixes

Edge Snapping Shortcut
The Alt-S edge snapping keyboard shortcut did not work.

Hold Node Frame Value Not Preserved
The Hold node Frame value was not preserved after a project restart. It always reset to 0.

Mac OpenColorIO library
The version of the OpenColorIO library included in the Silhouette Mac app didn't have the proper signature and could not be found on some systems.

Planar Tracker > Reference Frame
The Planar Tracker > Reference Frame was supposed to display the frame that you first started tracking on and then remain on that frame number. Instead, the frame number continuously changed until tracking completed.
Roto Delete Crash
Silhouette would crash after creating multiple layers and then pressing the Delete icon in the Object List.

Sapphire OFX Issues
- **S_Brush, S_Crosshatch, S_RomanTile, S_StripSlide**: Presets didn't do anything in the Sapphire browser.
- **S_Effect/S_Transition**: loaded the image with transparency in the Builder.
- **S_Effect**: crashed after entering and exiting the Builder.

Timebar Frame Markers Didn't Disappear After Delete
After deleting frames in the Auto Paint window, the frame markers did not automatically delete. You had to drag the Timebar to get them to disappear.

Tree Groups Did Not Minimize
Tree groups did not minimize.

Using DOD Or Crop On FG Before Composite Clipped FG
If a DOD or Crop node was adjusted smaller than the Session size and inserted on the FG input of a Composite node, the FG was cropped.

Known Issues

Trimmed Footage in Premier Pro Loaded Entire Clip
If a clip was trimmed in Premiere Pro, the entire clip was loaded into the Silhouette Paint plug-in instead of the trimmed clip. This is a Premiere Pro limitation and the issue has been logged with Adobe.
Features

Create Tracker > Center of View
Point Tracker > Create placed the tracker in the center of the screen. If you were zoomed in and panned off the center, you wouldn't see the tracker that was created. Point Trackers are now always created in the center of the current view when using Point Tracker > Create.

Note: Alt-clicking still adds a tracker wherever you click.

Dragging Past Min/Max Parameter Values
When dragging on a value field with an edit range different than the display range, for example the OCIO Gain control and some Sapphire controls, the value can now be Alt-dragged all the way to the edit range limits.

Scripting
Python API To Add Dynamic Ports
Added scripting support for dynamic ports.

- node.addPort() - adds a new dynamic input port and returns it, otherwise None if the node does not support dynamic ports.
- node.removePort(port) - removes the port if it is dynamic.

Remove Single Point Shapes In Nuke Export
When scripting a Nuke shape export, there is now a check for single point shapes.

Changes

Trees Window Interaction Rewrite
Trees window interactions were rewritten to solve various bugs.
Bug Fixes

32 Bit HDR Image Viewer Clamping
32 bit images were clamping in the Viewer as a result of a bug in OCIO v2. We have reverted to OCIO v1 to solve the issue.

Color Space Issue With Paint Color Picker
When viewing in certain color spaces, the Color Brush > Color Picker displayed a color darker than what was painted.

Cursor Offset From Crosshair in Paint Color Palette
On Windows, the cursor was offset from the crosshair in the Paint color palette.

Freehand Point Selection
When Freehand Point Selection is set as the default, pressing Ctrl/Cmd to do a rectangular selection did not work. The points highlighted for a moment, but then there was no selection.

Hold Node Frame Value Would Not Change
The Hold node Frame value could not be adjusted if the Session start frame exceeded the length of the clip.

Node Jumps To Different Location
When clicking from one node to another in the Trees window, nodes could randomly jump to a different location.

Object List Jumps To Top of List After Deletion
When the Object List had a scroll bar and you deleted an item towards the bottom of the list, the scroll bar jumped to the first item in the list and you would lose your place.

ROI Squishes Image With Mocha Distort Workflow
When Mocha was used to first undistort and then redistort, enabling the ROI squished the image in the Viewer.

Roto Node Delete Crash
Deleting Roto nodes with a lot of shapes could cause a crash.
**Scripting**

**Dock Widget Icons Were Too Big For Stock Docks**
When creating a QDockWidget in Python, the dock title icons were too big.

**Sfxsite and Sfxuser Scripts Wouldn't Load Properly in 2020.5+**
The startup.py script had a bug where it was using Python 2 style bulk imports for sfxsite and sfxuser which resulted in sfxsite and sfxuser scripts not loading properly in 2020.5+.

**Silhouette OFX Host Passed Wrong OCIO Display Property**
Silhouette was passing the wrong value for the OCIO kBorisFxOCIODisplayColourspace property. It was previously passing the OCIO display instead of the OCIO view.

**Source Alpha Affected All OFX Inputs**
In the OFX Paint plug-in, the Source Alpha parameter affected all inputs instead of just the Foreground input.

**Stroke Width Keyframe Icon Automatically Turned On**
When adjusted, the Roto > Object > Stroke Width keyframe icon automatically enabled.

**Tracker Preview Box Black When Preview Was Enabled**
When hovering over a Point Tracker with Pre-Processing > Preview enabled, the small magnifier box to the right of the cursor was black.

**Transform BG Crops FG In Composite**
A Transform node on the background input to the Composite node was clipping the foreground input.

**Undo State Corruption**
The Undo state could become corrupted in certain circumstances.
Features

**Paint Source**

With the exception of the Clone Brush, new brush strokes always affected the previously painted output. Now with the Paint > Paint Source control, you can select whether the Foreground or Output is used. For instance, Foreground is useful for painting multiple strokes to perform a constant color correction or blur adjustment. When using Output, each new stroke affects what was previously painted. Alt-S toggles between Foreground and Output.

Changes

**Paint Tab**

**Alpha Group Label and Border Removed**

The Alpha group label and border were removed to make room for the new Paint Source parameter.

**Alpha > Invert Renamed**

Invert was renamed to Invert Alpha.

**Alpha > Obey Renamed**

Obey was renamed to Obey Alpha.

**Alpha > Source Renamed**

Source was renamed to Alpha Source.

Bug Fixes

**OCIO > View XForm - Missing Items**

Only sRGB appeared in the OCIO > View XForm menu. There should also have been None and rec709.

**Pressing Tab In Console Hangs**

Pressing Tab in the Console hangs the interpreter.
Timeline > Markers Grayed Out
The Timeline > Markers were grayed out and there was no way to create them.

Windows PySide Installation
The Windows PySide installation didn’t work right with a clean install.
Features

Clone > Grade/Filter > Hue and Saturation
Hue and Saturation were added to the Clone > Grade/Filter controls.

Monthly Subscription Licensing Support
Monthly subscription licensing is now supported.

Changes

Timeline > Show Work Range Default to Off
The Timeline > Show Work Range now defaults to off.

Bug Fixes

Command-Line -info node Command Error
The -info node command-line option produced an attribute error.

Mac Icon Wrong Version Number in Applications Folder
Pressing Cmd-I on the Silhouette app in the Applications folder displayed the wrong version number.

Planar Tracker

ROI Crash
A crash occurred when using ROI with the Planar Tracker.

Tracker Points With ROI
With ROI enabled, the tracker points were not constrained by the tracking shape.
Sapphire OFX Support

Parameter Hiding
Silhouette did not support OFX parameter hiding. For instance, certain plug-ins like Luna and Night Sky had modes which displayed a different set of parameters.

Parameter Ranges Not Being Set
The parameter range for sliders was not being set properly, and in certain cases, allowed very large values.

Timeline > Work Range Could Not Be Trimmed/Moved
Moving or trimming the work range within the Timeline did not work.

Transform Corner-Pin Crash
A crash occurred if the top corner-pin points where positioned below the bottom points.
Bug Fixes

**Command Line Did Not Run On Windows**

The sfxcmd.exe command line program did not run on Windows.

**Pin Warp**

**Crash With Reset All**

Clicking Reset All with pins applied caused a crash.

**Pins Not Displaying As They Were Added**

As pins were added, they did not display in the Parameters windows unless you clicked on another node and then went back to Pin Warp.
Bug Fixes

Nuke 9+ Exporter - Fully Baked

When using the Fully Baked option, B-splines as well as feather points in general, did not transform properly.

Pin Warp Crash When Used In A Tree With The Color Node

Pin Warp would cause a crash when added to trees that included a Color node. This was because the Color node generated an infinite DOD, and Pin Warp needs the full DOD to work.

Shift-| Didn't Work With The Clone Brush

Shift-| didn't work with the Clone brush to snap the horizontal or vertical split to the cursor position.
Features

Paint

Paint Now Updates in Additional Viewers
Additional viewers set to the Paint node now update painted strokes after the main viewer updates.

Snap Vertical/Horizontal Split Position To The Cursor
To snap the vertical or horizontal split compare position to the cursor position, use the | key (vertical bar) keyboard shortcut.

Tracker > Shape Selection
Shapes can now be selected in the Tracker in both the Planar Tracker and Mocha Tracker tabs.

User Interface - Synchronize Viewers Of Same Node
Multiple viewers from the same node have the option of being synchronized in terms of zoom and pan using the Use Viewer > Synchronize Viewers preference. Synchronization is one way from the main viewer to the additional viewers.

Vegas OFX Support
The Silhouette Paint plug-in is now available for Vegas.

32 Bit EXR Support
Silhouette now supports 32 bit EXRs.

Changes

User Interface

Scroll Wheeling in Parameters Window Adjusted Numeric Fields
If you used the scroll wheel in the Parameters window to vertically navigate, the numeric fields would adjust if the cursor was located over them while scrolling. Now, you have to press Alt when hovering over a numeric field to adjust it.
Bug Fixes

**Film Convert Nitrate Plug-in Caused Silhouette to Crash**
If the Film Convert Nitrate OFX plugin was installed, Silhouette crashed on startup.

**Paint**

**Clone Offset Fails With Arrow Keys**
Clone offset using the arrow keys did nothing right after using a parameter’s numeric pop-up keyboard. To solve this, the Viewer now has focus after a numeric pop-up keyboard is used. This behavior is controlled by the Viewer > Restore Focus After Editing preference.

**Roto**

**Exported Shape Did Not Export Layer**
With a single shape selected within a layer and exporting to the Silhouette shape format, only the shape was exported. Instead, the layer and its transform should have also been exported.

**Feather Handle Flashed**
When the feather handles were hidden, the feather handle flashed on and off when the shape was closed.

**Joining Open Shapes**
If you had two points selected on two open shapes, you couldn't join the shapes using Alt.

**Nuke 9+ Full Baked Not Working Correctly**
The Nuke 9+ Fully Baked option was wrong with some transformations.

**Reset Feather On a Single Frame**
Reset in the context menu reset the feather on all frames. Now, it only resets on the current frame, unless you have MultiFrame mode on.
User Interface

Render Error - There Are No Output Nodes to Render

If you selected an Output node, it was highlighted blue and you could render. If you then clicked on a blank area of the Trees window, the Output node was still highlighted, but turned green. If you then tried to render, an error message appeared that said, “There Are No Output Nodes to Render”.
Features

Silhouette Paint Plug-in
Silhouette Paint is the industry's first paint and tracking plug-in designed to bring best-of-breed, 32 bit, high dynamic range paint tools to editing and effects applications. Artists can now access Silhouette's professional sequence based paint tools inside their host of choice including: Adobe After Effects and Premiere Pro, The Foundry’s NUKE, Blackmagic Fusion & Resolve, Autodesk Flame and more. Available on macOS, Windows, and Linux. A Silhouette standalone license can run either the standalone or plug-in.

Nodes

Cycle Active Node Menu Keyboard Shortcuts
Alt-]
Cycles to next node in the Node pop-up menu.

Alt-[  
Cycles to the previous node in the Node pop-up menu.

Math Composite Node Now Affects Alpha
The Math Composite node can now affect the Alpha channel. A Channels pop-up menu with RGB (the default), RGBA and Alpha are the available choices.

Node Favorites
Nodes can be tagged as a Favorite allowing them to be grouped separately in the Favorites tab of the Nodes window. You can tag a node as a Favorite by selecting the node (single click) and pressing the Favorite icon located at the top left of the Nodes window.

Time > Hold Node
The new Hold node repeats the specified frame for the duration of the session. Useful for freezing a single painted frame for a clean plate, among other things.
Paint

Auto Paint > Frame Range - New Options
Start>Current and Current>End options were added to the Auto Paint > Frame Range pop-up menu.

Paint Only Alpha
A new Paint Only Alpha parameter in the Paint > Node parameter selects either a hard or soft edged alpha channel when using the Paint Only output. Previously, a hard edged alpha was the one and only option.

Paint > Output Unpainted Frames Preference
An Output Unpainted Frames option was added to the Paint preferences. Normally, when using the Paint Only output, only painted frames are rendered. This preference renders the blank, unpainted frames as well, so there is a complete sequence.

Track

Exporting Mocha Tracked Layers as 4 Point Corner-Pin
You can now export a Mocha tracked layer as a 4 point corner-pin.

Point Tracker > Apply Behavior
Tracker > Apply is now enabled with only trackers selected and when clicked, a new layer is created and the tracking data is applied to that layer.

Note: If a layer is selected along with the trackers, the tracking data will be applied to the selected layer.

Trial Licensing
An unrestricted, 15 day trial license can now be obtained automatically.

Viewer

Onion Skin
A Viewer > Onion Skin mode was added to the Viewer. Onion Skin does a mix, as defined by the Mix value, between the current frame and either previous or later frames. This is useful for creating frame by frame, hand painted animations.
**Stereo Align > Mix Mode**

A Viewer > Stereo Alignment Type > Mix preference option is now available for the Viewer > Stereo Align mode.

**Architecture**

**Python 3**

Silhouette 2020.5 now uses Python 3.

**VFX Reference Platform 2020**

Silhouette 2020.5 now adheres to VFX Reference Platform 2020.

**Changes**

**Paint**

**Auto Paint - Delete Key**

The Delete key now deletes the selection in the Auto Paint window.

**Blemish and Grain Brushes Now Randomize**

The Blemish and Grain brushes now randomize from frame to frame.

**Clone > Red Triangle/Exclamation Point**

The red triangle/exclamation point icon in the Paint > Clone tabs was changed to a green dot.

**User Interface**

**Actions > Copy > Selection Moved/Renamed**

Actions > Copy > Selection was moved and renamed to Edit > Copy Selection.

**Cursor Position Color Values**

The cursor position color values when in the Paint node are now displayed in the Status Bar.

**Hide Disconnected Inputs**

Disconnected inputs are now hidden from the Paint and Roto View menus.
Zoom Default to Fit
The default zoom is set to Fit when activating a source or Session.

Bug Fixes

Alpha Only Render Issues
Alpha only renders from Silhouette either crashed when re-imported or couldn’t be displayed.

Freehand Tool In Tracked Layer - Spline In Wrong Place
The Freehand tool was not using the layer transform during shape creation. This could also affect Magnetic shapes in certain cases.

Layer Center Motion Vector Used Layer Center
In the Tracker, when viewing the motion vectors for a selected layer, the center of the layer rectangle was used instead of the layer's position + anchor.

Lens Flare
Flare Editor Crash
Clicking in the Flare Editor Viewer, but not on a control point, caused a crash.

Occlusion Crash
When View > Occlusion was selected with no Occlusion input, Silhouette crashed.

License Window Loop After Deactivation
After deactivating, selecting Cancel cycled between the Silhouette license window and the Boris FX license tool. The only way to stop it was to activate or run in demo mode.
**Mocha**

**Automatically Created Track Layers Not Really Selected**
If you had a selected shape in the Mocha tracker and tracked, a new layer was created, the shape was placed in the layer and it was tracked. After tracking, the layer appeared to be selected, but the track controls were grayed out. To track again, you had to click on the selected layer to really select it and you could then track again.

**Mocha Tracker With GPU Enabled In Hi-Res Sessions**
The integrated Mocha tracker drifted with the Tracker > Mocha > Use GPU If Available preference enabled.

**Mocha Stopped After 5 Frames**
The integrated Mocha tracker stopped after 5 frames the second time you tracked using Mocha.

**Multi-part EXR File Crash**
EXR layers containing only alpha or only two channels caused a crash in the Sources window when set to Thumbnails view.

**OCIO Initialization Failure**
When using the ACES OCIO config, the OCIO processor would not initialize because the sRGB view was named differently. This could cause a crash on startup.

**Paint**

**Align Mode Wrong With Source Match Move**
When using Source Match Move, Clone > Align was not positioned correctly.

**Clone > Interactive and Region**
With Interactive enabled, turning Region on and then off caused Interactive to not work, but the Interactive button was still highlighted.

**Clone > Warp Cursor Flashed in Onion Skin Mode**
The Clone > Warp cursor flashed while moving it when Onion Skin is on.
Cutout Brush Not Saving
If you painted a stroke with the Cutout brush, the result was not saved on the frames you painted on.

Paint Only - Undo Strokes Appear
Strokes removed with Undo appeared in the Paint Only output.

Arrow Cursor Sticks On - Mac
When using a pen/tablet on Mac, if you slowly moved over a sash, the cursor changed to a split icon and stuck on. You had to hit Esc to get rid of it.

Stroke Tool Not Selecting Paint State
When using the Stroke tool, the associated paint state changes, like brush size and opacity changes, were not selected.

Tracker Node > Black Viewer
When hooking a source into a Tracker node, the Viewer was black until the cache was cleared.

Viewer > Node Selector Pop-up Menu Did Not Open
The Viewer > Node selector intermittently did not open.

Weighted Keyframe Crash
If you there was only 1 keyframe, pressing Alt-K and then OK or Cancel caused Silhouette to crash.
Features

Dongle Support For Nodelocked Licenses
Dongles are now supported for nodelocked licenses.

Bug Fixes

Crash When Dragging TimeBar With Fields Enabled
Silhouette crashed when dragging the Timebar with Fields enabled.

Field Rendering Did Not Work
Rendering using any of the Field Handling options did not work.

Mocha Pro

Project Crashed With Insert Rendering Enabled
A Mocha Pro node set to render an insert hung Silhouette when loading the saved project. Fixed in Mocha Pro 7.0.3.

Stop Button Did Not Work
During the initial playback and caching of a Mocha Pro node, the Stop button did not work. Fixed in Mocha Pro 7.0.3.

Node Name Error
Certain OFX nodes had legacy naming when adding nodes from the Node window context menu.

Paint > Alpha > Obey From Roto Node Aliased
Painting with Alpha > Obey enabled using a Roto node as the input resulted in aliasing around shape edges.
Known Issues

Tracker Stopped After 5 Frames

When running the Mocha Pro tracker twice in a row, it would stop after 5 frames. The workaround is to undo and track again.
**Changes**

**Enable Source > Extend Duration On By Default**
Source > Extend Duration is now enabled by default. This means that the head and tail frames of a sequence are extended outside of the work range and that single frame imports exist on all frames.

**Timeline > Show Work Range On By Default**
Timeline > Show Work Range is now on by default. This allows keyframes set in the work ranges to be visible when different from the Session frame range.

**Bug Fixes**

**Legacy Feather Did Not Work**
Legacy feathering did not work.

**Node Name Error**
Certain OFX nodes had legacy naming in the Node window.

**Nuke 9+ Exporter Issues**
- The Silhouette Motion Blur > Samples value was not transferring to the Nuke Motion Blur > Global > motionblur parameter.
- The Silhouette Shutter Phase value was not transferring to the Nuke Motion Blur > Global > shutter offset parameter.

**Open Spline Feather Handles Couldn’t Be Hidden**
Alt-F now toggles open spline feather handles on and off.

**ROI Keyframes Not Saved With Project**
ROI keyframes were not saved with the project.

**RotoOverlay Was Opening By Default**
The RotoOverlay window was opening by default and was not supposed to.

**Shift-Alt Did Not Work For Stereo Align**
The Shift-Alt shortcut did not work for stereo alignment.
Viewer Proxy Resolution Problems

Paint Node
The Paint node displayed a cropped image in the Viewer at proxy resolutions.

Transform Node
When Viewer proxy resolutions were used with a Transform node, images of a different size than the Session were blank in the Viewer.
Features

Copying/Pasting Mocha Trackers & Shapes to Silhouette
Shapes and trackers copied to the clipboard in Mocha can now be pasted into a Silhouette Roto node. Requires Mocha Pro 7.0.2 or later.

Changes

Make Disabled Nodes More Obvious
To make it clearer when a node is disabled, there is now an X over the node while disabled.

Mocha Tracker Status Window - Initializing Message
When using the Mocha tracker, an “Initializing” message appears in the tracking status window while the GPU shaders compile prior to tracking.

Paint > Subpixel > Speed Up
Some Paint > Clone brush filters, like Sinc, take longer to process. If there is no transform and no Clone offset, Silhouette will use a fast processing path regardless of the Subpixel setting.

Request a Trial Screen - Removed Host ID
The Host ID was removed from the Request a Trial screen as it was not needed.

Bug Fixes

Composite Node Crash
The Composite node could crash when working with different sized foreground and background inputs.

Trees Window Won't Zoom In Until You Zoom Out
You had to zoom out before you could zoom in to the Trees window.
Windows Crash On Startup

Windows could crash or exit unexpectedly during startup.
Features

Paint

Auto Paint > Replay (Ctrl-Alt-R)
Replays the last stroke. This can be used to apply the last stroke with changed settings and/or on a different frame.

Brush Compare Modes
The brush compare modes preview brush settings prior to painting. You can choose from Vertical Split and Horizontal Split. Previously only available in the Clone Brush, the compare modes now work for all brushes except for Drag, Repair, and Cutout.

Brushes - New
New brushes include Dodge, Burn and Detail.

Dodge (Alt-Shift-D)
Lighten areas in the image.

Burn (Alt-Shift-B)
Darkens areas in the image.

Detail (Alt-D)
Sharpens or smooths by separating the image into coarse, medium and fine detail layers. This results in selective sharpening, detail enhancement and edge aware smoothing.
Detail Separation

Paint can now separate the image into color and detail layers. The color and detail layers can be painted separately or simultaneously.

Painting on the color layer preserves detail.

Painting on the detail layer preserves color.
Show Shapes
Shape outlines from a Roto node can be displayed in a Paint node. To do so, connect a Roto node's Objects output into a Paint node's Objects input and enable Show Shapes in the Paint tab.

Stroke Tool (S)
Displays all strokes. Strokes can be selected by clicking or drag selecting in the Viewer. Hold **Shift** to add to the selection and **Ctrl/Cmd** to toggle the selection. As strokes are selected, they are highlighted in the Viewer and the Paint History.
**Edit In Both Views**

Controls editing in the Left/Right View.

**Paint**

When enabled, paint is added to both views simultaneously. When disabled, the left or right view is painted individually.

**Roto**

When enabled, shapes are edited in both views simultaneously. When disabled, shapes in the left or right view are edited individually.
Roto

Magnetic Freehand (Shift-F)
Creates magnetic freehand shapes with or without magnetic properties. A magnetic freehand shape snaps the shape boundary to the nearest object edge.

Magnetic Shape
Creates a freehand shape with magnetic properties. There are two methods of creating a magnetic shape: Tracing or Strokes.

Tracing
Click once near the edge you want to start with and move your cursor along the edge you want to follow. The shape boundary snaps to the nearest edge to where the cursor lies, tracing the shortest path from any previous click. When you are done tracing, click the first control point that you added to close the shape.
**Strokes**
Draw temporary foreground (inside the shape) and background (outside the shape) strokes for the object you want to create a shape around. As soon as the foreground and background strokes are drawn, an X-Spline is created around the object.

**Edge Snapping**
You can snap the control points of any X-Spline to edges of an object by using the Edge Snapping tool. Select the points you want to move and press the Alt-S key.

Alternatively, start dragging the points, hold the Alt-S key down and they will snap to the nearest detectable edge. In some cases, the points may not snap to where you want them to. If this happens, adjust the points manually.
**Freehand Selection**

Shape control points can now be selected by drawing a freehand polygon. Ctrl/Cmd-drag in the Viewer to begin the selection. Once the selection is started, release Ctrl/Cmd and complete the selection.

![Freehand Selection](image)

**Layer > Corner-Pin**

Shape layers now have Corner-Pin parameters and associated on-screen controls on the corners of the image.

**RotoOverlay (Shift-O)**

The RotoOverlay tool provides three options to visualize the selected shape’s animation and motion blur: Motion Path, Motion Blur and Onion Skin.

Once selected, a Roto Overlay window opens allowing you to select or deselect various options.
Motion Path
Displays the shape’s motion path with visual indicators for frames and keyframes.

Motion Blur
Displays a dashed line to show the width of the motion blur.
Onion Skin
Shows the shape outline on previous and future frames as controlled by the Onion Skin Frame Range.

Holding **Alt** over an onion skin shape or motion path marker displays the frame number in the status bar. Clicking on the shape or marker jumps the Timebar to that frame.

**Add Weighted Key (Alt-K)**
Creates a keyframe at the current position which changes the timing of the animation between two surrounding keyframes. Park between two keyframes, select a shape, press **Alt-K** and drag the slider to adjust the weight.
Tracking

Planar Tracker > Group Tracking
You can now select multiple layers containing non-overlapping shapes and track them simultaneously. The layers are tracked as separate planar surfaces.

Planar Tracker > Part Tracking
With multiple layers containing overlapping shapes, there is an interaction between them whereby they share coarse motion, but have individual motion at the fine scale. This is helpful when tracking non-planar surfaces.
Mocha

Integrated Mocha Tracker
The integrated Mocha tracker is now included at no charge as part of the base Silhouette package. Note: Does not open the Mocha user interface.

Silhouette Mocha Pro Plug-in
Mocha Pro features GPU-accelerated tracking and object removal, advanced masking with edge-snapping, stabilization, lens calibration, 3D camera solver, stereo 360/VR support, and more. This purchasable option launches the Mocha Pro interface directly from within Silhouette.

Workflow Enhancements
- If shapes are selected and not in a layer, clicking the Track Forward/Backward buttons will create a new layer, make it active and begin tracking.
- If shapes are selected in an unselected layer, clicking the Track Forward/Backward buttons will make the layer active and begin tracking.

Output Node > Render Button
Added a Render button in the Output node that opens the Render Options. This is the equivalent of using the Ctrl/Cmd-R shortcut key.

New Nodes
DOD
The DOD (Domain of Definition) node located in the Transform tab defines the size of the DOD. The DOD can be expanded or reduced. A smaller DOD will speed up all image processes. Setting the DOD larger than the Session size will pad smaller images and the ROI (Region of Interest) can access the additional image area. This is useful for creating oversize plates.

Extract Detail
The Extract Detail node located in the Filter tab decomposes the image into color and detail layers. The color and detail can later be composited together using the Grain Composite node.

Session > Templates
Session > Templates are presets for automatically adding Roto and Paint nodes to the session and selecting a workspace.
The following templates are available:

**Composite**  
Automatically adds an Output node to the Source and selects the Composite workspace.

**Paint**  
Automatically adds Paint and Output nodes to the Source and selects the Streamlined workspace.

**Roto**  
Automatically adds Roto and Output nodes to the Source and selects the Streamlined workspace.

**Roto+Paint**  
Automatically adds Roto, Paint and Output nodes to the Source, connects the Roto > Objects output to the Paint > Objects input and selects the Streamlined workspace.

**User Interface**

**Viewer**

**Multiple Viewers**  
Multiple Viewers can be opened and set to any node or view using the New Viewer icon.

![Viewer Node Selector](image)

**Node Selector**  
A node selector at the top left of the Viewer selects the node to be displayed.
**Node Renaming**

If the node's name is renamed to be different from its type, the tooltip will show the node type in parenthesis. Likewise, a read-only field will appear to the right of the node name in the Node Parameters window, displaying the type.

**Streamlined Workspace**

Optimized for Roto and Paint projects, the size of the Trees window is reduced to make room for the Object List and Paint History immediately below.

**Window Enhancements**

**Multiple Node and Object Windows**

Like Object Lists, there can now be multiple Node and Object parameter windows. Click the Add Dock icon to create another window.

**Lock A Window To a Node**

Object Lists, Node or Object Windows can now be locked to any node in the tree regardless of which node is active using the Lock Node icon.

**Setting Environment Variables In Silhouette**

The Environments preference sets environment variables directly inside Silhouette without having doing so in the operating system. Once applied, variables are immediately available in Silhouette, sub-processes, and scripts.

**Upgrade and Support**

Designed to make upgrading and budgeting for Silhouette more convenient, the Upgrade and Support Plan is an annual program that ensures you have access to the latest available features, increased licensing flexibility, and the support you need. Each purchase of a new License or an Upgrade includes the 12-month Upgrade and Support Plan.
Changes

**Boris FX Licensing**

The Boris FX nodelocked and floating licensing system is used by Silhouette.

**Keyboard Shortcuts**

**Paint > Paint Only**

The View > Paint Only keyboard shortcut was changed to P so that View > Color Layer could be assigned 8.

**Roto - Shape Feather Handle Display**

The shape feather handle display was changed to Alt-F so that the new Magnetic Freehand tool could be assigned Shift-F.

**Paint > Scatter Brush**

The Paint > Scatter brush keyboard shortcut was changed to Shift-S so that the new Paint > Stroke tool could be assigned S.

**Panning**

The Space Bar-drag panning keyboard shortcut was changed to Space Bar-move mouse so as not to interfere with drawing freehand shapes and paint strokes. The mouse can now stay depressed while drawing when panning occurs. Note: Only the Trees window still uses Space Bar-drag.

**Mocha Tracker > Motion Default**

Changed the integrated Mocha Tracker > Motion default from Small to Large motion. This is to have consistency with the Mocha Pro plug-in.

**OFX List - Sash Added**

A sash to resize the OFX list was added.

**Paint**

**Color Correct Brush Icon**

The Color Correct brush icon was changed to the icon below.
Cursor Position Color Values Moved
The cursor position color values when using the Color brush have been moved from the brush parameters to the Viewer > Display Options and are now available for all brushes.

Transform Input Renamed to Objects Input
The Paint node’s Transform input has been renamed to Objects input since both shapes and tracker layers are utilized through this input port.

Version Format Change
Silhouette’s versioning has moved to yearly numbering. For instance, this release is named Silhouette 2020.

ROI > Set ROI to Current DOD icon
The Set ROI to Current DOD icon was changed to the icon below.

Roto > Feather Line Drawing
When drawing a semi-transparent shape, the dashed feather line no longer appears when there is no feather.

Streamlined Workspace
A Streamlined workspace optimized for Roto and Paint projects replaces the previous Roto workspace.

Tracker > Create Point Trackers In Root Preference
The Tracker > Create Point Trackers In Root preference is now on by default.
Bug Fixes

**Clone Offset Problem on Mac After Using Delete Frames**
On Mac, you could not set the Clone Offset with a pen/tablet after using Delete > All Frames.

**Mocha Tracker With ROI Larger Than DOD**
The Mocha Tracker did not handle cases where the ROI was larger than the DOD.

**Newly Created Object - Selection / Highlighting Error**
If you clicked on a newly created and selected object, it would deselect but remain highlighted.

**Output Node File Field Required File Extension - Windows**
A recent change to Windows required a file extension to be entered in the Output node’s File field.

**Planar / Mocha Tracker - Matrix Keyframe at Frame 1**
A Layer > Transform > Matrix keyframe was getting set at the first frame even when tracking from the middle of a sequence when using the Planar or Mocha Trackers.

**Shift-0 Display Issue**
**Shift-0**, which premultiplies the image in the Viewer, degraded shape outlines.