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About Us
Founded in 1995, Boris FX is a leading developer of VFX, compositing, titling,
video editing, and workflow tools for broadcast, post-production, and film
professionals. Boris FX products have grown to serve over a million artists
worldwide. The company’s success lies in its ability to tightly integrate and
leverage technologies through strong partnerships with Adobe, Apple, Avid,
Blackmagic Design, Autodesk, FilmLight, Grass Valley, Magix, SGO, and other
leading developers of video editing software. In 2014, Boris FX acquired
Imagineer Systems, the Academy Award-winning developer of Mocha planar
tracking software. In 2016, Boris FX acquired GenArts, the developer of
Sapphire, the gold standard plug-in package for high-end visual effects. In
2019, Boris FX acquired the Academy Award-winning Silhouette for advanced
feature film rotoscoping, painting, and effects.
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Features
Silhouette Plug-in

Previously, the Silhouette Paint plug-in was limited to paint functions, but now,
all limitations have been removed. The Silhouette Paint plug-in has been
transformed into a fully featured Silhouette plug-in that can do everything the
standalone version of Silhouette can do, but as a plug-in.

Lens Correction

Powered by Silhouette’s Roto tools and based on shared technology from
Mocha Pro’s Lens Module, Lens Correction undistorts lens distortion and
generates ST Maps for third party applications. To compute lens distortion, you
need an image with one or more distorted straight lines or a distortion map,
sometimes called a UV map or ST Map.
Before

After

GStreamer

Import of movie file formats is supported through GStreamer which is a versatile
media handling library for reading various codecs and footage containers.

External Monitor Support

Silhouette can now be displayed on an external broadcast monitor when using
a Blackmagic I/O device.
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Custom File Importer

A custom file import dialog now allows sequences to be collapsed, while the
previous OS native file dialog can still be used.

Drag and Drop Import
Dragging and dropping files/folders from the OS file system into the Sources
window automatically creates sources for any sequences that are found.
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Advanced Roto Editing Tools
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Brush Reshape

Brush Reshape uses a circular brush to automatically select and then move
points when you click and drag them using the Magnetic Reshape behavior.
Pressing Shift while dragging points disables the magnetic behavior. You can
also Shift-Alt click/drag in the Viewer, not on any control points or shapes, and
that becomes the magnet pull position instead of using a point.

Collapse Points
Collapses a selection of points into a very small area which can later be
distributed between surrounding points. This is useful for shapes whose
complexity changes over time.
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Distribute Points
Evenly distributes selected points.

Point Groups
Groups of points can be pre-defined and then quickly edited as a group in the
Reshape and Transform tools.

Control Point Selection Enhancements
Select Range
Select a range of shape control points by Shift-clicking start and end points.

Extend Selection
Extend the current selection by Shift-clicking an unselected point. The
selection is extended by finding the nearest point of the selection.

Roto Review and Approval
Notes assigned to objects (shapes, layers, trackers) can now be displayed in
the Viewer. This is a useful review and approval tool for artists to easily see
notes provided by their supervisors. Clicking the Viewer > Notes icon displays
notes for all objects in the Viewer.

Selecting a note’s text also selects the object and displays a callout line from
the note to the object. A new Select > Notes action will select all notes.
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Split Shapes
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Similar to Split Edit in non-linear editing systems where a clip is split in two, Split
Shapes is useful for shapes that transform from simple to complex and viceversa.
Accessed through the Reshape context menu, Split Shapes does the following:
The original shape is duplicated and named Shape-copy. If there is an active
selection, the new shape is created based on the selected points. At the current
frame, the original shape is set to 0% opacity and the copied shape set to
100%. Both shapes are placed in a layer named Shape-Compound Shape. In
editing terms, you are cutting from one shape to another.

Weighted MultiFrame
Using the new Fade In and Fade Out MultiFrame parameters, the keyframe
adjustment is weighted based on a specified Fade In or Fade Out time period.
Keyframes within the fade areas are adjusted less than those that are not. The
MultiFrame Start and End as well as the Fade In and Fade Out parameters can
be set in either the Timebar or Timeline.
Timebar

Set the Start and End as well as the Fade In and Fade Out values using the
numeric fields that appear in the Timebar when MultiFrame is selected.

Start

Fade In

Fade Out

End

Timeline

Set the Start and End by clicking and dragging the ends of the red MultiFrame
track in the Timeline.
Start

End
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Set the Fade In and Fade Out values by pressing Ctrl/Cmd and dragging the
start and end of the red MultiFrame range.
Fade In

Fade Out

Paint

New Color Picker
The ring sets the hue while the inner square sets the value (brightness) and
saturation.

Auto Paint > Step Selected Events Forward/Backward
Selected events in the Paint History can be stepped either forward or backward
one frame at a time.

Brush Opacity Shortcut
Ctrl/Cmd-Alt-drag sets the brush opacity.

Mask
Masks the clone source input using its alpha channel.
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When enabled, the Clone brush only paints using the masked area of the clone
source. In addition, when transforming the clone source, both rgb and alpha
channels are transformed.
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New Nodes

Alpha Composite
Composites alpha channels with channel and blend mode options for each of
the five sources.

Alpha Threshold
Threshold cuts the alpha channel at a certain value. Anything below the value
goes to zero (black), while anything above goes to 1 (white).

Dot
The Dot node, located in the Utility node group, cleanly routes node
connections and is displayed as a dot in the tree.

Create a Dot node by Alt-clicking on an existing node connection or add it from
the Utilities node group like any other node. To drag out an additional output,
hold Alt over the Dot node and drag the output port that appears.

Note
The Note node adds a node text frame to the Trees window. It can be resized,
moved behind other nodes and its background color can be set. The text can
be formatted using font type, size, color, bold, italics and underline.
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OCIO Colorspace
Converts from one colorspace to another using OpenColorIO.

OCIO Display
Determines the transform that occurs between the input scene’s colorspace
and the display colorspace.

OCIO LUT
Applies a custom OCIO LUT to the scene.

User Interface

Flyout Menus
Tools with multiple modes, like Roto > Transform and Reshape, now have flyout
menus.

Nodes
Alignment
Right-clicking over the Trees window displays a new Arrange menu containing
Clean Up, Align and Distribute options.
Clean Up

Neatly aligns all nodes in the Trees window.
Align

Lines up selected nodes either horizontally or vertically. Nodes are aligned
horizontally when they are on average horizontal, and vertically when they are
more or less vertical.
Distribute

Nodes are distributed in a line between the two nodes that are furthest away
from each other.
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Coloring
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The color of a node can be changed using the Node > Options controls.

Grouping
Nodes within a group can now be deleted.

Options
Per node controls are available in the Node > Options tab for Node Color,
Layout, and Connection type.

OCIO Roles
Silhouette now supports OCIO roles and categorizes colorspaces according to
their family, if defined.

Session Formats
Added UHD 4K/8K session formats.

Sapphire Node Tab
A dedicated Sapphire node tab appears when Sapphire is installed.

Timeline > Shape Visibility Bar
Shapes set to 100% opacity appear as a bar in the Timeline. This is achieved
by darkening all tracks associated with an object in areas where the opacity is
0.

Trees Window > Select Context Menu
Right-clicking in the Trees window with selected nodes displays a new Select
menu containing Sources, Upstream Nodes, and Downstream Nodes.
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Sources
Selects and highlights the sources in the Sources window.

Upstream Nodes
Selects upstream nodes.

Downstream Nodes
Selects downstream nodes.

Viewer > Channel Indicator
The Viewer > Channel icons now display a white outline around the currently
selected channel’s icon.

Viewer Snapshot
Viewer > Snapshot now works between Sessions.

UI Font Change
Changed the font used by Silhouette from the default system font to Inter UI.

Utility Node Group
A new Utility node group was added for nodes like Dot, Notes, and Null.

Preferences
Paint

Clone > Default Subpixel State
The Clone > Default Subpixel State preference sets whether Clone > Subpixel
is enabled or disabled by default.

Scripting
A new Scripting preference was added to make it easy to load your own scripts.

Enable External Scripts
Enable the loading of external scripts.
Note: Disabling external scripts will also have the scripting system ignore
$SFX_SCRIPT_PATH and $SFX_USER_PATH/scripts.

External Script Paths
Add one or more paths where your scripts are stored.
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User Interface
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Connection Color
Sets the node connection’s default color.

Default Group Color
Sets the group’s default background color.

Default Node Color
Sets the default node color.

Use Native File Dialog For Importing Media
When enabled, the OS’s native file dialog is used for importing files.

Scripting

Improved Communication With Tools
Expanded the "tool command" and "query" functionality to support arbitrary
values that can be sent to tools with the fx.viewer.toolCommand() and returned
with fx.viewer.queryTool(). This was necessary to allow [ ] editing of the brush
size in the Reshape > Brush Reshape tool.

object.objects attribute
Added a convenience attribute to object ("objects") which returns the first
property that can contain children, if there is one. This is usually the "objects"
property of Layers/Roto and Tracker nodes. This the equivalent of:
object.property("objects").
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Changes
Nodes

Node Selection Coloring
Active Node
The active node has a blue outline and white edges.

Selected Nodes
Selected nodes have white edges.

Null Node Moved From Image Group
The Null node was moved from the Image group to the Utility node group.

Roto
Adjust Feather Handles By Same Amount
If you hold Shift while dragging a feather handle, the same distance you moved
the active handle will be applied to all selected handles. Otherwise, the
distance will be scaled by the original distance of each point.

Math Composite - Individual Channels
Math Composite operations can now be done on a per channel basis.

Morph > Output Alpha of Shapes
In the Morph node, there is now a Cutout option to output the shape alpha.

Paint
Color Brush Icon
Anew Color brush icon was added to the Paint toolbar.

Input Naming
The Paint node inputs were renamed as follows:

• Renamed “Foreground” to “Input”
• Renamed “Input 1-5" to “Source 1-5"
Paint Missing Icon
An icon is displayed in the Output node when the painted data is missing.
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Preferences
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Colors

Shape and Viewer color preferences were moved into a new Colors category.

Fade Outline With Opacity
The Fade Outline With Opacity preference now defaults to off. In addition, the
V key still toggles the visibility of zero opacity shapes, but no longer turns the
Fade Outline With Opacity preference on/off.

User Interface

Eyedropper Removed
The Eyedropper next to color pots was removed. The operating system color
picker eyedropper is now used instead.

Object Naming Change
The default name of the first new object has changed so that it is appended with
the number 1. Previously, the first object was named <Object> with the second
named <Object> 1. Now, the naming is <Object> 1 and <Object> 2.

Render
Data Window
Determines the rendered image size and replaces the previous Render ROI
option. Now, you can choose from Session, ROI (Region of Interest) and DOD
(Domain of Definition).

Validate
When selected, rendering is aborted if a Paint node’s data can’t be found.

Streamlined Workspace Change
The Nodes tab in the Timeline was added to the Streamlined workspace.

Template Changes
Since roto and tracking are often used with paint, the previous Paint template
was deleted while the Roto+Paint template was renamed to Paint.
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Thumbnail Color Space
Previously, the thumbnail colorspace was set based on the colorspace of the
Viewer > OCIO controls. Now, it is inferred from the colorspace of the sources
themselves.

Timebar Numeric Fields
The Timebar > Start Frame, End Frame, Current Frame and Frame Step fields
can now be scrubbed by clicking and dragging while a single click opens a
numeric keyboard.

Viewer > View XForm Renamed
View XForm in the Viewer was renamed to View Transform.

Workspace Menu Moved
Workspace was moved out of the Window menu and placed at the main level
between Window and Actions.
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Bug Fixes
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Nodes

Composite
When the ROI did not contain both input FG and BG DOD’s, the composited
alpha channels displayed a line where they intersected.

Hold
Default Frame Wrong
The Hold node defaulted to 0 when the sequence started at 1.

Frame Field Too Small
The Frame field was too small in the Hold node. If you had 6 digit frame
numbers, they got cut off.

Linear/Radial Gradient Composite Artifacts
There were vertical line artifacts when comping Linear/Radial Gradients with
another image using Math Composite.

Mocha Pro 2021 Crash
Silhouette’s startup script had a conflict with Mocha Pro OFX 2021.

Morph and Power Matte - Missing Tools
The Magnetic Freehand and RotoOverlay tools were missing from the Morph
and Power Matte nodes.

Output
Alpha Only EXR With Automatic Data Window Corrupted
Rendering alpha only EXR’s with Automatic Data Window enabled produced a
corrupt image.

Render > Automatic Data Window Did Not Work
The Automatic Data Window rendering option was not rendering a data window
based on the alpha channel.
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Paint
Angle & Flatness Affected Square Brush Profile In Viewer
The Angle and Flatness controls should not have changed the square brush
profile in the Viewer.

Clone Corner-Pin Did Not Work - Linux
In some cases on Linux, nothing happed when moving the Clone transform
controls and then painting.

Clone Cursor Lag On Some Wacom Tablets - Windows
The Clone brush cursor lagged in the Viewer with some Wacom tablets.

Clone Would Occasionally Not Produce A Result
Sometimes, when the clone source was transformed, painting did not have any
effect.

Crash When Painting Outside The Image
Using an image smaller than the session size, Silhouette would crash when
painting outside the image area.

Plug-in: Resolve > Fusion Page Hangs
The Silhouette plug-in hung when trying to load images when opened from the
Fusion page within Resolve.

Power Matte Output Didn't Composite In Composite Node
Power Matte wasn't marking its output as RGBA and resulted in the output not
compositing in a Composite node unless all three inputs (Foreground,
Background, Matte) were connected.

Roto
B-Spline to Bezier Conversion Caused Undo To Fail
After converting a B-Spline to Bezier, Undo no longer worked.

Layers Became Inactive After A Move
Layers became inactive after they were moved.

Layer Transform Color Preference Had No Effect
The Layer Transform Color preference had no effect.
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Magnetic Shape Stroke Mode With ROI Did Not Work
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Magnetic Shape stroke mode did not work with ROI.

Nuke Export > Feather Falloff Settings Didn't Match
Silhouette exported shapes with a Shape > Feather Falloff of 2 set to Smooth
instead of the Nuke default of Feather Falloff of 1 set to Linear.

Open Shape B-Spline Required A Minimum Of 3 Points
Previously, a minimum of three points was required to create an open shape BSpline. Now, two points can be used.

Tracker
Automatically Created Layer Not Really Selected
If a layer was automatically created when applying trackers, like in the Mocha
and Planar trackers, the layer was highlighted and appeared selected, but was
not.

Point Tracker Inaccurate In Float 16/32 With Contrast/Gamma Adjustments
The Point Tracker did not track properly in float 16/32 bit sessions when using
Pre-Processing > Contrast and Gamma adjustments.

Shape Export Failed
If you attempted to export a shape to Nuke from the Tracker node, it failed.

Transform Node Sometimes Fell Back To CPU
In some cases, the Transform node would fall back to CPU mode.

Numeric Keypad Did Not Work On Linux

The numeric keypad did not work when using Num-Lock on Linux.

OFX Blacklisting

On Mac, the unsupported CineMatch OFX plug-in was blacklisted to prevent it
from loading because it was causing a crash on load.
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Scripting

invalid Rects() Don't Represent As Invalid
If you queried the default session "roi" property, you'd get an invalid Rect()
which means "not set", but there was a bug where it didn't come out as invalid,
but instead "infinite".

Select Siblings Action
The Select > Siblings action mistakenly unselected the originally selected
object once the new similar objects were selected.

Shift Source Time Action
The Shift Source Time action was not calculating correctly when both the
source time and session time were modified.

User Interface

Channel Selector Would Not Work
The Channel Selector could not be changed with Gain or Gamma adjusted.

Gang State Not Remembered
The enable/disable state of the Gang icon (Lock) was not remembered.

Lock Project Could Not Be Enabled
File > Lock Project could not be enabled.

Low Resolution Icons
On 4K monitors, some icons were low resolution.

OCIO View xForm Not Set Right With Cineon/DPX Files
Creating a new session in a new project did not set the OCIO View xForm
correctly. The View xForm was being set to None instead of sRGB as in
previous versions.

Trees Window
Clear Selection
Clicking on an open space in the Trees window to clear the selection was not
working.
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Crash When Deleting Nodes
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A crash would occur when deleting a node using the Delete key while
simultaneously moving the node.

Deleting Tree Wire Did Not Work
Clicking on a wire to select it and pressing the Delete key did not work.

Panning Trees Window When Over A Node Moved The Node
Middle-mouse dragging on a node in the Trees window moved the node
instead of panning the Tree.

Shift-Clicking Connected Node Crash
Selecting a node and then Shift-clicking another connected node caused a
crash.

Version Check Window Opened Behind Other Windows
The Boris FX version check window opened behind all other windows so you
didn't know that it was there and prevented the Silhouette plug-in from
recording its changes back in the host.
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Known Issues
Linux GStreamer Console Errors

In the Linux console, GStreamer module errors may appear and are related to
hardware accelerated decoding if certain libraries are not installed. These are
benign errors and can be ignored. However, to remove these errors, please
follow the instructions here: Hardware Video Acceleration

Silhouette Plug-in

Flame Sequence Numbering
Flame is not obeying the OFX parameter that determines the start frame, so a
Flame sequence starting at 1 instead starts at 0 in Silhouette.

Premiere Pro
Alpha Channels With Soft Edges
By default, Premiere Pro is linearizing the alpha channels exported from the
Silhouette plug-in even though they are already linear. This causes the alpha
to appear smaller when using soft edges. To avoid this issue, disable
Composite in Linear Color in the sequence settings.

Misreporting The Resolution
Silhouette requires that Premiere Pro’s Playback Resolution be set to Full.
Otherwise, an error message is displayed when you try to open the Silhouette
user interface. Sometimes, Premiere Pro misreports the correct resolution
even though it is set to Full. If this happens, change to a different frame and try
again. Adobe is aware of this issue and is working on a fix.

Trimmed Footage Loads Entire Clip Into Silhouette
If a clip is trimmed in Premiere Pro, the entire clip is loaded into the Silhouette
plug-in instead of the trimmed clip. Adobe is aware of this issue and is working
on a fix.

Resolve and Vegas > Multiple Inputs
Resolve and Vegas do not allow more than one input for plug-ins that use
custom user interfaces. However, additional sources can be added directly
within Silhouette.
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