
What’s New
SILHOUETTE



   Silhouette 2022.5 What’s New

2 About this Guide

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

 ABOUT THIS GUIDE

Copyright
No part of this document may be reproduced or transmitted in any form or by 
any means, electronic or mechanical, including photocopying and recording, 
for any purpose without the express written consent of Boris FX.

Copyright © Boris FX 2022. All Rights Reserved

December 1, 2022

About Us
Founded in 1995, Boris FX is a leading developer of VFX, compositing, titling, 
video editing, and workflow tools for broadcast, post-production, and film 
professionals. Boris FX products have grown to serve over a million artists 
worldwide. The company’s success lies in its ability to tightly integrate and 
leverage technologies through strong partnerships with Adobe, Apple, Avid, 
Blackmagic Design, Autodesk, FilmLight, Grass Valley, Magix, SGO, and other 
leading developers of video editing software. In 2014, Boris FX acquired 
Imagineer Systems, the Academy Award-winning developer of Mocha planar 
tracking software. In 2016, Boris FX acquired GenArts, the developer of 
Sapphire, the gold standard plug-in package for high-end visual effects. In 
2019, Boris FX acquired the Academy Award-winning Silhouette for advanced 
feature film rotoscoping, painting, and effects.
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 SILHOUETTE 2022.5.1 - 12/1/22
Bug Fixes

Cryptomatte
Cryptomatte Node Did Not Cache
The Cryptomatte node did not cache.

Output Multi-Part Did Not Display Cryptomatte Group
The Output Multi-Part node did not display the Cryptomatte group until you 
switched back and forth off the node.

OCIO Config Load Crash
If the internal OCIO config wasn’t loading for some reason, it would cause a 
crash. Now, it will log the reason for the failure.

Paint Keyframe Deletion Crash
If you deleted Paint keyframes from the Timeline using Delete, a crash 
occurred.

Sequence Editor Crash
If you opened the Sequence Editor and dragged in the window without any 
clips, it would crash.

Silhouette Interface Did Not Open From After Effects-Mac
On Mac, the Silhouette interface did not open when launched from After 
Effects.

Stabilize Crash With No Session
If there was no Session and a Source was active by double-clicking it in the 
Sources window, clicking the Stabilize icon would cause a crash.
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 SILHOUETTE 2022.5 - 11/21/22
Features

Cryptomatte
Cryptomatte is a tool created at Psyop by Jonah Friedman and Andy Jones 
designed to create ID mattes from the Roto node using organizational 
information available at render time. Cryptomatte generated images are very 
colorful, assigning each layer or shape a different random color.

In Silhouette, Roto shapes and layers are automatically assigned an ID and 
rank with layers and shapes being two entirely different sets of Cryptomatic 
data. Each layer gets its own ID based on its layer name while shapes get their 
own ID based on their shape name and layer hierarchy.

When the Roto > Data output is connected to the Data input of a:

• Cryptomatte node: The Cryptomatte data is displayed with each layer or shape as 
a different color.

• Output Multi-Part node: The Cryptomatte layer and shape data are written into 
their own EXR channels at render.

The Roto layers/shapes in the rendered Cryptomatte EXR file can then be 
selectively turned on or off in other products that support Cryptomatte like Nuke 
and After Effects. 
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Color Estimation - New Node
Estimates the color of the foreground in semi-transparent alpha areas. Color 
Estimation prevents fringing to create a seamless composite.

Inpaint
Output Alpha
The Output Alpha node parameter has three options: Input, Shapes Only and 
Merged Shapes, which is the previous behavior of combining the input alpha 
with Inpaint’s shapes.

Pre-Blur
The Pre-Blur parameter blurs the input prior to inpainting. This can reduce 
flicker in images with large contrast differences.

Transform Controls Grayed Out
The Transform Controls were grayed out when the algorithm was set to None.

Transform > Show Controls
Displays the transform overlay. When using multiple shapes, it can be useful to 
hide the Transform overlay so that it does not interfere with drawing new 
shapes.

Power Matte Single Shape Solution
A single closed shape with a feathered area can now define the entire trimap. 
Type > FG+Unknown assigns the closed portion of a shape as foreground, the 
feather region as unknown and the rest as background.

Roto
Incremental Feather (E)
In Reshape mode, the E key incrementally expands the feather outward.

Layer > Opacity
An Opacity parameter was added to Layers.

Motion Blur State
When a new shape is created, its motion blur state now matches the motion 
blur state of the of the Roto node.
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Reflect
An Edit > Reflect action mirrors the selected shapes left, right, top or bottom 
with the option to rotate by an arbitrary angle.

Preferences
Compact Sliders
Compact sliders are now used in the Preferences window.

Plugins > Enable Continuum
By default, Continuum OFX plug-ins are disabled except for Particle Illusion as 
they have not been officially qualified to run in Silhouette. This preference 
exposes all Continuum plug-ins.

Plug-ins > Load From Public OFX Location
Silhouette includes Mocha Pro, Particle Illusion, and Sapphire plug-ins. These 
plug-ins are installed and loaded from the Silhouette installation folder by 
default. Optionally, you can load these plug-ins from the public OFX location.

Scripting > Startup Script Preference
A Startup Script preference allows the use of user-defined code to run during 
startup. Note that the changes take effect immediately after dismissing the 
Preferences window. This is good for testing custom keyboard shortcuts.

QtUiTools PySide2 Module
The PySide2 build that ships with Silhouette now includes QtUiTools.

Qt 5.15.4 and Python 3.9
All 3 platforms have been upgraded to Qt 5.15.4 and Python 3.9.

Bug Fixes
3D View Did Not Update While Painting A Stroke

The 3D View was not updating while painting a stroke.

Glow Nodes With Color Correction Were Premultiplied
In certain cases, Diffusion, Frost, Glow, and Mist were mistakenly 
premultiplying the result.
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GStreamer
Command Line Errors
Using the Silhouette command-line renderer, benign errors appeared when 
rendering a movie file.

Interlaced Field Render Was Field Blending
Field interlaced rendered GStreamer movies were field blended instead of 
interlaced. The two fields were mixed together into a progressive frame.

Crash When Loading Interlaced Media Into Smaller Session
Silhouette crashed when dragging and dropping interlaced footage from the 
Sources window to the Trees window when the session was a smaller size than 
the footage.

RGBA Render Without Alpha Channel
On Windows, rendering as RGBA without an alpha channel caused the image 
to display as black in After Effects unless the Alpha was set to Ignore in the 
Interpretation menu.

Work Range
When rendering a work range, the rendered movie duration was too short and 
the last frame had skewed colors.

Licensing
Mocha Pro And Sapphire Were Unlicensed
Mocha Pro and Sapphire were unlicensed when using some bundle licenses.

Sapphire Not Licensed With a Render Only License
Sapphire was not licensed when using a render only license on the command 
line. 

Paint
Additional Viewers And Alpha
In additional viewers, opaque white color appeared in areas of alpha.
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Color/Detail Only Crash With 8K EXR Files
With some 8K EXR files, Silhouette would crash when the View was set to 
Color Only or Detail Only and when painting only in the Color or Detail layer.

Paint Preset Did Not Save Changes When Unlocking/Locking
Unlocking locked Paint presets, changing settings and then locking again did 
not save the changes.

RGBA Shortcuts Didn't Work In Render > Preview
The RGBA keyboard shortcuts didn’t work in the Render > Preview window.

Silhouette Browser Did Not Collapse Some Sequences
The Silhouette Browser did not collapse sequences that included a number 
before the actual sequence number.

Changes
Directional Blur - Default Premultiply To Off

Premultiply is now set to off by default in Directional Blur.

Particle Illusion and Sapphire Plug-ins Location
Silhouette includes Mocha Pro, Particle Illusion, and Sapphire plug-ins. These 
plug-ins are now all installed and loaded from the Silhouette installation folder 
by default. Optionally, you can load these plug-ins from the public OFX location 
using the Plugins preference.

Power Matte > Renamed Type Parameters
Renamed the Type > Foreground and Background parameters to be FG and 
BG.

Known Issues / Limitations
GStreamer

ProRes
All ProRes movies are imported as 16-bpc. This is a limitation of the GStreamer 
ProRes decoder.
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Rendering Interlaced Footage
Rendering interlaced footage is not supported at this time.

Some Quicktime Files Don't Render In OFX Plug-in
On Linux, some QuickTime movies that work in the Silhouette interface may not 
load when rendered within the host.

OpenColorIO - Particle Illusion and Flare Editor
OpenColorIO is not implemented in Particle Illusion or the Lens Flare > Flare 
Editor which results in the image in those interfaces not exactly matching the 
Silhouette viewer.

Power Mesh
The Power Mesh node renders a slightly different result than Mocha Pro.

Silhouette Plug-in
Flame Sequence Numbering
Flame is not obeying the OFX parameter that determines the start frame, so a 
Flame sequence starting at 1 instead starts at 0 in Silhouette.

Multiple Instances of Silhouette Plug-in
You can’t connect two Silhouette plug-ins in a row. There can be multiple 
Silhouette plug-ins, just not chained together.

Premiere Pro
Alpha Channels With Soft Edges
By default, Premiere Pro is linearizing the alpha channels exported from the 
Silhouette plug-in even though they are already linear. This causes the alpha 
to appear smaller when using soft edges. To avoid this issue, disable 
Composite in Linear Color in the sequence settings.

Misreporting The Resolution
Silhouette requires that Premiere Pro’s Playback Resolution be set to Full. 
Otherwise, an error message is displayed when opening the Silhouette user 
interface. In addition, sometimes Premiere Pro misreports the correct 
resolution even though it is set to Full. If this happens, change to a different 
frame and try again. Adobe is aware of this issue.
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Trimmed Footage Loads The Entire Clip Into Silhouette
If a clip is trimmed in Premiere Pro, the entire clip is loaded into the Silhouette 
plug-in instead of the trimmed clip. Adobe is aware of this issue.

Resolve > Multiple Inputs
Resolve does not allow more than one input for plug-ins that use custom user 
interfaces. However, additional sources can be added directly within Silhouette.
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 SILHOUETTE 2022.0.3 - 9/6/22
Features

Particle Illusion 2022.5 (v15.5.2)
Particle Illusion has been updated to 2022.5 (v15.5.2). For a complete list of 
features, fixed bugs and changes, see: Release Notes

Sapphire 2022.5.2
Sapphire has been updated to 2022.5.2. For a complete list of features, fixes 
and changes, see: Release Notes

Bug Fixes
DOD

DOD Status Display Did Not Update
Disabling the DOD did not update the DOD status menu.

DOD Not Active Until Parameters Were Adjusted
The DOD node used the input DOD as the output DOD unless the DOD 
parameter had been edited. Until it had been edited, it had an invalid value. 
Now, the Session size is used in cases where the DOD is undefined or infinite.

DOD Still Active When Disabled
The DOD node remained active when disabled.

Small DOD And Sapphire Filters
DOD’s smaller that the session size produced unexpected results when using 
Sapphire.

Glow Based Nodes Color Adjustments Outputted Black
Adjusting a Color Correct parameter in Diffusion, Frost, Glow or Mist outputted 
a black result.

https://borisfx.com/release-notes/particle-illusion-standalone-2022-5-v15-5-2-release-notes/
https://borisfx.com/release-notes/sapphire-2022-5-2-release-notes/
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GStreamer
Crash After Render
A crash occurred if the rendered movie file had been imported and then re-
rendered.

Command-Line GStreamer Renders EXR Instead Of Movie (Win)
On Windows, command-line rendering to the GStreamer format rendered EXR 
files instead of a movie file.

Imported Rendered Interlaced Movies At Half Height
Interlaced movies rendered by GStreamer imported as half height.

Interlace Render Corrupted
On Macs with hardware ProRes encoding, rendering an interlaced movie 
resulted in a zero-byte file.

Movie Files Don't Load On New Ubuntu System
On a new Ubuntu 2020.0.4 system, movie files did not load because of missing 
dependencies.

Licensing
Dongle Not Recognized on Windows
Hasp HL 3.25 dongles were not recognized on Windows.

Future Unlicensed Sapphire Versions
Future versions of Sapphire, when unlicensed, would cause a crash on Mac 
instead of being watermarked.

Linux Gtk Module Error
After activating a license on Linux, a benign error appeared: Failed to load 
module canberra-gtk-module. 

Mocha Pro
Force Quit Crash
Silhouette would sometimes crash when force quitting the Mocha Pro UI.
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Paint Corruption With Mocha Pro Stabilize Unwarp
When painting on a stabilize unwarp from Mocha Pro, the Paint node displayed 
corruption in the cloned areas unless a DOD node was placed after Mocha Pro. 

Sporadic Hang On M1 Systems
Mocha Pro sporadically hung on M1 systems when tracking or scrubbing the 
timeline.

Roto
Shift-Drag Shape & Feather Point
Shift-dragging a shape point was supposed to move the selected shape point 
and feather point simultaneously. Instead, all shape/feather points moved, 
rather than the selected one.

Surface Flipped On Some Shots
On some shots, the surface was flipped when using Actions > Layer > Set 
Surface or creating a shape and then tracking with Mocha or the Planar 
trackers.

Tracker Node Missing From Plug-in
The Tracker node was missing from the Silhouette plug-in.

Transform > Insert With Cropped Image
An image cropped using Crop or DOD was not in the correct location when 
doing an insert with the Transform node.

User Interface
Crash When Dragging From Input Up And Off The Screen
Dragging from an input port up and off the screen caused a crash.

Installers Did Not Show The Exact Point Release Version
The Mac and Windows installers did not show the exact point release version.

OCIO > View Transform Had No Effect With Custom Config
The OCIO > View Transform had no effect when using a custom config like 
Aces.
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Show Overview State
The Trees > Show Overview icon state was visible in an opened project even 
if the project was saved with Show Overview off. You then had to click the icon 
twice for the overview to appear.

Viewer Displayed Black - Sources To Trees Window
The Viewer turned black if you first double-clicked a source in the Sources 
window and then double-clicked a non-source node in the Trees window. The 
Viewer remained black until another node was selected.

Known Issues / Limitations
GStreamer

ProRes
All ProRes movies are imported as 16-bpc. This is a limitation of our ProRes 
decoder.

Rendering Interlaced Footage
Rendering interlaced footage is not supported at this time.

Work Range
Rendering a work range using GStreamer renders the wrong frames.

OpenColorIO - Particle Illusion and Flare Editor
OpenColorIO is not implemented in Particle Illusion or the Lens Flare > Flare 
Editor which results in the image in those interfaces not exactly matching the 
Silhouette viewer.

Power Mesh
The Power Mesh node renders a slightly different result than Mocha Pro.

Silhouette Plug-in
Flame Sequence Numbering
Flame is not obeying the OFX parameter that determines the start frame, so a 
Flame sequence starting at 1 instead starts at 0 in Silhouette.
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Multiple Instances of Silhouette Plug-in
You can’t connect two Silhouette plug-ins in a row. There can be multiple 
Silhouette plug-ins, just not chained together.

Premiere Pro
Alpha Channels With Soft Edges
By default, Premiere Pro is linearizing the alpha channels exported from the 
Silhouette plug-in even though they are already linear. This causes the alpha 
to appear smaller when using soft edges. To avoid this issue, disable 
Composite in Linear Color in the sequence settings.

Misreporting The Resolution
Silhouette requires that Premiere Pro’s Playback Resolution be set to Full. 
Otherwise, an error message is displayed when opening the Silhouette user 
interface. In addition, sometimes Premiere Pro misreports the correct 
resolution even though it is set to Full. If this happens, change to a different 
frame and try again. Adobe is aware of this issue.

Trimmed Footage Loads The Entire Clip Into Silhouette
If a clip is trimmed in Premiere Pro, the entire clip is loaded into the Silhouette 
plug-in instead of the trimmed clip. Adobe is aware of this issue.

Resolve and Vegas > Multiple Inputs
Resolve and Vegas do not allow more than one input for plug-ins that use 
custom user interfaces. However, additional sources can be added directly 
within Silhouette.
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 SILHOUETTE 2022.0.2 - 7/13/22
Features

HD 1080 23.976 Format
A HD 1080 23.976 session format was added.

Morph Node > Output Alpha Additions
Added Morph Alpha and Source Alpha options to the Output Alpha menu. The 
Source Alpha comes from the A side input.

Bug Fixes
3D Preview Not The Same Aspect Ratio As Session

The 3D preview displayed an aspect ration of 1:1 when the original plate was 
2:1.

Custom OCIO Configuration Caused Crash on Startup
If the OCIO Configuration preference was set to, for instance, 
aces_1.2\config.ocio, Silhouette would crash on startup with the following error: 
Color Space sRGB could not found.

GStreamer
Command Line Render Crash
Command-line rendering to GStreamer as the output format caused a crash.

Warning In Nuke Terminal
On Windows, there was a benign GStreamer warning in the Nuke terminal 
when running the Silhouette plug-in.

Morph > Output Alpha > Cutout At Proxy Resolutions
When Output Alpha > Cutout was selected with a Proxy Size smaller than 1:1, 
the output was cropped to the upper left quadrant of the image.

Plug-in Hang - Mac
On Mac, if you created a Paint session and later tried to enter Silhouette on a 
frame other than frame 1, Silhouette would hang on start.
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PowerMesh With Inpaint Crash
An Inpaint node placed after PowerMesh could cause a crash after the first 
frame.

Rendered Roto Color Was Not Accurate
When rendering shapes as filled colors, the rendered colors could vary slightly 
from the selected color.

Session
Bit Depth In Session Did Not Match Clip 
The Session dialog wasn’t handling 16 bit linear and 8 bit was selected in the 
Session settings. Now, Float 16 is selected instead.

Frame Rate In Session Did Not Match Clip
When creating a Session from a HD 1080 23.976 format, there was no 
corresponding format to match it to, so the rate was changed to 24.
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 SILHOUETTE 2022.0.1 - 7/1/22
Features

New Particle Illusion
Updated Silhouette with Continuum Particle Illusion 2022.5. The next evolution 
of Particle Illusion brings 3D models to the user-friendly generator. Import 
Maxon Cinema 4D files and map particles to different surface setups for full 
creative particle control.

Locked Color Sample Drag and Drop To Color Pot
The locked color sample can be dragged and dropped onto a color pot to define 
the color.

Viewer > Invert Alpha
The ; key inverts the alpha in the Viewer. When inverted, the alpha pot in the 
View Channel icon changes from white to black.

Bug Fixes
Dongle Not Recognized on Intel Mac

Hasp HL 3.25 dongles were not recognized on Intel Macs.

GStreamer > Force Motion Blur Option Removed
The Force Motion Blur setting in the GStreamer Options window was removed 
as it was not applicable to Silhouette.

Inpaint
Not Passing Through To OFX Host
The Inpaint node result was not passing through to the OFX host.

Not Rendering With Command-Line - Windows
On Windows, a command-line render that included an Inpaint node did not 
render the inpainted result.
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Layer Transform From Four Trackers 
A layer transform created from four Point Trackers did not have a keyframe set 
on the first frame.

Linux Installer
Added additional dependencies.

M1 Image Caching
Cache Limited To Only A Few Frames
The image caching on a M1 Mac was limited to a narrow range of frames.

Cache Text Appearance
The text in the cache display on a M1 Mac became dark and unreadable when 
the cache filled up.

Mocha Pro
Mesh Track Hang
Mocha Pro would hang sometimes while mesh tracking.

Result Not Passing Through To OFX Host
The Mocha Pro node result was not passing through to the OFX host.

Paint > Clone > Align Mode Solid Gray
Paint > Clone > Align mode did not work. The gray overlay was solid gray at all 
times.

PNG Render Crash
Silhouette crashed after 10 frames when rendering to PNG > Alpha.

Power Mesh
The Power Mesh node renders a slightly different result than Mocha Pro, but 
the result is now closer.

Tab > Node Creation Caused Crash With No Session
In a project without a session, pressing Tab, searching for a node, and adding 
the node caused Silhouette to crash.
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Viewer > LUT Was Not Loading
LUT’s selected in the Viewer > LUT menu did not load. In addition, once the 
LUT had been selected, the Viewer > Gain and Gamma controls had no effect.

Changes
GStreamer Channel Rendering

The Output node > Channels selection now determines the channels rendered 
in the output movie.
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 SILHOUETTE 2022 - 6/6/22
Features

Sapphire, Mocha Pro, Particle Illusion & Continuum
Sapphire, Mocha Pro, Particle Illusion and select Continuum BCC+ filters are 
now included in Silhouette.

Sapphire
Over 270 effects and thousands of presets seamlessly integrate into 
Silhouette’s resolution independent node-based compositor. Sapphire features 
the industry’s favorite lighting effects, lens flares, glows, blurs and useful 
processing filters for film and television visual effects work. 

Mocha Pro
Launch the Mocha Pro interface from within Silhouette to access the Academy-
award winning planar tracking interface. Mocha Pro brings PowerMesh organic 
mesh tracking, object removal, AdjustTrack and more advanced tracking 
features to Silhouette users. Mocha’s new Data port enables seamless 
workflows for passing tracking, shapes and mesh data from Mocha Pro to 
Silhouette.

Particle Illusion
Create realistic particle animations with Particle Illusion’s 3D emitters, fluid 
dynamics, and massive preset library. Add useful environmental elements such 
as dust, smoke, fire, explosions or explore curated graphics such as HUDs and 
sci-fi elements. Available for Mac and Windows.

Continuum BCC+ Filters
The following Continuum BCC+ filters are now included with Silhouette: Beauty 
Studio, Blur, Channel Blur, Channel Blur YUV, Directional Blur, Film Glow, Light 
Leaks, Magic Sharp, Prism, Radial Blur, Smear Blur and Video Glitch.
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Inpaint
Inpainting is a technique which fills a section of an image. This is useful for 
removal of unwanted objects such as wires, markers or blemishes. Integrated 
Roto tools create shapes and multiple algorithms are available to automatically 
fill-in the specified regions with information surrounding them. To create a 
seamless result, the detail (texture) from another part of the image or other 
image can optionally be composited over the inpainted area using the Detail 
controls. All of the tools from Silhouette’s Roto node are integrated within the 
Inpaint node.

PowerMesh Warp
PowerMesh enables a powerful sub-planar tracking process that tracks warped 
surfaces and organic objects. Mesh tracking takes place in the Mocha Pro node 
and when connected to the PowerMesh Warp > Data input, images are either 
warped or unwarped based on the generated mesh.

DOD - Surface
A Layer input and selector are now available in the DOD node. When selected, 
the input Layer > Surface size is used to define the DOD. A margin can also be 
added to the boundary of the surface.

GStreamer Rendering
Currently, Silhouette imports movie file formats using GStreamer, a versatile 
media handling library for reading various codecs and footage containers. Now, 
rendering to movie file formats is also supported.

Mocha Pro
Data Output
Mocha Pro’s Data output passes shape, layer and mesh data through to other 
nodes with Data inputs.

DOD
Use the selected Mocha Pro Layer > Surface to set the DOD dimensions.
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PowerMesh Warp
Warp or unwarp images based on the selected Mocha Pro mesh.

Transform
Select the Mocha Pro layer as a source for stabilization, match moving or 
inserts.

Node Actions
The Mocha Pro > Actions menu creates Silhouette Roto and Tracker nodes 
from the Mocha Pro project without having to go into the Mocha UI.

Copy Data
Copies all Mocha shapes, layers, and PowerMesh data which can then be 
pasted into nodes that accept layers and shapes.

Create Roto Node
Creates a Roto node from all Mocha shapes, layers and PowerMesh data.

Create Tracker Node
Creates a Tracker node from all Mocha shapes, layers and PowerMesh data.

Point Control Parameter Tracking
Point control parameters can now be match moved. To achieve this, a Data 
input port was added to all nodes with point control parameters. Match moving 
happens when a node with tracking data is plugged into the node’s Data input 
and either a point tracker or tracked layer is selected in the Transform pop-up 
menu to the right of the point control.

Roto
Jump To Midpoint Between Keyframes
Alt-Z jumps to the midpoint of the current frame and the previous shape 
keyframe while Alt-X jumps to the midpoint of the current frame and the next 
shape keyframe.
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Select All Open Shape Start or End Points
The Reshape context menu now has Select Start Points and Select End Points 
options which automatically select all open shape start or end points. The 
selected points can then be edited simultaneously, for instance, for feathering 
the ends of open shapes to a point when rotoing hair.

Surface
You can check the accuracy of a planar track by turning on the Viewer > 
Surface icon and setting the inner corners of the Surface to match the 
perspective of the tracked plane.

The following tasks can be achieved using a Surface:

• Create Corner Trackers from Layer Surface

When using Create Corner Trackers from Layer Surface, point trackers are 
created from the Surface corner points.

• DOD

When the Data output of a node with a layer surface is plugged into the DOD > 
Data input and the layer is selected, the DOD is automatically set to the 
bounding box of the surface.

• Transform Node > Insert

Use the Layer > Surface corner points to set the insert corner-pin.

Tracker Creation From Layer Surface
With the Point Tracker tab selected, right-clicking opens the Tracker pop-up 
menu and there are two new items:

Create Corner Trackers from Layer Surface
Creates four trackers around the four corners of the layer surface.

Create Tracker from Surface Center
Creates one tracker in the center of the surface.

Transform > Insert Mode
The Transform > Mode > Insert feature uses the selected Layer > Surface 
corner points to set the insert corner-pin.
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Native Mac M1 Support
Optics now runs as a native, Mac M1 application.

OpenColorIO v2
Upgraded from v1, OpenColorIO v2 is a major update and contains a number 
of new features including:

• A more accurate GPU renderer and faster CPU renderer

• More accurate ACES transforms and support for the Academy Common LUT 
Format (CLF)

• New mathematical operator types and inversion support for all operators 
(including 3d-LUTs)

• Better support for display color spaces and ICC monitor profiles

• New color space properties such as categories to support a better user 
experience

Alpha Channel Processing
Applicable filters, for instance lens flares, glows and blurs, can now affect the 
alpha channel.

Scripting
Import/Export Objects
Added the ability to import/export .sfxnodes files. Trees > Save/Load Nodes 
can be built on top of the following:

• fx.exportObjects(path, objects)

• fx.importObjects(path)

Paint Preset Menu Scriptable
Scripts now register menu actions with the PaintPresets root.

Shape Feather and Open Spline Info
In previous versions of Silhouette, you could change shape points/weights, but 
not feather or open spline info. The same syntax is used as before, but now is 
context sensitive depending on whether you pass the additional per-point tuple 
values.
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User Interface
Additional Viewers > OCIO Controls
Additional viewers now have their own OCIO controls. Previously, they were 
shared with the main viewer.

Color Picker Live Changes
When using a color picker, color changes update live in the Viewer.

Enhanced On-Screen Controls
The on-screen controls have been enhanced in a number of Silhouette nodes, 
most noticeably in gradient based effects.

Pixel Color Status
The pixel color status was previously only available in Paint. Now, it updates all 
the time. Pressing the ’ key locks the values and displays them to the left of the 
live values. Pressing " clears the locked values.

Preview
The Viewer > Preview includes a variety of display options when an alpha 
channel is present such as: RGB Straight, Over Black, Over Gray, Over White, 
and Over Checkerboard.

Tab Key Node Search/Add
Press the Tab key in the Trees window to open a search window, type the name 
of a node and press Enter to add it to the tree. With a selected node, the new 
node automatically connects to it. Without a node selection, the new node 
appears at the cursor location. You can also press the Tab key in the Nodes 
window to enter search mode.
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Two-Axis Dragging
2D control point fields now have an icon, located to the left of Reset, that acts 
as a two-axis dragger. Instead of dragging the X or Y parameters, you can click-
drag on the icon and the control point will move with respect to the mouse/tablet 
offset.
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Changes
Manual Mode

When Manual mode is engaged, opening a project or switching sessions does 
not force a render. This is useful to open up a project that may be crashing.

Preferences
Paint > Clone > Reset Frame Number With Transform
A Paint > Clone > Reset Frame Number With Transform preference was added 
and defaults to off.

User Interface
Data Ports Renamed
All Transform/Objects node inputs/outputs were renamed to Data.

Removed View and Update Labels From Viewer
The View and Update labels were removed from the Viewer.

Viewer > Gain Control Range
The Viewer > Gain control range was expanded from -3/3 to -5/5 and you can 
now type in values up to -10/10.
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Bug Fixes
GPU Selection

Silhouette didn’t always choose the best GPU when multiple GPU’s were 
present.

Nodes
Color Correct > Color Wheel Crash
Double-clicking in the center of the Color Wheel or in the Brightness bar caused 
Silhouette to crash.

Lens Flare > Flare Editor
Some Image Colorspaces Displayed Incorrectly
Some image colorspaces displayed incorrectly in the Flare Editor. When 
necessary, the images are now converted from linear to sRGB.

Flare Editor Didn't Open on Mac or Linux
The Flare Editor did not open on Mac or Linux.

Math Composite
The Difference blend mode did not work as expected.

Pin Warp and Sapphire Nodes Changed DOD
When compositing a smaller image over a larger background and a Pin Warp 
or Sapphire node was placed after the smaller image, the Composite DOD was 
clipped to the smaller image.

Sapphire And Swap Channel
If Swap Channels was used before a Sapphire node, the alpha was ignored 
and opaque alpha was used instead.

zMatte Composite Output Clipped Highlights On Linux
On Linux, zMatte’s Composite output clipped highlights.
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Paint
Paint > Average Color Selection With Pen
Right-click-drag to average the colors within the selection did not work with a 
pen/tablet.

Straight Line Overlay Not Visible With ROI Enabled
When the ROI controls were enabled, the straight line overlay was not visible 
when using Alt-click-click in Paint.

Paint > Clone > Interactive Issue
When using QWE with Clone > Interactive enabled, the Interactive overlay was 
removed, but the Interactive button was still enabled.

Clone Offset Not Matching Onion Skin - Linux
The clone offset did not match the onion skin view when using corner-pin and 
an image that was smaller than the session size.

Cloning From Other View And Stereo Offset
Cloning from the other view did not use the Stereo Offset.

Plug-in
After Effects MFR Error Message
After Effects MFR (Multi-Frame Rendering) error no longer appears.

Source Bit Depth Display Wrong
Sources always displayed as 8 bit on the thumbnail information even when it 
was 16 or 32 bit.

PNG
Corrupt Edges When Rendering 16 Bit PNG
When rendering a shape with blur or motion blur to the PNG file format in a 16 
bit float session, the shape edges were corrupt.

Grayscale PNG Would Not Load/Render
Grayscale PNG’s would not load or render.
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Roto
Adjusting A Shape In One View Affected Other View
When editing a shape in the Left or Right View with the Edit In Both Views icon 
enabled, the shape in the other view was also mistakenly edited.

Extract/Combine Shape Had No Effect
Extract Shape and Combine Shape had no effect.

Magnetic Reshape and Edit in Both Views
When Edit in Both Views was enabled while viewing the LR view, editing with 
Magnetic Reshape only affected the view the points were edited in instead of 
both views.

Tracking
Exporter Issues
Exported layers to Nuke trackers, when reloaded in Silhouette, only displayed 
the top right track. Exported layers to Simple format, when reloaded in 
Silhouette, displayed two sets of corner-pin tracks.

Extra Keyframe When Tracking Backwards
When tracking backwards with the Planar or Mocha tracker using a work range 
in the center of the sequence, for instance frame 60 to 30, a keyframe was 
created on frame 29.

Off-Screen Trackers Caused Crash When Selected
When selected, off-screen point trackers would, in some cases, crash 
Silhouette.

Tracking One Frame Displayed Progress Window
Tracking one frame would pop up the progress window.

User Interface
DOD Magnifier Corruption
The Magnifier window was corrupted when used outside of the DOD.
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Lock Project Crash
Silhouette crashed when the project was locked and a node was added to the 
Trees window. You can no longer add nodes to the Trees window when the 
project is locked.

Numeric Keypad Did Not Work
The Numeric Keypad did not work when using Num-Lock with numbered 
keyboard shortcuts.

OCIO
OCIO Colorspace Default Config
The Color Management > OCIO Configuration preference, when changed, now 
sets the default config displayed in the OCIO Colorspace node after a restart.

OCIO Colorspace Node With Aces Config
In the OCIO Colorspace node after loading the Aces Config, the pop-up menu 
size was so small that you could not tell what was being selected. You had to 
jump to another node and back before the pop-up menu would resize. The pop-
up menu now automatically changes size when a new config file is selected.
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