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 ABOUT THIS GUIDE

Copyright
No part of this document may be reproduced or transmitted in any form or by 
any means, electronic or mechanical, including photocopying and recording, 
for any purpose without the express written consent of Boris FX.

Copyright © Boris FX 2026. All Rights Reserved

January 26, 2026

About Us
Founded in 1995, Boris FX is a leading developer of VFX, compositing, titling, 
video editing, and workflow tools for broadcast, post-production, and film 
professionals. Boris FX products have grown to serve over a million artists 
worldwide. The company’s success lies in its ability to tightly integrate and 
leverage technologies through strong partnerships with Adobe, Apple, Avid, 
Blackmagic Design, Autodesk, FilmLight, Grass Valley, Magix, SGO, and other 
leading developers of video editing software. In 2014, Boris FX acquired 
Imagineer Systems, the Academy Award-winning developer of Mocha planar 
tracking software. In 2016, Boris FX acquired GenArts, the developer of 
Sapphire, the gold standard plug-in package for high-end visual effects. In 
2019, Boris FX acquired the Academy Award-winning Silhouette for advanced 
feature film rotoscoping, painting, and effects.
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 SILHOUETTE 2025.5.3 - 1/26/26

Features
UpRes ML

New v2.1 Better and Faster models.

Changes
Matte Refine ML / Matte Repair > Shrink/Grow Range

The range of the Shrink/Grow parameter range was expanded.

Bug Fixes
3D Scene Node - Set ROI To Current DOD Icon Missing

The Viewer > ROI > Set ROI to Current DOD icon was missing in the 3D Scene 
node.

Alpha Composite: Input Group Expansion Crash
Expanding the input group in Alpha Composite caused a crash.

Color Estimation Crash
Color Estimation could crash when using a DOD due to an assumption that the 
input image DOD always contained the ROI.

Mask ML – Second Point Not Recognized When Clicking 
Quickly

When two points were added in quick succession, the second point was not 
used in the render.

Matte Assist ML With DOD Matte Creation Failure
In Matte Assist ML, jumping forward in the sequence could fail to generate a 
matte when DOD was enabled.
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Matte Refine ML
Matte Refine ML Could Fail With DOD
With an upstream DOD present, the Matte Refine ML effect could randomly 
revert to the input instead of producing the refined result.

Shrink/Grow with DOD
When using a DOD prior to Matte Refine ML, the correct ROI would not be 
taken into account when doing the matte adjustment stage causing instability.

Multiple Viewers - Update Issue
When using two viewers, one set to Output and another set to a different node, 
only the main viewer was updating.

New Node – Image Did Not Appear in Viewer in Release 
Update Mode

When the Viewer was in Release Update mode, dragging a node into the Trees 
window and connecting it to the source did not update the Viewer.

Paint Object List – Add Layer Icon Missing
The Add Layer icon at the bottom-right of the Paint Object List was missing 
starting in v2025.

Printer Points > Gang Misbehaving
When Gang was enabled, adjusting the Red or Green controls affected both 
Red and Green, while Blue remained unchanged. Adjusting Blue correctly 
affected all three channels.

Revert Project Crash
Silhouette could crash when using File > Revert Project on a project containing 
ML nodes and a DOD.

Roto - IK Tool Crash
Fixed an issue where Silhouette would crash when adjusting layers with the IK 
tool’s on-screen controls.
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 SILHOUETTE 2025.5.2 - 12/2/25

Bug Fixes
3D Scene

Crash When Solving From Frame Other Than 1
Silhouette would crash if the 3D Scene node was solved starting from any 
frame other than frame 1.

Error Reporting
Previously, failed SynthEyes tracks did not generate an error message. The 
Solve Summary window now opens on failure, providing details about the 
reasons.

Point Selection Reset on Project Load
Points saved as selected in the 3D Scene node appeared highlighted when 
reopening a project, even though they were not truly selected. Point selections 
are now correctly cleared when a project is loaded.

Mask ML – Text Prompting Issue on macOS
Text Prompting in Mask ML stopped functioning on macOS Tahoe 26.1.

Matte Refine ML Crash
In certain isolated cases, using Matte Refine could result in a crash.

Motion Blur Produced Opaque Alpha When Alpha Was Not 
Present

Resolved an issue in Motion Blur ML where an opaque alpha channel was 
incorrectly produced when no input alpha was present. 

OCIO Input Colorspace and View Transform Set Incorrectly
Creating a new session with Ctrl/Cmd-N on a selected clip did not apply the 
correct color space.
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Paint > Clone > Align Not Working
The Align function in Paint > Clone did not display the difference view required 
for object alignment.

Regrain > Grain Strength Parameters Not Affected By 
Matte > Enable

The Regrain > Grain Strength Parameters applied grain everywhere even 
when Matte was enabled.
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 SILHOUETTE 2025.5.1 - 10/30/25

Features
NVIDIA RTX Video HDR Node – AI-Enhanced SDR to HDR 
Tone Mapping

Rec.709 SDR video is expanded into HDR10 compatible Rec. 2020 color, 
producing vibrant colors, deeper darks, and improving the overall sharpness of 
processed video frames. Windows-only / RTX GPU required.

Changes
Cryptomatte > Overlay

The Cryptomatte > Overlay parameter (enabled by default) composites a 
colored overlay of selectable mattes over the RGB channels--preserving the 
previous behavior but it blocked RGBA passthrough. Disabling this parameter 
allows RGBA to flow correctly to downstream nodes.

Bug Fixes
Auto-Matte Script Failed to Reliably Detect Output Format

The auto-matte script contained a bug that occasionally prevented it from 
identifying the correct output format. The issue originated in tools/session.py.

Cache > Preload Frames Functionality Broken
The Cache > Preload Frames feature stopped working due to a regression 
introduced in the threaded rendering system.

Composite Node Missing Matte Input
The matte input was missing from the Composite node.

Cryptomatte
Cryptomatte Object Selection Issues With Matte Assist ML
When using Cryptomatte with Matte Assist ML, selecting a tracked object could 
result in the wrong object being picked.
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Matte Refine ML Had No Effect When Placed After Cryptomatte
Matte Refine ML had no visible effect when placed downstream of Cryptomatte 
due to the overlay blocking RGBA passthrough. Cryptomatte now includes an 
Overlay parameter (enabled by default); disabling it allows RGBA to flow 
correctly to subsequent nodes like Matte Refine ML.

Depth Map ML
Gamma Availability Limited to Scale Mode
Gamma adjustments were restricted to Scale mode, rather than being 
accessible in both Scale and Points modes.

Gamma Slider Adjustment Was Reversed
Gamma slider behavior was reversed relative to the Color Correct Gamma 
adjustment.

Disconnecting A Port Did Not Update The Viewer
The Viewer failed to refresh after a port was disconnected.

DOD Rendering Was Broken
When rendering with the Data Window set to DOD, the renderer would fail.

Matte Refine ML Produced Block Artifacts
Sometimes Matte Refine ML produced rectangular artifacts at the edge of the 
matte.

ML Tooltips Incorrect
Some ML node tooltips incorrectly displayed internal identifiers instead of user-
facing labels.

Motion Blur ML Did Not Produce A Result
Motion Blur ML did not produce a result with an alpha channel from 
Cryptomatte.

Sapphire On-Screen Controls Became Unresponsive 
When Keyframing Was Enabled

In some Sapphire nodes, enabling keyframes caused the on-screen controls in 
the Viewer to become disabled.
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Streamlined Workspace
The Streamlined workspace did not match the window positioning in Silhouette 
2025.

UpRes ML Corruption
Visual corruption occurred in OFX hosts when UpRes ML was used with the 
NVIDIA RTX Super Resolution model and a high Scale value.

Viewer Gain and Gamma Adjustments Were Slow on 
Windows

On Windows systems, adjusting the Viewer’s Gain and Gamma controls under 
an ACES configuration resulted in noticeable lag—particularly on machines 
with NVIDIA GPUs.
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 SILHOUETTE 2025.5 - 9/25/25

Features
Automated Object Detection & Masking

Automatically detect and segment arbitrary objects in images based on simple 
text prompts—whether you specify a category name (“car,” “person,” “tree”) or 
use more descriptive phrases.

Masks are generated with Mask ML and seamlessly propagated using Matte 
Assist ML, giving you accurate and consistent results across frames. The 
workflow is fully flexible: use it through the UI or integrate it into pipelines via 
the command line for large-scale automation. This enables a true end-to-end 
automated workflow: prompt, segment, propagate, and render—dramatically 
reducing time spent on repetitive tasks

Face ML
Bring precision and flexibility to facial effects work. The Face ML node 
automatically detects and segments key facial regions—such as eyes, lips, 
mouth, and surrounding skin—into individual mattes. This granular separation 
allows for targeted adjustments or creative effects to each feature 
independently, all accomplished without manual rotoscoping.

When performing subtle beauty retouching or building complex composites, 
Face ML provides high-quality, tracked mattes, ensuring the fine control 
needed for invisible beauty work.

Syntheyes 3D Tracking
The 3D Scene node now includes a fully integrated SynthEyes camera tracking 
and solving system, directly inside Silhouette. Analyze 2D features in footage 
to accurately calculate the camera’s 3D position and orientation, generating 
both a point cloud of the scene and a reliable camera solve.

This powerful integration supports an Unproject/Reproject workflow, enabling 
paint or compositing directly into a locked-down sequence with precision and 
ease—without leaving the Silhouette environment.
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Mocha Pro 2025.5
Mocha Pro has been updated from v2025 to v2025.5. New features include 
face detection layers, Matte Assist ML improvements, updated export dialog, 
and camera solve improvements.

For a complete list of features, fixed bugs and changes, see: Release Notes

Sapphire 2025.5
Sapphire has been updated from v2025 to v2025.5. The latest update includes 
user interface improvements to the Preset Browser, Effect Builder, and Flare 
Designer. GPU support for AMD cards has been added on Windows, 
expanding compatibility for more users. The release also introduces new lens 
flares and Builder presets, along with additional presets for a variety of effects. 

For a complete list of features, fixed bugs and changes, see: Release Notes

Particle Illusion 2025.5
Particle Illusion has been updated from v2025 to v2025.5. New features include 
3D camera animation presets, allowing users to select from a range of pre-
animated options or create and save their own. The updated 2025.5 Emitter 
Library adds new content for enhanced visual variety and refinements to the 
user interface improve overall ease of use.

For a complete list of features, fixed bugs and changes, see: Release Notes

Node Enhancements
Cryptomatte
Image Input
Available mattes are applied as overlays to the optional image input.

Selection
The Cryptomatte node now supports selective matte activation directly within 
the viewer. Once enabled, these mattes become available for use in other 
nodes and are added to the Selection list. Hovering over the image highlights 
selectable mattes; clicking confirms your selection. To adjust the selection, use 
shortcut keys: Ctrl/Cmd-click or Shift-click adds mattes, Ctrl/Cmd-click 
removes them, and dragging over an area selects multiple mattes 
simultaneously.

https://borisfx.com/release-notes/mochapro-2025-5-release-notes/
https://borisfx.com/release-notes/sapphire-2025-5-release-notes/
https://borisfx.com/release-notes/particle-illusion-pro-2025-5-1-release-notes/
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Depth Map ML
Depth Preview
Increased the resolution of the Depth Preview.

Gamma
Added a Gamma parameter to Depth ML.

Mask ML
Cryptomatte Output
Mask ML objects are output as Cryptomatte data via the data port.

Multiple Object Support
Mask ML now supports multiple objects in an Object List. When Mask ML and 
Matte Assist ML’s data ports are connected and Matte Assist ML > Mask 
Source > Cryptomatte is selected, each Mask ML object is considered a 
separate object.

• The first point or rectangle added automatically creates a new object.

• To manually create an empty object, click the Add Object icon in the Object List.

• Selecting an object reveals its controls; changes apply only to the selected object.

• Use the Object List to rename, delete, or toggle visibility per object.

Object Detection
Automatically detect arbitrary objects in images using text prompts—such as 
category names or descriptive phrases—instead of manual selection. Supports 
automation via scripting.

Matte Assist ML
Compute Cache
When advancing to a future frame, matte calculations are performed and 
cached for all intermediate frames. As a result, playback is seamles--those 
intermediate frames retrieve from cache instantly, without requiring 
recomputation.
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Cryptomatte Output
When either the Mask Source > Cryptomatte or Roto options are selected and 
multiple objects are present in the Roto and Mask ML nodes, each object is 
output separately as Cryptomatte data via the data port.

ML Node Caching
Enhanced performance of the Mask ML, Matte Assist ML, Matte Refine ML, 
and Face ML nodes by caching their mattes. Once a node is played through, 
its mattes are computed and stored in the project, significantly improving 
responsiveness in both the Silhouette standalone application and plug-in.

Tracker
Occlusion Matte Input
Added an Occlusion Matte input on the left side of tracker nodes to mark areas 
that interfere with tracking so they’re automatically ignored.

Tracked Layer Creation Based On 3D Point Selection
When a 3D Scene node is connected to Tracker capable node’s data port, the 
Point Tracker can generate a tracked layer from the selected 3D track points. 
If one or more shapes are selected, their enclosed points are automatically 
used to create the layer, and the shapes are added to it.

New ML Models
Denoise ML
Compression+Noise Single Image v3.0 comes in two variants: Better and 
Faster. Both models are optimized for processing individual images rather than 
sequences.

Matte Assist ML
The matte propagation object count upper limit increased from 16 to 48. This is 
useful for when either the Mask Source > Cryptomatte or Roto options are 
selected and multiple objects are present in the Roto and Mask ML nodes.
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Upres ML
NVIDIA RTX Video Super Resolution
This Windows-only model leverages an NVIDIA RTX GPU to enhance video 
quality. It processes each frame through an AI model trained to sharpen edges, 
restore intricate details and patterns, and remove blocky compression artifacts.

UpRes v2.0
The v2.0 model retains finer details compared to v1, which tends to smooth 
features. As a result, v2.0 delivers outputs that appear more natural and less 
painterly. Additionally, it processes frames individually rather than in six-frame 
chunks.

Preference Reset Options
Mac & Windows (Standalone and Plug-in)
Holding Shift-Ctrl/Cmd during startup now resets preferences.

Linux
Preferences can be reset using the -reset_prefs command-line option or by 
setting the environment variable SFX_RESET_PREFS=1

Scripting
Automate Mask ML And Matte Assist ML With Text Prompts And 
The auto-matte.py Script
Use the auto-matte.py script to drive object detection and masking with text 
prompts in Mask ML, which are then propagated by Matte Assist ML and 
rendered--all through the command line.

Batch > Transcode Action
The Batch Transcode action converts source media into a different file format. 
This is useful if you want a sequence of stills instead of a movie file.

New Command-Line Options
New command-line arguments/behavior to facilitate running scripts that do 
interesting things:
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-save <path>
Saves the active project to <path>, overwriting if it exists.

-xscript <script> [args]
Executes the script at <script>, passing in the remaining command-line 
arguments as sys.argv.

New Behavior
If a script causes a project to become active, the -save switch will save it. Also, 
the -render and other session control options like -range will work. This allows 
a script to build an ephemeral project that can be saved and/or rendered as if 
it was loaded normally.

Scriptable Button Triggers With Optional Parameters
Options can now be passed when triggering buttons from scripts. Button 
properties include a trigger() method, which now accepts an optional dictionary 
of options. This allows scripts to provide necessary information that may not be 
available when running from the command line. For example, the “Find” button 
in Mask ML requires an option with a “frame” member to specify which frame 
to search. In the UI, this is automatically set from the player frame--but scripts 
must pass it explicitly.

Changes
Backups Directory Is Automatically Created If Missing

If the project’s Backups folder is deleted, Silhouette automatically creates a 
new one.

Depth ML Parameter Ranges
Near Scale
Maximum value increased to 2.

Far Scale
Updated range now spans from -2 to 1.
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Cryptomatte
Default Type
Objects (previously named Shapes) is now the default Type.

Renamed Type > Shapes
Updated the label from Type > Shapes to Objects, as Cryptomatte output is no 
longer limited to Roto nodes.

Matte Assist ML
Create Mask ML Node
To support multiple objects in a Mask ML to Matte Assist ML workflow, the 
Matte Assist ML > Create Mask ML Node button now automatically sets the 
Mask Source to Cryptomatte (data port).

Matte Assist ML Session Template
The Matte Assist ML session template now sets Matte Assist ML > Mask 
Source to Cryptomatte (data port).

Obey Matte Enabled By Default
Obey Matte is now enabled by default.

Point Tracker > Create Button Enhancements
Clicking the Point Tracker > Create button now opens a pop-up menu with 
options for converting 3D trackers or cards in any Tracker-capable node. Newly 
added options include Point Trackers From 3D Points, Layer From 3D Points, 
and Layer From Card.

Silhouette Shapes To After Effects Masks
To convert Silhouette shapes into After Effects masks, use the Silhouette plug-
in’s Create AE Masks button.

UpRes ML Now in Transform Group
UpRes ML was moved from the Filter group to the Transform group to better 
reflect its functional role.
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Bug Fixes
Alpha Composite Layout Issue

The Alpha Composite parameters were not arranged in rows as expected.

Beauty Studio - Incorrect Result In 8 bit Sessions
Beauty Studio produced a result even when the Master Amount was set to 0.

Default OCIO Config Preference Required A Restart
Changing the Color Management > Default OCIO Config preference now 
applies as expected. Previously, updates to this preference did not take effect 
until the Silhouette was restarted.

Enter Key Unresponsive in Manual Update Mode
When Viewer > Update Mode was set to Manual, pressing the Enter key failed 
to initiate processing as intended.

Extract Detail Node - Did Not Preserve Alpha in Detail 
Output

When decomposing an image using the Extract Detail node, only the Color 
output retained the original alpha, while the Detail pass did not.

Mocha Pro - FBX Import Offset Misalignment
Fixed an issue where FBX exports from Mocha Pro to Silhouette did not respect 
the restricted frame range, causing tracking data to start at frame 1 instead of 
the intended offset (e.g., frame 50).

Resolve > Fusion Incorrect Frames
A negative start frame appeared in the Silhouette timeline, causing incorrect 
frames to display in the Fusion tab.

Tree Refresh Delay After Node Deletion
Deleting nodes could result in a noticeable delay before the Tree view fully 
refreshed and reflected the updated state.
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